]> git.pld-linux.org Git - packages/dovecot.git/blobdiff - dovecot.spec
- up to 1.1.14
[packages/dovecot.git] / dovecot.spec
index 64fd669ff2d909b18df3175f039f357f82a27d9b..118d1acb5684e0caffca8894f91496bde87fb826 100644 (file)
@@ -1,5 +1,6 @@
 #
 # Conditional build:
+%bcond_with    gssapi  # with GSSAPI support
 %bcond_without ldap    # without LDAP auth
 %bcond_without mysql   # without MySQL auth
 %bcond_without pgsql   # without PostgreSQL auth
 Summary:       IMAP and POP3 server written with security primarily in mind
 Summary(pl.UTF-8):     Serwer IMAP i POP3 pisany głównie z myślą o bezpieczeństwie
 Name:          dovecot
-Version:       1.0.11
+Version:       1.1.14
 Release:       1
 Epoch:         1
 License:       MIT (libraries), LGPL v2.1 (the rest)
 Group:         Networking/Daemons
-Source0:       http://dovecot.org/releases/1.0/%{name}-%{version}.tar.gz
-# Source0-md5: eafc8bab69d176cfdbb8343658e7feca
+Source0:       http://dovecot.org/releases/1.1/%{name}-%{version}.tar.gz
+# Source0-md5: 60b1deccc0ae77e5669060d2b1894e5e
 Source1:       %{name}.pamd
 Source2:       %{name}.init
 Source3:       %{name}.sysconfig
@@ -25,7 +26,7 @@ BuildRequires:        autoconf
 BuildRequires: automake
 %{?with_sasl:BuildRequires:    cyrus-sasl-devel >= 2.0}
 BuildRequires: gettext-devel
-BuildRequires: krb5-devel
+%{?with_gssapi:BuildRequires:  krb5-devel}
 BuildRequires: libtool
 %{?with_mysql:BuildRequires:   mysql-devel}
 %{?with_ldap:BuildRequires:    openldap-devel >= 2.3.3}
@@ -144,7 +145,7 @@ touch config.rpath
        %{?with_pgsql:--with-pgsql} \
        %{?with_sasl:--with-cyrus-sasl2} \
        %{?with_sqlite:--with-sqlite} \
-       --with-gssapi \
+       %{?with_gssapi:--with-gssapi} \
        --with-ssl=openssl \
        --with-ssl-dir=/var/lib/openssl \
        --sysconfdir=/etc/%{name}
@@ -154,7 +155,6 @@ touch config.rpath
 %install
 rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT/etc/{pam.d,rc.d/init.d,sysconfig,security}
-install -d $RPM_BUILD_ROOT{%{_libdir},%{_bindir}}
 install -d $RPM_BUILD_ROOT{/var/lib/dovecot,/var/run/dovecot/login}
 
 %{__make} install \
@@ -172,13 +172,17 @@ touch $RPM_BUILD_ROOT/etc/security/blacklist.imap
 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/plugins{,/imap}/*.la
 
 # devel
+for folder in deliver imap lib lib-imap lib-mail lib-storage; do
+       install -d $RPM_BUILD_ROOT%{_includedir}/%{name}/$folder
+       install -p -m644 src/$folder/*.h $RPM_BUILD_ROOT%{_includedir}/%{name}/$folder/
+done
 for dir in lib lib-imap lib-mail lib-storage; do
        install -d $RPM_BUILD_ROOT%{_libdir}/%{name}-devel/src/$dir
        install -p -m644 src/$dir/*.a $RPM_BUILD_ROOT%{_libdir}/%{name}-devel/src/$dir
 done
 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/dovecot-config $RPM_BUILD_ROOT%{_libdir}/%{name}-devel
 
-rm -r $RPM_BUILD_ROOT%{_docdir}/%{name}/wiki
+rm -rf $RPM_BUILD_ROOT%{_docdir}/%{name}
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -209,6 +213,10 @@ if [ "$1" = "0" ]; then
        %groupremove dovecot
 fi
 
+%triggerpostun -- dovecot < 1:1.1
+echo "Configuration change default_mail_env -> mail_location"
+%{__sed} -i -e "s/^default_mail_env/mail_location/" /etc/dovecot/dovecot.conf
+
 %files
 %defattr(644,root,root,755)
 # COPYING contains some notes, not actual LGPL text
@@ -217,6 +225,9 @@ fi
 %attr(755,root,root) %{_sbindir}/%{name}pw
 %attr(750,root,root) %dir %{_sysconfdir}/%{name}
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/%{name}.conf
+%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/%{name}-db-example.conf
+%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/%{name}-ldap-example.conf
+%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/%{name}-sql-example.conf
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/%{name}
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/security/blacklist.imap
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/%{name}
@@ -230,7 +241,11 @@ fi
 %attr(755,root,root) %{_libdir}/%{name}/idxview
 %attr(755,root,root) %{_libdir}/%{name}/imap
 %attr(755,root,root) %{_libdir}/%{name}/imap-login
+%attr(755,root,root) %{_libdir}/%{name}/convert-tool
+%attr(755,root,root) %{_libdir}/%{name}/expire-tool
+%attr(755,root,root) %{_libdir}/%{name}/listview
 %attr(755,root,root) %{_libdir}/%{name}/logview
+%attr(755,root,root) %{_libdir}/%{name}/maildirlock
 %attr(755,root,root) %{_libdir}/%{name}/pop3
 %attr(755,root,root) %{_libdir}/%{name}/pop3-login
 %attr(755,root,root) %{_libdir}/%{name}/rawlog
This page took 0.031917 seconds and 4 git commands to generate.