]> git.pld-linux.org Git - packages/dovecot.git/blobdiff - dovecot.spec
- fd leak fix
[packages/dovecot.git] / dovecot.spec
index c8ec8bf079834404c51a07f09c9ca1a49d8c0ae0..0aea78e4513cb3293e61701d942fb46f579accdd 100644 (file)
@@ -1,5 +1,6 @@
 #
 # Conditional build:
+%bcond_with    gssapi  # with GSSAPI support
 %bcond_without ldap    # without LDAP auth
 %bcond_without mysql   # without MySQL auth
 %bcond_without pgsql   # without PostgreSQL auth
 Summary:       IMAP and POP3 server written with security primarily in mind
 Summary(pl.UTF-8):     Serwer IMAP i POP3 pisany głównie z myślą o bezpieczeństwie
 Name:          dovecot
-Version:       1.0.10
-Release:       5
+Version:       1.1.2
+Release:       1
 Epoch:         1
 License:       MIT (libraries), LGPL v2.1 (the rest)
 Group:         Networking/Daemons
-Source0:       http://dovecot.org/releases/1.0/%{name}-%{version}.tar.gz
-# Source0-md5: c050fa2a7dae8984d432595e3e8183e1
+Source0:       http://dovecot.org/releases/1.1/%{name}-%{version}.tar.gz
+# Source0-md5: fcebb6c099421049632b2f1f019f55cd
 Source1:       %{name}.pamd
 Source2:       %{name}.init
 Source3:       %{name}.sysconfig
@@ -25,7 +26,7 @@ BuildRequires:        autoconf
 BuildRequires: automake
 %{?with_sasl:BuildRequires:    cyrus-sasl-devel >= 2.0}
 BuildRequires: gettext-devel
-BuildRequires: krb5-devel
+%{?with_gssapi:BuildRequires:  krb5-devel}
 BuildRequires: libtool
 %{?with_mysql:BuildRequires:   mysql-devel}
 %{?with_ldap:BuildRequires:    openldap-devel >= 2.3.3}
@@ -144,7 +145,7 @@ touch config.rpath
        %{?with_pgsql:--with-pgsql} \
        %{?with_sasl:--with-cyrus-sasl2} \
        %{?with_sqlite:--with-sqlite} \
-       --with-gssapi \
+       %{?with_gssapi:--with-gssapi} \
        --with-ssl=openssl \
        --with-ssl-dir=/var/lib/openssl \
        --sysconfdir=/etc/%{name}
@@ -172,6 +173,10 @@ touch $RPM_BUILD_ROOT/etc/security/blacklist.imap
 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/plugins{,/imap}/*.la
 
 # devel
+for folder in deliver imap lib lib-imap lib-mail lib-storage; do
+       install -d $RPM_BUILD_ROOT%{_includedir}/%{name}/$folder
+       install -p -m644 src/$folder/*.h $RPM_BUILD_ROOT%{_includedir}/%{name}/$folder/
+done
 for dir in lib lib-imap lib-mail lib-storage; do
        install -d $RPM_BUILD_ROOT%{_libdir}/%{name}-devel/src/$dir
        install -p -m644 src/$dir/*.a $RPM_BUILD_ROOT%{_libdir}/%{name}-devel/src/$dir
@@ -217,6 +222,8 @@ fi
 %attr(755,root,root) %{_sbindir}/%{name}pw
 %attr(750,root,root) %dir %{_sysconfdir}/%{name}
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/%{name}.conf
+%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/%{name}-ldap-example.conf
+%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/%{name}-sql-example.conf
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/%{name}
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/security/blacklist.imap
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/%{name}
@@ -230,7 +237,11 @@ fi
 %attr(755,root,root) %{_libdir}/%{name}/idxview
 %attr(755,root,root) %{_libdir}/%{name}/imap
 %attr(755,root,root) %{_libdir}/%{name}/imap-login
+%attr(755,root,root) %{_libdir}/%{name}/convert-tool
+%attr(755,root,root) %{_libdir}/%{name}/expire-tool
+%attr(755,root,root) %{_libdir}/%{name}/listview
 %attr(755,root,root) %{_libdir}/%{name}/logview
+%attr(755,root,root) %{_libdir}/%{name}/maildirlock
 %attr(755,root,root) %{_libdir}/%{name}/pop3
 %attr(755,root,root) %{_libdir}/%{name}/pop3-login
 %attr(755,root,root) %{_libdir}/%{name}/rawlog
This page took 0.036884 seconds and 4 git commands to generate.