]> git.pld-linux.org Git - packages/dnf.git/blobdiff - dnf.spec
rpm version for noarch subpackage
[packages/dnf.git] / dnf.spec
index ff81fc3edc0f861331677fa6233848df60172551..6fc447a3449b329b398e57753832769ce0af41ab 100644 (file)
--- a/dnf.spec
+++ b/dnf.spec
@@ -2,16 +2,18 @@
 # Conditional build:
 %bcond_without tests           # build without tests
 #
-%define        hawkey_ver      0.59.0
-%define        libcomps_ver    0.1.8
-%define        libmodulemd_ver 2.9.3
-%define        rpm_ver         4.14.0
+%define                hawkey_ver              0.67.0
+%define                libcomps_ver            0.1.8
+%define                libmodulemd_ver         2.9.3
+%define                rpm_ver                 4.14.0
+
+%define                _enable_debug_packages  0
 
 Summary:       Package manager
 Summary(pl.UTF-8):     Zarządca pakietów
 Name:          dnf
 Version:       4.12.0
-Release:       0.1
+Release:       2
 Group:         Base
 # GPL v2+ with GPL v2 and GPL parts; for a breakdown of the licensing, see PACKAGE-LICENSING
 License:       GPL v2 (parts on GPL v2+ or GPL)
@@ -23,6 +25,7 @@ Source3:      pld-debuginfo.repo
 Source4:       pld-multilib.repo
 Patch0:                install.patch
 Patch1:                repos.d.patch
+Patch2:                uname-cpuinfo-deps.patch
 URL:           https://github.com/rpm-software-management/dnf
 BuildRequires: bash-completion-devel
 BuildRequires: cmake >= 2.4
@@ -36,6 +39,7 @@ BuildRequires:        python3-libdnf >= %{hawkey_ver}
 BuildRequires: python3-modules
 BuildRequires: python3-nose
 BuildRequires: python3-rpm >= %{rpm_ver}
+BuildRequires: rpm-build >= 4.6
 BuildRequires: rpmbuild(macros) >= 1.647
 BuildRequires: rpm-pythonprov
 BuildRequires: sed >= 4.0
@@ -47,13 +51,13 @@ Requires:   python3-gpg
 Requires:      python3-hawkey >= %{hawkey_ver}
 Requires:      python3-libcomps >= %{libcomps_ver}
 Requires:      python3-libdnf >= %{hawkey_ver}
+Requires:      python3-modules
 Requires:      python3-rpm
 Requires:      systemd-units >= 0.38
 Recommends:    deltarpm
 Recommends:    python3-dbus
 Recommends:    python3-unbound
 Recommends:    rpm-plugin-systemd-inhibit
-BuildArch:     noarch
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
@@ -63,18 +67,6 @@ supports RPMs, modules and comps groups & environments.
 %description -l pl.UTF-8
 Marzędzie umożliwiające użytkownikom zarządzanie pakietami w systemie.
 
-%package common
-Summary:       Common data and configuration files for DNF
-Summary(pl.UTF-8):     Wspólne dane i pliki konfiguracyjne dla DNF-a
-Group:         Base
-Requires:      libreport-filesystem
-
-%description common
-Common data and configuration files for DNF.
-
-%description common -l pl.UTF-8
-Wspólne dane i pliki konfiguracyjne dla DNF-a.
-
 %package automatic
 Summary:       Alternative CLI to "dnf upgrade" suitable for automatic, regular execution
 Summary(pl.UTF-8):     Alternatywny interfejs do "dnf upgrade" nadający się do automatycznego wywoływania
@@ -83,6 +75,8 @@ Requires(post):       systemd
 Requires(preun):       systemd
 Requires(postun):      systemd
 Requires:      %{name} = %{version}-%{release}
+Requires:      python3-modules
+BuildArch:     noarch
 
 %description automatic
 Alternative CLI to "dnf upgrade" suitable for automatic, regular
@@ -98,6 +92,7 @@ Summary(pl.UTF-8):    Bashowe uzupełnianie parametrów dla polecenia dnf
 Group:         Applications/Shells
 Requires:      %{name} = %{version}-%{release}
 Requires:      bash-completion
+BuildArch:     noarch
 
 %description -n bash-completion-dnf
 Bash completion for dnf command.
@@ -112,6 +107,7 @@ Group:              Base
 Requires:      %{name} = %{version}-%{release}
 Recommends:    sqlite3
 Conflicts:     yum < 3.4.3-505
+BuildArch:     noarch
 
 %description -n yum
 Yum compatibility layer for DNF.
@@ -123,6 +119,7 @@ Warstwa zgodności z YUM-em dla DNF-a.
 %setup -q
 %patch0 -p1
 %patch1 -p1
+%patch2 -p1
 
 %build
 install -d build
This page took 0.123923 seconds and 4 git commands to generate.