]> git.pld-linux.org Git - packages/dbus-glib.git/blobdiff - dbus-glib.spec
- 0.82
[packages/dbus-glib.git] / dbus-glib.spec
index 6747fc4bc1f231b728165343d3fe8498f776558e..fb993567eb0d836f716f03a6e48ca09bb0d6a537 100644 (file)
@@ -1,26 +1,32 @@
 #
-%define                dbus_version    0.94
+# Conditional build:
+%bcond_without apidocs         # disable gtk-doc
+%bcond_without static_libs     # don't build static library
+#
+%define                dbus_version    1.1
 %define                expat_version   1:1.95.5
 %define                glib_version    1:2.10.1
 #
 Summary:       GLib-based library for using D-BUS
-Summary(pl.UTF-8):   Biblioteka do używania D-BUS oparta o GLib
+Summary(pl.UTF-8):     Biblioteka do używania D-BUS oparta o GLib
 Name:          dbus-glib
-Version:       0.72
+Version:       0.82
 Release:       1
 License:       AFL v2.1 or GPL v2
 Group:         Libraries
 Source0:       http://dbus.freedesktop.org/releases/dbus-glib/%{name}-%{version}.tar.gz
-# Source0-md5: 6e92993aed234f13ea41c674dec40889
+# Source0-md5: aa2a4517de0e9144be3bce2cf8cdd924
 Source1:       dbus-bus-introspect.xml
 Patch0:                %{name}-configure.patch
-Patch1:                %{name}-nolibs.patch
+Patch1:                %{name}-as-needed.patch
 URL:           http://www.freedesktop.org/Software/DBusBindings
 BuildRequires: autoconf >= 2.52
 BuildRequires: automake >= 1:1.9
 BuildRequires: dbus-devel >= %{dbus_version}
 BuildRequires: expat-devel >= %{expat_version}
+BuildRequires: gettext-devel
 BuildRequires: glib2-devel >= %{glib_version}
+%{?with_apidocs:BuildRequires: gtk-doc-automake >= 1.8}
 BuildRequires: libtool
 BuildRequires: pkgconfig
 BuildRequires: rpmbuild(macros) >= 1.98
@@ -37,7 +43,7 @@ z abstrakcją wątków i główną pętlą GLib.
 
 %package devel
 Summary:       Header files for GLib-based library for using D-BUS
-Summary(pl.UTF-8):   Pliki nagłówkowe biblioteki do używania D-BUS opartej o GLib
+Summary(pl.UTF-8):     Pliki nagłówkowe biblioteki do używania D-BUS opartej o GLib
 Group:         Development/Libraries
 Requires:      %{name} = %{version}-%{release}
 Requires:      dbus-devel >= %{dbus_version}
@@ -51,7 +57,7 @@ Pliki nagłówkowe biblioteki do używania D-BUS opartej o GLib.
 
 %package static
 Summary:       Static GLib-based library for using D-BUS
-Summary(pl.UTF-8):   Statyczna biblioteka do używania D-BUS oparta o GLib
+Summary(pl.UTF-8):     Statyczna biblioteka do używania D-BUS oparta o GLib
 Group:         Development/Libraries
 Requires:      %{name}-devel = %{version}-%{release}
 
@@ -63,7 +69,7 @@ Statyczna biblioteka do używania D-BUS oparta o GLib.
 
 %package apidocs
 Summary:       D-BUS-GLib API documentation
-Summary(pl.UTF-8):   Dokumentacja API D-BUS-GLib
+Summary(pl.UTF-8):     Dokumentacja API D-BUS-GLib
 Group:         Documentation
 Requires:      gtk-doc-common
 
@@ -73,11 +79,28 @@ D-BUS-GLib API documentation.
 %description apidocs -l pl.UTF-8
 Dokumentacja API D-BUS-GLib.
 
+%package -n bash-completion-dbus
+Summary:       bash-completion for dbus-send
+Summary(pl.UTF-8):     Bashowe uzupełnianie poleceń dla dbus-send
+Group:         Applications/Shells
+Requires:      bash-completion
+
+%description -n bash-completion-dbus
+This package provides bash-completion for dbus-send.
+
+%description -n bash-completion-dbus -l pl.UTF-8
+Ten pakiet dostarcza bashowe uzupełnianie poleceń dla dbus-send.
+
 %prep
 %setup -q
 %patch0 -p1
 %patch1 -p1
 
+%if %{without apidocs}
+echo 'EXTRA_DIST=' > gtk-doc.make
+echo 'AC_DEFUN([GTK_DOC_CHECK],[])' >> acinclude.m4
+%endif
+
 %build
 %{__libtoolize}
 %{__aclocal}
@@ -85,7 +108,9 @@ Dokumentacja API D-BUS-GLib.
 %{__autoheader}
 %{__automake}
 %configure \
-       --with-html-dir=%{_gtkdocdir} \
+       %{!?with_apidocs:--disable-gtk-doc} \
+       %{?with_apidocs:--with-html-dir=%{_gtkdocdir}} \
+       %{!?with_static_libs:--disable-static} \
        --with-xml=expat
 
 cp %{SOURCE1} tools
@@ -96,7 +121,10 @@ cp %{SOURCE1} tools
 rm -rf $RPM_BUILD_ROOT
 
 %{__make} install \
-       DESTDIR=$RPM_BUILD_ROOT
+       DESTDIR=$RPM_BUILD_ROOT \
+       profiledir=/etc/bash_completion.d
+
+mv -f $RPM_BUILD_ROOT/etc/bash_completion.d/{dbus-bash-completion.sh,dbus}
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -109,20 +137,31 @@ rm -rf $RPM_BUILD_ROOT
 # AFL not in common-licenses, so COPYING included
 %doc AUTHORS COPYING ChangeLog NEWS README
 %attr(755,root,root) %{_libdir}/libdbus-glib-1.so.*.*.*
+%attr(755,root,root) %ghost %{_libdir}/libdbus-glib-1.so.2
 
 %files devel
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/dbus-binding-tool
 %attr(755,root,root) %{_libdir}/libdbus-glib-1.so
 %{_libdir}/libdbus-glib-1.la
+%{_mandir}/man1/dbus-binding-tool.1*
 %{_includedir}/dbus*/dbus/dbus-glib*.h
 %{_includedir}/dbus*/dbus/dbus-gtype-specialized.h
 %{_pkgconfigdir}/dbus-glib-1.pc
 
+%if %{with static_libs}
 %files static
 %defattr(644,root,root,755)
 %{_libdir}/libdbus-glib-1.a
+%endif
 
+%if %{with apidocs}
 %files apidocs
 %defattr(644,root,root,755)
 %{_gtkdocdir}/dbus-glib
+%endif
+
+%files -n bash-completion-dbus
+%defattr(644,root,root,755)
+/etc/bash_completion.d/dbus
+%attr(755,root,root) %{_libdir}/dbus-bash-completion-helper
This page took 0.083984 seconds and 4 git commands to generate.