]> git.pld-linux.org Git - packages/dahdi-linux.git/blobdiff - dahdi-linux.spec
- userspace bcond
[packages/dahdi-linux.git] / dahdi-linux.spec
index 1fac3056e06ce86cd7a6c98383b272697ab595e1..b0c006ed23e872f18ac22f05c24cd1d27b1bf857 100644 (file)
@@ -1,13 +1,26 @@
 #
 # TODO:
 # - IMPORTANT rename: http://www.asterisk.org/zaptel-to-dahdi
+# - Fix --without xpp:
+#   + check_modules
+#   unpackaged module: drivers/dahdi/xpp/xpd_bri
+#   unpackaged module: drivers/dahdi/xpp/xpd_fxo
+#   unpackaged module: drivers/dahdi/xpp/xpd_fxs
+#   unpackaged module: drivers/dahdi/xpp/xpd_pri
+#   unpackaged module: drivers/dahdi/xpp/xpp
+#   unpackaged module: drivers/dahdi/xpp/xpp_usb
 #
 # Conditional build:
 %bcond_without dist_kernel     # without distribution kernel
 %bcond_with    oslec           # with Open Source Line Echo Canceller
 %bcond_without xpp             # without Astribank
+%bcond_without userspace       # don't build userspace packages
 %bcond_with    verbose
 
+%if "%{_alt_kernel}" != "%{nil}"
+%undefine      with_userspace
+%endif
+
 %ifarch sparc
 %undefine      with_smp
 %endif
@@ -15,7 +28,7 @@
 %undefine      with_xpp
 %endif
 
-%define                rel     2
+%define                rel     3
 %define                pname   dahdi-linux
 %define                FIRMWARE_URL http://downloads.digium.com/pub/telephony/firmware/releases
 Summary:       DAHDI telephony device support
@@ -87,6 +100,7 @@ Summary:     udev rules for DAHDI kernel modules
 Summary(pl.UTF-8):     Reguły udev dla modułów jądra Linuksa dla DAHDI
 Release:       %{rel}
 Group:         Base/Kernel
+Requires:      dahdi-tools >= 2.2.0
 Requires:      udev-core
 
 %description udev
@@ -155,12 +169,14 @@ cd drivers/dahdi
 %install_kernel_modules -m %{modules_in} -d misc
 cd ../..
 
+%if %{with userspace}
 install -d $RPM_BUILD_ROOT/etc/udev/rules.d
 
 %{make} \
        DESTDIR=$RPM_BUILD_ROOT \
        install-devices \
        install-include
+%endif
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -171,6 +187,7 @@ rm -rf $RPM_BUILD_ROOT
 %postun -n kernel%{_alt_kernel}-%{pname}
 %depmod %{_kernel_ver}
 
+%if %{with userspace}
 %files devel
 %defattr(644,root,root,755)
 %{_includedir}/dahdi
@@ -179,6 +196,7 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %config(noreplace) %verify(not md5 mtime size) /etc/udev/rules.d/dahdi.rules
 %config(noreplace) %verify(not md5 mtime size) /etc/udev/rules.d/xpp.rules
+%endif
 
 %files -n kernel%{_alt_kernel}-%{pname}
 %defattr(644,root,root,755)
This page took 0.088774 seconds and 4 git commands to generate.