]> git.pld-linux.org Git - packages/curl.git/blobdiff - curl.spec
- --enable-ldaps
[packages/curl.git] / curl.spec
index f692673d00d80fe6c566f30e5fdd0a2ee8e6596c..ebec61145c6bd158f15b5b128a2466866377914c 100644 (file)
--- a/curl.spec
+++ b/curl.spec
@@ -3,6 +3,7 @@
 %bcond_with    ares            # with c-ares (asynchronous DNS operations) library (disables IPv6)
 %bcond_without ssh             # without SSH support
 %bcond_without ssl             # without SSL support
+%bcond_without gnutls          # use GnuTLS instead of OpenSSL
 %bcond_without kerberos5       # without MIT Kerberos 5 support
 #
 Summary:       A utility for getting files from remote servers (FTP, HTTP, and others)
@@ -12,12 +13,12 @@ Summary(pt_BR.UTF-8):       Busca URL (suporta FTP, TELNET, LDAP, GOPHER, DICT, HTTP e
 Summary(ru.UTF-8):     Утилита для получения файлов с серверов FTP, HTTP и других
 Summary(uk.UTF-8):     Утиліта для отримання файлів з серверів FTP, HTTP та інших
 Name:          curl
-Version:       7.17.0
+Version:       7.19.2
 Release:       1
 License:       MIT-like
 Group:         Applications/Networking
 Source0:       http://curl.haxx.se/download/%{name}-%{version}.tar.bz2
-# Source0-md5: b529a8d2778c8ad09c33d9bbddee7e44
+# Source0-md5: 3a461b145a4a31fe7d5a44684e7fbdbc
 Patch0:                %{name}-no_strip.patch
 Patch1:                %{name}-ac.patch
 Patch2:                %{name}-pc.patch
@@ -29,11 +30,18 @@ BuildRequires:      automake
 BuildRequires: libidn-devel >= 0.4.1
 %{?with_ssh:BuildRequires:     libssh2-devel >= 0.16}
 BuildRequires: libtool
-%{?with_ssl:BuildRequires:     openssl-devel >= 0.9.7d}
+BuildRequires: openldap-devel
+%if %{with ssl}
+%if %{with gnutls}
+BuildRequires: gnutls-devel
+%else
+BuildRequires: openssl-devel >= 0.9.7d
+%endif
+%endif
 BuildRequires: zlib-devel
 Requires:      %{name}-libs = %{version}-%{release}
 Requires:      libidn >= 0.4.1
-Requires:      libssh2 >= 0.16
+%{?with_ssh:Requires:  libssh2 >= 0.16}
 Requires:      openssl-tools >= 0.9.7d
 Obsoletes:     libcurl2
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
@@ -110,7 +118,13 @@ Requires:  %{name}-libs = %{version}-%{release}
 %{?with_kerberos5:Requires:    krb5-devel}
 Requires:      libidn-devel >= 0.4.1
 %{?with_ssh:Requires:  libssh2-devel >= 0.16}
-%{?with_ssl:Requires:  openssl-devel >= 0.9.7c}
+%if %{with ssl}
+%if %{with gnutls}
+Requires:      gnutls-devel
+%else
+Requires:      openssl-devel >= 0.9.7c
+%endif
+%endif
 Requires:      zlib-devel
 Obsoletes:     libcurl2-devel
 
@@ -165,16 +179,23 @@ Bibliotecas estáticas para desenvolvimento com o curl.
 
 %build
 %{__libtoolize}
-%{__aclocal}
+%{__aclocal} -I m4
 %{__autoconf}
 %{__autoheader}
 %{__automake}
 %configure \
        ac_cv_header_gss_h=no \
-       %{?with_ssl:--with-ssl=%{_prefix}} \
-       %{?with_ssl:--with-ca-bundle=/usr/share/ssl/ca-bundle.crt} \
+%if %{with ssl}
+       --with-ca-bundle=/etc/certs/ca-certificates.crt \
+%if %{with gnutls}
+       --with-gnutls=%{_prefix} --without-ssl \
+%else
+       --with-ssl=%{_prefix} \
+%endif
+%endif
        %{?with_kerberos5:--with-gssapi=%{_prefix}} \
        %{?with_ares:--enable-ares=%{_prefix}} \
+       --enable-ldaps \
        --%{?with_ares:dis}%{!?with_ares:en}able-ipv6
 
 %{__make}
@@ -200,6 +221,7 @@ rm -rf $RPM_BUILD_ROOT
 %files libs
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/libcurl.so.*.*.*
+%attr(755,root,root) %ghost %{_libdir}/libcurl.so.4
 
 %files devel
 %defattr(644,root,root,755)
@@ -210,7 +232,8 @@ rm -rf $RPM_BUILD_ROOT
 %{_includedir}/curl
 %{_pkgconfigdir}/libcurl.pc
 %{_mandir}/man1/curl-config.1*
-%{_mandir}/man3/*curl*.3*
+%{_mandir}/man3/curl_*.3*
+%{_mandir}/man3/libcurl*.3*
 
 %files static
 %defattr(644,root,root,755)
This page took 0.528935 seconds and 4 git commands to generate.