]> git.pld-linux.org Git - packages/curl.git/blobdiff - curl.spec
- --enable-ldaps
[packages/curl.git] / curl.spec
index 9586d9d88a89e7afea559fe1f4ac493f78fbb0fc..ebec61145c6bd158f15b5b128a2466866377914c 100644 (file)
--- a/curl.spec
+++ b/curl.spec
@@ -3,6 +3,7 @@
 %bcond_with    ares            # with c-ares (asynchronous DNS operations) library (disables IPv6)
 %bcond_without ssh             # without SSH support
 %bcond_without ssl             # without SSL support
+%bcond_without gnutls          # use GnuTLS instead of OpenSSL
 %bcond_without kerberos5       # without MIT Kerberos 5 support
 #
 Summary:       A utility for getting files from remote servers (FTP, HTTP, and others)
@@ -12,12 +13,12 @@ Summary(pt_BR.UTF-8):       Busca URL (suporta FTP, TELNET, LDAP, GOPHER, DICT, HTTP e
 Summary(ru.UTF-8):     Утилита для получения файлов с серверов FTP, HTTP и других
 Summary(uk.UTF-8):     Утиліта для отримання файлів з серверів FTP, HTTP та інших
 Name:          curl
-Version:       7.18.2
+Version:       7.19.2
 Release:       1
 License:       MIT-like
 Group:         Applications/Networking
 Source0:       http://curl.haxx.se/download/%{name}-%{version}.tar.bz2
-# Source0-md5: c389be5b0525276e58865956b7465562
+# Source0-md5: 3a461b145a4a31fe7d5a44684e7fbdbc
 Patch0:                %{name}-no_strip.patch
 Patch1:                %{name}-ac.patch
 Patch2:                %{name}-pc.patch
@@ -30,7 +31,13 @@ BuildRequires:       libidn-devel >= 0.4.1
 %{?with_ssh:BuildRequires:     libssh2-devel >= 0.16}
 BuildRequires: libtool
 BuildRequires: openldap-devel
-%{?with_ssl:BuildRequires:     openssl-devel >= 0.9.7d}
+%if %{with ssl}
+%if %{with gnutls}
+BuildRequires: gnutls-devel
+%else
+BuildRequires: openssl-devel >= 0.9.7d
+%endif
+%endif
 BuildRequires: zlib-devel
 Requires:      %{name}-libs = %{version}-%{release}
 Requires:      libidn >= 0.4.1
@@ -111,7 +118,13 @@ Requires:  %{name}-libs = %{version}-%{release}
 %{?with_kerberos5:Requires:    krb5-devel}
 Requires:      libidn-devel >= 0.4.1
 %{?with_ssh:Requires:  libssh2-devel >= 0.16}
-%{?with_ssl:Requires:  openssl-devel >= 0.9.7c}
+%if %{with ssl}
+%if %{with gnutls}
+Requires:      gnutls-devel
+%else
+Requires:      openssl-devel >= 0.9.7c
+%endif
+%endif
 Requires:      zlib-devel
 Obsoletes:     libcurl2-devel
 
@@ -166,16 +179,23 @@ Bibliotecas estáticas para desenvolvimento com o curl.
 
 %build
 %{__libtoolize}
-%{__aclocal}
+%{__aclocal} -I m4
 %{__autoconf}
 %{__autoheader}
 %{__automake}
 %configure \
        ac_cv_header_gss_h=no \
-       %{?with_ssl:--with-ssl=%{_prefix}} \
-       %{?with_ssl:--with-ca-bundle=/usr/share/ssl/ca-bundle.crt} \
+%if %{with ssl}
+       --with-ca-bundle=/etc/certs/ca-certificates.crt \
+%if %{with gnutls}
+       --with-gnutls=%{_prefix} --without-ssl \
+%else
+       --with-ssl=%{_prefix} \
+%endif
+%endif
        %{?with_kerberos5:--with-gssapi=%{_prefix}} \
        %{?with_ares:--enable-ares=%{_prefix}} \
+       --enable-ldaps \
        --%{?with_ares:dis}%{!?with_ares:en}able-ipv6
 
 %{__make}
This page took 0.064636 seconds and 4 git commands to generate.