]> git.pld-linux.org Git - packages/curl.git/blobdiff - curl.spec
- up to 7.15.3, resolves CVE-2006-1061
[packages/curl.git] / curl.spec
index 937286e0a20a3f5f5213d789329324435eea92af..a5b99e892b7b0413e81ee5160e0b199952b5cbab 100644 (file)
--- a/curl.spec
+++ b/curl.spec
@@ -10,24 +10,25 @@ Summary(pt_BR):     Busca URL (suporta FTP, TELNET, LDAP, GOPHER, DICT, HTTP e HTTPS
 Summary(ru):   õÔÉÌÉÔÁ ÄÌÑ ÐÏÌÕÞÅÎÉÑ ÆÁÊÌÏ× Ó ÓÅÒ×ÅÒÏ× FTP, HTTP É ÄÒÕÇÉÈ
 Summary(uk):   õÔÉ̦ÔÁ ÄÌÑ ÏÔÒÉÍÁÎÎÑ ÆÁÊ̦נڠÓÅÒ×ÅҦנFTP, HTTP ÔÁ ¦ÎÛÉÈ
 Name:          curl
-Version:       7.14.0
-Release:       0.1
+Version:       7.15.3
+Release:       1
 License:       MIT-like
-Vendor:                Daniel Stenberg <Daniel.Stenberg@sth.frontec.se>
 Group:         Applications/Networking
 Source0:       http://curl.haxx.se/download/%{name}-%{version}.tar.bz2
-# Source0-md5: 46ce665e47d37fce1a0bad935cce58a9
+# Source0-md5: d71b2ee8febfde2c7dc30a43638ec0d9
 Patch0:                %{name}-no_strip.patch
 Patch1:                %{name}-ac.patch
+Patch2:                %{name}-heimdal.patch
 URL:           http://curl.haxx.se/
 BuildRequires: autoconf >= 2.57
 BuildRequires: automake
+%{?with_heimdal:BuildRequires: heimdal-devel >= 0.7}
 BuildRequires: libidn-devel >= 0.4.1
-%{?with_heimdal:BuildRequires: heimdal-devel}
 BuildRequires: libtool
 %{?with_ssl:BuildRequires:     openssl-devel >= 0.9.7d}
-Requires:      openssl-tools >= 0.9.7d
+Requires:      %{name}-libs = %{version}-%{release}
 Requires:      libidn >= 0.4.1
+Requires:      openssl-tools >= 0.9.7d
 Obsoletes:     libcurl2
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
@@ -80,6 +81,17 @@ curl Ц
 ÐÒÏËÓ¦, Á×ÔÏÒÉÚÁæѠËÏÒÉÓÔÕ×ÁÞÁ, ×¦Ä×ÁÎÔÁÖÅÎÎÑ ÐÏ FTP, HTTP POST,
 ×¦ÄÎÏ×ÌÅÎÎÑ ÐÅÒÅÒ×ÁÎϧ ÐÅÒÅÓÉÌËÉ ÔÁ ÂÁÇÁÔÏ ¦ÎÛÏÇÏ.
 
+%package libs
+Summary:       curl library
+Summary(pl):   Biblioteka curl
+Group:         Libraries
+
+%description libs
+curl library.
+
+%description libs -l pl
+Biblioteka curl.
+
 %package devel
 Summary:       Header files and development documentation for curl library
 Summary(pl):   Pliki nag³ówkowe i dokumentacja do biblioteki curl
@@ -87,9 +99,9 @@ Summary(pt_BR):       Arquivos de cabe
 Summary(ru):   æÁÊÌÙ ÄÌÑ ÒÁÚÒÁÂÏÔËÉ Ó ÉÓÐÏÌØÚÏ×ÁÎÉÅÍ ÂÉÂÌÉÏÔÅËÉ curl
 Summary(uk):   æÁÊÌÉ ÄÌÑ ÒÏÚÒÏÂËÉ Ú ×ÉËÏÒÉÓÔÁÎÎÑ͠¦Â̦ÏÔÅËÉ curl
 Group:         Development/Libraries
-Requires:      %{name} = %{version}-%{release}
-Requires:      libidn-devel >= 0.4.1
+Requires:      %{name}-libs = %{version}-%{release}
 %{?with_heimdal:Requires:      heimdal-devel}
+Requires:      libidn-devel >= 0.4.1
 %{?with_ssl:Requires:  openssl-devel >= 0.9.7c}
 Obsoletes:     libcurl2-devel
 
@@ -140,6 +152,7 @@ Bibliotecas est
 %setup -q
 %patch0 -p1
 %patch1 -p1
+%{?with_heimdal:%patch2 -p0}
 
 %build
 %{__libtoolize}
@@ -150,7 +163,7 @@ Bibliotecas est
 %configure \
        %{?with_ssl:--with-ssl=%{_prefix}} \
        %{?with_ssl:--with-ca-bundle=/usr/share/ssl/ca-bundle.crt} \
-       %{?with_heimdal:--with-gssapi-includes=%{_includedir}} \
+       %{?with_heimdal:--with-gssapi=%{_prefix}} \
        --with-ipv6
 
 %{__make}
@@ -164,16 +177,19 @@ rm -rf $RPM_BUILD_ROOT
 %clean
 rm -rf $RPM_BUILD_ROOT
 
-%post  -p /sbin/ldconfig
-%postun -p /sbin/ldconfig
+%post  libs -p /sbin/ldconfig
+%postun libs -p /sbin/ldconfig
 
 %files
 %defattr(644,root,root,755)
 %doc CHANGES COPYING README docs/{BUGS,FAQ,FEATURES,HISTORY,KNOWN_BUGS,MANUAL,SSLCERTS,THANKS,TODO,TheArtOfHttpScripting}
 %attr(755,root,root) %{_bindir}/curl
-%attr(755,root,root) %{_libdir}/libcurl.so.*.*.*
 %{_mandir}/man1/curl.1*
 
+%files libs
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_libdir}/libcurl.so.*.*.*
+
 %files devel
 %defattr(644,root,root,755)
 %doc docs/{CONTRIBUTE,INTERNALS,LICENSE-MIXING,RESOURCES}
@@ -181,6 +197,7 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_libdir}/libcurl.so
 %{_libdir}/libcurl.la
 %{_includedir}/curl
+%{_pkgconfigdir}/libcurl.pc
 %{_mandir}/man1/curl-config.1*
 %{_mandir}/man3/*curl*.3*
 
This page took 0.119424 seconds and 4 git commands to generate.