]> git.pld-linux.org Git - packages/curl.git/blobdiff - curl.spec
- updated to 7.12.2
[packages/curl.git] / curl.spec
index 1f374d40e21fa354fb333751855f46a1cb5f9d61..97d26b0446c2615b2e86d6ea855611bd365e3ec8 100644 (file)
--- a/curl.spec
+++ b/curl.spec
@@ -1,3 +1,7 @@
+#
+# Conditional build:
+%bcond_without  ssl    # without SSL support
+#
 Summary:       A utility for getting files from remote servers (FTP, HTTP, and others)
 Summary(es):   Busca URL (soporta FTP, TELNET, LDAP, GOPHER, DICT, HTTP y HTTPS)
 Summary(pl):   Narzêdzie do ¶ci±gania plików z serwerów (FTP, HTTP i innych)
@@ -5,17 +9,25 @@ Summary(pt_BR):       Busca URL (suporta FTP, TELNET, LDAP, GOPHER, DICT, HTTP e HTTPS
 Summary(ru):   õÔÉÌÉÔÁ ÄÌÑ ÐÏÌÕÞÅÎÉÑ ÆÁÊÌÏ× Ó ÓÅÒ×ÅÒÏ× FTP, HTTP É ÄÒÕÇÉÈ
 Summary(uk):   õÔÉ̦ÔÁ ÄÌÑ ÏÔÒÉÍÁÎÎÑ ÆÁÊ̦נڠÓÅÒ×ÅҦנFTP, HTTP ÔÁ ¦ÎÛÉÈ
 Name:          curl
-Version:       7.10
+Version:       7.12.2
 Release:       1
 License:       MPL
 Vendor:                Daniel Stenberg <Daniel.Stenberg@sth.frontec.se>
 Group:         Applications/Networking
-Source0:       http://curl.haxx.se/download/%{name}-%{version}.tar.gz
+Source0:       http://curl.haxx.se/download/%{name}-%{version}.tar.bz2
+# Source0-md5: e468222fc7240dc701ea3fc8ffd641dc
 Patch0:                %{name}-no_strip.patch
+Patch1:                %{name}-ac.patch
 URL:           http://curl.haxx.se/
-%{!?_without_ssl:BuildRequires:        openssl-devel >= 0.9.6a}
-BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
+BuildRequires: autoconf
+BuildRequires: automake
+BuildRequires: libidn-devel >= 0.4.1
+BuildRequires: heimdal-devel
+%{?with_ssl:BuildRequires:     openssl-devel >= 0.9.7d}
+Requires:      openssl-tools >= 0.9.7d
+Requires:      libidn >= 0.4.1
 Obsoletes:     libcurl2
+BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
 cURL is a tool for getting files with URL syntax, supporting FTP,
@@ -47,8 +59,7 @@ oparte na formularzu, serwery proksy, ciasteczka, autoryzacja
 u¿ytkownik/has³o oraz wiele innych u¿ytecznych sztuczek. Curla u¿ywa
 siê g³ównie wtedy, kiedy chce siê automatycznie ¶ci±gn±æ lub wys³aæ
 pliki z/na serwer u¿ywaj±c jednego z dostêpnych protoko³ów.
-
-Uwaga: ten pakiet wspiera takze SSL.
+%{?with_ssl:Ten pakiet obs³uguje tak¿e SSL.}
 
 %description -l pt_BR
 Curl é um cliente para baixar/enviar arquivos de/para servidores
@@ -82,7 +93,9 @@ Summary(pt_BR):       Arquivos de cabe
 Summary(ru):   æÁÊÌÙ ÄÌÑ ÒÁÚÒÁÂÏÔËÉ Ó ÉÓÐÏÌØÚÏ×ÁÎÉÅÍ ÂÉÂÌÉÏÔÅËÉ curl
 Summary(uk):   æÁÊÌÉ ÄÌÑ ÒÏÚÒÏÂËÉ Ú ×ÉËÏÒÉÓÔÁÎÎÑ͠¦Â̦ÏÔÅËÉ curl
 Group:         Development/Libraries
-Requires:      %{name} = %{version}
+Requires:      %{name} = %{version}-%{release}
+Requires:      libidn-devel >= 0.4.1
+%{?with_ssl:Requires:  openssl-devel >= 0.9.7c}
 Obsoletes:     libcurl2-devel
 
 %description devel
@@ -109,7 +122,7 @@ Summary(pt_BR):     Bibliotecas est
 Summary(ru):   óÔÁÔÉÞÅÓËÉÅ ÂÉÂÌÉÏÔÅËÉ ÄÌÑ ÒÁÚÒÁÂÏÔËÉ Ó ÉÓÐÏÌØÚÏ×ÁÎÉÅÍ ÂÉÂÌÉÏÔÅËÉ curl
 Summary(uk):   óÔÁÔÉÞΦ Â¦Â̦ÏÔÅËÉ ÄÌÑ ÒÏÚÒÏÂËÉ Ú ×ÉËÏÒÉÓÔÁÎÎÑ͠¦Â̦ÏÔÅËÉ curl
 Group:         Development/Libraries
-Requires:      %{name}-devel = %{version}
+Requires:      %{name}-devel = %{version}-%{release}
 
 %description static
 Static version of curl library.
@@ -131,10 +144,16 @@ Bibliotecas est
 %prep
 %setup -q
 %patch0 -p1
+%patch1 -p1
 
 %build
+cp -f /usr/share/automake/config.* .
+%{__autoconf}
+%{__autoheader}
 %configure \
-       %{!?_without_ssl:--with-ssl=%{_prefix}} \
+       %{?with_ssl:--with-ssl=%{_prefix}} \
+       %{?with_ssl:--with-ca-bundle=/usr/share/ssl/ca-bundle.crt} \
+       --with-gssapi-includes=%{_includedir} \
        --with-ipv6
 
 %{__make}
@@ -142,7 +161,8 @@ Bibliotecas est
 %install
 rm -rf $RPM_BUILD_ROOT
 
-%{__make} install DESTDIR=$RPM_BUILD_ROOT
+%{__make} install \
+       DESTDIR=$RPM_BUILD_ROOT
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -162,7 +182,7 @@ rm -rf $RPM_BUILD_ROOT
 %doc docs/{BUGS,CONTRIBUTE,FAQ,FEATURES,INTERNALS,MANUAL,README*,RESOURCES,THANKS,TODO}
 %attr(755,root,root) %{_bindir}/%{name}-config
 %attr(755,root,root) %{_libdir}/lib*.so
-%attr(755,root,root) %{_libdir}/lib*.la
+%{_libdir}/lib*.la
 %{_includedir}/*
 %{_mandir}/man3/*
 
This page took 0.081934 seconds and 4 git commands to generate.