]> git.pld-linux.org Git - packages/curl.git/blobdiff - curl.spec
- up to 7.20.0
[packages/curl.git] / curl.spec
index a7413416ac8a39fbab724d4da83c4617fed58d63..33866a09b9c67ed9570414e3600d192d72096676 100644 (file)
--- a/curl.spec
+++ b/curl.spec
@@ -1,38 +1,51 @@
+# TODO
+# - VMware needs curl with ares
 #
 # Conditional build:
-%bcond_with    ares    # with c-ares (asynchronous DNS operations) library (disables IPv6)
-%bcond_without ssh     # without SSH support
-%bcond_without ssl     # without SSL support
-%bcond_without heimdal # without HEIMDAL support
+%bcond_without ares            # with c-ares (asynchronous DNS operations) library (c-ares may not work properly with ipv6)
+%bcond_without ssh             # without SSH support
+%bcond_without ssl             # without SSL support
+%bcond_without gnutls          # use GnuTLS instead of OpenSSL
+%bcond_without kerberos5       # without Heimdal Kerberos 5 support
 #
 Summary:       A utility for getting files from remote servers (FTP, HTTP, and others)
-Summary(es.UTF-8):   Un cliente para bajar archivos de servidores (FTP, HTTP, y otros)
-Summary(pl.UTF-8):   Narzędzie do ściągania plików z serwerów (FTP, HTTP i innych)
-Summary(pt_BR.UTF-8):   Busca URL (suporta FTP, TELNET, LDAP, GOPHER, DICT, HTTP e HTTPS)
-Summary(ru.UTF-8):   Утилита для получения файлов с серверов FTP, HTTP и других
-Summary(uk.UTF-8):   Утиліта для отримання файлів з серверів FTP, HTTP та інших
+Summary(es.UTF-8):     Un cliente para bajar archivos de servidores (FTP, HTTP, y otros)
+Summary(pl.UTF-8):     Narzędzie do ściągania plików z serwerów (FTP, HTTP i innych)
+Summary(pt_BR.UTF-8):  Busca URL (suporta FTP, TELNET, LDAP, GOPHER, DICT, HTTP e HTTPS)
+Summary(ru.UTF-8):     Утилита для получения файлов с серверов FTP, HTTP и других
+Summary(uk.UTF-8):     Утиліта для отримання файлів з серверів FTP, HTTP та інших
 Name:          curl
-Version:       7.16.1
+Version:       7.20.0
 Release:       1
 License:       MIT-like
 Group:         Applications/Networking
-Source0:       http://curl.haxx.se/download/%{name}-%{version}.tar.bz2
-# Source0-md5: acdab0b0467c55e10ed02d2afed80575
+Source0:       http://curl.haxx.se/download/%{name}-%{version}.tar.lzma
+# Source0-md5: a68d8169e4aae58d35977ae355c9b38a
 Patch0:                %{name}-no_strip.patch
 Patch1:                %{name}-ac.patch
-Patch2:                %{name}-heimdal.patch
+Patch2:                %{name}-pc.patch
+Patch3:                %{name}-krb5flags.patch
 URL:           http://curl.haxx.se/
 BuildRequires: autoconf >= 2.57
 BuildRequires: automake
 %{?with_ares:BuildRequires:    c-ares-devel}
-%{?with_heimdal:BuildRequires: heimdal-devel >= 0.7}
+%{?with_kerberos5:BuildRequires:       heimdal-devel}
 BuildRequires: libidn-devel >= 0.4.1
-%{?with_ssh:BuildRequires:     libssh2-devel}
+%{?with_ssh:BuildRequires:     libssh2-devel >= 0.16}
 BuildRequires: libtool
-%{?with_ssl:BuildRequires:     openssl-devel >= 0.9.7d}
+BuildRequires: openldap-devel
+%if %{with ssl}
+%if %{with gnutls}
+BuildRequires: gnutls-devel
+%else
+BuildRequires: openssl-devel >= 0.9.7d
+%endif
+%endif
+BuildRequires: tar >= 1:1.22
 BuildRequires: zlib-devel
 Requires:      %{name}-libs = %{version}-%{release}
 Requires:      libidn >= 0.4.1
+%{?with_ssh:Requires:  libssh2 >= 0.16}
 Requires:      openssl-tools >= 0.9.7d
 Obsoletes:     libcurl2
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
@@ -88,8 +101,10 @@ curl п╕дтриму╓ багато корисних можливостей,
 
 %package libs
 Summary:       curl library
-Summary(pl.UTF-8):   Biblioteka curl
+Summary(pl.UTF-8):     Biblioteka curl
 Group:         Libraries
+Suggests:      ca-certificates
+Conflicts:     ca-certificates < 20080809-4
 
 %description libs
 curl library.
@@ -99,16 +114,23 @@ Biblioteka curl.
 
 %package devel
 Summary:       Header files and development documentation for curl library
-Summary(pl.UTF-8):   Pliki nagłówkowe i dokumentacja do biblioteki curl
-Summary(pt_BR.UTF-8):   Arquivos de cabeçalho e bibliotecas de desenvolvimento
-Summary(ru.UTF-8):   Файлы для разработки с использованием библиотеки curl
-Summary(uk.UTF-8):   Файли для розробки з використанням бібліотеки curl
+Summary(pl.UTF-8):     Pliki nagłówkowe i dokumentacja do biblioteki curl
+Summary(pt_BR.UTF-8):  Arquivos de cabeçalho e bibliotecas de desenvolvimento
+Summary(ru.UTF-8):     Файлы для разработки с использованием библиотеки curl
+Summary(uk.UTF-8):     Файли для розробки з використанням бібліотеки curl
 Group:         Development/Libraries
 Requires:      %{name}-libs = %{version}-%{release}
 %{?with_ares:Requires: c-ares-devel}
-%{?with_heimdal:Requires:      heimdal-devel}
+%{?with_kerberos5:Requires:    heimdal-devel}
 Requires:      libidn-devel >= 0.4.1
-%{?with_ssl:Requires:  openssl-devel >= 0.9.7c}
+%{?with_ssh:Requires:  libssh2-devel >= 0.16}
+%if %{with ssl}
+%if %{with gnutls}
+Requires:      gnutls-devel
+%else
+Requires:      openssl-devel >= 0.9.7c
+%endif
+%endif
 Requires:      zlib-devel
 Obsoletes:     libcurl2-devel
 
@@ -131,10 +153,10 @@ Arquivos de cabeçalho e bibliotecas de desenvolvimento.
 
 %package static
 Summary:       Static version of curl library
-Summary(pl.UTF-8):   Statyczna wersja biblioteki curl
-Summary(pt_BR.UTF-8):   Bibliotecas estáticas para desenvolvimento com o curl
-Summary(ru.UTF-8):   Статические библиотеки для разработки с использованием библиотеки curl
-Summary(uk.UTF-8):   Статичні бібліотеки для розробки з використанням бібліотеки curl
+Summary(pl.UTF-8):     Statyczna wersja biblioteki curl
+Summary(pt_BR.UTF-8):  Bibliotecas estáticas para desenvolvimento com o curl
+Summary(ru.UTF-8):     Статические библиотеки для разработки с использованием библиотеки curl
+Summary(uk.UTF-8):     Статичні бібліотеки для розробки з використанням бібліотеки curl
 Group:         Development/Libraries
 Requires:      %{name}-devel = %{version}-%{release}
 
@@ -159,20 +181,29 @@ Bibliotecas estáticas para desenvolvimento com o curl.
 %setup -q
 %patch0 -p1
 %patch1 -p1
-%{?with_heimdal:%patch2 -p0}
+%patch2 -p1
+%patch3 -p1
 
 %build
 %{__libtoolize}
-%{__aclocal}
+%{__aclocal} -I m4
 %{__autoconf}
 %{__autoheader}
 %{__automake}
 %configure \
-       %{?with_ssl:--with-ssl=%{_prefix}} \
-       %{?with_ssl:--with-ca-bundle=/usr/share/ssl/ca-bundle.crt} \
-       %{?with_heimdal:--with-gssapi=%{_prefix}} \
+       ac_cv_header_gss_h=no \
+%if %{with ssl}
+       --with-ca-bundle=/etc/certs/ca-certificates.crt \
+%if %{with gnutls}
+       --with-gnutls=%{_prefix} --without-ssl \
+%else
+       --with-ssl=%{_prefix} \
+%endif
+%endif
+       %{?with_kerberos5:--with-gssapi=%{_prefix}} \
        %{?with_ares:--enable-ares=%{_prefix}} \
-       --%{?with_ares:dis}%{!?with_ares:en}able-ipv6
+       --enable-ldaps \
+       --enable-ipv6
 
 %{__make}
 
@@ -197,6 +228,7 @@ rm -rf $RPM_BUILD_ROOT
 %files libs
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/libcurl.so.*.*.*
+%attr(755,root,root) %ghost %{_libdir}/libcurl.so.4
 
 %files devel
 %defattr(644,root,root,755)
@@ -207,7 +239,8 @@ rm -rf $RPM_BUILD_ROOT
 %{_includedir}/curl
 %{_pkgconfigdir}/libcurl.pc
 %{_mandir}/man1/curl-config.1*
-%{_mandir}/man3/*curl*.3*
+%{_mandir}/man3/curl_*.3*
+%{_mandir}/man3/libcurl*.3*
 
 %files static
 %defattr(644,root,root,755)
This page took 0.043192 seconds and 4 git commands to generate.