]> git.pld-linux.org Git - packages/curl.git/blobdiff - curl.spec
- up to 7.20.0
[packages/curl.git] / curl.spec
index 56da924e757906a51d7dec8f35eeea5ec0a310cf..33866a09b9c67ed9570414e3600d192d72096676 100644 (file)
--- a/curl.spec
+++ b/curl.spec
@@ -1,10 +1,12 @@
+# TODO
+# - VMware needs curl with ares
 #
 # Conditional build:
-%bcond_with    ares            # with c-ares (asynchronous DNS operations) library (disables IPv6)
+%bcond_without ares            # with c-ares (asynchronous DNS operations) library (c-ares may not work properly with ipv6)
 %bcond_without ssh             # without SSH support
 %bcond_without ssl             # without SSL support
 %bcond_without gnutls          # use GnuTLS instead of OpenSSL
-%bcond_without kerberos5       # without MIT Kerberos 5 support
+%bcond_without kerberos5       # without Heimdal Kerberos 5 support
 #
 Summary:       A utility for getting files from remote servers (FTP, HTTP, and others)
 Summary(es.UTF-8):     Un cliente para bajar archivos de servidores (FTP, HTTP, y otros)
@@ -13,20 +15,21 @@ Summary(pt_BR.UTF-8):       Busca URL (suporta FTP, TELNET, LDAP, GOPHER, DICT, HTTP e
 Summary(ru.UTF-8):     Утилита для получения файлов с серверов FTP, HTTP и других
 Summary(uk.UTF-8):     Утиліта для отримання файлів з серверів FTP, HTTP та інших
 Name:          curl
-Version:       7.19.1
+Version:       7.20.0
 Release:       1
 License:       MIT-like
 Group:         Applications/Networking
-Source0:       http://curl.haxx.se/download/%{name}-%{version}.tar.bz2
-# Source0-md5: 6c4921e55ad276154065052c9e34e1cb
+Source0:       http://curl.haxx.se/download/%{name}-%{version}.tar.lzma
+# Source0-md5: a68d8169e4aae58d35977ae355c9b38a
 Patch0:                %{name}-no_strip.patch
 Patch1:                %{name}-ac.patch
 Patch2:                %{name}-pc.patch
+Patch3:                %{name}-krb5flags.patch
 URL:           http://curl.haxx.se/
 BuildRequires: autoconf >= 2.57
 BuildRequires: automake
 %{?with_ares:BuildRequires:    c-ares-devel}
-%{?with_kerberos5:BuildRequires:       krb5-devel}
+%{?with_kerberos5:BuildRequires:       heimdal-devel}
 BuildRequires: libidn-devel >= 0.4.1
 %{?with_ssh:BuildRequires:     libssh2-devel >= 0.16}
 BuildRequires: libtool
@@ -38,6 +41,7 @@ BuildRequires:        gnutls-devel
 BuildRequires: openssl-devel >= 0.9.7d
 %endif
 %endif
+BuildRequires: tar >= 1:1.22
 BuildRequires: zlib-devel
 Requires:      %{name}-libs = %{version}-%{release}
 Requires:      libidn >= 0.4.1
@@ -99,6 +103,8 @@ curl п╕дтриму╓ багато корисних можливостей,
 Summary:       curl library
 Summary(pl.UTF-8):     Biblioteka curl
 Group:         Libraries
+Suggests:      ca-certificates
+Conflicts:     ca-certificates < 20080809-4
 
 %description libs
 curl library.
@@ -115,7 +121,7 @@ Summary(uk.UTF-8):  Файли для розробки з використанн
 Group:         Development/Libraries
 Requires:      %{name}-libs = %{version}-%{release}
 %{?with_ares:Requires: c-ares-devel}
-%{?with_kerberos5:Requires:    krb5-devel}
+%{?with_kerberos5:Requires:    heimdal-devel}
 Requires:      libidn-devel >= 0.4.1
 %{?with_ssh:Requires:  libssh2-devel >= 0.16}
 %if %{with ssl}
@@ -176,17 +182,18 @@ Bibliotecas estáticas para desenvolvimento com o curl.
 %patch0 -p1
 %patch1 -p1
 %patch2 -p1
+%patch3 -p1
 
 %build
 %{__libtoolize}
-%{__aclocal}
+%{__aclocal} -I m4
 %{__autoconf}
 %{__autoheader}
 %{__automake}
 %configure \
        ac_cv_header_gss_h=no \
 %if %{with ssl}
-       --with-ca-bundle=/usr/share/ssl/ca-bundle.crt \
+       --with-ca-bundle=/etc/certs/ca-certificates.crt \
 %if %{with gnutls}
        --with-gnutls=%{_prefix} --without-ssl \
 %else
@@ -195,7 +202,8 @@ Bibliotecas estáticas para desenvolvimento com o curl.
 %endif
        %{?with_kerberos5:--with-gssapi=%{_prefix}} \
        %{?with_ares:--enable-ares=%{_prefix}} \
-       --%{?with_ares:dis}%{!?with_ares:en}able-ipv6
+       --enable-ldaps \
+       --enable-ipv6
 
 %{__make}
 
This page took 0.062252 seconds and 4 git commands to generate.