]> git.pld-linux.org Git - packages/cronie.git/blobdiff - cronie.spec
- use rpmbuild(macros) that disables systemd stuff for ac
[packages/cronie.git] / cronie.spec
index 9a803b2f96712b5758700cb4ecb50ebcd9f04d46..d41d3ec4fa8da31a7a998a95ed03c284dd375b07 100644 (file)
@@ -7,8 +7,8 @@
 # Conditional build:
 %bcond_without inotify         # without inotify support
 %if "%{pld_release}" == "ac"
-%bcond_with            selinux         # without SELinux support
-%bcond_with            audit           # without audit support
+%bcond_with            selinux         # with SELinux support
+%bcond_with            audit           # with audit support
 %else
 %bcond_without selinux         # without SELinux support
 %bcond_without audit           # without audit support
@@ -17,7 +17,7 @@
 Summary:       Cron daemon for executing programs at set times
 Name:          cronie
 Version:       1.4.8
-Release:       12
+Release:       18
 License:       MIT and BSD and GPL v2
 Group:         Daemons
 Source0:       https://fedorahosted.org/releases/c/r/cronie/%{name}-%{version}.tar.gz
@@ -32,6 +32,7 @@ Source7:      crond.service
 Patch0:                inotify-nosys.patch
 Patch1:                %{name}-nosyscrontab.patch
 Patch2:                sendmail-path.patch
+Patch3:                cronie-1.4.8-inotify-fix.patch
 URL:           https://fedorahosted.org/cronie/
 %{?with_audit:BuildRequires:   audit-libs-devel}
 BuildRequires: autoconf
@@ -39,7 +40,7 @@ BuildRequires:        automake
 %{?with_selinux:BuildRequires: libselinux-devel}
 BuildRequires: pam-devel
 BuildRequires: rpm >= 4.4.9-56
-BuildRequires: rpmbuild(macros) >= 1.626
+BuildRequires: rpmbuild(macros) >= 1.647
 Requires(post):        fileutils
 Requires(post,preun):  /sbin/chkconfig
 Requires(postun):      /usr/sbin/groupdel
@@ -48,7 +49,9 @@ Requires(pre):        /usr/sbin/groupadd
 Requires:      /bin/run-parts
 Requires:      psmisc >= 20.1
 Requires:      rc-scripts >= 0.4.3.0
-Requires:      systemd-units >= 37-0.10
+%if %{pld_release} != "ac"
+Requires:      systemd-units >= 37-0.10}
+%endif
 %{?with_inotify:Requires:      uname(release) >= 2.6.13}
 Provides:      crondaemon
 Provides:      crontabs = 1.7
@@ -99,6 +102,7 @@ Opis zadania Upstart dla Cronie.
 %patch0 -p1
 %patch1 -p1
 %patch2 -p1
+%patch3 -p1
 
 %build
 %{__aclocal}
@@ -113,7 +117,9 @@ Opis zadania Upstart dla Cronie.
        --with%{!?with_selinux:out}-selinux \
        --with%{!?with_audit:out}-audit \
        --with%{!?with_inotify:out}-inotify \
+%if "%{cc_version}" >= "3.4"
        --enable-pie \
+%endif
        --enable-relro \
        --enable-anacron
 
@@ -136,8 +142,7 @@ cp -a %{SOURCE3} $RPM_BUILD_ROOT/etc/sysconfig/cron
 cp -a %{SOURCE4} $RPM_BUILD_ROOT/etc/cron.d/crontab
 cp -a %{SOURCE5} $RPM_BUILD_ROOT/etc/pam.d/crond
 cp -a %{SOURCE6} $RPM_BUILD_ROOT/etc/init/crond.conf
-cp -a %{SOURCE7} $RPM_BUILD_ROOT%{systemdunitdir}/cronie.service
-ln -s cronie.service $RPM_BUILD_ROOT%{systemdunitdir}/crond.service
+cp -a %{SOURCE7} $RPM_BUILD_ROOT%{systemdunitdir}/crond.service
 
 touch $RPM_BUILD_ROOT/var/log/cron
 
@@ -164,14 +169,14 @@ if [ ! -f /var/log/cron ]; then
 fi
 /sbin/chkconfig --add crond
 %service crond restart "Cron Daemon"
-%systemd_post cronie.service
+%systemd_post crond.service
 
 %preun
 if [ "$1" = "0" ]; then
        %service crond stop
        /sbin/chkconfig --del crond
 fi
-%systemd_preun cronie.service
+%systemd_preun crond.service
 
 %postun
 if [ "$1" = "0" ]; then
@@ -179,19 +184,20 @@ if [ "$1" = "0" ]; then
 fi
 %systemd_reload
 
-%triggerpostun -- cronie < 1.4.8-11
+%triggerpostun -- cronie < 1.4.8-13
 if [ -f /etc/sysconfig/cron ]; then
        . /etc/sysconfig/cron
        __CROND_ARGS=
        [ "$CROND_SYSLOG_RESULT" = "yes" ] && __CROND_ARGS="-s"
        [ -n "$CROND_MAIL_PROG" ] && __CROND_ARGS="$__CROND_ARGS -m $CROND_MAIL_PROG"
-       [ -z "$__CROND_ARGS" ] && exit 0
-       cp -f /etc/sysconfig/cron{,.rpmsave}
-       echo >>/etc/sysconfig/cron
-       echo "# Added by rpm trigger" >>/etc/sysconfig/cron
-       echo "CROND_ARGS=\"$CROND_ARGS $__CROND_ARGS\"" >>/etc/sysconfig/cron
+       if [ -n "$__CROND_ARGS" ]; then
+               %{__cp} -f /etc/sysconfig/cron{,.rpmsave}
+               echo >>/etc/sysconfig/cron
+               echo "# Added by rpm trigger" >>/etc/sysconfig/cron
+               echo "CROND_ARGS=\"$CROND_ARGS $__CROND_ARGS\"" >>/etc/sysconfig/cron
+       fi
 fi
-%systemd_trigger cronie.service
+%systemd_trigger crond.service
 
 %triggerun -- hc-cron,fcron,vixie-cron
 # Prevent preun from crond from working
@@ -222,7 +228,6 @@ chmod 754 /etc/rc.d/init.d/crond
 %attr(754,root,root) /etc/rc.d/init.d/crond
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/cron
 %{systemdunitdir}/crond.service
-%{systemdunitdir}/cronie.service
 %attr(755,root,root) %{_sbindir}/crond
 %attr(2755,root,crontab) %{_bindir}/crontab
 
@@ -243,7 +248,7 @@ chmod 754 /etc/rc.d/init.d/crond
 
 %attr(1730,root,crontab) /var/spool/anacron
 
-%if "%{pld_release}" != "ti"
+%if "%{pld_release}" == "th"
 %files upstart
 %defattr(644,root,root,755)
 %config(noreplace) %verify(not md5 mtime size) /etc/init/crond.conf
This page took 0.031478 seconds and 4 git commands to generate.