]> git.pld-linux.org Git - packages/cluster-glue.git/blobdiff - cluster-glue.spec
rebuild with openssl 3.0.0
[packages/cluster-glue.git] / cluster-glue.spec
index b9ec649868efed49f16d4815082c89e11a3536ef..d82245962d544100afe0e9e11d222002c1359315 100644 (file)
@@ -9,17 +9,21 @@
 Summary:       Reusable cluster components
 Summary(pl.UTF-8):     Komponenty klastrowe wielokrotnego użytku
 Name:          cluster-glue
-Version:       1.0.11
-Release:       7
+Version:       1.0.12
+Release:       6
 License:       GPL v2+ and LGPL v2+
 Group:         Aplications/System
+# for future releases:
+#Source0Download: https://github.com/ClusterLabs/cluster-glue/releases
+#Source0:      https://github.com/ClusterLabs/cluster-glue/archive/%{version}/glue-%{version}.tar.gz
 Source0:       http://hg.linux-ha.org/glue/archive/glue-%{version}.tar.bz2
-# Source0-md5: 7d0acd99d43edac849dc76f43cfa4c7f
-Source1:       logd.service
+# Source0-md5: ec620466d6f23affa3b074b72bca7870
 Patch0:                %{name}-link.patch
 Patch1:                %{name}-opt.patch
-Patch2:                x32-long-long-time-types.patch
-URL:           http://www.linux-ha.org/
+Patch2:                %{name}-rc.patch
+Patch3:                %{name}-heartbeat-libexecdir.patch
+Patch4:                x32-long-long-time-types.patch
+URL:           http://www.linux-ha.org/wiki/Cluster_Glue
 BuildRequires: OpenIPMI-devel >= 1.4
 BuildRequires: autoconf >= 2.53
 BuildRequires: automake
@@ -141,12 +145,17 @@ STONITH (Shoot The Other Node In The Head) to interfejs służący do
 %setup -q -n Reusable-Cluster-Components-glue--glue-%{version}
 %patch0 -p1
 %patch1 -p1
-%ifarch x32
 %patch2 -p1
+%patch3 -p1
+%ifarch x32
+%patch4 -p1
 %endif
 
-sed -i -e's;#!/usr/bin/env \(python\|perl\);#!/usr/bin/\1;' \
-                                       lib/plugins/stonith/external/*
+%{__sed} -i -e '1{
+       s,^#!.*python$,#!%{__python},
+       s,^#!.*bin/env perl,#!%{__perl},
+}' \
+       lib/plugins/stonith/external/*
 
 %build
 %{__libtoolize}
@@ -154,13 +163,17 @@ sed -i -e's;#!/usr/bin/env \(python\|perl\);#!/usr/bin/\1;' \
 %{__autoheader}
 %{__automake}
 %{__autoconf}
+CPPFLAGS="%{rpmcppflags} -DOPENIPMI_DEFINE_SELECTOR_T"
 %configure \
+       PYTHON=%{__python} \
        --docdir=%{_docdir}/%{name}-%{version} \
        --disable-fatal-warnings \
        --disable-static \
+       --enable-ipmilan \
        --with-daemon-group=haclient \
        --with-daemon-user=hacluster \
-       --with-initdir=/etc/rc.d/init.d
+       --with-initdir=/etc/rc.d/init.d \
+       --with-rundir=/var/run
 %{__make}
 
 %install
@@ -172,9 +185,6 @@ install -d $RPM_BUILD_ROOT%{systemdunitdir}
 
 find $RPM_BUILD_ROOT -name '*.la' -delete
 
-%{__sed} -e 's;@libdir@;%{_libdir};g' \
-       %{SOURCE1} > $RPM_BUILD_ROOT%{systemdunitdir}/logd.service
-
 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}
 
 %clean
@@ -216,7 +226,6 @@ fi
 %attr(755,root,root) %{_sbindir}/hb_report
 %attr(755,root,root) %{_sbindir}/lrmadmin
 %attr(755,root,root) %{_sbindir}/meatclient
-%attr(755,root,root) %{_sbindir}/sbd
 %attr(755,root,root) %{_sbindir}/cibsecret
 %{_mandir}/man1/ha_logger.1*
 %{_mandir}/man8/ha_logd.8*
@@ -228,18 +237,18 @@ fi
 %attr(755,root,root) %{_datadir}/%{name}/ha_cf_support.sh
 %attr(755,root,root) %{_datadir}/%{name}/openais_conf_support.sh
 %attr(755,root,root) %{_datadir}/%{name}/utillib.sh
-%attr(755,root,root) %{_datadir}/%{name}/combine-logs.pl
 %attr(755,root,root) %{_datadir}/%{name}/ha_log.sh
 
-%dir %{_libdir}/heartbeat/plugins/RAExec
+%attr(755,root,root) %{_libexecdir}/heartbeat/ha_logd
+%attr(755,root,root) %{_libexecdir}/heartbeat/lrmd
+
 %dir %{_libdir}/heartbeat/plugins/InterfaceMgr
-%dir %{_libdir}/heartbeat/plugins/compress
-%attr(755,root,root) %{_libdir}/heartbeat/lrmd
-%attr(755,root,root) %{_libdir}/heartbeat/ha_logd
 %attr(755,root,root) %{_libdir}/heartbeat/plugins/InterfaceMgr/generic.so
+%dir %{_libdir}/heartbeat/plugins/RAExec
 %attr(755,root,root) %{_libdir}/heartbeat/plugins/RAExec/heartbeat.so
 %attr(755,root,root) %{_libdir}/heartbeat/plugins/RAExec/lsb.so
 %attr(755,root,root) %{_libdir}/heartbeat/plugins/RAExec/ocf.so
+%dir %{_libdir}/heartbeat/plugins/compress
 %attr(755,root,root) %{_libdir}/heartbeat/plugins/compress/bz2.so
 %attr(755,root,root) %{_libdir}/heartbeat/plugins/compress/zlib.so
 
@@ -284,12 +293,12 @@ fi
 
 %files tests
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_libdir}/heartbeat/ipctest
-%attr(755,root,root) %{_libdir}/heartbeat/ipctransientclient
-%attr(755,root,root) %{_libdir}/heartbeat/ipctransientserver
-%attr(755,root,root) %{_libdir}/heartbeat/transient-test.sh
-%attr(755,root,root) %{_libdir}/heartbeat/base64_md5_test
-%attr(755,root,root) %{_libdir}/heartbeat/logtest
+%attr(755,root,root) %{_libexecdir}/heartbeat/ipctest
+%attr(755,root,root) %{_libexecdir}/heartbeat/ipctransientclient
+%attr(755,root,root) %{_libexecdir}/heartbeat/ipctransientserver
+%attr(755,root,root) %{_libexecdir}/heartbeat/transient-test.sh
+%attr(755,root,root) %{_libexecdir}/heartbeat/base64_md5_test
+%attr(755,root,root) %{_libexecdir}/heartbeat/logtest
 
 %dir %{_libdir}/heartbeat/plugins/test
 %attr(755,root,root) %{_libdir}/heartbeat/plugins/test/test.so
This page took 0.059037 seconds and 4 git commands to generate.