]> git.pld-linux.org Git - packages/chromium-browser.git/blobdiff - chromium-browser.spec
up to 33.0.1750.117, disable system ffmpeg
[packages/chromium-browser.git] / chromium-browser.spec
index 60048ae4c25e07906a8958ec238f3c20d40286be..f99051a780882b3bd1f9cb34b217395825d9471a 100644 (file)
@@ -7,20 +7,20 @@
 %bcond_without keyring                 # with keyring support (gnome-keyring dlopened, kwalletd via dbus)
 %bcond_with            gps                     # with gps support (linked), if enabled must use exactly same gpsd as shm structures may change leading to unexpected results (crash)
 %bcond_without libjpegturbo    # use libjpeg-turbo features
-%bcond_without nacl                    # build Native Client support
+%bcond_with    nacl                    # build Native Client support, disabled: http://crbug.com/269560
 %bcond_without pulseaudio              # with pulseaudio
 %bcond_without sandboxing              # with sandboxing
 %bcond_with            selinux                 # with SELinux (need policy first)
 %bcond_with            shared_libs             # with shared libs
 %bcond_with            sse2                    # use SSE2 instructions
 %bcond_without system_flac             # system flac
-%bcond_without system_ffmpeg   # system ffmpeg instead of ffmpegsumo
+%bcond_with    system_ffmpeg   # system ffmpeg instead of ffmpegsumo
 %bcond_without system_harfbuzz # system harfbuzz
 %bcond_without system_jsoncpp  # system jsoncpp
 %bcond_without system_libexif  # system libexif
 %bcond_without system_libmtp   # system libmtp
-%bcond_without system_libusb   # system libusb-1
-%bcond_without system_libwebp  # system libwebp
+%bcond_with    system_libusb   # system libusb-1, disabled: http://crbug.com/266149
+%bcond_with    system_libwebp  # system libwebp, disabled: http://crbug.com/288019
 %bcond_without system_libxnvctrl       # system libxnvctrl
 %bcond_with    system_mesa             # system Mesa
 %bcond_without system_minizip  # system minizip
@@ -59,9 +59,9 @@
 # - http://code.google.com/p/chromium/wiki/LinuxBuildInstructionsPrerequisites
 # - to look for new tarball, use update-source.sh script
 
-%define                branch          29.0.1547
-%define                basever         57
-%define                patchver        76
+%define                branch          33.0.1750
+%define                basever         117
+#define                patchver        107
 %define                gyp_rev 1014
 Summary:       A WebKit powered web browser
 Name:          chromium-browser
@@ -73,11 +73,11 @@ Version:    %{branch}.%{basever}
 Release:       1
 License:       BSD%{!?with_system_ffmpeg:, LGPL v2+ (ffmpeg)}
 Group:         X11/Applications/Networking
-Source0:       http://carme.pld-linux.org/~glen/chromium-browser/src/stable/%{name}-%{branch}.%{basever}.tar.xz
-# Source0-md5: fcdeb8cb650d64e326d4ae84ca491432
+Source0:       http://carme.pld-linux.org/~glen/chromium-browser/src/dev/%{name}-%{branch}.%{basever}.tar.gz
+# Source0-md5: 1b273c1a80983ca7679a7031855a9b41
 %if "%{?patchver}" != ""
 Patch0:                http://carme.pld-linux.org/~glen/chromium-browser/src/stable/%{name}-%{version}.patch.xz
-# Patch0-md5:  ffbb56731a752ce52caaf0448dd6e073
+# Patch0-md5:  82e3012b5510187907bba50dadbe7137
 %endif
 Source1:       %{name}.default
 Source2:       %{name}.sh
@@ -103,14 +103,17 @@ Patch24:  nacl-verbose.patch
 Patch25:       gnome3-volume-control.patch
 Patch26:       master-prefs-path.patch
 Patch28:       system-mesa.patch
+Patch30:       system-ply.patch
+Patch31:       system-jinja.patch
+Patch32:       remove_bundled_libraries-stale.patch
+Patch33:       gn.patch
 URL:           http://www.chromium.org/Home
 %{?with_gconf:BuildRequires:   GConf2-devel}
 %{?with_system_mesa:BuildRequires:     Mesa-libGL-devel >= 9.1}
-%{?with_system_mesa:BuildRequires:     Mesa-libGLES-devel >= 9.1}
+BuildRequires: Mesa-libGLES-devel >= 9.1
 %{?with_system_mesa:BuildRequires:     Mesa-libGLU-devel}
 %{?with_system_mesa:BuildRequires:     Mesa-libOSMesa-devel >= 9.1}
 BuildRequires: alsa-lib-devel
-BuildRequires: perl-JSON
 BuildRequires: atk-devel
 BuildRequires: bison
 BuildRequires: bzip2-devel
@@ -158,14 +161,16 @@ BuildRequires:    nss-devel >= 1:3.12.3
 BuildRequires: pam-devel
 BuildRequires: pango-devel
 BuildRequires: pciutils-devel
+BuildRequires: perl-JSON
 BuildRequires: perl-modules
 BuildRequires: pkgconfig
 %{?with_system_protobuf:BuildRequires: protobuf-devel}
 %{?with_pulseaudio:BuildRequires:      pulseaudio-devel}
 BuildRequires: python
 #BuildRequires:        python-gyp >= 1-%{gyp_rev}
+BuildRequires: python-jinja2 >= 2.7
 BuildRequires: python-modules
-BuildRequires: python-ply
+BuildRequires: python-ply >= 3.4
 %{?with_system_re2:BuildRequires:      re2-devel >= 20130115-2}
 BuildRequires: rpm >= 4.4.9-56
 BuildRequires: rpmbuild(macros) >= 1.453
@@ -174,7 +179,6 @@ BuildRequires:      speech-dispatcher-devel >= 0.8
 %{?with_system_speex:BuildRequires:    speex-devel >= 1:1.2-rc1}
 %{?with_system_sqlite:BuildRequires:   sqlite3-devel >= 3.7}
 %{?with_system_libsrtp:BuildRequires:  srtp-devel >= 1.4.4}
-BuildRequires: subversion
 BuildRequires: tar >= 1:1.22
 BuildRequires: udev-devel
 BuildRequires: usbutils
@@ -182,6 +186,7 @@ BuildRequires:      util-linux
 %{?with_system_v8:BuildRequires:       v8-devel >= 3.7}
 BuildRequires: which
 BuildRequires: xorg-lib-libXScrnSaver-devel
+BuildRequires: xorg-lib-libXtst-devel
 BuildRequires: xz
 %{?with_system_yasm:BuildRequires:     yasm}
 %{?with_system_zlib:BuildRequires:     zlib-devel}
@@ -218,6 +223,13 @@ BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 # Usage: gyp_with BCOND_NAME [OPTION_NAME]
 %define                gyp_with() %{expand:%%{?with_%{1}:-D%{?2:use_%{2}}%{!?2:use_%{1}}=1}%%{!?with_%{1}:-D%{?2:use_%{2}}%{!?2:use_%{1}}=0}}
 
+%ifarch %{ix86}
+%define                target_arch ia32
+%endif
+%ifarch %{x8664}
+%define                target_arch x64
+%endif
+
 %if %{without debuginfo}
 %define                _enable_debug_packages  0
 %endif
@@ -282,7 +294,7 @@ sed -e 's/@BUILD_DIST@/PLD %{pld_version}/g' \
 %{__sed} -e 's,@localedir@,%{_datadir}/%{name},' %{SOURCE5} > find-lang.sh
 ln -s %{SOURCE7} .
 
-%patch1 -p2
+%patch1 -p1
 %patch4 -p3
 %patch7 -p1
 %patch10 -p1
@@ -291,11 +303,16 @@ ln -s %{SOURCE7} .
 %patch12 -p1
 %patch16 -p1
 %patch28 -p1
-%patch25 -p2
-%patch18 -p1
+%patch25 -p1
+%{?with_nacl:%patch18 -p1}
 %patch24 -p2
 %patch26 -p2
+%patch30 -p1
+%patch31 -p0
+%patch32 -p1
+%patch33 -p0
 
+exit 0
 sh -x clean-source.sh \
        %{!?with_nacl:nacl=0} \
        %{!?with_system_libvpx:libvpx=0} \
@@ -306,6 +323,7 @@ sh -x clean-source.sh \
        %{!?with_system_snappy:snappy=0} \
        %{!?with_system_sqlite:sqlite=0} \
        %{!?with_system_v8:v8=0} \
+       %{!?with_system_libwebp:libwebp=0} \
        %{!?with_system_zlib:zlib=0} \
        %{nil}
 
@@ -346,19 +364,21 @@ cd ../../../../..
 fi
 %endif
 
-flags="
-%ifarch %{ix86}
-       -Dtarget_arch=ia32 \
-%endif
-%ifarch %{x8664}
-       -Dtarget_arch=x64 \
+%if %{without system_ffmpeg}
+# Re-configure bundled ffmpeg
+cd third_party/ffmpeg
+chromium/scripts/build_ffmpeg.sh linux %{target_arch} "$PWD" config-only
+chromium/scripts/copy_config.sh
+cd -
 %endif
+
+flags="
+       -Dtarget_arch=%{target_arch} \
+       -Dpython_arch=%{target_arch} \
+       -Dsystem_libdir=%{_lib} \
+       -Dpython_ver=%{py_ver} \
 %if "%{cc_version}" >= "4.4.0" && "%{cc_version}" < "4.5.0"
        -Dno_strict_aliasing=1 -Dgcc_version=44 \
-%endif
-%if %{with sandboxing}
-       -Dlinux_sandbox_path=%{_libdir}/%{name}/chromium-sandbox \
-       -Dlinux_sandbox_chrome_path=%{_libdir}/%{name}/%{name} \
 %endif
        %{!?debug:-Dwerror=} \
        %{!?debuginfo:-Dfastbuild=1 -Dremove_webcore_debug_symbols=1} \
@@ -481,7 +501,7 @@ ln -s %{_datadir}/%{name}/locales $RPM_BUILD_ROOT%{_libdir}/%{name}/locales
 ln -s %{_datadir}/%{name}/resources $RPM_BUILD_ROOT%{_libdir}/%{name}/resources
 cp -p chrome.1 $RPM_BUILD_ROOT%{_mandir}/man1/%{name}.1
 install -p chrome $RPM_BUILD_ROOT%{_libdir}/%{name}/%{name}
-install -p chrome_sandbox $RPM_BUILD_ROOT%{_libdir}/%{name}/chromium-sandbox
+install -p chrome_sandbox $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome-sandbox
 %if %{without system_ffmpeg}
 install -p libffmpegsumo.so $RPM_BUILD_ROOT%{_libdir}/%{name}
 %endif
@@ -577,7 +597,7 @@ fi
 %dir %{_libdir}/%{name}/plugins
 %attr(755,root,root) %{_libdir}/%{name}/%{name}
 # These unique permissions are intentional and necessary for the sandboxing
-%attr(4555,root,root) %{_libdir}/%{name}/chromium-sandbox
+%attr(4555,root,root) %{_libdir}/%{name}/chrome-sandbox
 
 # ffmpeg libs
 %if %{without system_ffmpeg}
This page took 0.088268 seconds and 4 git commands to generate.