]> git.pld-linux.org Git - packages/chromium-browser.git/blobdiff - chromium-browser.spec
use system webp, vpx
[packages/chromium-browser.git] / chromium-browser.spec
index 1b2fd085ab429697191d78ace9ae888ca5a9c3ca..e83fa16d8a277132df6a8b35d03a961a04081aa3 100644 (file)
 %bcond_with            shared_libs             # with shared libs
 %bcond_with            sse2                    # use SSE2 instructions
 %bcond_without system_flac             # system flac
-%bcond_without system_ffmpeg   # system ffmpeg instead of ffmpegsumo
+%bcond_with    system_ffmpeg   # system ffmpeg instead of ffmpegsumo
 %bcond_without system_harfbuzz # system harfbuzz
 %bcond_without system_jsoncpp  # system jsoncpp
 %bcond_without system_libexif  # system libexif
 %bcond_without system_libmtp   # system libmtp
 %bcond_with    system_libusb   # system libusb-1, disabled: http://crbug.com/266149
-%bcond_with    system_libwebp  # system libwebp, disabled: http://crbug.com/288019
+%bcond_without system_libwebp  # system libwebp
 %bcond_without system_libxnvctrl       # system libxnvctrl
 %bcond_with    system_mesa             # system Mesa
 %bcond_without system_minizip  # system minizip
@@ -59,9 +59,9 @@
 # - http://code.google.com/p/chromium/wiki/LinuxBuildInstructionsPrerequisites
 # - to look for new tarball, use update-source.sh script
 
-%define                branch          31.0.1650
-%define                basever         57
-%define                patchver        63
+%define                branch          33.0.1750
+%define                basever         117
+#define                patchver        107
 %define                gyp_rev 1014
 Summary:       A WebKit powered web browser
 Name:          chromium-browser
@@ -70,14 +70,14 @@ Version:    %{branch}.%{patchver}
 %else
 Version:       %{branch}.%{basever}
 %endif
-Release:       2
+Release:       1
 License:       BSD%{!?with_system_ffmpeg:, LGPL v2+ (ffmpeg)}
 Group:         X11/Applications/Networking
 Source0:       http://carme.pld-linux.org/~glen/chromium-browser/src/stable/%{name}-%{branch}.%{basever}.tar.xz
-# Source0-md5: 8fcdee6bdefad83dedaecc7ca2a1cf5f
+# Source0-md5: c14a4bcb8bed66ea2204cd698d938250
 %if "%{?patchver}" != ""
 Patch0:                http://carme.pld-linux.org/~glen/chromium-browser/src/stable/%{name}-%{version}.patch.xz
-# Patch0-md5:  f17f75a65414167cf822c6aaf409a537
+# Patch0-md5:  82e3012b5510187907bba50dadbe7137
 %endif
 Source1:       %{name}.default
 Source2:       %{name}.sh
@@ -103,10 +103,10 @@ Patch24:  nacl-verbose.patch
 Patch25:       gnome3-volume-control.patch
 Patch26:       master-prefs-path.patch
 Patch28:       system-mesa.patch
-Patch29:       system-icu.patch
 Patch30:       system-ply.patch
 Patch31:       system-jinja.patch
 Patch32:       remove_bundled_libraries-stale.patch
+Patch33:       gn.patch
 URL:           http://www.chromium.org/Home
 %{?with_gconf:BuildRequires:   GConf2-devel}
 %{?with_system_mesa:BuildRequires:     Mesa-libGL-devel >= 9.1}
@@ -149,8 +149,8 @@ BuildRequires:      libpng-devel
 %{?with_selinux:BuildRequires: libselinux-devel}
 BuildRequires: libstdc++-devel
 %{?with_system_libusb:BuildRequires:   libusb-devel >= 1.0}
-%{?with_system_libvpx:BuildRequires:   libvpx-devel >= 0.9.5-2}
-%{?with_system_libwebp:BuildRequires:  libwebp-devel >= 0.1.99}
+%{?with_system_libvpx:BuildRequires:   libvpx-devel >= 1.3.0}
+%{?with_system_libwebp:BuildRequires:  libwebp-devel >= 0.4.0}
 BuildRequires: libxml2-devel
 BuildRequires: libxslt-devel
 BuildRequires: man-db
@@ -198,7 +198,7 @@ Requires:   fonts-Type1-urw
 Requires:      hicolor-icon-theme
 Requires:      libevent >= 2.0.21
 %{?with_libjpegturbo:Requires: libjpeg-turbo >= 1.2.0}
-%{?with_system_libvpx:Requires:        libvpx >= 0.9.5-2}
+%{?with_system_libvpx:Requires:        libvpx >= 1.3.0}
 Requires:      lsb-release
 %{?with_system_re2:Requires:   re2 >= 20130115-2}
 Requires:      shared-mime-info
@@ -223,6 +223,13 @@ BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 # Usage: gyp_with BCOND_NAME [OPTION_NAME]
 %define                gyp_with() %{expand:%%{?with_%{1}:-D%{?2:use_%{2}}%{!?2:use_%{1}}=1}%%{!?with_%{1}:-D%{?2:use_%{2}}%{!?2:use_%{1}}=0}}
 
+%ifarch %{ix86}
+%define                target_arch ia32
+%endif
+%ifarch %{x8664}
+%define                target_arch x64
+%endif
+
 %if %{without debuginfo}
 %define                _enable_debug_packages  0
 %endif
@@ -296,14 +303,14 @@ ln -s %{SOURCE7} .
 %patch12 -p1
 %patch16 -p1
 %patch28 -p1
-%patch25 -p2
+%patch25 -p1
 %{?with_nacl:%patch18 -p1}
 %patch24 -p2
 %patch26 -p2
-%patch29 -p0
 %patch30 -p1
 %patch31 -p0
 %patch32 -p1
+%patch33 -p0
 
 sh -x clean-source.sh \
        %{!?with_nacl:nacl=0} \
@@ -317,6 +324,7 @@ sh -x clean-source.sh \
        %{!?with_system_v8:v8=0} \
        %{!?with_system_libwebp:libwebp=0} \
        %{!?with_system_zlib:zlib=0} \
+       %{!?with_system_ffmpeg:ffmpeg=0} \
        %{nil}
 
 %build
@@ -356,17 +364,19 @@ cd ../../../../..
 fi
 %endif
 
-flags="
-%ifarch %{ix86}
-       -Dtarget_arch=ia32 \
-       -Dpython_arch=ia32 \
-%endif
-%ifarch %{x8664}
-       -Dtarget_arch=x64 \
-       -Dpython_arch=x64 \
+%if %{without system_ffmpeg}
+# Re-configure bundled ffmpeg
+cd third_party/ffmpeg
+chromium/scripts/build_ffmpeg.sh linux %{target_arch} "$PWD" config-only
+chromium/scripts/copy_config.sh
+cd -
 %endif
+
+flags="
+       -Dtarget_arch=%{target_arch} \
+       -Dpython_arch=%{target_arch} \
        -Dsystem_libdir=%{_lib} \
-       -Dpython_ver=2.7 \
+       -Dpython_ver=%{py_ver} \
 %if "%{cc_version}" >= "4.4.0" && "%{cc_version}" < "4.5.0"
        -Dno_strict_aliasing=1 -Dgcc_version=44 \
 %endif
@@ -412,7 +422,7 @@ flags="
        %{gyp_with system_libmtp} \
        %{gyp_with system_libsrtp} \
        %{gyp_with system_libusb} \
-       %{gyp_with system_libvpx} -Dmedia_use_libvpx=0 \
+       %{gyp_with system_libvpx} -Dmedia_use_libvpx=1 \
        %{gyp_with system_libwebp} \
        %{gyp_with system_libxnvctrl} \
        %{gyp_with system_mesa} \
This page took 0.05345 seconds and 4 git commands to generate.