]> git.pld-linux.org Git - packages/chromium-browser.git/blobdiff - chromium-browser.spec
rel 1
[packages/chromium-browser.git] / chromium-browser.spec
index b9f4fb8d997e10046be097bd9be1a214a039f23d..e259e4e6381c7d91f997a08f5dcaf3ab303aa73f 100644 (file)
@@ -7,7 +7,7 @@
 %bcond_without keyring                 # with keyring support (gnome-keyring dlopened, kwalletd via dbus)
 %bcond_with            gps                     # with gps support (linked), if enabled must use exactly same gpsd as shm structures may change leading to unexpected results (crash)
 %bcond_without libjpegturbo    # use libjpeg-turbo features
-%bcond_without nacl                    # build Native Client support
+%bcond_with    nacl                    # build Native Client support, disabled: http://crbug.com/269560
 %bcond_without pulseaudio              # with pulseaudio
 %bcond_without sandboxing              # with sandboxing
 %bcond_with            selinux                 # with SELinux (need policy first)
@@ -20,7 +20,7 @@
 %bcond_without system_libexif  # system libexif
 %bcond_without system_libmtp   # system libmtp
 %bcond_with    system_libusb   # system libusb-1, disabled: http://crbug.com/266149
-%bcond_without system_libwebp  # system libwebp
+%bcond_with    system_libwebp  # system libwebp, disabled: http://crbug.com/288019
 %bcond_without system_libxnvctrl       # system libxnvctrl
 %bcond_with    system_mesa             # system Mesa
 %bcond_without system_minizip  # system minizip
@@ -59,9 +59,9 @@
 # - http://code.google.com/p/chromium/wiki/LinuxBuildInstructionsPrerequisites
 # - to look for new tarball, use update-source.sh script
 
-%define                branch          30.0.1599
-%define                basever         66
-#define                patchver        76
+%define                branch          32.0.1700
+%define                basever         77
+#define                patchver        63
 %define                gyp_rev 1014
 Summary:       A WebKit powered web browser
 Name:          chromium-browser
@@ -70,14 +70,14 @@ Version:    %{branch}.%{patchver}
 %else
 Version:       %{branch}.%{basever}
 %endif
-Release:       1
+Release:       0.2
 License:       BSD%{!?with_system_ffmpeg:, LGPL v2+ (ffmpeg)}
 Group:         X11/Applications/Networking
-Source0:       http://carme.pld-linux.org/~glen/chromium-browser/src/beta/%{name}-%{branch}.%{basever}.tar.gz
-# Source0-md5: 48e0806c4eab5dcc428fd59a826d0498
+Source0:       http://carme.pld-linux.org/~glen/chromium-browser/src/stable/%{name}-%{branch}.%{basever}.tar.xz
+# Source0-md5: 80f2651040917887c8a7b42010c2ba6c
 %if "%{?patchver}" != ""
 Patch0:                http://carme.pld-linux.org/~glen/chromium-browser/src/stable/%{name}-%{version}.patch.xz
-# Patch0-md5:  ffbb56731a752ce52caaf0448dd6e073
+# Patch0-md5:  f17f75a65414167cf822c6aaf409a537
 %endif
 Source1:       %{name}.default
 Source2:       %{name}.sh
@@ -103,7 +103,9 @@ Patch24:    nacl-verbose.patch
 Patch25:       gnome3-volume-control.patch
 Patch26:       master-prefs-path.patch
 Patch28:       system-mesa.patch
-Patch29:       system-icu.patch
+Patch30:       system-ply.patch
+Patch31:       system-jinja.patch
+Patch32:       remove_bundled_libraries-stale.patch
 URL:           http://www.chromium.org/Home
 %{?with_gconf:BuildRequires:   GConf2-devel}
 %{?with_system_mesa:BuildRequires:     Mesa-libGL-devel >= 9.1}
@@ -165,9 +167,9 @@ BuildRequires:      pkgconfig
 %{?with_pulseaudio:BuildRequires:      pulseaudio-devel}
 BuildRequires: python
 #BuildRequires:        python-gyp >= 1-%{gyp_rev}
-BuildRequires: python-jinja2
+BuildRequires: python-jinja2 >= 2.7
 BuildRequires: python-modules
-BuildRequires: python-ply
+BuildRequires: python-ply >= 3.4
 %{?with_system_re2:BuildRequires:      re2-devel >= 20130115-2}
 BuildRequires: rpm >= 4.4.9-56
 BuildRequires: rpmbuild(macros) >= 1.453
@@ -294,12 +296,13 @@ ln -s %{SOURCE7} .
 %patch16 -p1
 %patch28 -p1
 %patch25 -p2
-%patch18 -p1
+%{?with_nacl:%patch18 -p1}
 %patch24 -p2
 %patch26 -p2
-%patch29 -p0
+%patch30 -p1
+%patch31 -p0
+%patch32 -p1
 
-exit 0
 sh -x clean-source.sh \
        %{!?with_nacl:nacl=0} \
        %{!?with_system_libvpx:libvpx=0} \
@@ -310,6 +313,7 @@ sh -x clean-source.sh \
        %{!?with_system_snappy:snappy=0} \
        %{!?with_system_sqlite:sqlite=0} \
        %{!?with_system_v8:v8=0} \
+       %{!?with_system_libwebp:libwebp=0} \
        %{!?with_system_zlib:zlib=0} \
        %{nil}
 
@@ -353,16 +357,16 @@ fi
 flags="
 %ifarch %{ix86}
        -Dtarget_arch=ia32 \
+       -Dpython_arch=ia32 \
 %endif
 %ifarch %{x8664}
        -Dtarget_arch=x64 \
+       -Dpython_arch=x64 \
 %endif
+       -Dsystem_libdir=%{_lib} \
+       -Dpython_ver=2.7 \
 %if "%{cc_version}" >= "4.4.0" && "%{cc_version}" < "4.5.0"
        -Dno_strict_aliasing=1 -Dgcc_version=44 \
-%endif
-%if %{with sandboxing}
-       -Dlinux_sandbox_path=%{_libdir}/%{name}/chromium-sandbox \
-       -Dlinux_sandbox_chrome_path=%{_libdir}/%{name}/%{name} \
 %endif
        %{!?debug:-Dwerror=} \
        %{!?debuginfo:-Dfastbuild=1 -Dremove_webcore_debug_symbols=1} \
@@ -485,7 +489,7 @@ ln -s %{_datadir}/%{name}/locales $RPM_BUILD_ROOT%{_libdir}/%{name}/locales
 ln -s %{_datadir}/%{name}/resources $RPM_BUILD_ROOT%{_libdir}/%{name}/resources
 cp -p chrome.1 $RPM_BUILD_ROOT%{_mandir}/man1/%{name}.1
 install -p chrome $RPM_BUILD_ROOT%{_libdir}/%{name}/%{name}
-install -p chrome_sandbox $RPM_BUILD_ROOT%{_libdir}/%{name}/chromium-sandbox
+install -p chrome_sandbox $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome-sandbox
 %if %{without system_ffmpeg}
 install -p libffmpegsumo.so $RPM_BUILD_ROOT%{_libdir}/%{name}
 %endif
@@ -581,7 +585,7 @@ fi
 %dir %{_libdir}/%{name}/plugins
 %attr(755,root,root) %{_libdir}/%{name}/%{name}
 # These unique permissions are intentional and necessary for the sandboxing
-%attr(4555,root,root) %{_libdir}/%{name}/chromium-sandbox
+%attr(4555,root,root) %{_libdir}/%{name}/chrome-sandbox
 
 # ffmpeg libs
 %if %{without system_ffmpeg}
This page took 0.029612 seconds and 4 git commands to generate.