]> git.pld-linux.org Git - packages/chromium-browser.git/blobdiff - chromium-browser.spec
use .gz source for beta branch, cleanup todo; update disk usage
[packages/chromium-browser.git] / chromium-browser.spec
index 1c84e762c5dc3eb7383f55e314194567f0d7ae87..dec886469a8ef9b0a203361d5d73b9762214d1e2 100644 (file)
 %bcond_with            sse2                    # use SSE2 instructions
 %bcond_without system_flac             # system flac
 %bcond_without system_jsoncpp  # system jsoncpp
+%bcond_without system_libexif  # system libexif
+%bcond_without system_libmtp   # system libmtp
 %bcond_without system_libusb   # system libusb-1
 %bcond_without system_libwebp  # system libwebp
+%bcond_without system_minizip  # system minizip
+%bcond_without system_opus             # system opus codec support, http://www.opus-codec.org/examples/
 %bcond_without system_speex    # system speex
 %bcond_with            system_sqlite   # system sqlite
 %bcond_without system_srtp             # system srtp (can be used if using bundled libjingle)
 %bcond_with            system_v8               # system v8
-%bcond_without system_vpx              # system vpx
+%bcond_without system_libvpx   # system libvpx
 %bcond_without system_yasm             # system yasm
-# system zlib disabled because of mixed-source.patch
-# https://code.google.com/p/chromium/issues/detail?id=143623
-%bcond_with            system_zlib             # system zlib
+%bcond_without system_zlib             # system zlib
 %bcond_with            tcmalloc                # use tcmalloc
 %bcond_without verbose                 # verbose build (V=1)
 
@@ -52,8 +54,8 @@
 # - mute BEEP mixer if you do not want to hear horrible system bell when
 #   pressing home/end in url bar or more ^F search results on page.
 # - space considerations:
-#   - unpacked sources: ~800MiB
-#   - built code: ~1.4GiB (x86_64)
+#   - unpacked sources: ~668MiB
+#   - built code: ~1.4GiB (x86_64/i686)
 # - http://code.google.com/p/chromium/wiki/LinuxBuildInstructionsPrerequisites
 # - to look for new tarball, use update-source.sh script
 
 # http://carme.pld-linux.org/~glen/chromium-browser/th/x86_64/chromium-nightly.conf
 # http://carme.pld-linux.org/~glen/chromium-browser/th/i686/chromium-nightly.conf
 
-%define                branch          23.0.1271
-%define                basever         64
-%define                patchver        97
 %define                gyp_rev 1014
 Summary:       A WebKit powered web browser
 Name:          chromium-browser
-Version:       %{branch}.%{patchver}
-Release:       2
+Version:       24.0.1312.45
+Release:       0.15
 License:       BSD, LGPL v2+ (ffmpeg)
 Group:         X11/Applications/Networking
-Source0:       http://carme.pld-linux.org/~glen/chromium-browser/src/stable/%{name}-%{branch}.%{basever}.tar.xz
-# Source0-md5: 6c467affd292ee9a9020ac91147969c8
-%if "%{?patchver}" != ""
-Patch0:                http://carme.pld-linux.org/~glen/chromium-browser/src/stable/%{name}-%{version}.patch.xz
-# Patch0-md5:  2f4e98e37053705fd86ffcb49f1f2247
-%endif
+Source0:       http://carme.pld-linux.org/~glen/chromium-browser/src/beta/%{name}-%{version}.tar.gz
+# Source0-md5: 2995d5aa3f1ecb470e60e0984229fcce
 Source1:       %{name}.default
 Source2:       %{name}.sh
 Source3:       %{name}.desktop
@@ -88,7 +83,6 @@ Source8:      get-source.sh
 Source9:       master_preferences.json
 #Patch10:              system-libs.patch
 Patch1:                plugin-searchdirs.patch
-Patch2:                gyp-system-minizip.patch
 Patch3:                disable_dlog_and_dcheck_in_release_builds.patch
 Patch4:                path-libpdf.patch
 Patch5:                options-support.patch
@@ -101,13 +95,14 @@ Patch9:            chromium-ppapi.patch
 Patch11:       chromium-revert-jpeg-swizzle-r2.patch
 Patch15:       nacl-build-irt.patch
 Patch16:       nacl-linkingfix.patch
-Patch17:       system-icu.patch
 Patch18:       nacl-no-untar.patch
 Patch19:       system-jsoncpp.patch
-Patch20:       system-speex.patch
 Patch21:       system-srtp.patch
-Patch22:       gnome3-volume-control.patch
-Patch23:       master-prefs-path.patch
+Patch22:       pulse_fix-157876.patch
+Patch23:       no-pnacl.patch
+Patch24:       nacl-verbose.patch
+Patch25:       gnome3-volume-control.patch
+Patch26:       master-prefs-path.patch
 URL:           http://www.chromium.org/Home
 %{?with_gconf:BuildRequires:   GConf2-devel}
 BuildRequires: OpenGL-GLU-devel
@@ -140,12 +135,15 @@ BuildRequires:    libpng-devel
 %{?with_selinux:BuildRequires: libselinux-devel}
 BuildRequires: libstdc++-devel
 %{?with_system_libusb:BuildRequires:   libusb-devel >= 1.0}
-%{?with_system_vpx:BuildRequires:      libvpx-devel >= 0.9.5-2}
+%{?with_system_libvpx:BuildRequires:   libvpx-devel >= 0.9.5-2}
 %{?with_system_libwebp:BuildRequires:  libwebp-devel >= 0.1.99}
 BuildRequires: libxml2-devel
 BuildRequires: libxslt-devel
 BuildRequires: lzma
-BuildRequires: minizip-devel
+%{?with_system_minizip:BuildRequires:  minizip-devel}
+%{?with_system_libexif:BuildRequires:  libexif-devel >= 1:0.6.21}
+%{?with_system_libmtp:BuildRequires:   libmtp-devel >= 1.1.3}
+%{?with_system_opus:BuildRequires:     opus-devel >= 1.0.2}
 BuildRequires: nspr-devel
 BuildRequires: nss-devel >= 1:3.12.3
 BuildRequires: pam-devel
@@ -178,7 +176,7 @@ Requires:   desktop-file-utils
 %{?with_system_flac:Requires:  flac >= 1.2.1-7}
 Requires:      hicolor-icon-theme
 %{?with_libjpegturbo:Requires: libjpeg-turbo >= 1.2.0}
-%{?with_system_vpx:Requires:   libvpx >= 0.9.5-2}
+%{?with_system_libvpx:Requires:        libvpx >= 0.9.5-2}
 Requires:      xdg-utils >= 1.0.2-4
 Provides:      wwwbrowser
 Obsoletes:     chromium-browser-bookmark_manager < 5.0.388.0
@@ -222,13 +220,7 @@ pt-BR, pt-PT, ro, ru, sk, sl, sr, sv, ta, te, th, tr, uk, vi, zh-CN,
 zh-TW
 
 %prep
-%setup -qc
-%if "%{?patchver}" != ""
-cd %{name}-%{branch}.%{basever}
-%patch0 -p1
-cd ..
-%endif
-mv %{name}-%{branch}.%{basever}/src .
+%setup -q
 
 # Google's versioning is interesting. They never reset "BUILD", which is how we jumped
 # from 3.0.201.0 to 4.0.202.0 as they moved to a new major branch
@@ -253,7 +245,6 @@ ln -s %{SOURCE7} src
 
 #%patch10 -p1
 %patch1 -p1
-%patch2 -p1
 %patch3 -p1
 %patch4 -p1
 %patch5 -p1
@@ -264,14 +255,15 @@ cd src
 %patch9 -p0
 %{!?with_libjpegturbo:%patch11 -p0}
 %patch16 -p1
-%patch17 -p0
 %patch19 -p1
 %patch21 -p1
 %patch22 -p1
+%patch25 -p1
 cd ..
 %patch18 -p1
-%patch20 -p1
 %patch23 -p1
+%patch24 -p1
+%patch26 -p1
 
 cd src
 
@@ -294,44 +286,40 @@ cat > chrome/test/data/nacl/nacl_test_data.gyp <<-EOF
 }
 EOF
 
-sh -x clean-source.sh %{!?with_system_v8:v8=0} %{!?with_nacl:nacl=0} libxml=0 %{!?with_system_zlib:zlib=0}
-
-rm -rf native_client/toolchain/linux_x86_newlib
+sh -x clean-source.sh %{!?with_system_v8:v8=0} %{!?with_nacl:nacl=0} %{!?with_system_zlib:zlib=0}
 
 %build
 cd src
 
 %if %{with nacl}
 if [ ! -d native_client/toolchain/linux_x86_newlib ]; then
-# Make symlinks for nacl
-cd native_client/toolchain
-install -d linux_x86_newlib/x86_64-nacl/bin
-install -d linux_x86_newlib/x86_64-nacl/lib
-install -d linux_x86_newlib/x86_64-nacl/lib32
-install -d linux_x86_newlib/x86_64-nacl/nacl/include/bits
-install -d linux_x86_newlib/x86_64-nacl/nacl/include/machine
-install -d linux_x86_newlib/x86_64-nacl/nacl/include/sys
-# link newlib toolchain to glibc as well, see gentoo bug #417019
-#ln -s linux_x86_newlib linux_x86
-cd linux_x86_newlib/x86_64-nacl/bin
-ln -s %{_bindir}/x86_64-nacl-gcc gcc
-ln -s %{_bindir}/x86_64-nacl-g++ g++
+# Make symlinks for NaCL
+install -d native_client/toolchain/linux_x86_newlib/x86_64-nacl/{bin,lib,lib32,nacl}
+
+cd native_client/toolchain/linux_x86_newlib/x86_64-nacl/bin
+__cc='%{__cc}'
+if [ "${__cc}#ccache}" != "$__cc" ]; then
+       echo 'exec ccache %{_bindir}/x86_64-nacl-gcc "$@"' > gcc
+       echo 'exec ccache %{_bindir}/x86_64-nacl-g++ "$@"' > g++
+       %{__sed} -i -e '1i#!/bin/sh' gcc g++
+       chmod +x gcc g++
+else
+       ln -s %{_bindir}/x86_64-nacl-gcc gcc
+       ln -s %{_bindir}/x86_64-nacl-g++ g++
+fi
 ln -s %{_bindir}/x86_64-nacl-ar ar
 ln -s %{_bindir}/x86_64-nacl-as as
 ln -s %{_bindir}/x86_64-nacl-ranlib ranlib
 ln -s %{_bindir}/x86_64-nacl-strip x86-64-nacl-strip
 ln -s %{_bindir}/x86_64-nacl-strip strip
-ln -s %{_prefix}/x86_64-nacl/lib/*.a ../lib/
-ln -s %{_prefix}/x86_64-nacl/lib/32/*.a ../lib32/
-cd ../nacl/include
-for i in $(find %{_prefix}/x86_64-nacl/include -type f | grep -v "c++"); do
-       ln -s $i ${i#%{_prefix}/x86_64-nacl/include/}
-done
-cd ../../../../../..
+ln -s %{_prefix}/x86_64-nacl/lib/*.a ../lib
+ln -s %{_prefix}/x86_64-nacl/lib/32/*.a ../lib32
+ln -s %{_prefix}/x86_64-nacl/include ../nacl/include
+cd ../../../../..
 fi
 %endif
 
-test %{_specdir}/%{name}.spec -nt Makefile && %{__rm} Makefile
+test %{_specdir}/%{name}.spec -nt Makefile && %{__rm} -f Makefile
 test -e Makefile || %{__python} build/gyp_chromium \
        --format=make \
        -Goutput_dir=../out \
@@ -356,33 +344,40 @@ test -e Makefile || %{__python} build/gyp_chromium \
        -Dffmpeg_branding=Chrome \
        -Dremove_webcore_debug_symbols=1 \
        -Dproprietary_codecs=1 \
+       -Dinclude_tests=0 \
 %if %{with nacl}
-       -Ddisable_glibc=1 \
        -Dnaclsdk_mode=custom:/usr/x86_64-nacl \
        -Ddisable_glibc_untar=1 \
        -Ddisable_newlib_untar=1 \
-       -Ddisable_pnacl_untar=1 \
+       -Ddisable_glibc=1 \
+       -Ddisable_pnacl=1 \
+       -Dbuild_pnacl_newlib=0 \
 %else
+       -Ddisable_pnacl_untar=1 \
        -Ddisable_nacl=1 \
 %endif
-       -Ddisable_pnacl=1 \
        %{!?with_sse2:-Ddisable_sse2=1} \
        %{?with_selinux:-Dselinux=1} \
        %{gyp_with cups} \
-       %{gyp_with gconf} \
+       %{gyp_with gconf} -Dlinux_link_gsettings=0 \
        %{gyp_with kerberos} -Dlinux_link_kerberos=0 \
        %{gyp_with keyring gnome_keyring} -Dlinux_link_gnome_keyring=0 \
        %{gyp_with pulseaudio} \
        %{gyp_with system_flac} \
+       %{gyp_with system_libexif} \
+       %{gyp_with system_libmtp} \
        %{gyp_with system_libusb} \
+       %{gyp_with system_libvpx} \
        %{gyp_with system_libwebp} \
+       %{gyp_with system_minizip} \
+       %{gyp_with system_opus} \
        %{gyp_with system_speex} \
        %{gyp_with system_sqlite} \
        %{gyp_with system_v8} \
-       %{gyp_with system_vpx} \
        %{gyp_with system_yasm} \
        %{gyp_with system_zlib} \
        -Duse_system_bzip2=1 \
+       -Duse_system_expat=1 \
        -Duse_system_icu=1 \
        -Duse_system_libevent=1 \
        -Duse_system_libjpeg=1 \
This page took 0.033808 seconds and 4 git commands to generate.