]> git.pld-linux.org Git - packages/chromium-browser.git/blobdiff - chromium-browser.spec
skip delete remoting/base/resources_unittest.* to get build going
[packages/chromium-browser.git] / chromium-browser.spec
index 05db5a6e0be9094d3d2ebc7c54ba1532195c706b..dc8b0d533037ef980b0ea567ecd35892141f53b7 100644 (file)
@@ -14,6 +14,7 @@
 %bcond_with            sse2                    # use SSE2 instructions
 %bcond_without system_flac             # system flac
 %bcond_with            system_ffmpeg   # system ffmpeg instead of ffmpegsumo
+%bcond_without system_harfbuzz # system harfbuzz
 %bcond_without system_jsoncpp  # system jsoncpp
 %bcond_without system_libexif  # system libexif
 %bcond_without system_libmtp   # system libmtp
 %bcond_without system_libxnvctrl       # system libxnvctrl
 %bcond_without system_minizip  # system minizip
 %bcond_without system_opus             # system opus codec support, http://www.opus-codec.org/examples/
-%bcond_with            system_protobuf # system protobuf
+%bcond_without system_protobuf # system protobuf
 %bcond_without system_speex    # system speex
 %bcond_with            system_sqlite   # system sqlite
-%bcond_without system_srtp             # system srtp (can be used if using bundled libjingle)
+%bcond_without system_libsrtp  # system srtp (can be used if using bundled libjingle)
 %bcond_with            system_v8               # system v8
 %bcond_without system_libvpx   # system libvpx
 %bcond_without system_yasm             # system yasm
 %bcond_without system_zlib             # system zlib
-%bcond_with            tcmalloc                # use tcmalloc
+%bcond_without tcmalloc                # use tcmalloc
 %bcond_without verbose                 # verbose build (V=1)
 
 %if %{with nacl}
 # - use_system_hunspell
 # - use_system_stlport
 # - other defaults: src/build/common.gypi
+# - system usb-ids stuff
+# - libpci: link, because xserver loads it anyway
 
 # NOTES:
 # - mute BEEP mixer if you do not want to hear horrible system bell when
 #   pressing home/end in url bar or more ^F search results on page.
 # - space considerations:
-#   - unpacked sources: ~649MiB
+#   - unpacked sources: ~574MiB
 #   - built code: ~1.4GiB (x86_64/i686)
 # - http://code.google.com/p/chromium/wiki/LinuxBuildInstructionsPrerequisites
 # - to look for new tarball, use update-source.sh script
 %define                gyp_rev 1014
 Summary:       A WebKit powered web browser
 Name:          chromium-browser
-Version:       24.0.1312.45
-Release:       0.21
+Version:       25.0.1364.26
+Release:       0.24
 License:       BSD, LGPL v2+ (ffmpeg)
 Group:         X11/Applications/Networking
-Source0:       http://carme.pld-linux.org/~glen/chromium-browser/src/beta/%{name}-%{version}.tar.gz
+Source0:       http://carme.pld-linux.org/~glen/chromium-browser/src/dev/%{name}-%{version}.tar.gz
 # Source0-md5: 2995d5aa3f1ecb470e60e0984229fcce
 Source1:       %{name}.default
 Source2:       %{name}.sh
@@ -94,16 +97,18 @@ Patch10:    system-libxnvctrl.patch
 # https://bugs.gentoo.org/show_bug.cgi?id=393471
 # libjpeg-turbo >= 1.1.90 supports that feature
 Patch11:       chromium-revert-jpeg-swizzle-r2.patch
+Patch12:       system-ffmpeg.patch
+Patch13:       system-libpng.patch
+Patch14:       system-opus.patch
 Patch15:       nacl-build-irt.patch
 Patch16:       nacl-linkingfix.patch
 Patch18:       nacl-no-untar.patch
 Patch19:       system-jsoncpp.patch
-Patch21:       system-srtp.patch
-Patch22:       pulse_fix-157876.patch
 Patch23:       no-pnacl.patch
 Patch24:       nacl-verbose.patch
 Patch25:       gnome3-volume-control.patch
 Patch26:       master-prefs-path.patch
+Patch27:       tcmalloc-glibc2.16.patch
 URL:           http://www.chromium.org/Home
 %{?with_gconf:BuildRequires:   GConf2-devel}
 BuildRequires: OpenGL-GLU-devel
@@ -124,7 +129,9 @@ BuildRequires:      flex
 BuildRequires: fontconfig-devel
 BuildRequires: glib2-devel
 BuildRequires: gperf
+BuildRequires: gtest-devel
 BuildRequires: gtk+2-devel
+%{?with_system_harfbuzz:BuildRequires: harfbuzz-devel}
 %{?with_kerberos:BuildRequires:        heimdal-devel}
 BuildRequires: hicolor-icon-theme
 %{?with_system_jsoncpp:BuildRequires:  jsoncpp-devel}
@@ -162,7 +169,7 @@ BuildRequires:      rpm >= 4.4.9-56
 BuildRequires: rpmbuild(macros) >= 1.453
 %{?with_system_speex:BuildRequires:    speex-devel >= 1:1.2-rc1}
 BuildRequires: sqlite3-devel >= 3.6.1
-%{?with_system_srtp:BuildRequires:     srtp-devel >= 1.4.4}
+%{?with_system_libsrtp:BuildRequires:  srtp-devel >= 1.4.4}
 BuildRequires: subversion
 BuildRequires: tar >= 1:1.22
 BuildRequires: udev-devel
@@ -257,11 +264,13 @@ cd src
 %patch9 -p0
 #%patch2 -p1
 %{!?with_libjpegturbo:%patch11 -p0}
+%patch12 -p1
+%patch13 -p0
+%patch14 -p2
 %patch16 -p1
 %patch19 -p1
-%patch21 -p1
-%patch22 -p1
 %patch25 -p1
+%patch27 -p1
 cd ..
 %patch18 -p1
 %patch23 -p1
@@ -300,13 +309,16 @@ sh -x clean-source.sh \
 cd src
 
 %if %{with nacl}
+rm -rf native_client/toolchain/linux_x86_newlib
 if [ ! -d native_client/toolchain/linux_x86_newlib ]; then
 # Make symlinks for NaCL
-install -d native_client/toolchain/linux_x86_newlib/x86_64-nacl/{bin,lib,lib32,nacl}
+install -d native_client/toolchain/linux_x86_newlib/x86_64-nacl/{bin,nacl}
 
-cd native_client/toolchain/linux_x86_newlib/x86_64-nacl/bin
+cd native_client/toolchain/linux_x86_newlib
+ln -s x86_64-nacl/bin bin
+cd x86_64-nacl/bin
 __cc='%{__cc}'
-if [ "${__cc}#ccache}" != "$__cc" ]; then
+if [ "${__cc#ccache}" != "$__cc" ]; then
        echo 'exec ccache %{_bindir}/x86_64-nacl-gcc "$@"' > gcc
        echo 'exec ccache %{_bindir}/x86_64-nacl-g++ "$@"' > g++
        %{__sed} -i -e '1i#!/bin/sh' gcc g++
@@ -315,13 +327,17 @@ else
        ln -s %{_bindir}/x86_64-nacl-gcc gcc
        ln -s %{_bindir}/x86_64-nacl-g++ g++
 fi
+ln -s gcc x86_64-nacl-gcc
+ln -s g++ x86_64-nacl-g++
+ln -s %{_bindir}/x86_64-nacl-ar .
 ln -s %{_bindir}/x86_64-nacl-ar ar
 ln -s %{_bindir}/x86_64-nacl-as as
+ln -s %{_bindir}/x86_64-nacl-ranlib .
 ln -s %{_bindir}/x86_64-nacl-ranlib ranlib
-ln -s %{_bindir}/x86_64-nacl-strip x86-64-nacl-strip
+ln -s %{_bindir}/x86_64-nacl-strip .
 ln -s %{_bindir}/x86_64-nacl-strip strip
-ln -s %{_prefix}/x86_64-nacl/lib/*.a ../lib
-ln -s %{_prefix}/x86_64-nacl/lib/32/*.a ../lib32
+ln -s %{_prefix}/x86_64-nacl/lib ../lib
+ln -s %{_prefix}/x86_64-nacl/lib32 ../lib32
 ln -s %{_prefix}/x86_64-nacl/include ../nacl/include
 cd ../../../../..
 fi
@@ -370,8 +386,10 @@ test -e Makefile || %{__python} build/gyp_chromium \
        %{gyp_with pulseaudio} \
        %{gyp_with system_ffmpeg} \
        %{gyp_with system_flac} \
+       %{gyp_with system_harfbuzz} \
        %{gyp_with system_libexif} \
        %{gyp_with system_libmtp} \
+       %{gyp_with system_libsrtp} \
        %{gyp_with system_libusb} \
        %{gyp_with system_libvpx} \
        %{gyp_with system_libwebp} \
@@ -422,7 +440,7 @@ cp -a *.pak locales resources $RPM_BUILD_ROOT%{_libdir}/%{name}
 cp -p chrome.1 $RPM_BUILD_ROOT%{_mandir}/man1/%{name}.1
 install -p chrome $RPM_BUILD_ROOT%{_libdir}/%{name}/%{name}
 install -p chrome_sandbox $RPM_BUILD_ROOT%{_libdir}/%{name}/chromium-sandbox
-%if %{with ffmpegsumo}
+%if %{without system_ffmpeg}
 install -p libffmpegsumo.so $RPM_BUILD_ROOT%{_libdir}/%{name}
 %endif
 cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_desktopdir}
@@ -508,7 +526,7 @@ fi
 %attr(4555,root,root) %{_libdir}/%{name}/chromium-sandbox
 
 # ffmpeg libs
-%if %{with ffmpegsumo}
+%if %{without system_ffmpeg}
 %attr(755,root,root) %{_libdir}/%{name}/libffmpegsumo.so
 %endif
 
This page took 0.036479 seconds and 4 git commands to generate.