]> git.pld-linux.org Git - packages/chromium-browser.git/blobdiff - chromium-browser.spec
- up to 18.0.1025.162
[packages/chromium-browser.git] / chromium-browser.spec
index 043672f5373d4997ca3f9401065dedebe1ed10dc..ca320b9553f8d9fc66b9229dec8ef3a3e173d063 100644 (file)
 %bcond_without system_flac             # with system flac
 %bcond_without system_libwebp  # with system libwebp
 %bcond_without system_speex    # with system speex
-%bcond_without system_v8               # with system v8
+%bcond_with            system_v8               # with system v8
 %bcond_without system_vpx              # with system vpx
 %bcond_without system_yasm             # with system yasm
 %bcond_without system_zlib             # with system zlib
+%bcond_without libjpegturbo            # use libjpeg-turbo features
 %bcond_with            verbose                 # verbose build (V=1)
 
 # TODO
 # or:
 # http://carme.pld-linux.org/~glen/chromium-browser/th/x86_64/chromium-nightly.conf
 
-%define                svndate %{nil}
-%define                svnver  113337
-%define                rel             2
-
 %define                gyp_rev 1014
 Summary:       A WebKit powered web browser
 Name:          chromium-browser
-Version:       16.0.912.63
-Release:       0.%{svnver}.%{rel}
+Version:       18.0.1025.162
+Release:       1
 License:       BSD, LGPL v2+ (ffmpeg)
 Group:         X11/Applications/Networking
-Source0:       http://carme.pld-linux.org/~glen/chromium-browser/src/beta/%{name}_%{version}~r%{svnver}.orig.tar.gz
-# Source0-md5: c01869f276a9bf5f651771d93b07dac8
-#SourceX:      http://ppa.launchpad.net/chromium-daily/ppa/ubuntu/pool/main/c/chromium-browser/%{name}_%{version}~svn%{svndate}r%{svnver}.orig.tar.gz
+Source0:       http://carme.pld-linux.org/~glen/chromium-browser/src/stable/%{name}-%{version}.tar.xz
+# Source0-md5: 189c506b33faeecf2c80617b170201b8
 Source2:       %{name}.sh
 Source3:       %{name}.desktop
 Source5:       find-lang.sh
 Source6:       update-source.sh
 Source7:       clean-source.sh
+Source8:       get-source.sh
 Patch0:                system-libs.patch
 Patch1:                plugin-searchdirs.patch
 Patch2:                gyp-system-minizip.patch
@@ -74,6 +71,11 @@ Patch6:              get-webkit_revision.patch
 Patch7:                dlopen_sonamed_gl.patch
 Patch8:                chromium_useragent.patch.in
 Patch9:                system-expat.patch
+Patch10:       %{name}-pulse.patch
+# https://bugs.gentoo.org/show_bug.cgi?id=393471
+# libjpeg-turbo >= 1.1.90 supports that feature
+Patch11:       chromium-revert-jpeg-swizzle-r2.patch
+Patch12:       chromium-glib.patch
 URL:           http://www.chromium.org/Home
 %{?with_gconf:BuildRequires:   GConf2-devel}
 BuildRequires: OpenGL-GLU-devel
@@ -91,10 +93,12 @@ BuildRequires:      glib2-devel
 BuildRequires: gperf
 BuildRequires: gtk+2-devel
 %{?with_kerberos:BuildRequires:        heimdal-devel}
+BuildRequires: hicolor-icon-theme
 BuildRequires: libevent-devel
 %{?with_keyring:BuildRequires: libgnome-keyring-devel}
 BuildRequires: libicu-devel >= 4.6
 BuildRequires: libjpeg-devel
+%{?with_libjpegturbo:BuildRequires:    libjpeg-turbo-devel >= 1.2.0}
 BuildRequires: libpng-devel
 %{?with_selinux:BuildRequires: libselinux-devel}
 BuildRequires: libstdc++-devel
@@ -121,17 +125,20 @@ BuildRequires:    rpmbuild(macros) >= 1.453
 BuildRequires: sqlite3-devel >= 3.6.1
 BuildRequires: tar >= 1:1.22
 BuildRequires: util-linux
-%{?with_system_v8:BuildRequires:       v8-devel >= 3.6}
+%{?with_system_v8:BuildRequires:       v8-devel >= 3.7}
 BuildRequires: which
 BuildRequires: xorg-lib-libXScrnSaver-devel
 BuildRequires: xorg-lib-libXt-devel
 BuildRequires: xorg-lib-libXtst-devel
+BuildRequires: xz
 %{?with_system_yasm:BuildRequires:     yasm}
 %{?with_system_zlib:BuildRequires:     zlib-devel}
 Requires:      browser-plugins >= 2.0
 Requires:      desktop-file-utils
+Requires:      hicolor-icon-theme
 %{?with_system_vpx:Requires:   libvpx >= 0.9.5-2}
 Requires:      xdg-utils >= 1.0.2-4
+%{?with_libjpegturbo:Requires: libjpeg-turbo >= 1.2.0}
 Provides:      wwwbrowser
 Obsoletes:     chromium-browser-bookmark_manager < 5.0.388.0
 Obsoletes:     chromium-browser-inspector < 15.0.863.0
@@ -146,11 +153,6 @@ BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 %define                _enable_debug_packages  0
 %endif
 
-# undefine if empty, makes prep simplier
-%if "%{svndate}" == "%{nil}"
-%undefine      svndate
-%endif
-
 %description
 Chromium is an open-source browser project that aims to build a safer,
 faster, and more stable way for all Internet users to experience the
@@ -178,10 +180,7 @@ pt-BR, pt-PT, ro, ru, sk, sl, sr, sv, ta, te, th, tr, uk, vi, zh-CN,
 zh-TW
 
 %prep
-%setup -q -n %{name}-%{version}~%{?svndate:svn%{svndate}}r%{svnver}
-SRC=%{name}-%{version}~%{?svndate:svn%{svndate}}r%{svnver}-source.tar.*
-tar xf $SRC
-%{__rm} $SRC
+%setup -q
 
 # Google's versioning is interesting. They never reset "BUILD", which is how we jumped
 # from 3.0.201.0 to 4.0.202.0 as they moved to a new major branch
@@ -192,10 +191,10 @@ test "$ver" = %{version}
 gyp_rev=$(grep googlecode_url.*gyp src/DEPS | cut -d'"' -f6 | cut -d@ -f2)
 test "$gyp_rev" = %{gyp_rev} || :
 
-v8_ver=$(awk 'NR=1 {print $NF; exit}' src/v8/ChangeLog)
+v8_ver=$(awk 'NR=1 {print $NF; exit}' src/v8/ChangeLog || :)
 
 # Populate the LASTCHANGE file template as we no longer have the VCS files at this point
-echo "%{svnver}" > src/build/LASTCHANGE.in
+#echo "%{svnver}" > src/build/LASTCHANGE.in
 
 # add chromium and pld to useragent
 %define pld_version %(echo %{pld_release} | sed -e 'y/[at]/[AT]/')
@@ -216,10 +215,13 @@ ln -s %{SOURCE7} src
 %patch7 -p1
 cd src
 %patch9 -p1
+%patch10 -p1
+%{!?with_libjpegturbo:%patch11 -p0}
+%patch12 -p3
 cd ..
 
 cd src
-sh -x clean-source.sh %{?with_system_v8:v8=1} %{?with_nacl:nacl=1}
+sh -x clean-source.sh %{!?with_system_v8:v8=0} %{!?with_nacl:nacl=0}
 
 %build
 cd src
@@ -283,7 +285,7 @@ test -e Makefile || %{__python} build/gyp_chromium --format=make build/all.gyp \
 %install
 rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT%{_libdir}/%{name}/{themes,plugins,extensions} \
-       $RPM_BUILD_ROOT{%{_bindir},%{_mandir}/man1,%{_pixmapsdir},%{_desktopdir}}
+       $RPM_BUILD_ROOT{%{_bindir},%{_mandir}/man1,%{_desktopdir}}
 
 cd src/out/%{!?debug:Release}%{?debug:Debug}
 install -p %{SOURCE2} $RPM_BUILD_ROOT%{_bindir}/%{name}
@@ -311,7 +313,17 @@ install -p nacl_irt_x86_32.nexe $RPM_BUILD_ROOT%{_libdir}/%{name}
 
 cd -
 
-cp -p src/chrome/app/theme/chromium/product_logo_48.png $RPM_BUILD_ROOT%{_pixmapsdir}/%{name}.png
+for icon in src/chrome/app/theme/chromium/product_logo_[0-9]*.png; do
+       size=${icon##*/product_logo_}
+       size=${size%.png}
+
+       # this will skip non-numeric (22_mono_invert, 22_mono)
+       dir=%{_iconsdir}/hicolor/${size}x${size}/apps
+       test -d "$dir" || continue
+
+       install -d $RPM_BUILD_ROOT$dir
+       cp -p $icon $RPM_BUILD_ROOT$dir/%{name}.png
+done
 
 %browser_plugins_add_browser %{name} -p %{_libdir}/%{name}/plugins -b <<'EOF'
 # http://code.google.com/p/chromium/issues/detail?id=24507
@@ -327,11 +339,13 @@ EOF
 rm -rf $RPM_BUILD_ROOT
 
 %post
+%update_icon_cache hicolor
 %update_desktop_database
 %update_browser_plugins
 
 %postun
 if [ "$1" = 0 ]; then
+       %update_icon_cache hicolor
        %update_browser_plugins
 fi
 
@@ -341,10 +355,11 @@ fi
 %config(noreplace) %verify(not md5 mtime size) %{_browserpluginsconfdir}/blacklist.d/%{name}.*.blacklist
 %attr(755,root,root) %{_bindir}/%{name}
 %{_mandir}/man1/%{name}.1*
-%{_pixmapsdir}/%{name}.png
 %{_desktopdir}/*.desktop
+%{_iconsdir}/hicolor/*/apps/%{name}.png
 %dir %{_libdir}/%{name}
 %{_libdir}/%{name}/chrome.pak
+%{_libdir}/%{name}/content_resources.pak
 %{_libdir}/%{name}/resources.pak
 %dir %{_libdir}/%{name}/locales
 %{_libdir}/%{name}/locales/en-US.pak
This page took 0.035189 seconds and 4 git commands to generate.