]> git.pld-linux.org Git - packages/chromium-browser.git/blobdiff - chromium-browser.spec
- rediffed nacl-linkingfix,gnome3-volume-control patches, build patch obsolete
[packages/chromium-browser.git] / chromium-browser.spec
index a8516af7c2dc6a66228375eff27281eda88306a9..69321a292413aca080897ac01a899b71229b2c4a 100644 (file)
@@ -5,38 +5,39 @@
 %bcond_with    dev                     # with dev optimizations (skip clean source)
 %bcond_without gconf                   # with GConf
 %bcond_without kerberos                # build with kerberos support (dlopened if support compiled, library names in net/http/http_auth_gssapi_posix.cc)
-%bcond_without keyring                 # with keyring support (gnome-keyring dlopened, kwalletd via dbus)
-%bcond_with            gps                     # with gps support (linked), if enabled must use exactly same gpsd as shm structures may change leading to unexpected results (crash)
-%bcond_without libjpegturbo    # use libjpeg-turbo features
+%bcond_without keyring                 # with keyring support (gnome-keyring dlopened, kwalletd via dbus)
+%bcond_with    gps                     # with gps support (linked), if enabled must use exactly same gpsd as shm structures may change leading to unexpected results (crash)
+%bcond_without libjpegturbo            # use libjpeg-turbo features
 %bcond_with    nacl                    # build Native Client support, disabled: http://crbug.com/269560
 %bcond_without ninja                   # use Ninja instead of make to build
 %bcond_without pulseaudio              # with pulseaudio
 %bcond_without sandboxing              # with sandboxing
-%bcond_with            selinux                 # with SELinux (need policy first)
-%bcond_with            shared_libs             # with shared libs
-%bcond_with            sse2                    # use SSE2 instructions
+%bcond_with    selinux                 # with SELinux (need policy first)
+%bcond_with    shared_libs             # with shared libs
+%bcond_with    sse2                    # use SSE2 instructions
 %bcond_without system_flac             # system flac
-%bcond_with    system_ffmpeg   # system ffmpeg instead of ffmpegsumo
-%bcond_without system_harfbuzz # system harfbuzz
-%bcond_without system_icu      # system icu
-%bcond_without system_jsoncpp  # system jsoncpp
-%bcond_without system_libexif  # system libexif
-%bcond_without system_libmtp   # system libmtp
-%bcond_with    system_libusb   # system libusb-1, disabled: http://crbug.com/266149
-%bcond_without system_libwebp  # system libwebp
+%bcond_without system_ffmpeg           # system ffmpeg
+%bcond_without system_harfbuzz         # system harfbuzz
+# http://bugs.gentoo.org/576370
+%bcond_with    system_icu              # system icu
+%bcond_without system_jsoncpp          # system jsoncpp
+%bcond_without system_libexif          # system libexif
+%bcond_without system_libmtp           # system libmtp
+%bcond_with    system_libusb           # system libusb-1, disabled: http://crbug.com/266149
+%bcond_without system_libwebp          # system libwebp
 %bcond_without system_libxnvctrl       # system libxnvctrl
 %bcond_with    system_mesa             # system Mesa
-%bcond_without system_minizip  # system minizip
+%bcond_without system_minizip          # system minizip
 %bcond_without system_opus             # system opus codec support, http://www.opus-codec.org/examples/
 # protobuf broken: https://bugs.gentoo.org/show_bug.cgi?id=525560
-%bcond_with    system_protobuf # system protobuf
-%bcond_without system_re2              # system re2
-%bcond_without system_snappy   # system snappy
-%bcond_without system_speex    # system speex
-%bcond_with    system_sqlite   # system sqlite WebSQL (http://www.w3.org/TR/webdatabase/) will not work
-%bcond_without system_libsrtp  # system srtp (can be used if using bundled libjingle), http://bugs.gentoo.org/459932
-%bcond_with            system_v8               # system v8
-%bcond_without system_libvpx   # system libvpx, http://crbug.com/494939
+%bcond_with    system_protobuf         # system protobuf
+%bcond_with    system_re2              # system re2
+%bcond_without system_snappy           # system snappy
+%bcond_without system_speex            # system speex
+%bcond_with    system_sqlite           # system sqlite WebSQL (http://www.w3.org/TR/webdatabase/) will not work
+%bcond_without system_libsrtp          # system srtp (can be used if using bundled libjingle), http://bugs.gentoo.org/459932
+%bcond_with    system_v8               # system v8
+%bcond_with    system_libvpx           # system libvpx, http://crbug.com/494939
 %bcond_without system_yasm             # system yasm
 %bcond_without system_zlib             # system zlib
 %bcond_with    tcmalloc                # use tcmalloc
@@ -72,9 +73,9 @@
 # - http://code.google.com/p/chromium/wiki/LinuxBuildInstructionsPrerequisites
 # - to look for new tarball, use update-source.sh script
 
-%define                branch          47.0.2526
-%define                basever         58
-#define                patchver        130
+%define                branch          50.0.2661
+%define                basever         75
+%define                patchver        102
 %define                gyp_rev 1014
 Summary:       A WebKit powered web browser
 Name:          chromium-browser
@@ -83,14 +84,15 @@ Version:    %{branch}.%{patchver}
 %else
 Version:       %{branch}.%{basever}
 %endif
-Release:       1
+Release:       3
 License:       BSD%{!?with_system_ffmpeg:, LGPL v2+ (ffmpeg)}
 Group:         X11/Applications/Networking
-Source0:       http://carme.pld-linux.org/~glen/chromium-browser/src/stable/%{name}-%{branch}.%{basever}.tar.gz
-# Source0-md5: ea1c198c02d6adf803150627d6ba2e14
+Source0:       http://carme.pld-linux.org/~glen/chromium-browser/src/stable/%{name}-%{branch}.%{basever}.tar.xz
+# Source0-md5: f6ae41191ec560a0d1cd238ac2a618cf
+#Source0:      http://carme.pld-linux.org/~glen/chromium-browser/src/beta/%{name}-%{branch}.%{basever}.tar.gz
 %if "%{?patchver}" != ""
 Patch0:                http://carme.pld-linux.org/~glen/chromium-browser/src/stable/%{name}-%{version}.patch.xz
-# Patch0-md5:  02973b87b9564ed36220497b4bf83109
+# Patch0-md5:  a8bd6c3c0f6befac88c81632a9360761
 %endif
 Source1:       %{name}.default
 Source2:       %{name}.sh
@@ -118,11 +120,12 @@ Patch31:  system-jinja.patch
 Patch32:       remove_bundled_libraries-stale.patch
 Patch35:       etc-dir.patch
 Patch36:       angle.patch
-Patch37:       %{name}-build.patch
 Patch38:       vaapi_include.patch
 Patch39:       libsecret.patch
 Patch40:       ffmpeg-generate-errors.patch
 Patch41:       ffmpeg-generate.patch
+Patch42:       system-ffmpeg.patch
+Patch43:       cups22.patch
 URL:           http://www.chromium.org/Home
 %{?with_gconf:BuildRequires:   GConf2-devel}
 %{?with_system_mesa:BuildRequires:     Mesa-libGL-devel >= 9.1}
@@ -140,7 +143,7 @@ BuildRequires:      bzip2-devel
 %{?with_cups:BuildRequires:    cups-devel}
 BuildRequires: elfutils-devel
 BuildRequires: expat-devel
-%{?with_system_ffmpeg:BuildRequires:   ffmpeg-devel >= 1.0}
+%{?with_system_ffmpeg:BuildRequires:   ffmpeg-devel >= 2.7.2}
 %{?with_system_flac:BuildRequires:     flac-devel >= 1.2.1-7}
 BuildRequires: fontconfig-devel
 BuildRequires: glib2-devel
@@ -166,7 +169,7 @@ BuildRequires:      libsecret-devel
 %{?with_selinux:BuildRequires: libselinux-devel}
 BuildRequires: libstdc++-devel
 %{?with_system_libusb:BuildRequires:   libusb-devel >= 1.0}
-%{?with_system_libvpx:BuildRequires:   libvpx-devel >= 1.4.0}
+%{?with_system_libvpx:BuildRequires:   libvpx-devel >= 1.5.0}
 %{?with_system_libwebp:BuildRequires:  libwebp-devel >= 0.4.0}
 BuildRequires: libxml2-devel
 BuildRequires: libxslt-devel
@@ -187,10 +190,11 @@ BuildRequires:    pkgconfig
 BuildRequires: python
 BuildRequires: python-BeautifulSoup
 #BuildRequires:        python-gyp >= 1-%{gyp_rev}
+BuildRequires: python-html5lib
 BuildRequires: python-jinja2 >= 2.7
 BuildRequires: python-modules
 BuildRequires: python-ply >= 3.4
-%{?with_system_re2:BuildRequires:      re2-devel >= 20130115-2}
+%{?with_system_re2:BuildRequires:      re2-devel >= 20151101}
 BuildRequires: rpm >= 4.4.9-56
 BuildRequires: rpmbuild(macros) >= 1.453
 %{?with_system_snappy:BuildRequires:   snappy-devel}
@@ -219,7 +223,7 @@ Requires:   libevent >= 2.0.21
 %{?with_libjpegturbo:Requires: libjpeg-turbo >= 1.2.0}
 %{?with_system_libvpx:Requires:        libvpx >= 1.4.0}
 Requires:      lsb-release
-%{?with_system_re2:Requires:   re2 >= 20130115-2}
+%{?with_system_re2:Requires:   re2 >= 20151101}
 %{?with_system_protobuf:Requires:      protobuf-libs >= 2.5.0-2}
 Requires:      shared-mime-info
 %{?with_system_sqlite:Requires:        sqlite3(icu)}
@@ -271,9 +275,7 @@ tracking and an auto-updater system.
 Summary:       chromium-browser language packages
 Group:         I18n
 Requires:      %{name} = %{version}-%{release}
-%if "%{_rpmversion}" >= "5"
 BuildArch:     noarch
-%endif
 
 %description l10n
 Chromium is an open-source browser project that aims to build a safer,
@@ -329,13 +331,15 @@ ln -s %{SOURCE7} .
 %patch32 -p1
 %patch35 -p1
 %patch36 -p1
-%patch37 -p1
 #%patch38 -p1 CHECK
 %patch39 -p1
-%patch40 -p1
-%patch41 -p1
+#%patch40 -p1 UPDATE
+#%patch41 -p1 CHECK
+%patch42 -p1
+%patch43 -p1
 
 # https://groups.google.com/a/chromium.org/forum/#!topic/chromium-packagers/9JX1N2nf4PU
+install -d chrome/test/data/webui
 touch chrome/test/data/webui/i18n_process_css_test.html
 
 %{?with_dev:exit 0}
@@ -441,6 +445,7 @@ flags="
        %{?with_gps:-Dlinux_use_libgps=1 -Dlinux_link_libgps=1} \
        -Dclang=0 \
        -Dhost_clang=0 \
+       -Dsysroot= \
        -Dlinux_use_bundled_binutils=0 \
        -Dlinux_use_bundled_gold=0 \
        -Dlinux_use_gold_flags=0 \
@@ -621,6 +626,7 @@ exit 0
 %postun
 if [ "$1" = 0 ]; then
        %update_icon_cache hicolor
+       %update_desktop_database
        %update_browser_plugins
 fi
 
This page took 0.082156 seconds and 4 git commands to generate.