]> git.pld-linux.org Git - packages/chromium-browser.git/blobdiff - chromium-browser.spec
- faster test builds with -Dremove_webcore_debug_symbols=1
[packages/chromium-browser.git] / chromium-browser.spec
index b14ce89b846193c72ffa67ed81f2379c6d366d8f..0d3013389fe0bc78c2167e620f92c602b73350ae 100644 (file)
 # http://carme.pld-linux.org/~glen/chromium-browser/th/x86_64/chromium-nightly.conf
 
 %define                svndate %{nil}
-%define                svnver  109393
-%define                rel             3
+%define                svnver  112386
+%define                rel             1
 
 %define                gyp_rev 1014
 Summary:       A WebKit powered web browser
 Name:          chromium-browser
-Version:       16.0.912.36
+Version:       16.0.912.59
 Release:       0.%{svnver}.%{rel}
 License:       BSD, LGPL v2+ (ffmpeg)
 Group:         X11/Applications/Networking
 Source0:       http://carme.pld-linux.org/~glen/chromium-browser/src/beta/%{name}_%{version}~r%{svnver}.orig.tar.gz
-# Source0-md5: 92eda1bd49fff2e70b703032f1aaab0d
+# Source0-md5: 79d7767698b1522ddf5f7cf725e0594f
 #SourceX:      http://ppa.launchpad.net/chromium-daily/ppa/ubuntu/pool/main/c/chromium-browser/%{name}_%{version}~svn%{svndate}r%{svnver}.orig.tar.gz
 Source2:       %{name}.sh
 Source3:       %{name}.desktop
 Source4:       find-lang.sh
 Source5:       update-source.sh
+Source6:       clean-source.sh
 Patch0:                system-libs.patch
 Patch1:                plugin-searchdirs.patch
 Patch2:                gyp-system-minizip.patch
@@ -72,6 +73,7 @@ Patch5:               options-support.patch
 Patch6:                get-webkit_revision.patch
 Patch7:                dlopen_sonamed_gl.patch
 Patch8:                chromium_useragent.patch.in
+Patch9:                system-expat.patch
 URL:           http://www.chromium.org/Home
 %{?with_gconf:BuildRequires:   GConf2-devel}
 BuildRequires: OpenGL-GLU-devel
@@ -81,6 +83,7 @@ BuildRequires:        bison
 BuildRequires: bzip2-devel
 %{?with_cups:BuildRequires:    cups-devel}
 BuildRequires: dbus-glib-devel
+BuildRequires: expat-devel
 %{?with_system_flac:BuildRequires:     flac-devel}
 BuildRequires: flex
 BuildRequires: fontconfig-devel
@@ -189,6 +192,8 @@ test "$ver" = %{version}
 gyp_rev=$(grep googlecode_url.*gyp src/DEPS | cut -d'"' -f6 | cut -d@ -f2)
 test "$gyp_rev" = %{gyp_rev} || :
 
+v8_ver=$(awk 'NR=1 {print $NF; exit}' src/v8/ChangeLog)
+
 # Populate the LASTCHANGE file template as we no longer have the VCS files at this point
 echo "%{svnver}" > src/build/LASTCHANGE.in
 
@@ -200,6 +205,7 @@ sed -e 's/@BUILD_DIST@/PLD %{pld_version}/g' \
     < %{PATCH8} | %{__patch} -p1
 
 %{__sed} -e 's,@localedir@,%{_libdir}/%{name},' %{SOURCE4} > find-lang.sh
+ln -s %{SOURCE6} src
 
 %patch0 -p1
 %patch1 -p1
@@ -208,48 +214,12 @@ sed -e 's/@BUILD_DIST@/PLD %{pld_version}/g' \
 %patch5 -p1
 %patch6 -p1
 %patch7 -p1
-
-# drop bundled libs, from gentoo
-remove_bundled_lib() {
-       echo "Removing bundled library $1 ..."
-       local out
-       out=$(find $1 -mindepth 1 ! -iname '*.gyp' -print -delete)
-       if [ -z "$out" ]; then
-               echo >&2 "No files matched when removing bundled library $1"
-               exit 1
-       fi
-}
-
 cd src
-remove_bundled_lib "third_party/bzip2"
-remove_bundled_lib "third_party/icu"
-remove_bundled_lib "third_party/libevent"
-remove_bundled_lib "third_party/libjpeg"
-remove_bundled_lib "third_party/libpng"
-# third_party/libvpx/libvpx.h should be kept
-#remove_bundled_lib "third_party/libvpx"
-remove_bundled_lib "third_party/libxml"
-remove_bundled_lib "third_party/libxslt"
-remove_bundled_lib "third_party/zlib"
-# third_party/yasm/source/patched-yasm/modules/arch/x86/gen_x86_insn.py', needed by `out/Release/obj/gen/third_party/yasm/x86insns.c'.  Stop.
-#remove_bundled_lib "third_party/yasm"
-
-%if %{with system_v8}
-# Remove bundled v8.
-find v8 -type f \! -iname '*.gyp*' -delete
-
-# The implementation files include v8 headers with full path,
-# like #include "v8/include/v8.h". Make sure the system headers
-# will be used.
-rmdir v8/include
-ln -s %{_includedir} v8/include
-%endif
+%patch9 -p1
+cd ..
 
-%if %{with nacl}
-# NOTE: here is always x86_64
-rm -rf native_client/toolchain/linux_x86_newlib
-ln -s %{_prefix}/x86_64-nacl-newlib native_client/toolchain/linux_x86_newlib
-%endif
+cd src
+sh -x clean-source.sh %{?with_system_v8:v8=1} %{?with_nacl:nacl=1}
 
 %build
 cd src
@@ -268,7 +238,7 @@ test -e Makefile || %{__python} build/gyp_chromium --format=make build/all.gyp \
        -Dlinux_sandbox_chrome_path=%{_libdir}/%{name}/%{name} \
 %endif
        %{!?debug:-Dwerror=} \
-       %{!?debuginfo:-Dfastbuild=1} \
+       %{!?debuginfo:-Dfastbuild=1 -Dremove_webcore_debug_symbols=1} \
        %{?with_shared_libs:-Dlibrary=shared_library} \
        -Dbuild_ffmpegsumo=%{?with_ffmpegsumo:1}%{!?with_ffmpegsumo:0} \
        -Dffmpeg_branding=Chrome \
This page took 0.034004 seconds and 4 git commands to generate.