]> git.pld-linux.org Git - packages/chromaprint.git/blobdiff - chromaprint.spec
- release 3 (by relup.sh)
[packages/chromaprint.git] / chromaprint.spec
index 910b71d4f0e50af45855058769214e8301695a67..a21057377b07bac2f3137ff43f769e980aed9101 100644 (file)
@@ -1,20 +1,28 @@
+#
+# Conditional build:
+%bcond_without ffmpeg  # fpcalc build + libchromaprint using avfft
+%bcond_with    fftw3   # libchromaprint using fftw3 instead of avfft
+#
+%if %{without ffmpeg}
+%define        with_fftw3      1
+%endif
 Summary:       Library implementing the AcoustID fingerprinting
 Summary(pl.UTF-8):     Biblioteka implementująca odciski AcoustID
 Name:          chromaprint
-Version:       0.7
-Release:       4
+Version:       1.3.1
+Release:       3
 License:       LGPL v2.1+
 Group:         Libraries
-Source0:       https://github.com/downloads/lalinsky/chromaprint/%{name}-%{version}.tar.gz
-# Source0-md5: 3005fc2c69b9ef4a5c6787ef9355a855
-Patch0:                %{name}-ffmpeg.patch
-Patch1:                %{name}-ffmpeg2.0.patch
-URL:           http://www.acoustid.org/chromaprint/
+Source0:       https://bitbucket.org/acoustid/chromaprint/downloads/%{name}-%{version}.tar.gz
+# Source0-md5: f3745ac10b4d4d992cabe743c4a3ed0f
+URL:           https://acoustid.org/chromaprint
 BuildRequires: boost-devel
 BuildRequires: cmake >= 2.6
-BuildRequires: ffmpeg-devel
+%{?with_ffmpeg:BuildRequires:  ffmpeg-devel >= 0.6}
+%{?with_fftw3:BuildRequires:   fftw3-devel >= 3}
 BuildRequires: libstdc++-devel
 BuildRequires: taglib-devel
+Requires:      libchromaprint = %{version}-%{release}
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
@@ -74,13 +82,12 @@ tworzenia aplikacji wykorzystujących bibliotekę libchromaprint.
 
 %prep
 %setup -q
-%patch0 -p1
-%patch1 -p1
 
 %build
 %cmake . \
-       -DBUILD_TOOLS=ON \
-       -DWITH_AVFFT=ON
+       %{?with_ffmpeg:-DBUILD_EXAMPLES=ON} \
+       %{!?with_fftw3:-DWITH_AVFFT=ON} \
+       %{?with_fftw3:-DWITH_FFTW3=ON}
 
 %{__make}
 
@@ -89,21 +96,23 @@ rm -rf $RPM_BUILD_ROOT
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT
 
-# omitted by make install
-install -D tools/fpcollect $RPM_BUILD_ROOT%{_bindir}/fpcollect
-
 %clean
 rm  -rf $RPM_BUILD_ROOT
 
 %post  -n libchromaprint -p /sbin/ldconfig
 %postun        -n libchromaprint -p /sbin/ldconfig
 
+%if %{with ffmpeg}
+%files
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_bindir}/fpcalc
+%endif
+
 %files -n libchromaprint
 %defattr(644,root,root,755)
-%doc CHANGES.txt NEWS.txt README.txt
-%attr(755,root,root) %{_bindir}/fpcollect
+%doc NEWS.txt README.md
 %attr(755,root,root) %{_libdir}/libchromaprint.so.*.*.*
-%attr(755,root,root) %ghost %{_libdir}/libchromaprint.so.0
+%attr(755,root,root) %ghost %{_libdir}/libchromaprint.so.1
 
 %files -n libchromaprint-devel
 %defattr(644,root,root,755)
This page took 0.08034 seconds and 4 git commands to generate.