]> git.pld-linux.org Git - packages/chromaprint.git/blobdiff - chromaprint.spec
- release 3 (by relup.sh)
[packages/chromaprint.git] / chromaprint.spec
index 25784d6052f8a9f134bf6fa26899a3473e6ceea1..a21057377b07bac2f3137ff43f769e980aed9101 100644 (file)
@@ -1,14 +1,28 @@
+#
+# Conditional build:
+%bcond_without ffmpeg  # fpcalc build + libchromaprint using avfft
+%bcond_with    fftw3   # libchromaprint using fftw3 instead of avfft
+#
+%if %{without ffmpeg}
+%define        with_fftw3      1
+%endif
 Summary:       Library implementing the AcoustID fingerprinting
+Summary(pl.UTF-8):     Biblioteka implementująca odciski AcoustID
 Name:          chromaprint
-Version:       0.5
-Release:       1
-License:       LGPL v2+
+Version:       1.3.1
+Release:       3
+License:       LGPL v2.1+
 Group:         Libraries
-URL:           http://www.acoustid.org/chromaprint/
-Source0:       https://github.com/downloads/lalinsky/chromaprint/%{name}-%{version}.tar.gz
-BuildRequires: cmake
-BuildRequires: fftw3-devel >= 3
-BuildRequires: python
+Source0:       https://bitbucket.org/acoustid/chromaprint/downloads/%{name}-%{version}.tar.gz
+# Source0-md5: f3745ac10b4d4d992cabe743c4a3ed0f
+URL:           https://acoustid.org/chromaprint
+BuildRequires: boost-devel
+BuildRequires: cmake >= 2.6
+%{?with_ffmpeg:BuildRequires:  ffmpeg-devel >= 0.6}
+%{?with_fftw3:BuildRequires:   fftw3-devel >= 3}
+BuildRequires: libstdc++-devel
+BuildRequires: taglib-devel
+Requires:      libchromaprint = %{version}-%{release}
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
@@ -16,89 +30,92 @@ Chromaprint library is the core component of the AcoustID project.
 It's a client-side library that implements a custom algorithm for
 extracting fingerprints from raw audio sources.
 
-The library exposes a simple C API and the package also includes
-bindings for the Python language. The documentation for the C API can
-be found in the main header file.
+The library exposes a simple C API and the Python language binding is
+also available. The documentation for the C API can be found in the
+main header file.
+
+%description -l pl.UTF-8
+Biblioteka Chromaprint to główny element projektu AcoustID. Jest to
+biblioteka kliencka implementująca własny algorytm wydobywania
+odcisków identyfikacyjnych z surowych strumieni dźwiękowych.
+
+Biblioteka udostępnia proste API C. Dostępne są także wiązania dla
+Pythona. Dokumentację dla API C można znaleźć w głównym pliku
+nagłówkowym.
 
 %package -n libchromaprint
 Summary:       Library implementing the AcoustID fingerprinting
-Group:         Development/Libraries
+Summary(pl.UTF-8):     Biblioteka implementująca odciski AcoustID
+Group:         Libraries
 
 %description -n libchromaprint
 Chromaprint library is the core component of the AcoustID project.
 It's a client-side library that implements a custom algorithm for
 extracting fingerprints from raw audio sources.
 
-The library exposes a simple C API and the package also includes
-bindings for the Python language. The documentation for the C API can
-be found in the main header file.
+The library exposes a simple C API and the Python language binding
+is also available. The documentation for the C API can be found in the
+main header file.
+
+%description -n libchromaprint -l pl.UTF-8
+Biblioteka Chromaprint to główny element projektu AcoustID. Jest to
+biblioteka kliencka implementująca własny algorytm wydobywania
+odcisków identyfikacyjnych z surowych strumieni dźwiękowych.
+
+Biblioteka udostępnia proste API C. Dostępne są także wiązania dla
+Pythona. Dokumentację dla API C można znaleźć w głównym pliku
+nagłówkowym.
 
 %package -n libchromaprint-devel
-Summary:       Headers for developing programs that will use %{name}
+Summary:       Headers for developing programs that will use libchromaprint
+Summary(pl.UTF-8):     Pliki nagłówkowe do tworzenia programów wykorzystujących libchromaprint
 Group:         Development/Libraries
 Requires:      libchromaprint = %{version}-%{release}
-Requires:      pkgconfig
 
 %description -n libchromaprint-devel
 This package contains the headers that programmers will need to
-develop applications which will use %{name}.
-
-%package -n python-chromaprint
-Summary:       Python module for %{name}
-License:       MIT
-Group:         Development/Libraries
-Requires:      libchromaprint = %{version}-%{release}
+develop applications which will use libchromaprint.
 
-%description -n python-chromaprint
-This package contains the python module to use %{name}.
+%description -n libchromaprint-devel -l pl.UTF-8
+Ten pakiet zawiera pliki nagłówkowe potrzebne programistom do
+tworzenia aplikacji wykorzystujących bibliotekę libchromaprint.
 
 %prep
 %setup -q
 
 %build
-# examples require ffmpeg, so turn off examples
-%cmake \
-       -DBUILD_EXAMPLES=off \
-       -DBUILD_TESTS=off
+%cmake . \
+       %{?with_ffmpeg:-DBUILD_EXAMPLES=ON} \
+       %{!?with_fftw3:-DWITH_AVFFT=ON} \
+       %{?with_fftw3:-DWITH_FFTW3=ON}
 
 %{__make}
 
-cd python
-CFLAGS="%{rpmcflags}" \
-%{__python} setup.py build
-
 %install
 rm -rf $RPM_BUILD_ROOT
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT
 
-cd python
-%{__python} setup.py install \
-       --skip-build \
-       --optimize=2 \
-       --root=$RPM_BUILD_ROOT
-
 %clean
 rm  -rf $RPM_BUILD_ROOT
 
 %post  -n libchromaprint -p /sbin/ldconfig
 %postun        -n libchromaprint -p /sbin/ldconfig
 
+%if %{with ffmpeg}
+%files
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_bindir}/fpcalc
+%endif
+
 %files -n libchromaprint
 %defattr(644,root,root,755)
-%doc CHANGES.txt COPYING.txt NEWS.txt README.txt
+%doc NEWS.txt README.md
 %attr(755,root,root) %{_libdir}/libchromaprint.so.*.*.*
-%ghost %{_libdir}/libchromaprint.so.0
+%attr(755,root,root) %ghost %{_libdir}/libchromaprint.so.1
 
 %files -n libchromaprint-devel
 %defattr(644,root,root,755)
+%attr(755,root,root) %{_libdir}/libchromaprint.so
 %{_includedir}/chromaprint.h
-%{_libdir}/libchromaprint.so
 %{_pkgconfigdir}/libchromaprint.pc
-
-# MIT licensed
-%files -n python-chromaprint
-%defattr(644,root,root,755)
-%doc python/examples python/LICENSE
-%{py_sitescriptdir}/chromaprint
-%{py_sitescriptdir}/*.egg-info
This page took 0.278963 seconds and 4 git commands to generate.