]> git.pld-linux.org Git - packages/bitlbee.git/blobdiff - bitlbee.spec
- up to 3.5.1
[packages/bitlbee.git] / bitlbee.spec
index 71f49d8ef8130345817ba127cd2de3eb7e1f2208..723b731d52db40e4a735478168caa2496dd20480 100644 (file)
@@ -1,24 +1,38 @@
 # TODO
 # - sync pl
-# - bilbee user
 #
 # Conditional build:
-%bcond_without otr             # build without OTR
+%bcond_with            otr             # build without OTR
+%bcond_with            purple  # build with libpurple (not recommended for public servers). http://wiki.bitlbee.org/HowtoPurple
 
 Summary:       An IRC to other chat networks gateway
 Summary(pl.UTF-8):     Bramka pomiÄ™dzy IRC-em i innymi sieciami komunikacyjnymi
 Name:          bitlbee
-Version:       3.0.5
-Release:       0.6
+Version:       3.5.1
+Release:       1
 License:       GPL v2+ and MIT
 Group:         Daemons
 Source0:       http://get.bitlbee.org/src/%{name}-%{version}.tar.gz
-# Source0-md5: 9ff97260a2a7f3a7d102db158a8d9887
+# Source0-md5: ec866f937258c16e1e2e70f3dec67430
 URL:           http://www.bitlbee.org/
+Patch0:                config.patch
 BuildRequires: asciidoc
+BuildRequires: glib2-devel >= 1:2.14
 BuildRequires: gnutls-devel
 %{?with_otr:BuildRequires:     libotr-devel >= 3.2.0}
+%{?with_purple:BuildRequires:  libpurple-devel}
+BuildRequires: rpmbuild(macros) >= 1.461
 BuildRequires: systemd-units
+Requires(postun):      /usr/sbin/groupdel
+Requires(postun):      /usr/sbin/userdel
+Requires(pre): /bin/id
+Requires(pre): /usr/bin/getgid
+Requires(pre): /usr/sbin/groupadd
+Requires(pre): /usr/sbin/useradd
+Requires(post,preun,postun):   systemd-units >= 38
+Requires:      systemd-units >= 38
+Provides:      group(bitlbee)
+Provides:      user(bitlbee)
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
@@ -51,27 +65,13 @@ Requires:   %{name} = %{version}-%{release}
 The bitlbee-otr package includes OTR plugin for bitlbee. Not
 completely stable and not 100% foolproof so use at your own risk.
 
-%package protocol-skype
-Summary:       Skype protocol support for bitlbee
-Group:         Daemons
-Requires:      %{name} = %{version}-%{release}
-Requires:      python-skype
-
-%description protocol-skype
-Skype protocol support for bitlbee.
-
 %prep
 %setup -q
+%patch0 -p1
 
 # fix wrong assumption with $DESTDIR
 %{__sed} -i -e 's,$(shell id -u),0,' Makefile
 
-# fix #!%{_bindir}/env python -> #!%{__python}:
-%{__sed} -i -e '1s,^#!.*python.*,#!%{__python},' protocols/skype/*.py
-
-# fix config path
-%{__sed} -i -e 's,/usr/local/etc/skyped,%{_sysconfdir}/skyped,' protocols/skype/*.py
-
 %build
 CFLAGS="%{rpmcflags}" \
 ./configure \
@@ -86,10 +86,14 @@ CFLAGS="%{rpmcflags}" \
        --strip=0 \
        --plugins=1 \
        --ssl=gnutls \
+       --pie=1 \
+%if %{with purple}
+       --purple=1 \
+%endif
 %if %{with otr}
        --otr=plugin \
 %endif
-       --skype=plugin \
+       --skype=0
 
 %{__make}
 
@@ -102,18 +106,32 @@ install -d $RPM_BUILD_ROOT%{_localstatedir}/lib/%{name}
 %clean
 rm -rf $RPM_BUILD_ROOT
 
+%pre
+%groupadd -g 280 bitlbee
+%useradd -u 280 -d /var/lib/bitlbee -g bitlbee -c "Bitlbee User" bitlbee
+%systemd_post bitlbee.service
+
+%preun
+%systemd_preun bitlbee.service
+
+%postun
+if [ "$1" = "0" ]; then
+       %userremove bitlbee
+       %groupremove bitlbee
+fi
+%systemd_reload
+
 %files
 %defattr(644,root,root,755)
-%doc doc/{AUTHORS,CHANGES,CREDITS,FAQ,README}
-%dir %{_sysconfdir}/%{name}
-%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/bitlbee.conf
-%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/motd.txt
+%doc doc/{AUTHORS,CHANGES,CREDITS,FAQ,README} utils
+%dir %attr(750,root,bitlbee) %{_sysconfdir}/%{name}
+%attr(640,root,bitlbee) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/bitlbee.conf
+%attr(640,root,bitlbee) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/motd.txt
 %attr(755,root,root) %{_sbindir}/bitlbee
 %{_mandir}/man5/bitlbee.conf.5*
 %{_mandir}/man8/bitlbee.8*
 %{_datadir}/bitlbee
-%dir %{_libdir}/%{name}
-%attr(700,root,root) %{_localstatedir}/lib/bitlbee
+%attr(770,root,bitlbee) %{_localstatedir}/lib/bitlbee
 %{systemdunitdir}/bitlbee.service
 %{systemdunitdir}/bitlbee.socket
 %{systemdunitdir}/bitlbee@.service
@@ -129,13 +147,3 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/%{name}/otr.so
 %endif
-
-%files protocol-skype
-%defattr(644,root,root,755)
-%doc protocols/skype/{HACKING,NEWS,README,skyped.txt}
-%dir %{_sysconfdir}/skyped
-%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/skyped/skyped.cnf
-%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/skyped/skyped.conf
-%attr(755,root,root) %{_libdir}/%{name}/skype.so
-%attr(755,root,root) %{_sbindir}/skyped
-%{_mandir}/man1/skyped.1*
This page took 0.050724 seconds and 4 git commands to generate.