]> git.pld-linux.org Git - packages/bcc.git/blobdiff - bcc.spec
- updated to 0.16.8, cleanups etc.
[packages/bcc.git] / bcc.spec
index b187c7b1d8f3cdd1f4d090b24726b0b13d7b397f..3afe3a691252aa48b3cfbd4b6d482a4ce96cdab5 100644 (file)
--- a/bcc.spec
+++ b/bcc.spec
@@ -1,20 +1,22 @@
 Summary:       Bruce's C compiler
 Summary(pl):   Kompiler C Bruce'a
 Name:          bcc
-Version:       0.16.0
-Release:       4
+Version:       0.16.8
+Release:       1
 License:       GPL
 Group:         Development/Languages
 Source0:       http://www.cix.co.uk/~mayday/Dev86src-%{version}.tar.gz
 Patch0:                Dev86src-noroot.patch
 Patch1:                Dev86src-nobcc.patch
-Patch2:                Dev86src-bccpaths.patch
-Patch3:                Dev86src-opt.patch
+Patch2:                Dev86src-opt.patch
 URL:           http://www.cix.co.uk/~mayday/
 Requires:      bin86
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 ExclusiveArch: %{ix86}
 
+# don't try to strip Linux-8086 objects
+%define                no_install_post_strip   1
+
 %description
 Bcc is a simple C compiler that produces 8086 assembler, in addition
 compiler compile time options allow 80386 or 6809 versions. The
@@ -32,10 +34,9 @@ s
 %patch0 -p1
 %patch1 -p1
 %patch2 -p1
-%patch3 -p1
 
 %build
-CC="%{__cc}" %{__make} OPT="%{rpmcflags}" <<!FooBar!
+CC="%{__cc}" %{__make} all other OPT="%{rpmcflags}" <<!FooBar!
 5
 quit
 !FooBar!
@@ -43,7 +44,7 @@ quit
 %install
 rm -rf $RPM_BUILD_ROOT
 
-%{__make} install \
+%{__make} install-all \
        DIST=$RPM_BUILD_ROOT
 
 install $RPM_BUILD_ROOT/lib/elksemu $RPM_BUILD_ROOT%{_bindir}
@@ -60,36 +61,40 @@ mv -f $RPM_BUILD_ROOT%{_includedir} $RPM_BUILD_ROOT%{_libdir}/bcc
 install -d $RPM_BUILD_ROOT%{_mandir}
 rm -f $RPM_BUILD_ROOT/usr/man/man1/{as,ld}86.1*
 mv -f $RPM_BUILD_ROOT/usr/man/* $RPM_BUILD_ROOT%{_mandir}
+# these are separated in bin86 package
+rm -f $RPM_BUILD_ROOT%{_bindir}/{as86,ld86}
+
+%{!?debug:strip -R .comment -R .note $RPM_BUILD_ROOT%{_bindir}/{ar86,bcc,elksemu,objdump86}}
+%{!?debug:strip -R .comment -R .note $RPM_BUILD_ROOT%{_libdir}/bcc/{bcc*,copt,unproto}}
 
-gzip -9nf README MAGIC Contributors bootblocks/README copt/README \
-       dis88/README elksemu/README unproto/README bin86/README-0.4 \
-       bin86/README bin86/ChangeLog
+mv -f bootblocks/README README.bootblocks
+mv -f copt/README README.copt
+mv -f dis88/README README.dis88
+mv -f elksemu/README README.elksemu
+mv -f unproto/README README.unproto
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
-%doc *.gz */*.gz
-%dir %{_libdir}/bcc
-%dir %{_libdir}/bcc/i86
-%dir %{_libdir}/bcc/i386
-%dir %{_libdir}/bcc/include
-%dir %{_libdir}/bcc/kinclude
+%doc Changes Contributors README*
 %attr(755,root,root) %{_bindir}/bcc
-#%attr(755,root,root) %{_bindir}/as86
+%attr(755,root,root) %{_bindir}/ar86
 %attr(755,root,root) %{_bindir}/as86_encap
-#%attr(755,root,root) %{_bindir}/ld86
+%attr(755,root,root) %{_bindir}/dis86
 %attr(755,root,root) %{_bindir}/objdump86
 %attr(755,root,root) %{_bindir}/nm86
 %attr(755,root,root) %{_bindir}/size86
+%{_libdir}/liberror.txt
+%dir %{_libdir}/bcc
+%attr(755,root,root) %{_libdir}/bcc/bcc-cpp
 %attr(755,root,root) %{_libdir}/bcc/bcc-cc1
 %attr(755,root,root) %{_libdir}/bcc/copt
 %attr(755,root,root) %{_libdir}/bcc/unproto
-%{_libdir}/bcc/i86/*
-%{_libdir}/bcc/i386/*
-%{_libdir}/liberror.txt
-%{_libdir}/bcc/include/*
-%{_libdir}/bcc/kinclude/*
+%{_libdir}/bcc/i86
+%{_libdir}/bcc/i386
+%{_libdir}/bcc/include
+%{_libdir}/bcc/kinclude
 %attr(755,root,root) %{_bindir}/elksemu
 %{_mandir}/man1/*
This page took 0.03558 seconds and 4 git commands to generate.