]> git.pld-linux.org Git - packages/bcc.git/commitdiff
- updated to 0.16.8, cleanups etc.
authorJakub Bogusz <qboosh@pld-linux.org>
Tue, 27 Aug 2002 21:17:36 +0000 (21:17 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
- removed obsolete bccpaths, updated opt patch

Changed files:
    Dev86src-bccpaths.patch -> 1.2
    Dev86src-opt.patch -> 1.2
    bcc.spec -> 1.13

Dev86src-bccpaths.patch [deleted file]
Dev86src-opt.patch
bcc.spec

diff --git a/Dev86src-bccpaths.patch b/Dev86src-bccpaths.patch
deleted file mode 100644 (file)
index fe34476..0000000
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -uNr linux-86/bcc/bcc.c linux-86-bccpaths/bcc/bcc.c
---- linux-86/bcc/bcc.c Sat Feb  7 06:01:44 1998
-+++ linux-86-bccpaths/bcc/bcc.c        Fri Feb  4 19:50:25 2000
-@@ -80,7 +80,7 @@
- #else
- #define STANDARD_EXEC_PREFIX_2        "/usr/bin/"
- #endif
--#define DEFAULT_INCLUDE         "-I~/include"
-+#define DEFAULT_INCLUDE         "-I~/lib/bcc/include"
- #define DEFAULT_LIBDIR0         "-L~/lib/bcc/i86/"
- #define DEFAULT_LIBDIR3         "-L~/lib/bcc/i386/"
- #define OPTIM_RULES                   "-d~/lib/bcc/i86"
index 56ab60b53193201bd814a93c4b3a6e3fb9368433..930fe9c7ce58f1cbd155107680e3fdb9a228d51b 100644 (file)
@@ -10,15 +10,36 @@ diff -Nur dev86-0.16.0.orig/libbsd/Make.defs dev86-0.16.0/libbsd/Make.defs
  WALL= -ansi -pedantic -Wwrite-strings -Wpointer-arith -Wcast-qual \
        -Wcast-align -Wtraditional -Wstrict-prototypes -Wmissing-prototypes \
        -Wnested-externs -Winline -Wshadow
-diff -Nur dev86-0.16.0.orig/makefile.in dev86-0.16.0/makefile.in
---- dev86-0.16.0.orig/makefile.in      Sun Nov 11 19:25:16 2001
-+++ dev86-0.16.0/makefile.in   Sun Nov 11 19:26:23 2001
-@@ -39,7 +39,7 @@
- WALL  =-Wstrict-prototypes
+--- dev86-0.16.8/Makefile.orig Tue Aug 27 21:54:49 2002
++++ dev86-0.16.8/Makefile      Tue Aug 27 21:57:17 2002
+@@ -16,7 +16,7 @@
+ LIBPRE=  $(PREFIX)
+ BINDIR=        $(PREFIX)/bin
+ LIBDIR=  $(LIBPRE)/lib/bcc
+-CFLAGS=  -O
++CFLAGS=  $(OPT)
  
- CC    =gcc
--CFLAGS        =$(GCCFLAG) -Wall $(WALL) -O6 -g
-+CFLAGS        =$(GCCFLAG) -Wall $(WALL) $(OPT)
+ # Some makes take the last of a list as the default ...
+ all: make.fil
+--- dev86-0.16.8/makefile.in.orig      Tue Aug 27 21:57:45 2002
++++ dev86-0.16.8/makefile.in   Tue Aug 27 22:00:41 2002
+@@ -40,7 +40,7 @@
+ WALL  =-Wall -Wstrict-prototypes
+ CC    =%CC%
+-CFLAGS        =$(GCCFLAG) $(WALL) -O2 -g
++CFLAGS        =$(GCCFLAG) $(WALL) $(OPT)
  #endif
  
  #ifndef GNUMAKE
+--- dev86-0.16.8/dis88/Makefile.orig   Fri Jul 31 15:01:40 1998
++++ dev86-0.16.8/dis88/Makefile        Tue Aug 27 22:38:03 2002
+@@ -25,7 +25,7 @@
+ # be necessary to alter the formats of the tables.
+ #CC=bcc
+-CFLAGS=-O
++CFLAGS=$(OPT)
+ LDFLAGS=
+ PREFIX=/usr
index b187c7b1d8f3cdd1f4d090b24726b0b13d7b397f..3afe3a691252aa48b3cfbd4b6d482a4ce96cdab5 100644 (file)
--- a/bcc.spec
+++ b/bcc.spec
@@ -1,20 +1,22 @@
 Summary:       Bruce's C compiler
 Summary(pl):   Kompiler C Bruce'a
 Name:          bcc
-Version:       0.16.0
-Release:       4
+Version:       0.16.8
+Release:       1
 License:       GPL
 Group:         Development/Languages
 Source0:       http://www.cix.co.uk/~mayday/Dev86src-%{version}.tar.gz
 Patch0:                Dev86src-noroot.patch
 Patch1:                Dev86src-nobcc.patch
-Patch2:                Dev86src-bccpaths.patch
-Patch3:                Dev86src-opt.patch
+Patch2:                Dev86src-opt.patch
 URL:           http://www.cix.co.uk/~mayday/
 Requires:      bin86
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 ExclusiveArch: %{ix86}
 
+# don't try to strip Linux-8086 objects
+%define                no_install_post_strip   1
+
 %description
 Bcc is a simple C compiler that produces 8086 assembler, in addition
 compiler compile time options allow 80386 or 6809 versions. The
@@ -32,10 +34,9 @@ s
 %patch0 -p1
 %patch1 -p1
 %patch2 -p1
-%patch3 -p1
 
 %build
-CC="%{__cc}" %{__make} OPT="%{rpmcflags}" <<!FooBar!
+CC="%{__cc}" %{__make} all other OPT="%{rpmcflags}" <<!FooBar!
 5
 quit
 !FooBar!
@@ -43,7 +44,7 @@ quit
 %install
 rm -rf $RPM_BUILD_ROOT
 
-%{__make} install \
+%{__make} install-all \
        DIST=$RPM_BUILD_ROOT
 
 install $RPM_BUILD_ROOT/lib/elksemu $RPM_BUILD_ROOT%{_bindir}
@@ -60,36 +61,40 @@ mv -f $RPM_BUILD_ROOT%{_includedir} $RPM_BUILD_ROOT%{_libdir}/bcc
 install -d $RPM_BUILD_ROOT%{_mandir}
 rm -f $RPM_BUILD_ROOT/usr/man/man1/{as,ld}86.1*
 mv -f $RPM_BUILD_ROOT/usr/man/* $RPM_BUILD_ROOT%{_mandir}
+# these are separated in bin86 package
+rm -f $RPM_BUILD_ROOT%{_bindir}/{as86,ld86}
+
+%{!?debug:strip -R .comment -R .note $RPM_BUILD_ROOT%{_bindir}/{ar86,bcc,elksemu,objdump86}}
+%{!?debug:strip -R .comment -R .note $RPM_BUILD_ROOT%{_libdir}/bcc/{bcc*,copt,unproto}}
 
-gzip -9nf README MAGIC Contributors bootblocks/README copt/README \
-       dis88/README elksemu/README unproto/README bin86/README-0.4 \
-       bin86/README bin86/ChangeLog
+mv -f bootblocks/README README.bootblocks
+mv -f copt/README README.copt
+mv -f dis88/README README.dis88
+mv -f elksemu/README README.elksemu
+mv -f unproto/README README.unproto
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
-%doc *.gz */*.gz
-%dir %{_libdir}/bcc
-%dir %{_libdir}/bcc/i86
-%dir %{_libdir}/bcc/i386
-%dir %{_libdir}/bcc/include
-%dir %{_libdir}/bcc/kinclude
+%doc Changes Contributors README*
 %attr(755,root,root) %{_bindir}/bcc
-#%attr(755,root,root) %{_bindir}/as86
+%attr(755,root,root) %{_bindir}/ar86
 %attr(755,root,root) %{_bindir}/as86_encap
-#%attr(755,root,root) %{_bindir}/ld86
+%attr(755,root,root) %{_bindir}/dis86
 %attr(755,root,root) %{_bindir}/objdump86
 %attr(755,root,root) %{_bindir}/nm86
 %attr(755,root,root) %{_bindir}/size86
+%{_libdir}/liberror.txt
+%dir %{_libdir}/bcc
+%attr(755,root,root) %{_libdir}/bcc/bcc-cpp
 %attr(755,root,root) %{_libdir}/bcc/bcc-cc1
 %attr(755,root,root) %{_libdir}/bcc/copt
 %attr(755,root,root) %{_libdir}/bcc/unproto
-%{_libdir}/bcc/i86/*
-%{_libdir}/bcc/i386/*
-%{_libdir}/liberror.txt
-%{_libdir}/bcc/include/*
-%{_libdir}/bcc/kinclude/*
+%{_libdir}/bcc/i86
+%{_libdir}/bcc/i386
+%{_libdir}/bcc/include
+%{_libdir}/bcc/kinclude
 %attr(755,root,root) %{_bindir}/elksemu
 %{_mandir}/man1/*
This page took 0.050538 seconds and 4 git commands to generate.