]> git.pld-linux.org Git - packages/bacula.git/blobdiff - bacula.spec
- obsolete also virtual (should work and is cleaner)
[packages/bacula.git] / bacula.spec
index 6761675e741dd11df3fec4abe56862936981f9b2..d0abeed4c8967033ae5c2506f39da784c1dead6c 100644 (file)
@@ -7,37 +7,14 @@
 %bcond_without console_wx              # wx-console program
 %bcond_without bat                     # bat Qt4 GUI
 %bcond_without dbi                     # use Database Independent Abstraction Layer (libdbi)
-%bcond_with    mysql                   # use MySQL
-%bcond_with    pgsql                   # use PostgreSQL
+%bcond_without mysql                   # use MySQL
+%bcond_without pgsql                   # use PostgreSQL
 %bcond_with    python
 %bcond_with    rescue
-%bcond_with    sqlite3                 # use SQLite3 instead of SQLite 2
+%bcond_without sqlite3                 # use SQLite3
 %bcond_with    sqlite3_sync_off        # makes SQLite3 backend much faster, but less reliable
-%if %{with dbi}
-%define                database        dbi
-%undefine       with_mysql
-%undefine       with_pgsql
-%undefine       with_sqlite3
-%endif
-%if %{with sqlite3}
-%define                database        sqlite3
-%undefine       with_dbi
-%undefine       with_mysql
-%undefine       with_pgsql
-%endif
-%if %{with pgsql}
-%define                database        postgresql
-%undefine       with_dbi
-%undefine       with_mysql
-%undefine       with_sqlite3
-%endif
-%if %{with mysql}
-%define                database        mysql
-%undefine       with_dbi
-%undefine       with_pgsql
-%undefine       with_sqlite3
-%endif
-%if !%{with sqlite3}
+#
+%if %{without sqlite3}
 %undefine       with_sqlite3_sync_off
 %endif
 #
@@ -45,15 +22,15 @@ Summary:    Bacula - The Network Backup Solution
 Summary(pl.UTF-8):     Bacula - rozwiązanie do wykonywania kopii zapasowych po sieci
 Name:          bacula
 Version:       5.0.1
-Release:       0.1
+Release:       0.5
 Epoch:         0
 License:       extended GPL v2
 Group:         Networking/Utilities
-Source0:       http://downloads.sourceforge.net/bacula/%{name}-%{version}.tar.gz
+Source0:       http://dl.sourceforge.net/bacula/%{name}-%{version}.tar.gz
 # Source0-md5: beb9f8da196b3c9ffb0356f087dbdb99
-Source1:       http://downloads.sourceforge.net/bacula/%{name}-docs-%{version}.tar.bz2
+Source1:       http://dl.sourceforge.net/bacula/%{name}-docs-%{version}.tar.bz2
 # Source1-md5: ce2ef0dca50ab916fd6701b53b7bb4df
-Source2:       http://downloads.sourceforge.net/bacula/%{name}-rescue-5.0.0.tar.gz
+Source2:       http://dl.sourceforge.net/bacula/%{name}-rescue-5.0.0.tar.gz
 # Source2-md5: 349623581cfe0bcd798dd137abac959a
 Source10:      %{name}-dir.init
 Source11:      %{name}-fd.init
@@ -70,9 +47,16 @@ Patch4:              %{name}-conf.patch
 Patch5:                %{name}-desktop.patch
 Patch6:                %{name}-64bitbuild_fix.patch
 Patch7:                %{name}-dbi_fixes.patch
+Patch8:                %{name}-dbi_dbcheck.patch
+Patch9:                %{name}-config_no_clean.patch
 URL:           http://www.bacula.org/
+BuildRequires: acl-devel
+BuildRequires: autoconf
 BuildRequires: automake
+BuildRequires: gettext-devel
+BuildRequires: libcap-devel
 %{?with_dbi:BuildRequires:     libdbi-devel >= 0.8.4}
+BuildRequires: libtool
 %if %{with rescue}
 BuildRequires: fakeroot
 %endif
@@ -106,6 +90,8 @@ BuildRoot:   %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 %define                _sysconfdir     /etc/%{name}
 %define                _localstatedir  /var/lib/%{name}
 
+%define        databases %{?with_pgsql:postgresql} %{?with_mysql:mysql} %{?with_sqlite3:sqlite3} %{?with_dbi:dbi}
+
 # dependency section is broken. ccache usage is instead to makefiles
 %undefine      with_ccache
 
@@ -179,6 +165,7 @@ Summary(pl.UTF-8):  Usługi Bacula Director i Catalog
 Group:         Networking/Utilities
 Requires(post):        sed >= 4.0
 Requires:      %{name}-common = %{epoch}:%{version}-%{release}
+Requires:      bacula(db) = %{epoch}:%{version}-%{release}
 Obsoletes:     bacula-updatedb
 
 %description dir
@@ -354,6 +341,66 @@ przechowywania danych, np. plików). Usługi Storage działają jako demon
 na maszynie, która zawiera urządzenie backupowe (zwykle napęd
 taśmowy).
 
+%package db-postgresql
+Summary:       PostgreSQL database driver for Bacula
+Summary(pl.UTF-8):     Sterownik bazy PostgreSQL dla Baculi
+Group:         Networking/Utilities
+Requires(post):        /sbin/ldconfig
+Requires:      %{name}-common = %{epoch}:%{version}-%{release}
+Provides:      bacula(db) = %{epoch}:%{version}-%{release}
+Obsoletes:     bacula(db)
+
+%description db-postgresql
+PostgreSQL database driver for Bacula.
+
+%description db-postgresql -l pl.UTF-8
+Sterownik bazy PostgreSQL dla Baculi.
+
+%package db-mysql
+Summary:       MySQL database driver for Bacula
+Summary(pl.UTF-8):     Sterownik bazy MySQL dla Baculi
+Group:         Networking/Utilities
+Requires(post):        /sbin/ldconfig
+Requires:      %{name}-common = %{epoch}:%{version}-%{release}
+Provides:      bacula(db) = %{epoch}:%{version}-%{release}
+Obsoletes:     bacula(db)
+
+%description db-mysql
+MySQL database driver for Bacula.
+
+%description db-mysql -l pl.UTF-8
+Sterownik bazy MySQL dla Baculi.
+
+%package db-sqlite3
+Summary:       SQLite database driver for Bacula
+Summary(pl.UTF-8):     Sterownik bazy SQLite dla Baculi
+Group:         Networking/Utilities
+Requires(post):        /sbin/ldconfig
+Requires:      %{name}-common = %{epoch}:%{version}-%{release}
+Provides:      bacula(db) = %{epoch}:%{version}-%{release}
+Obsoletes:     bacula(db)
+
+%description db-sqlite3
+SQLite database driver for Bacula.
+
+%description db-sqlite3 -l pl.UTF-8
+Sterownik bazy SQLite dla Baculi.
+
+%package db-dbi
+Summary:       libdbi database driver for Bacula
+Summary(pl.UTF-8):     Sterownik bazy libdbi dla Baculi
+Group:         Networking/Utilities
+Requires(post):        /sbin/ldconfig
+Requires:      %{name}-common = %{epoch}:%{version}-%{release}
+Provides:      bacula(db) = %{epoch}:%{version}-%{release}
+Obsoletes:     bacula(db)
+
+%description db-dbi
+libdbi database driver for Bacula.
+
+%description db-dbi -l pl.UTF-8
+Sterownik baz libdbi dla Baculi.
+
 %package rescue
 Summary:       Bacula - The Network Backup Solution
 Summary(pl.UTF-8):     Bacula - rozwiązanie do wykonywania kopii zapasowych po sieci
@@ -377,12 +424,6 @@ recover lost or damaged files.
 This package installs scripts for disaster recovery and builds rescue
 floppy disk for bare metal recovery.
 
-To make the bacula rescue disk run "./make_rescue_disk
---copy-static-bacula
-- --copy-etc-files" from the %{_sysconfdir}/rescue directory. To
-  recreate the rescue information for this system run ./getdiskinfo
-  again.
-
 %description rescue -l pl.UTF-8
 Bacula - przychodzi nocą i wysysa żywotny ekstrakt z komputerów.
 
@@ -398,11 +439,6 @@ plików.
 Ten pakiet zawiera skrypty do odtwarzania po awarii i tworzy dyskietkę
 ratunkowe do odtwarzania systemu od zera.
 
-Aby stworzyć dyskietkę ratunkową Baculi, należy uruchomić "./make_rescue_disk
---copy-static-bacula - --copy-etc-files" z katalogu
-%{_sysconfdir}/rescue . Aby ponownie utworzyć informacje ratunkowe dla
-danego systemu, należy ponownie uruchomić ./getdiskinfo .
-
 %prep
 %setup -q -a 1
 %patch0 -p1
@@ -412,7 +448,9 @@ danego systemu, należy ponownie uruchomić ./getdiskinfo .
 %patch4 -p1
 %patch5 -p1
 #%patch6 -p1
-%{?with_dbi:%patch7 -p1}
+%patch7 -p1
+%patch8 -p1
+%patch9 -p1
 
 tar -xf %{SOURCE2} && ln -s bacula-rescue-* rescue
 
@@ -422,7 +460,7 @@ sed -i -e 's#bindir=.*#bindir=%{_bindir}#g' \
 sed -i -e 's/@hostname@/--hostname--/' src/*/*.conf.in
 
 %if %{with dbi}
-for dbtype in bdb mysql postgresql sqlite3; do
+for dbtype in mysql postgresql sqlite3; do
        sed -i -e "s,@DB_TYPE@,$dbtype,g" src/cats/*_${dbtype}_*
 done
 %endif
@@ -436,42 +474,59 @@ cd ..
 %{__autoconf} --prepend-include=$(pwd)/autoconf autoconf/configure.in > configure
 
 CPPFLAGS="-I/usr/include/ncurses -I%{_includedir}/readline"
-WXCONFIG=%{_bindir}/wx-gtk2-unicode-config \
-%configure \
-       --with-scriptdir=%{_libexecdir}/%{name} \
-       %{?with_bat:--enable-bat} \
-       --disable-conio \
-       --enable-smartalloc \
-       %{?with_console_wx:--enable-bwx-console} \
-       --enable-tray-monitor \
-       %{?with_python:--with-python} \
-       --with-readline \
-       --with-tcp-wrappers \
-       --with-working-dir=%{_var}/lib/%{name} \
-       --with-dump-email="root@localhost" \
-       --with-job-email="root@localhost" \
-       --with-smtp-host=localhost \
-       --with-pid-dir=/var/run \
-       --with-subsys-dir=/var/lock/subsys \
-       --enable-batch-insert \
-       --with-%{database} \
-       %{?with_sqlite3_sync_off:--enable-extra-sqlite3-init="pragma synchronous=0;"} \
-       --with-dir-password="#FAKE-dir-password#" \
-       --with-fd-password="#FAKE-fd-password#" \
-       --with-sd-password="#FAKE-sd-password#" \
-       --with-mon-dir-password="#FAKE-mon-dir-password#" \
-       --with-mon-fd-password="#FAKE-mon-fd-password#" \
-       --with-mon-sd-password="#FAKE-mon-sd-password#" \
-       --with-openssl
 
-%if %{with bat}
-cd src/qt-console
-%{__libtoolize}
-qmake-qt4 bat.pro
-cd ../..
-%endif
+# we wan't the 'base' build built with the first database in the list,
+# to make sure it is full-featured
+base_built="no"
+
+for database in %{databases} ; do
+       WXCONFIG=%{_bindir}/wx-gtk2-unicode-config \
+       %configure \
+               --with-scriptdir=%{_libexecdir}/%{name} \
+               %{?with_bat:--enable-bat} \
+               --disable-conio \
+               --enable-smartalloc \
+               %{?with_console_wx:--enable-bwx-console} \
+               --enable-tray-monitor \
+               %{?with_python:--with-python} \
+               --with-readline \
+               --with-tcp-wrappers \
+               --with-working-dir=%{_var}/lib/%{name} \
+               --with-dump-email="root@localhost" \
+               --with-job-email="root@localhost" \
+               --with-smtp-host=localhost \
+               --with-pid-dir=/var/run \
+               --with-subsys-dir=/var/lock/subsys \
+               --enable-batch-insert \
+               --with-$database \
+               %{?with_sqlite3_sync_off:--enable-extra-sqlite3-init="pragma synchronous=0;"} \
+               --with-dir-password="#FAKE-dir-password#" \
+               --with-fd-password="#FAKE-fd-password#" \
+               --with-sd-password="#FAKE-sd-password#" \
+               --with-mon-dir-password="#FAKE-mon-dir-password#" \
+               --with-mon-fd-password="#FAKE-mon-fd-password#" \
+               --with-mon-sd-password="#FAKE-mon-sd-password#" \
+               --with-openssl
+
+       if [ "$base_built" = "no" ] ; then
+               %if %{with bat}
+               cd src/qt-console
+               qmake-qt4 bat.pro
+               cd ../..
+               %endif
+
+               %{__make}
+
+               base_built="yes"
+       else
+               %{__make} -C src/cats clean
+               %{__make} -C src/cats
+       fi
 
-%{__make}
+               # install the database library in a temporary location
+       install -d libbacsql/$database%{_libdir}
+       %{__make} -C src/cats libtool-install DESTDIR=$PWD/libbacsql/$database
+done
 
 %if %{with rescue}
 cd rescue
@@ -491,6 +546,19 @@ install -d $RPM_BUILD_ROOT{%{_pixmapsdir},%{_desktopdir},%{_mandir},%{_bindir},/
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT
 
+# install libraries for all the database backends
+# ldconfig will add the soname symlinks when one of the packages is installed
+for database in %{databases} ; do
+       for libfile in libbacsql/$database%{_libdir}/lib*-*.so ; do
+               orig_name=`basename $libfile`
+               file_prefix="${orig_name%%-*.so}"
+               file_suffix="${orig_name#*-}"
+               file_name="$file_prefix-$database-$file_suffix"
+               install "$libfile" "$RPM_BUILD_ROOT/%{_libdir}/$file_name"
+               ln -sf "$file_name" "$RPM_BUILD_ROOT/%{_libdir}/$orig_name"
+       done
+done
+
 install %{SOURCE10} $RPM_BUILD_ROOT/etc/rc.d/init.d/bacula-dir
 install %{SOURCE11} $RPM_BUILD_ROOT/etc/rc.d/init.d/bacula-fd
 install %{SOURCE12} $RPM_BUILD_ROOT/etc/rc.d/init.d/bacula-sd
@@ -533,15 +601,45 @@ install updatedb/update_sqlite* $RPM_BUILD_ROOT%{_libexecdir}/%{name}
 touch $RPM_BUILD_ROOT%{_sysconfdir}/{dir-password,fd-password,sd-password}
 touch $RPM_BUILD_ROOT%{_sysconfdir}/{mon-dir-password,mon-fd-password,mon-sd-password}
 
-install scripts/mtx-changer.conf $RPM_BUILD_ROOT%{_sysconfdir}/
+mv $RPM_BUILD_ROOT%{_libdir}/bacula/mtx-changer.conf $RPM_BUILD_ROOT/etc/bacula/mtx-changer.conf
 
 # some file changes
 rm -f $RPM_BUILD_ROOT%{_libexecdir}/%{name}/{gconsole,startmysql,stopmysql,bacula,bconsole,fd}
-%if !%{with console_wx}
+%if %{without console_wx}
 rm -f $RPM_BUILD_ROOT%{_desktopdir}/bacula-wx.desktop
 %endif
 touch $RPM_BUILD_ROOT%{_sysconfdir}/.pw.sed
 
+rm $RPM_BUILD_ROOT%{_docdir}/bacula/ChangeLog
+rm $RPM_BUILD_ROOT%{_docdir}/bacula/INSTALL
+rm $RPM_BUILD_ROOT%{_docdir}/bacula/LICENSE
+rm $RPM_BUILD_ROOT%{_docdir}/bacula/README
+rm $RPM_BUILD_ROOT%{_docdir}/bacula/ReleaseNotes
+rm $RPM_BUILD_ROOT%{_docdir}/bacula/VERIFYING
+rm $RPM_BUILD_ROOT%{_docdir}/bacula/technotes
+
+# startup scripts, those in /etc/rc.d/init.d are better
+rm $RPM_BUILD_ROOT%{_sbindir}/bacula
+rm $RPM_BUILD_ROOT%{_libexecdir}/%{name}/bacula-ctl-*
+
+# unsupported
+rm $RPM_BUILD_ROOT%{_libexecdir}/%{name}/*_bdb_*
+
+# rename to avoid possible conflicts
+mv $RPM_BUILD_ROOT%{_sbindir}/{,bacula-}dbcheck
+mv $RPM_BUILD_ROOT%{_mandir}/man8/{,bacula-}dbcheck.8.gz
+
+# no -devel files packaged, so this is also useless
+rm $RPM_BUILD_ROOT%{_libdir}/libbac{,cfg,find,py,sql}.{so,la}
+
+# placeholders for the symlinks set in %%post db-*
+for f in create_bacula_database drop_bacula_database drop_bacula_tables \
+       grant_bacula_privileges make_bacula_tables update_bacula_tables ; do
+
+       ln -sf /dev/null $RPM_BUILD_ROOT%{_libexecdir}/%{name}/$f
+done
+
+
 %clean
 rm -rf $RPM_BUILD_ROOT
 
@@ -728,29 +826,68 @@ if [ "$1" = "0" ]; then
        rm -rf %{_sysconfdir}/rescue/diskinfo/*
 fi
 
+%define db_post() \
+/sbin/ldconfig \
+for name in "create database" "drop tables" "drop database" "grant privileges" "make tables" "update tables" ; do \
+       prefix="${name%% *}" \
+       suffix="${name#* }" \
+       ln -sf "${prefix}_%{1}_${suffix}" %{_libexecdir}/%{name}/"${prefix}_bacula_${suffix}" || :  \
+done \
+%service bacula-dir restart "Bacula Director daemon"
+
+%define db_postun() \
+/sbin/ldconfig \
+if [ "$1" = "0" ]; then \
+       for f in %{_libexecdir}/%{name}/*_bacula_* ; do \
+               if [ ! -e "$f" ] ; then \
+                       rm "$f" \
+               fi \
+       done \
+fi
+
+%post db-postgresql
+%db_post postgresql
+
+%postun db-postgresql
+%db_postun postgresql
+
+%post db-mysql
+%db_post mysql
+
+%postun db-mysql
+%db_postun mysql
+
+%post db-sqlite3
+%db_post sqlite3
+
+%postun db-sqlite3
+%db_postun sqlite3
+
+# dbi backend is different, as it is not bound with a specific db engine
+%post db-dbi
+/sbin/ldconfig
+
+%postun db-dbi -p /sbin/ldconfig
+
 %files common
 %defattr(644,root,root,755)
 %doc LICENSE
 %dir %{_sysconfdir}
 %attr(600,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/*-password
+# do not remove bsmtp from files. Fix build if it is not installed.
 %attr(755,root,root) %{_sbindir}/bsmtp
 %attr(755,root,root) %{_sbindir}/btraceback
-%attr(755,root,root) /%{_libdir}/libbac.so.1.*.*
-%attr(755,root,root) %ghost /%{_libdir}/libbac.so.1
-%attr(755,root,root) /%{_libdir}/libbaccfg.so.1.*.*
-%attr(755,root,root) %ghost /%{_libdir}/libbaccfg.so.1
-%attr(755,root,root) /%{_libdir}/libbacfind.so.1.*.*
-%attr(755,root,root) %ghost /%{_libdir}/libbacfind.so.1
-%attr(755,root,root) /%{_libdir}/libbacpy.so.1.*.*
-%attr(755,root,root) %ghost /%{_libdir}/libbacpy.so.1
-%attr(755,root,root) /%{_libdir}/libbacsql.so.1.*.*
-%attr(755,root,root) %ghost /%{_libdir}/libbacsql.so.1
+%attr(755,root,root) %{_libdir}/libbac-%{version}.so
+%attr(755,root,root) %{_libdir}/libbaccfg-%{version}.so
+%attr(755,root,root) %{_libdir}/libbacfind-%{version}.so
+%attr(755,root,root) %{_libdir}/libbacpy-%{version}.so
 %{_mandir}/man8/bacula.8*
 %{_mandir}/man1/bsmtp.1*
 %{_mandir}/man8/btraceback.8*
 %dir %{_libexecdir}/%{name}
 %{_libexecdir}/%{name}/btraceback.dbx
 %{_libexecdir}/%{name}/btraceback.gdb
+%{_libexecdir}/%{name}/bacula_config
 %attr(770,root,bacula) %dir %{_localstatedir}
 %attr(750,bacula,logs) %dir /var/log/bacula
 %attr(640,bacula,logs) %ghost /var/log/bacula/log
@@ -767,52 +904,93 @@ fi
 %attr(755,root,root) %{_sbindir}/bacula-dir
 %attr(755,root,root) %{_sbindir}/bregex
 %attr(755,root,root) %{_sbindir}/bwild
-%attr(755,root,root) %{_sbindir}/dbcheck
+%attr(755,root,root) %{_sbindir}/bacula-dbcheck
 %{_mandir}/man8/bacula-dir.8*
-%{_mandir}/man8/dbcheck.8*
+%{_mandir}/man8/bacula-dbcheck.8*
 %{_libexecdir}/%{name}/query.sql
-%if %{with bdb} || %{with dbi}
-%attr(755,root,root) %{_libexecdir}/%{name}/create_bdb_database
-%attr(755,root,root) %{_libexecdir}/%{name}/drop_bdb_database
-%attr(755,root,root) %{_libexecdir}/%{name}/drop_bdb_tables
-%attr(755,root,root) %{_libexecdir}/%{name}/grant_bdb_privileges
-%attr(755,root,root) %{_libexecdir}/%{name}/make_bdb_tables
-%attr(755,root,root) %{_libexecdir}/%{name}/update_bdb_*
-%endif
-%if %{with sqlite3} || %{with dbi}
-%attr(755,root,root) %{_libexecdir}/%{name}/create_sqlite3_database
-%attr(755,root,root) %{_libexecdir}/%{name}/drop_sqlite3_database
-%attr(755,root,root) %{_libexecdir}/%{name}/drop_sqlite3_tables
-%attr(755,root,root) %{_libexecdir}/%{name}/grant_sqlite3_privileges
-%attr(755,root,root) %{_libexecdir}/%{name}/make_sqlite3_tables
-%attr(755,root,root) %{_libexecdir}/%{name}/update_sqlite3_*
-%endif
-%if %{with mysql} || %{with dbi}
+#%attr(755,root,root) %{_libexecdir}/%{name}/make_catalog_backup
+#%attr(755,root,root) %{_libexecdir}/%{name}/delete_catalog_backup
+
+%files db-postgresql
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_libexecdir}/%{name}/create_postgresql_database
+%attr(755,root,root) %{_libexecdir}/%{name}/drop_postgresql_database
+%attr(755,root,root) %{_libexecdir}/%{name}/drop_postgresql_tables
+%attr(755,root,root) %{_libexecdir}/%{name}/grant_postgresql_privileges
+%attr(755,root,root) %{_libexecdir}/%{name}/make_postgresql_tables
+%attr(755,root,root) %{_libexecdir}/%{name}/update_postgresql_*
+%attr(755,root,root) %{_libdir}/libbacsql-postgresql-%{version}.so
+
+%ghost %attr(755,root,root) %{_libdir}/libbacsql-%{version}.so
+%ghost %{_libexecdir}/%{name}/create_bacula_database
+%ghost %{_libexecdir}/%{name}/drop_bacula_tables
+%ghost %{_libexecdir}/%{name}/drop_bacula_database
+%ghost %{_libexecdir}/%{name}/grant_bacula_privileges
+%ghost %{_libexecdir}/%{name}/make_bacula_tables
+%ghost %{_libexecdir}/%{name}/update_bacula_tables
+
+%files db-mysql
+%defattr(644,root,root,755)
 %attr(755,root,root) %{_libexecdir}/%{name}/create_mysql_database
 %attr(755,root,root) %{_libexecdir}/%{name}/drop_mysql_database
 %attr(755,root,root) %{_libexecdir}/%{name}/drop_mysql_tables
 %attr(755,root,root) %{_libexecdir}/%{name}/grant_mysql_privileges
 %attr(755,root,root) %{_libexecdir}/%{name}/make_mysql_tables
 %attr(755,root,root) %{_libexecdir}/%{name}/update_mysql_*
-%endif
-%if %{with pgsql} || %{with dbi}
+%attr(755,root,root) %{_libdir}/libbacsql-mysql-%{version}.so
+
+%ghost %attr(755,root,root) %{_libdir}/libbacsql-%{version}.so
+%ghost %{_libexecdir}/%{name}/create_bacula_database
+%ghost %{_libexecdir}/%{name}/drop_bacula_tables
+%ghost %{_libexecdir}/%{name}/drop_bacula_database
+%ghost %{_libexecdir}/%{name}/grant_bacula_privileges
+%ghost %{_libexecdir}/%{name}/make_bacula_tables
+%ghost %{_libexecdir}/%{name}/update_bacula_tables
+
+%files db-sqlite3
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_libexecdir}/%{name}/create_sqlite3_database
+%attr(755,root,root) %{_libexecdir}/%{name}/drop_sqlite3_database
+%attr(755,root,root) %{_libexecdir}/%{name}/drop_sqlite3_tables
+%attr(755,root,root) %{_libexecdir}/%{name}/grant_sqlite3_privileges
+%attr(755,root,root) %{_libexecdir}/%{name}/make_sqlite3_tables
+%attr(755,root,root) %{_libexecdir}/%{name}/update_sqlite3_*
+%attr(755,root,root) %{_libexecdir}/%{name}/update_sqlite_*
+%attr(755,root,root) %{_libdir}/libbacsql-sqlite3-%{version}.so
+
+%ghost %attr(755,root,root) %{_libdir}/libbacsql-%{version}.so
+%ghost %{_libexecdir}/%{name}/create_bacula_database
+%ghost %{_libexecdir}/%{name}/drop_bacula_tables
+%ghost %{_libexecdir}/%{name}/drop_bacula_database
+%ghost %{_libexecdir}/%{name}/grant_bacula_privileges
+%ghost %{_libexecdir}/%{name}/make_bacula_tables
+%ghost %{_libexecdir}/%{name}/update_bacula_tables
+
+%files db-dbi
+%defattr(644,root,root,755)
 %attr(755,root,root) %{_libexecdir}/%{name}/create_postgresql_database
 %attr(755,root,root) %{_libexecdir}/%{name}/drop_postgresql_database
 %attr(755,root,root) %{_libexecdir}/%{name}/drop_postgresql_tables
 %attr(755,root,root) %{_libexecdir}/%{name}/grant_postgresql_privileges
 %attr(755,root,root) %{_libexecdir}/%{name}/make_postgresql_tables
 %attr(755,root,root) %{_libexecdir}/%{name}/update_postgresql_*
-%endif
-%if %{without dbi}
-%attr(755,root,root) %{_libexecdir}/%{name}/create_bacula_database
-%attr(755,root,root) %{_libexecdir}/%{name}/drop_bacula_database
-%attr(755,root,root) %{_libexecdir}/%{name}/drop_bacula_tables
-%attr(755,root,root) %{_libexecdir}/%{name}/grant_bacula_privileges
-%attr(755,root,root) %{_libexecdir}/%{name}/make_bacula_tables
-%attr(755,root,root) %{_libexecdir}/%{name}/update_bacula_tables
-%endif
-%attr(755,root,root) %{_libexecdir}/%{name}/make_catalog_backup
-%attr(755,root,root) %{_libexecdir}/%{name}/delete_catalog_backup
+%attr(755,root,root) %{_libexecdir}/%{name}/create_mysql_database
+%attr(755,root,root) %{_libexecdir}/%{name}/drop_mysql_database
+%attr(755,root,root) %{_libexecdir}/%{name}/drop_mysql_tables
+%attr(755,root,root) %{_libexecdir}/%{name}/grant_mysql_privileges
+%attr(755,root,root) %{_libexecdir}/%{name}/make_mysql_tables
+%attr(755,root,root) %{_libexecdir}/%{name}/update_mysql_*
+%attr(755,root,root) %{_libexecdir}/%{name}/create_sqlite3_database
+%attr(755,root,root) %{_libexecdir}/%{name}/drop_sqlite3_database
+%attr(755,root,root) %{_libexecdir}/%{name}/drop_sqlite3_tables
+%attr(755,root,root) %{_libexecdir}/%{name}/grant_sqlite3_privileges
+%attr(755,root,root) %{_libexecdir}/%{name}/make_sqlite3_tables
+%attr(755,root,root) %{_libexecdir}/%{name}/update_sqlite3_*
+%attr(755,root,root) %{_libexecdir}/%{name}/update_sqlite_*
+%attr(755,root,root) %{_libdir}/libbacsql-dbi-%{version}.so
+
+%ghost %attr(755,root,root) %{_libdir}/libbacsql-%{version}.so
+
 
 %files fd
 %defattr(644,root,root,755)
@@ -821,6 +999,7 @@ fi
 %attr(754,root,root) /etc/rc.d/init.d/bacula-fd
 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/bacula-fd
 %attr(755,root,root) %{_sbindir}/bacula-fd
+%attr(755,root,root) %{_libdir}/bpipe-fd.so
 %{_mandir}/man8/bacula-fd.8*
 
 %files sd
@@ -873,14 +1052,16 @@ fi
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/bat.conf
 %attr(755,root,root) %{_sbindir}/bat
 %{_mandir}/man1/bat.1*
+%{_docdir}/%{name}
 %endif
 
 %if %{with console_wx}
 %files tray-monitor
 %defattr(644,root,root,755)
 %doc LICENSE
-%{_pixmapsdir}/%{name}-tray-monitor.xpm
-%{_desktopdir}/%{name}-tray-monitor.desktop
+%attr(755,root,root) %{_sbindir}/bacula-tray-monitor
+#%{_pixmapsdir}/%{name}-tray-monitor.xpm
+#%{_desktopdir}/%{name}-tray-monitor.desktop
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/tray-monitor.conf
 %{_mandir}/man1/bacula-tray-monitor.1*
 %endif
This page took 0.369153 seconds and 4 git commands to generate.