]> git.pld-linux.org Git - packages/asterisk.git/blobdiff - asterisk.spec
- BR freetds >= 0.63
[packages/asterisk.git] / asterisk.spec
index 738f28f152dd2b10b7f71ed398e2f3ff3fbf04bb..aded160209fd27c07e7dde1906ec17e95bb65b00 100644 (file)
@@ -5,30 +5,35 @@
 # - put chan_h323 into separate package and make obsoletes to chan_oh323 from external spec
 #   These two h323 plugin are conflicting...
 # - CFLAGS passing
-
-%bcond_without openh323
-
+#
+# Conditional build:
+%bcond_without openh323        # without OpenH323 support
+#
 Summary:       Asterisk PBX
 Summary(pl):   Centralka (PBX) Asterisk
 Name:          asterisk
-Version:       1.0
-%define snap 20040828
-Release:       0.%{snap}.1
+Version:       1.0.7
+Release:       3
 License:       GPL v2
 Group:         Applications/System
-#Source0:      ftp://ftp.asterisk.org/pub/telephony/asterisk/%{name}-%{version}.tar.gz
-Source0:       %{name}-%{snap}.tar.gz
-# Source0-md5: a9b7841b26dea4d92530a46956399da7
-#Source0:      %{name}-%{version}.tar.bz2
+Source0:       ftp://ftp.digium.com/pub/%{name}/%{name}-%{version}.tar.gz
+# Source0-md5: 4cc3c1e4a1b12e0e4c748326ad153291
 Source1:       %{name}.init
 Source2:       %{name}.sysconfig
 Patch0:                %{name}-openh323-makefile.patch
+Patch1:                %{name}-Makefile_fix_gcc33.patch
+Patch2:                %{name}-no_k6_on_sparc.patch
+Patch3:                %{name}-lib.patch
+Patch4:                %{name}-openh323-formats.patch
+Patch5:                %{name}-openh323-rtti.patch
+Patch6:                %{name}-freetds.patch
 # It's included, but these sources are broken by me :)
 # will fit on clean cvs source
 #Patch1:               %{name}-DESTDIR.patch
 #Patch2:               %{name}-Makefile2.patch
-URL:           http://www.asteriskpbx.com/
+URL:           http://www.asterisk.org/
 BuildRequires: bison
+BuildRequires: freetds >= 0.63
 BuildRequires: gawk
 #BuildRequires:        glib-devel
 #BuildRequires:        gtk+-devel
@@ -36,19 +41,21 @@ BuildRequires:      libpri-devel
 BuildRequires: mysql-devel
 BuildRequires: ncurses-devel
 BuildRequires: openssl-devel >= 0.9.7d
+BuildRequires: sed >= 4.0
 BuildRequires: speex-devel
 BuildRequires: zaptel-devel
 BuildRequires: zlib-devel
+#BuildRequires:        mpg123
 # These libraries are crazy...
 # With openh323 1.11.7 and pwlib 1.4.11 i had sig11
 #BuildRequires:        openh323-devel = 1.10.4
 #BuildRequires:        pwlib-devel = 1.4.4
-%{?with_h323:BuildRequires:    openh323-devel}
-%{?with_h323:BuildRequires:    pwlib-devel}
+%{?with_openh323:BuildRequires:        openh323-devel}
+%{?with_openh323:BuildRequires:        pwlib-devel}
 PreReq:                rc-scripts
 Requires(post,preun):  /sbin/chkconfig
-%{?with_h323:%requires_eq      openh323}
-%{?with_h323:%requires_eq      pwlib}
+%{?with_openh323:%requires_eq  openh323}
+%{?with_openh323:%requires_eq  pwlib}
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
@@ -61,7 +68,7 @@ content through a web browser using CGI and a web server.
 Asterisk talks to a variety of telephony hardware including BRI, PRI,
 POTS, and IP telephony clients using the Inter-Asterisk eXchange
 protocol (e.g. gnophone or miniphone). For more information and a
-current list of supported hardware, see http://www.asteriskpbx.com/.
+current list of supported hardware, see http://www.asterisk.org/.
 
 %description -l pl
 Asterisk to wolnodostêpna centralka (PBX) i platforma programistyczna
@@ -74,13 +81,13 @@ serwera WWW.
 Asterisk wspó³pracuje z wielorakim sprzêtem telefonicznym, w tym BRI,
 PRI, POTS oraz klienty telefonii IP u¿ywaj±ce protoko³u Inter-Asterisk
 eXchange (np. gnophone lub miniphone). Wiêcej informacji i listê
-obs³ugiwanego sprzêtu mo¿na znale¼æ pod http://www.asteriskpbx.com/.
+obs³ugiwanego sprzêtu mo¿na znale¼æ pod http://www.asterisk.org/.
 
 %package devel
 Summary:       Header files for Asterisk platform
 Summary(pl):   Pliki nag³ówkowe platformy Asterisk
 Group:         Development
-Requires:      %{name} = %{version}
+Requires:      %{name} = %{version}-%{release}
 
 %description devel
 Header files for Asterisk development platform.
@@ -90,30 +97,41 @@ Pliki nag
 
 %package examples
 Summary:       Example files for the Asterisk PBX
+Summary(pl):   Pliki przyk³adowe dla centralki Asterisk
 Group:         Applications/System
-Requires:      %{name} = %{version}
+Requires:      %{name} = %{version}-%{release}
 
 %description examples
-Example files for the Asterisk PBX
+Example files for the Asterisk PBX.
 
+%description examples -l pl
+Pliki przyk³adowe dla centralki Asterisk.
 
 %prep
-%setup -q -n %{name}
-#%patch0 -p1
-#%patch1 -p1
-#%patch2 -p1
+%setup -q
+%patch1 -p0
+%patch2
+%patch3 -p1
+%patch4 -p1
+%patch5 -p1
+%patch6 -p1
+
+sed -i -e "s#/usr/lib/#/usr/%{_lib}/#g#" Makefile
 
 %build
 rm -f pbx/.depend
-%{__make}
+%{__make} -j1 \
+       CC="%{__cc}" \
+       OPTIMIZE="%{rpmcflags}"
 
-%if %{with h323}
+%if %{with openh323}
 # H323 plugin:
-cd channels/h323/
-%{__make} \
-       PWLIBDIR="/usr" \
-       OPENH323DIR="/usr"
-cd ../../
+%{__make} -j1 -C channels/h323 \
+       PWLIBDIR="%{_prefix}" \
+       OPENH323DIR="%{_prefix}" \
+       CC="%{__cc}" \
+       CFLAGS="%{rpmcflags} -I/usr/include/openh323 -fPIC -I../../include"
+
 %endif
 
 # it requires doxygen - I don't know if we should do this...
@@ -123,14 +141,18 @@ cd ../../
 rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT{/var/{log/asterisk/cdr-csv,spool/asterisk/monitor},/etc/{rc.d/init.d,sysconfig}}
 
-%{__make} install \
+%{__make} -j1 install \
        DESTDIR=$RPM_BUILD_ROOT 
-%{__make} samples \
+%{__make} -j1 samples \
        DESTDIR=$RPM_BUILD_ROOT
 
 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
 install %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/%{name}
 
+%if %{with openh323}
+install channels/h323/h323.conf.sample $RPM_BUILD_ROOT/%{_sysconfdir}/%{name}/h323.conf
+%endif
+
 %clean
 rm -rf $RPM_BUILD_ROOT
 
@@ -167,12 +189,19 @@ fi
 %dir /var/lib/asterisk/images
 %dir /var/lib/asterisk/keys
 %dir /var/lib/asterisk/mohmp3
+/var/lib/asterisk/mohmp3/fpm-calm-river.mp3
+/var/lib/asterisk/mohmp3/fpm-sunshine.mp3
+/var/lib/asterisk/mohmp3/fpm-world-mix.mp3
 %dir /var/lib/asterisk/sounds
 %dir /var/lib/asterisk/sounds/digits
+%dir /var/lib/asterisk/sounds/letters
+%dir /var/lib/asterisk/sounds/phonetic
 /var/lib/asterisk/images/*.jpg
 /var/lib/asterisk/keys/*.pub
 /var/lib/asterisk/sounds/*.gsm
 /var/lib/asterisk/sounds/digits/*.gsm
+/var/lib/asterisk/sounds/letters/*.gsm
+/var/lib/asterisk/sounds/phonetic/*.gsm
 %dir /var/spool/asterisk
 %dir /var/spool/asterisk/monitor
 %dir /var/spool/asterisk/vm
@@ -180,13 +209,16 @@ fi
 %dir /var/spool/asterisk/voicemail/default
 %dir /var/log/asterisk
 %dir /var/log/asterisk/cdr-csv
+%{_mandir}/man8/asterisk.8*
+%dir /var/lib/asterisk/firmware
+%dir /var/lib/asterisk/firmware/iax
+/var/lib/asterisk/firmware/iax/iaxy.bin
 
 %files examples
 %defattr(644,root,root,755)
 %attr(755,root,root) /var/lib/asterisk/agi-bin/agi-test.agi
 %attr(755,root,root) /var/lib/asterisk/agi-bin/eagi-sphinx-test
 %attr(755,root,root) /var/lib/asterisk/agi-bin/eagi-test
-/var/lib/asterisk/mohmp3/sample-hold.mp3
 /var/spool/asterisk/voicemail/default/1234/busy.gsm
 /var/spool/asterisk/voicemail/default/1234/unavail.gsm
 
This page took 0.083316 seconds and 4 git commands to generate.