]> git.pld-linux.org Git - packages/apache.git/blobdiff - apache.spec
- apache.rpm main package provides only stuff that was in apache-2.0.rpm
[packages/apache.git] / apache.spec
index d2f6a8d682987ebdb373a941ae6cb4395cad986f..0117afc5fbe8569b715c43161d736478cc999933 100644 (file)
@@ -12,7 +12,6 @@
 # - mod_auth_digest and mod_auth_basic R: apache(authn) ?
 # - drop mod_case_filter* or find summary and description for them
 # - build modules only once (not with each mpm)
-# - add to apache external packages apache_module_api dependency (like apache-mod_rpaf.spec)
 
 # Conditional build:
 %bcond_without ssl             # build without SSL support
@@ -36,7 +35,7 @@ Summary(ru):  
 Summary(tr):   Lider WWW tarayýcý
 Name:          apache
 Version:       2.2.0
-Release:       6
+Release:       9
 License:       Apache Group License
 Group:         Networking/Daemons
 Source0:       http://www.apache.org/dist/httpd/httpd-%{version}.tar.gz
@@ -67,7 +66,6 @@ Source22:     %{name}-mod_userdir.conf
 Source23:      %{name}-mpm.conf
 Source24:      %{name}-languages.conf
 Source25:      %{name}-mod_mime.conf
-Source26:      %{name}-mod_alias.conf
 Source27:      %{name}-mod_authz_host.conf
 Source28:      %{name}-mod_cgid.conf
 Source29:      %{name}-mod_log_config.conf
@@ -85,6 +83,7 @@ Patch5:               httpd-2.0.48-metuxmpm-r8.patch
 Patch6:                httpd-2.0.40-xfsz.patch
 Patch7:                %{name}-syslibs.patch
 Patch8:                httpd-2.0.45-encode.patch
+Patch9:                %{name}-paths.patch
 Patch10:       httpd-2.0.46-dav401dest.patch
 Patch12:       httpd-2.0.46-sslmutex.patch
 Patch14:       httpd-2.0.48-corelimit.patch
@@ -115,12 +114,12 @@ BuildRequires:    rpm-perlprov >= 4.1-13
 BuildRequires: rpmbuild(macros) >= 1.228
 BuildRequires: sed >= 4.0
 BuildRequires: zlib-devel
+# packages that were in apache-2.0.rpm, for compatibility
 Requires:      %{name}-errordocs = %{version}-%{release}
 Requires:      %{name}-mod_alias = %{version}-%{release}
-#Requires:     %{name}-mod_asis = %{version}-%{release}
+Requires:      %{name}-mod_asis = %{version}-%{release}
 Requires:      %{name}-mod_authz_host = %{version}-%{release}
-Requires:      %{name}-mod_autoindex = %{version}-%{release}
-#Requires:     %{name}-mod_cern_meta = %{version}-%{release}
+Requires:      %{name}-mod_cern_meta = %{version}-%{release}
 Requires:      %{name}-mod_cgi = %{version}-%{release}
 Requires:      %{name}-mod_env = %{version}-%{release}
 Requires:      %{name}-mod_include = %{version}-%{release}
@@ -449,6 +448,7 @@ Group:              Networking/Daemons
 Requires:      %{name}-base = %{version}-%{release}
 Requires:      %{name}-mod_authn_file = %{version}-%{release}
 Requires:      %{name}-mod_authz_groupfile = %{version}-%{release}
+Requires:      %{name}-mod_auth_basic = %{version}-%{release}
 Provides:      apache(mod_auth) = %{version}-%{release}
 
 %description mod_auth
@@ -1479,7 +1479,7 @@ according to whether different aspects of the request match regular
 expressions you specify. These environment variables can be used by
 other parts of the server to make decisions about actions to be taken.
 
-%description mod_setenvif
+%description mod_setenvif -l pl
 Modu³ mod_setenvif pozwala na ustawianie zmiennych ¶rodowiskowych w
 zale¿no¶ci od ró¿nych aspektów ¿±dania pasuj±cych do podanych wyra¿eñ
 regularnych. Te zmienne ¶rodowiskowe mog± byæ u¿ywane przez inne
@@ -1709,6 +1709,7 @@ Dwa programy testowe/przyk
 %patch5 -p1
 %patch7 -p1
 %patch8 -p1
+%patch9 -p1
 %patch10 -p1
 %patch12 -p1
 %patch14 -p1
@@ -1722,14 +1723,6 @@ Dwa programy testowe/przyk
 # using system apr, apr-util and pcre
 rm -rf srclib/{apr,apr-util,pcre}
 
-# fixup perl path
-sed -i -e '1s@#!.*local/bin/perl@#!%{__perl}@' docs/cgi-examples/printenv
-
-# fix location of build dir in generated apxs
-sed -i -e '
-s:@exp_installbuilddir@:%{_libdir}/apache/build:g
-' support/apxs.in
-
 # sanity check
 MODULES_API=`awk '/#define MODULE_MAGIC_NUMBER_MAJOR/ {print $3}' include/ap_mmn.h`
 if [ "$MODULES_API" != "%_apache_modules_api" ]; then
@@ -1758,11 +1751,8 @@ CPPFLAGS="-DMAX_SERVER_LIMIT=200000 -DBIG_SECURITY_HOLE=1"
 for mpm in prefork worker %{?with_metuxmpm:metuxmpm} %{?with_peruser:peruser} %{?with_event:event}; do
 install -d "buildmpm-${mpm}"; cd "buildmpm-${mpm}"
 ../%configure \
-       --prefix=%{_sysconfdir} \
-       --exec-prefix=%{_libexecdir} \
-       --with-installbuilddir=%{_libdir}/apache/build \
-       --disable-v4-mapped \
        --enable-layout=PLD \
+       --disable-v4-mapped \
        --enable-modules=all \
        --enable-mods-shared=all \
        --enable-auth-anon \
@@ -1858,25 +1848,15 @@ install -d $RPM_BUILD_ROOT/etc/{logrotate.d,rc.d/init.d,sysconfig,monit} \
 
 # prefork is default one
 %{__make} -C buildmpm-prefork install \
-       DESTDIR=$RPM_BUILD_ROOT \
-       installbuilddir=%{_libdir}/apache/build \
-       prefix=%{_sysconfdir}/httpd \
-       libexecdir=%{_libdir}/%{name} \
-       iconsdir=%{_datadir}/icons \
-       errordir=%{_datadir}/error \
-       htdocsdir=%{_datadir}/html \
-       manualdir=%{_datadir}/manual \
-       cgidir=%{_cgibindir} \
-       runtimedir=%{_var}/run \
-       logdir=%{_var}/log/httpd \
-       proxycachedir=%{_var}/cache/httpd
+       DESTDIR=$RPM_BUILD_ROOT
 
+# install other mpm-s
 for mpm in %{?with_metuxmpm:metuxmpm} %{?with_peruser:peruser} worker %{?with_event:event}; do
        install buildmpm-${mpm}/httpd.${mpm} $RPM_BUILD_ROOT%{_sbindir}/httpd.${mpm}
 done
 
 ln -s httpd.prefork $RPM_BUILD_ROOT%{_sbindir}/httpd
-ln -s %{_libdir}/apache $RPM_BUILD_ROOT%{_sysconfdir}/modules
+ln -s %{_libexecdir} $RPM_BUILD_ROOT%{_sysconfdir}/modules
 ln -s %{_localstatedir}/run/httpd $RPM_BUILD_ROOT%{_sysconfdir}/run
 ln -s %{_var}/log/httpd $RPM_BUILD_ROOT%{_sysconfdir}/logs
 ln -s conf.d $RPM_BUILD_ROOT%{_sysconfdir}/httpd.conf
@@ -1901,7 +1881,6 @@ CFG="$RPM_BUILD_ROOT%{_sysconfdir}/conf.d/"
 install %{SOURCE7} $CFG/10_common.conf
 
 install %{SOURCE25} $CFG/01_mod_mime.conf
-install %{SOURCE26} $CFG/80_cgi-bin.conf
 install %{SOURCE27} $CFG/01_mod_authz_host.conf
 install %{SOURCE28} $CFG/01_mod_cgid.conf
 install %{SOURCE29} $CFG/01_mod_log_config.conf
@@ -2028,6 +2007,7 @@ if [ ! -L /etc/httpd/httpd.conf ]; then
        fi
 
        # always have httpd.conf symlink (until all packages from Ac use new dir)
+       install -d /etc/httpd
        ln -s conf.d /etc/httpd/httpd.conf
 fi
 exit 0
@@ -2098,7 +2078,7 @@ fi
 
 # change HTTPD_CONF to point to new location. *only* if it's the
 # default config setting
-cp -f /etc/sysconfig/httpd{,.rpmsave}
+cp -f /etc/sysconfig/httpd{,.rpmorig}
 sed -i -e '/^HTTPD_CONF="\/etc\/httpd\/httpd.conf"/s,.*,HTTPD_CONF="/etc/httpd/apache.conf",' /etc/sysconfig/httpd
 
 # FIXME what other important things to notify about Apache 2.2
@@ -2333,9 +2313,8 @@ fi
 %files devel
 %defattr(644,root,root,755)
 %{_includedir}
+# FIXME: httpd.exp needed only on AIX
 %{_libexecdir}/*.exp
-# is this symlink needed?
-#%{_sysconfdir}/build
 %{_libexecdir}/build/[lprs]*.mk
 %attr(755,root,root) %{_libexecdir}/build/*.sh
 
@@ -2347,7 +2326,6 @@ fi
 %files mod_alias
 %defattr(644,root,root,755)
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/*_mod_alias.conf
-%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/*_cgi-bin.conf
 %attr(755,root,root) %{_libexecdir}/mod_alias.so
 
 %files mod_asis
This page took 0.062435 seconds and 4 git commands to generate.