]> git.pld-linux.org Git - packages/apache-mod_pagespeed.git/blobdiff - apache-mod_pagespeed.spec
add comments about third party dirs
[packages/apache-mod_pagespeed.git] / apache-mod_pagespeed.spec
index d51482e829eaead27e26a7b709093c7753f0bca4..ed8eea243cc12e35c858d8be75b23d30d800f433 100644 (file)
@@ -3,63 +3,87 @@
 %bcond_without verbose         # verbose build (V=1)
 
 # NOTE
+# - relase notes: https://developers.google.com/speed/pagespeed/module/release_notes
 # - http://code.google.com/p/modpagespeed/wiki/HowToBuild
 # - http://wiki.mediatemple.net/w/(dv)_HOWTO:_Install_mod_pagespeed
 # TODO
-# - add unit tests running
-# - possible sysdeps (uses release tags)
-#  "serf_src": "http://serf.googlecode.com/svn/tags/0.3.1",
-#  "gflags_root": "http://google-gflags.googlecode.com/svn/tags/gflags-1.3/src",
-#  "google_sparsehash_root": "http://google-sparsehash.googlecode.com/svn/tags/sparsehash-1.8.1/src",
-#  protobuf_lite
-
-%if "%{pld_release}" == "ac"
-# add suffix, but allow ccache, etc in ~/.rpmmacros
-%{expand:%%define      __cc    %(echo '%__cc' | sed -e 's,-gcc,-gcc4,')}
-%{expand:%%define      __cxx   %(echo '%__cxx' | sed -e 's,-g++,-g++4,')}
-%{expand:%%define      __cpp   %(echo '%__cpp' | sed -e 's,-gcc,-gcc4,')}
-%endif
+# - run unit tests
+# third_party libraries:
+# - apr - using system apr package
+# - aprutil - using system apr-util, but from this repo modified apr_memcache2.c
+# - gflags - system package may work
+# - giflib - 4.1.6, no local modifications
+# - google-sparsehash
+# - httpd, httpd24 - using system apache-devel
+# - icu - using system icu
+# - jsoncpp - no local changes
+# - libjpeg_turbo - 1.2.80 with chromium changes (but system lib should be fine)
+# - libpng - no local changes
+# - libwebp - 0.4.0, irrelevant local changes
+# - optipng - 0.7.4, local changes: only the opngreduc component of optipng is included.
+# - protobuf - should be possible to use full protobuf (not lite) to gain same functionality
+# - re2 - should be possible to use system re2
+# - serf - 0.7.2 bunch of google fixes
+# - zlib - 1.2.5, no local changes
+#
+# third_party/chromium/src/base/third_party:
+# - nspr - should be possible to use system lib
+# - dmg_fp
+# - dynamic_annotations
+# - icu - not icu lib, but two files only
+# - valgrind
+#
+# could be possible to use system libs, not packaged in pld:
+# - base64
+# - chromium
+# - chromium_deps
+# - css_parser
+# - domain_registry_provider
+# - instaweb
+# - mod_spdy
+# - modp_b64
+# - rdestl
 
 %define                mod_name        pagespeed
-%define        apxs            %{_sbindir}/apxs
+%define                apxs            %{_sbindir}/apxs
 Summary:       Apache module for rewriting web pages to reduce latency and bandwidth
 Name:          apache-mod_%{mod_name}
-Version:       1.4.26.1
-Release:       2
+# beta: 1.9.32.2-beta
+# stable: 1.8.31.5
+Version:       1.8.31.5
+Release:       0.26
 License:       Apache v2.0
 Group:         Networking/Daemons/HTTP
 Source0:       modpagespeed-%{version}.tar.xz
-# Source0-md5: d2273ce11c3d382fc7e3755c57393237
+# Source0-md5: ea82f2a05f16e9136a0a5d6275621377
 Source1:       get-source.sh
 Source2:       gclient.conf
 Patch0:                system-libs.patch
-Patch1:                gcc-headers.patch
 Patch2:                bug-632.patch
-Patch3:                opencv.patch
-URL:           https://developers.google.com/speed/pagespeed/
+Patch4:                no-dev-stdout.patch
+URL:           https://developers.google.com/speed/pagespeed/module
 BuildRequires: %{apxs}
 BuildRequires: apache-devel >= 2.2
+BuildRequires: bash
 BuildRequires: glib2-devel
 BuildRequires: gperf
+BuildRequires: libicu-devel
 BuildRequires: libselinux-devel
 BuildRequires: libstdc++-devel >= 5:4.1
 BuildRequires: opencv-devel >= 2.3.1
 BuildRequires: openssl-devel
 BuildRequires: pkgconfig
 BuildRequires: python-devel >= 1:2.6
+BuildRequires: yasm
 # This version of gyp is new enough that it knows to use make for Linux 3.x
 # and FreeBSD, but old enough that 'type': 'settings' works and
 # LINKER_SUPPORTS_ICF hasn't been removed yet.
-BuildRequires: python-gyp >= 1-1175
+BuildRequires: python-gyp >= 0.1-0.svn1602.1
 BuildRequires: rpmbuild(macros) >= 1.268
 BuildRequires: tar >= 1:1.22
 BuildRequires: util-linux
 BuildRequires: xz
 BuildRequires: zlib-devel
-# gcc4 might be installed, but not current __cc
-%if "%(echo %{cc_version} | cut -d. -f1,2)" < "4.0"
-BuildRequires: __cc >= 4.0
-%endif
 Requires:      apache(modules-api) = %apache_modules_api
 Requires:      apache-mod_authz_host
 Requires:      apache-mod_headers
@@ -82,9 +106,14 @@ site is maintained.
 %prep
 %setup -q -n modpagespeed-%{version}
 %patch0 -p2
-%patch1 -p2
-%patch2 -p2
-%patch3 -p3
+%patch2 -p1
+%patch4 -p1
+
+rm -r third_party/icu/source
+rm -r third_party/icu/genfiles
+install -d third_party/icu/source/{common,i18n}
+ln -s %{_includedir}/unicode third_party/icu/source/i18n/unicode
+ln -s %{_includedir}/unicode third_party/icu/source/common/unicode
 
 %build
 # re-gen makefiles
@@ -96,9 +125,12 @@ CXX="%{__cxx}" \
        build/all.gyp \
        -Duse_openssl=1 \
        -Duse_system_apache_dev=1 \
+       -Duse_system_icu=1 \
        -Duse_system_libjpeg=1 \
        -Duse_system_libpng=1 \
        -Duse_system_opencv=1 \
+       -Duse_system_openssl=1 \
+       -Duse_system_yasm=1 \
        -Duse_system_zlib=1 \
        -Dsystem_include_path_apr=%{_includedir}/apr \
        -Dsystem_include_path_aprutil=%{_includedir}/apr-util \
This page took 0.068101 seconds and 4 git commands to generate.