]> git.pld-linux.org Git - packages/apache-mod_pagespeed.git/blobdiff - apache-mod_pagespeed.spec
- added format patch (fix size_t vs uint64_t format string)
[packages/apache-mod_pagespeed.git] / apache-mod_pagespeed.spec
index eb6c3147f9e3036defb4fc1f4dd20598660324f1..2fb28eada3dde1f06aa38d032f97e5acdff60787 100644 (file)
@@ -1,6 +1,7 @@
 #
 # Conditional build:
 %bcond_without verbose         # verbose build (V=1)
+%bcond_with    sse2            # use SSE2 instructions
 
 # NOTE
 # - relase notes: https://developers.google.com/speed/pagespeed/module/release_notes
@@ -51,17 +52,25 @@ Name:               apache-mod_%{mod_name}
 # beta: 1.9.32.x-beta
 # stable: 1.9.32.x-stable
 Version:       1.9.32.4
-Release:       0.1
+Release:       7
 License:       Apache v2.0
 Group:         Networking/Daemons/HTTP
+#Source0Download: https://github.com/pagespeed/mod_pagespeed/releases
+#Source0:      https://github.com/pagespeed/mod_pagespeed/archive/%{version}/mod_pagespeed-%{version}.tar.gz
 Source0:       modpagespeed-%{version}.tar.xz
-# Source0-md5: c902122f7d85d4e43cad92911ad59a85
+# Source0-md5: c6740a5de9cb7f20f0cf29c8835f6f95
 Source1:       get-source.sh
 Source2:       gclient.conf
 Patch0:                system-libs.patch
+Patch1:                addrinfo.patch
 Patch2:                bug-632.patch
 Patch4:                no-dev-stdout.patch
 Patch5:                apache24-config.patch
+Patch6:                no-force-xxbit.patch
+Patch7:                no-arch-opt.patch
+Patch8:                %{name}-icu.patch
+Patch9:                %{name}-format.patch
+Patch10:       serf-openssl1.1.patch
 URL:           https://developers.google.com/speed/pagespeed/module
 BuildRequires: %{apxs}
 BuildRequires: apache-devel >= 2.2
@@ -69,10 +78,12 @@ BuildRequires:      bash
 BuildRequires: glib2-devel
 BuildRequires: gperf
 BuildRequires: libicu-devel
+BuildRequires: libjpeg-turbo-devel
+BuildRequires: libpng-devel
 BuildRequires: libselinux-devel
 BuildRequires: libstdc++-devel >= 5:4.1
 BuildRequires: opencv-devel >= 2.3.1
-BuildRequires: openssl-devel
+BuildRequires: openssl-devel >= 1.1
 BuildRequires: pkgconfig
 BuildRequires: python-devel >= 1:2.6
 BuildRequires: yasm
@@ -110,15 +121,24 @@ site is maintained.
 
 %prep
 %setup -q -n modpagespeed-%{version}
-%patch0 -p2
+%patch0 -p1
+%patch1 -p0
 %patch2 -p1
 %patch4 -p1
 %patch5 -p1
+%patch6 -p1
+%patch7 -p1
+%patch8 -p1
+%patch9 -p1
+%patch10 -p1
 
+%if 0
 sh -x %{_sourcedir}/clean-source.sh
+%endif
 
-rm -r third_party/icu/source
-rm -r third_party/icu/genfiles
+%{__rm} -r third_party/icu/source
+%{__rm} -r third_party/icu/genfiles
+# third_party_chromium uses "third_party/icu/..." includes
 install -d third_party/icu/source/{common,i18n}
 ln -s %{_includedir}/unicode third_party/icu/source/i18n/unicode
 ln -s %{_includedir}/unicode third_party/icu/source/common/unicode
@@ -131,6 +151,7 @@ CXX="%{__cxx}" \
        --format=make \
        --depth=. \
        build/all.gyp \
+       %{!?with_sse2:-Ddisable_sse2=1} \
        -Duse_openssl=1 \
        -Duse_system_apache_dev=1 \
        -Duse_system_icu=1 \
@@ -153,8 +174,8 @@ CXX="%{__cxx}" \
        CC.host="%{__cc}" \
        CXX.host="%{__cxx}" \
        LINK.host="%{__cxx}" \
-       CFLAGS="%{rpmcflags} %{rpmcppflags}" \
-       CXXFLAGS="%{rpmcxxflags} %{rpmcppflags}" \
+       CFLAGS="%{rpmcflags} %{rpmcppflags} -DUSE_SYSTEM_LIBJPEG" \
+       CXXFLAGS="%{rpmcxxflags} %{rpmcppflags} -DUSE_SYSTEM_LIBJPEG" \
        %{nil}
 
 %install
This page took 0.038031 seconds and 4 git commands to generate.