]> git.pld-linux.org Git - packages/anjuta.git/blobdiff - anjuta.spec
- 2.0.2, unfinished
[packages/anjuta.git] / anjuta.spec
index 58ce9302b17faf8895edb85d7c70cb4e7ae8b9b8..85b4c149c6870c68ce5294b965cb4e93f276d1b7 100644 (file)
@@ -1,45 +1,68 @@
-%define snap 2002-10-24-15
-Summary:       Gnome integrated development environment
-Summary(pl):   Zintegrowane ¶rodowisko programowania dla Gnome
+#
+# TODO: Add message window when apropriate terminal is missing, not only
+#       stderr message
+#
+Summary:       GNOME integrated development environment
+Summary(es):   Entorno integrado de desarrollo (IDE) de GNOME
+Summary(pl):   Zintegrowane ¶rodowisko programowania dla GNOME
 Summary(pt_BR):        Ambiente de desenvolvimento integrado C e C++
 Name:          anjuta
-Version:       1.0.
-Release:       0.%(echo %{snap} | sed 's/-//g').1
+Version:       2.0.2
+Release:       0.1
+Epoch:         1
 License:       GPL
 Group:         Development/Tools
-Source0:       http://anjuta.sourceforge.net/cvs/anjuta-cvs-HEAD-hourly-%{snap}.tar.gz
-Patch0:                %{name}-ac_am.patch
-Patch1:                %{name}-no_systemtags.patch
-Patch2:                %{name}-omf.patch
-Patch3:                %{name}-module_no_version.patch
-Patch4:                %{name}-use_AM_CXXFLAGS.patch
-Patch5:                %{name}-desktop_fix.patch
+Source0:       http://dl.sourceforge.net/anjuta/%{name}-%{version}.tar.gz
+# Source0-md5: e0d1e216da809df32816d233d7c55165
+#Patch0:       %{name}-gettext.patch
+#Patch1:       %{name}-home_etc.patch
+Patch2:                %{name}-desktop.patch
 URL:           http://anjuta.sourceforge.net/
-BuildRequires: autoconf
+BuildRequires: ORBit2-devel >= 1:2.12.1
+BuildRequires: autoconf >= 2.52
 BuildRequires: automake
+BuildRequires: gdl-devel >= 0.6.1
+BuildRequires: gettext-devel
+BuildRequires: gnome-common >= 2.8.0
+BuildRequires: gnome-vfs2-devel >= 2.10.0-2
 BuildRequires: intltool
+BuildRequires: libglade2-devel >= 1:2.5.1
+BuildRequires: libgnomeprintui-devel >= 2.10.2
+BuildRequires: libgnomeui-devel >= 2.10.0-2
+BuildRequires: libstdc++-devel
 BuildRequires: libtool
+BuildRequires: libxml2-devel >= 1:2.6.19
+BuildRequires: ncurses-devel
+BuildRequires: pcre-devel >= 3.9
 BuildRequires: pkgconfig
+BuildRequires: popt-devel
+BuildRequires: rpmbuild(macros) >= 1.197
 BuildRequires: scrollkeeper
-BuildRequires: libgnomeui-devel >= 2.0.5
-BuildRequires: libgnomeprintui-devel >= 1.116.0
+BuildRequires: vte-devel >= 0.11.0
+Requires(post,postun): scrollkeeper
+# Requires:    gnome-terminal
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
-%define         _prefix         /usr/X11R6
-%define                _mandir         %{_prefix}/man
-
 %description
 Anjuta is a very versatile integrated development environment for C
-and C++ GNU/Linux. Written in GTK/Gnome and written for GTK/Gnome, it
-features many advanced programming tools and utilities. Besides many
-other, it has project management, application wizards, onboard
+and C++ for GNU/Linux. Written in GTK/GNOME and written for GTK/GNOME,
+it features many advanced programming tools and utilities. Besides
+many other, it has project management, application wizards, onboard
 interactive debugger, and a powerful source editor with source
 browsing.
 
+%description -l es
+Anjuta es un entorno integrado de desarrollo para C y C++ para
+GNU/Linux. Escrito en y para GTK/GNOME, proporciona muchas
+herramientas de programación avanzadas. Entre otros, habilita
+manejamiento de proyectos, wizards de aplicaciones, depurador
+interactivo y un editador potente de código fuente que permite
+hojearlo.
+
 %description -l pl
 Anjuta to wszechstronne zintegrowane ¶rodowisko programowania dla
 jêzyka C oraz C++. Zosta³o napisane z wykorzystaniem tandemu
-GTK/Gnome, w³a¶nie po to by go w takim otoczeniu u¿ywaæ. Miêdzy innymi
+GTK/GNOME, w³a¶nie po to by go w takim otoczeniu u¿ywaæ. Miêdzy innymi
 posiada zarz±dcê projektów, kreator aplikacji, wbudowany interaktywny
 odpluskwiacz oraz edytor z mo¿liwo¶ci± przegl±dania ¼róde³.
 
@@ -53,20 +76,22 @@ s
 amigáveis.
 
 %prep
-%setup -q -n %{name}
+%setup -q
+#%patch0 -p0
+#%patch1 -p1 NEEDS checking
+%patch2 -p1
+
+%{__perl} -pi -e 's@^(packageplugindir=)lib/@$1%{_lib}/@' configure.in
 
 %build
 CXXFLAGS="%{rpmcflags} -fno-exceptions"
-rm -f missing
-glib-gettextize
-intltoolize
+CFLAGS="%{rpmcflags} -fno-omit-frame-pointer"
 %{__libtoolize}
 %{__aclocal}
 %{__autoheader}
 %{__autoconf}
 %{__automake}
 %configure \
-       --with-gnome \
        --disable-static
 %{__make}
 
@@ -75,23 +100,35 @@ rm -rf $RPM_BUILD_ROOT
 
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT \
-       gnomemenudir=%{_applnkdir}/Development
+       gnomemenudir=%{_desktopdir}
 
-%find_lang %{name} --with-gnome
+# *.la not needed - *.so loaded through libgmodule
+rm -f $RPM_BUILD_ROOT%{_libdir}/anjuta/lib*.la
+
+rm -r $RPM_BUILD_ROOT%{_datadir}/mime-info
 
-%post   -p /usr/bin/scrollkeeper-update
-%postun -p /usr/bin/scrollkeeper-update
+rm -r $RPM_BUILD_ROOT%{_datadir}/locale/no
+
+%find_lang %{name} --with-gnome
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
+%post
+%scrollkeeper_update_post
+
+%postun
+%scrollkeeper_update_postun
+
 %files -f %{name}.lang
 %defattr(644,root,root,755)
-%doc README ChangeLog NEWS TODO
+%doc AUTHORS ChangeLog FUTURE NEWS README TODO doc/ScintillaDoc.html
 %attr(755,root,root) %{_bindir}/*
-%dir %{_libdir}/anjuta
-%attr(755,root,root) %{_libdir}/anjuta/lib*.so
+%dir %{_libdir}/%{name}
+%attr(755,root,root) %{_libdir}/%{name}/lib*.so*
+%{_pixmapsdir}/%{name}
+%{_datadir}/%{name}
+%{_datadir}/mimelnk/application/*
+%{_desktopdir}/*.desktop
+%{_mandir}/man1/*
 %{_omf_dest_dir}/%{name}
-%{_datadir}/anjuta
-%{_applnkdir}/Development/*
-%{_pixmapsdir}/*
This page took 0.031781 seconds and 4 git commands to generate.