]> git.pld-linux.org Git - packages/amanda.git/blobdiff - amanda.spec
- fix gtar and smbclient detection on ac260/ksh
[packages/amanda.git] / amanda.spec
index b9e0c9aed2f807e05c5c741aace4a80e49050323..cd583b66c206a00038895b0480afedcc0d82fe78 100644 (file)
@@ -1,14 +1,15 @@
 #
 # Conditional build:
-%bcond_with    xfs     # with support for xfsdump
+%bcond_without xfs     # without (possible) support for xfsdump
+%bcond_without samba   # without smbclient support
 %bcond_without client  # without client package
 %bcond_without server  # without server package
 #
 Summary:       A network-capable tape backup solution
-Summary(pl):   Sieciowo zorientowany system tworzenia kopii zapasowych
+Summary(pl.UTF-8):     Sieciowo zorientowany system tworzenia kopii zapasowych
 Name:          amanda
 Version:       2.5.1p2
-Release:       0.7
+Release:       0.9
 License:       BSD
 Group:         Networking/Utilities
 Source0:       http://dl.sourceforge.net/amanda/%{name}-%{version}.tar.gz
@@ -31,6 +32,7 @@ BuildRequires:        libxslt-progs
 BuildRequires: libtool
 BuildRequires: readline-devel >= 4.2
 BuildRequires: rpmbuild(macros) >= 1.268
+%{?with_samba:BuildRequires:   samba-client}
 %{?with_xfs:BuildRequires:     xfsdump}
 Conflicts:     shadow < 1:4.0.4.1-4
 Conflicts:     pwdutils < 3.1.2-2
@@ -52,24 +54,25 @@ be installed on both AMANDA clients and AMANDA servers. Note that you
 will have to install the amanda-client and amanda-server packages as
 well.
 
-%description -l pl
+%description -l pl.UTF-8
 AMANDA jest sieciowo zorientowanym systemem tworzenia kopii
-zapasowych. Umo¿liwia administratorowi sieci tworzenie kopii z kilku
-hostów na jednej maszynie wyposa¿onej w pojemny dysk lub streamer.
-Nowsze wersje programu umo¿liwiaj± zabezpieczanie zasobów Microsoft
-Windows 95/98/NT/2000 przy u¿yciu protoko³u Samba. Ten pakiet zawiera
-podstawowe pliki programu i powinien byæ zainstalowany zarówno na
-serwerze jak i na kliencie. Pamiêtaj tak¿e o instalacji pakietów
+zapasowych. Umożliwia administratorowi sieci tworzenie kopii z kilku
+hostów na jednej maszynie wyposażonej w pojemny dysk lub streamer.
+Nowsze wersje programu umożliwiają zabezpieczanie zasobów Microsoft
+Windows 95/98/NT/2000 przy użyciu protokołu Samba. Ten pakiet zawiera
+podstawowe pliki programu i powinien być zainstalowany zarówno na
+serwerze jak i na kliencie. Pamiętaj także o instalacji pakietów
 amanda-client i amanda-server!
 
 %package libs
 Summary:       Amanda shared libraries
-Summary(pl):   Biblioteki wspó³dzielone pakietu amanda
+Summary(pl.UTF-8):     Biblioteki współdzielone pakietu amanda
 Group:         Networking/Utilities
 Requires(postun):      /sbin/ldconfig
 Requires(postun):      /usr/sbin/groupdel
 Requires(postun):      /usr/sbin/userdel
 Requires(pre): /bin/id
+Requires(pre): /usr/bin/chsh
 Requires(pre): /usr/bin/getgid
 Requires(pre): /usr/sbin/groupadd
 Requires(pre): /usr/sbin/useradd
@@ -79,12 +82,12 @@ Provides:   user(amanda)
 %description libs
 Amanda shared libraries.
 
-%description libs -l pl
-Biblioteki wspó³dzielone pakietu amanda.
+%description libs -l pl.UTF-8
+Biblioteki współdzielone pakietu amanda.
 
 %package client
 Summary:       The client side of Amanda
-Summary(pl):   Klient Amandy
+Summary(pl.UTF-8):     Klient Amandy
 Group:         Networking/Utilities
 Requires(post,postun): /sbin/ldconfig
 Requires:      %{name}-libs = %{version}-%{release}
@@ -97,14 +100,14 @@ be backed up by AMANDA (including the server if it also needs to be
 backed up). You will also need to install the amanda package to each
 AMANDA client. It requires at least one of dump and GNU tar installed.
 
-%description client -l pl
-Ten pakiet powinien byæ zainstalowany ma maszynach, z których
-zawarto¶ci bêd± tworzone kopie zapasowe. Wymaga zainstalowanego co
-najmniej jednego z pakietów dump i GNU tar.
+%description client -l pl.UTF-8
+Ten pakiet powinien być zainstalowany ma maszynach, z których
+zawartości będą tworzone kopie zapasowe. Wymaga zainstalowanego co
+najmniej jednego z pakietów dump i GNU tar.
 
 %package server
 Summary:       The server side of Amanda
-Summary(pl):   Serwer Amandy
+Summary(pl.UTF-8):     Serwer Amandy
 Group:         Networking/Utilities
 Requires(post,postun): /sbin/ldconfig
 Requires:      %{name}-libs = %{version}-%{release}
@@ -123,9 +126,9 @@ backups will be written. You will also need to install the amanda
 package to the AMANDA server. And, if the server is also to be backed
 up, the server also needs to have the amanda-client package installed.
 
-%description server -l pl
-Ten pakiet powinien byæ zainstalowany na maszynach, na których bêd±
-magazynowane kopie zapasowe (lub do których podpiête s± urz±dzenia
+%description server -l pl.UTF-8
+Ten pakiet powinien być zainstalowany na maszynach, na których będą
+magazynowane kopie zapasowe (lub do których podpięte są urządzenia
 typu streamer).
 
 %prep
@@ -163,7 +166,7 @@ mv -f acinc.tmp acinclude.m4
        --with-ftape-rawdevice=/dev/null \
        --with-changer-device=/dev/null \
        --with-fqdn \
-       --with-smbclient=%{_bindir}/smbclient \
+       %{?with_samba:--with-smbclient=%{_bindir}/smbclient} \
        --with-bsd-security \
        --with-ssh-security \
        --with-buffered-dump \
@@ -203,6 +206,11 @@ echo "Adding amanda to disk and backup groups"
 /usr/sbin/usermod -G disk,backup amanda
 echo "Setting amanda shell to /bin/sh"
 /usr/bin/chsh -s /bin/sh amanda
+if [ -f %{_localstatedir}/amanda/.amandahosts ]; then
+       echo "Fixing permissions of %{_localstatedir}/amanda/.amandahosts file"
+       chown amanda:amanda %{_localstatedir}/amanda/.amandahosts
+       chmod 600 %{_localstatedir}/amanda/.amandahosts
+fi
 
 %pre libs
 %groupadd -P %{name}-libs -g 80 amanda
This page took 0.540207 seconds and 4 git commands to generate.