]> git.pld-linux.org Git - packages/adobe-flash.git/blobdiff - adobe-flash.spec
- update URL
[packages/adobe-flash.git] / adobe-flash.spec
index bedb2bdd5c6bd1a6fae0f5148bcf85c0d581491d..ee54b06b8ebade9c89f96951d057ffcd8a86964b 100644 (file)
@@ -2,65 +2,60 @@
 # Conditional build:
 %bcond_with    license_agreement       # generates package
 #
-%define                _ver_major      7
+%define                _ver_major      9
 %define                _ver_minor      0
-%define                _ver_patch      61
+%define                _ver_patch      31
 %define                _ver_serial     0
+%define                base_name       macromedia-flash
 Summary:       Flash plugin for Netscape-compatible WWW browsers
 Summary(pl):   Wtyczka Flash dla przegl±darek WWW zgodnych z Netscape
-%define                base_name       macromedia-flash
 %if %{with license_agreement}
 Name:          %{base_name}
 %else
 Name:          %{base_name}-installer
 %endif
-Version:       %{_ver_major}.%{_ver_minor}.%{_ver_patch}.%{_ver_serial}
 %define                _rel 1
+Version:       %{_ver_major}.%{_ver_minor}.%{_ver_patch}.%{_ver_serial}
 Release:       %{_rel}%{?with_license_agreement:wla}
 License:       Free to use, non-distributable
 Group:         X11/Applications/Multimedia
 %if %{with license_agreement}
-Source0:       http://distfiles.gentoo.org/distfiles/flash-plugin-%{_ver_major}.%{_ver_minor}.%{_ver_patch}.tar.gz
-# NoSource0-md5:       b063b512076d4c88a56cb7521e6b5409
+Source0:       http://fpdownload.macromedia.com/get/flashplayer/current/install_flash_player_9_linux.tar.gz
+# NoSource0-md5:       76b38231a68995935185aa42dfda9db7
 %else
 Source0:       license-installer.sh
+# NoSource0-md5:       76b38231a68995935185aa42dfda9db7
 %endif
-URL:           http://www.macromedia.com/software/flashplayer/
+URL:           http://www.adobe.com/products/flashplayer/
 %if %{with license_agreement}
-BuildRequires: rpmbuild(macros) >= 1.236
-%endif
-Requires:      browser-plugins(%{_target_cpu})
-%if %{without license_agreement}
-Requires:      cpio
+BuildRequires: rpmbuild(macros) >= 1.357
+Requires:      browser-plugins >= 2.0
+%else
 Requires:      rpm-build-tools
-Requires:      wget
 %endif
 Obsoletes:     flash-plugin
-Obsoletes:     mozilla-plugin-macromedia-flash
-Obsoletes:     mozilla-firefox-plugin-macromedia-flash
 Obsoletes:     konqueror-plugin-macromedia-flash
+Obsoletes:     mozilla-firefox-plugin-macromedia-flash
+Obsoletes:     mozilla-plugin-macromedia-flash
 ExclusiveArch: %{ix86}
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
-%define                _plugindir      %{_libdir}/browser-plugins
-
-# TODO: galeon and skipstone.
-# use macro, otherwise extra LF inserted along with the ifarch
-%define        browsers mozilla, mozilla-firefox, konqueror, opera
+%define                _sysconfdir     /etc/adobe
 
 %description
-Flash plugin for Netscape-compatible WWW browsers.
-
-Supported browsers: %{browsers}.
+Adobe(R) Flash(R) Player is the high-performance, lightweight, highly expressive
+client runtime that delivers powerful and consistent user experiences across
+major operating systems, browsers, mobile phones, and devices. Installed on
+over 700 million Internet-connected desktops and mobile devices, Flash Player
+enables organizations and individuals to build and deliver great digital
+experiences to their end users.
 
 %description -l pl
 Wtyczka Flash dla przegl±darek WWW zgodnych z Netscape.
 
-Obs³ugiwane przegl±darki: %{browsers}.
-
 %prep
 %if %{with license_agreement}
-%setup -q -n install_flash_player_7_linux
+%setup -q -n install_flash_player_%{_ver_major}_linux
 %endif
 
 %install
@@ -80,8 +75,13 @@ install %{_specdir}/%{base_name}.spec $RPM_BUILD_ROOT%{_datadir}/%{base_name}
 
 %else
 
-install -d $RPM_BUILD_ROOT%{_plugindir}
-install *.{so,xpt} $RPM_BUILD_ROOT%{_plugindir}
+install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_browserpluginsdir}}
+cat <<'EOF' > $RPM_BUILD_ROOT%{_sysconfdir}/mms.cfg
+# http://www.adobe.com/cfusion/knowledgebase/index.cfm?id=16701594
+AutoUpdateDisable=1
+AutoUpdateInterval=0
+EOF
+install *.so $RPM_BUILD_ROOT%{_browserpluginsdir}
 
 %endif
 
@@ -91,68 +91,24 @@ rm -rf $RPM_BUILD_ROOT
 %if %{without license_agreement}
 %post
 %{_bindir}/%{base_name}.install
-
 %else
+%post
+%update_browser_plugins
 
-%triggerin -- mozilla-firefox
-%nsplugin_install -d %{_libdir}/mozilla-firefox/plugins libflashplayer.so flashplayer.xpt
-
-%triggerun -- mozilla-firefox
-%nsplugin_uninstall -d %{_libdir}/mozilla-firefox/plugins libflashplayer.so flashplayer.xpt
-
-%triggerin -- mozilla
-%nsplugin_install -d %{_libdir}/mozilla/plugins libflashplayer.so flashplayer.xpt
-if [ -d /usr/%{_lib}/mozilla ]; then
-       umask 022
-       rm -f /usr/%{_lib}/mozilla/components/{compreg,xpti}.dat
-       if [ -x /usr/bin/regxpcom ]; then
-               MOZILLA_FIVE_HOME=/usr/%{_lib}/mozilla /usr/bin/regxpcom
-       fi
-fi
-
-%triggerun -- mozilla
-%nsplugin_uninstall -d %{_libdir}/mozilla/plugins libflashplayer.so flashplayer.xpt
-if [ -d /usr/%{_lib}/mozilla ]; then
-       umask 022
-       rm -f /usr/%{_lib}/mozilla/components/{compreg,xpti}.dat
-       if [ -x /usr/bin/regxpcom ]; then
-               MOZILLA_FIVE_HOME=/usr/%{_lib}/mozilla /usr/bin/regxpcom
-       fi
+%postun
+if [ "$1" = 0 ]; then
+       %update_browser_plugins
 fi
-
-%triggerin -- konqueror
-%nsplugin_install -d %{_libdir}/kde3/plugins/konqueror libflashplayer.so
-
-%triggerun -- konqueror
-%nsplugin_uninstall -d %{_libdir}/kde3/plugins/konqueror libflashplayer.so
-
-%triggerin -- opera
-%nsplugin_install -d %{_libdir}/opera/plugins libflashplayer.so
-
-%triggerun -- opera
-%nsplugin_uninstall -d %{_libdir}/opera/plugins libflashplayer.so
-
-# as rpm removes the old obsoleted package files after the triggers
-# above are ran, add another trigger to make the links there.
-%triggerpostun -- mozilla-firefox-plugin-macromedia-flash
-%nsplugin_install -f -d %{_libdir}/mozilla-firefox/plugins libflashplayer.so flashplayer.xpt
-
-%triggerpostun -- mozilla-plugin-macromedia-flash
-%nsplugin_install -f -d %{_libdir}/mozilla/plugins libflashplayer.so flashplayer.xpt
-
-%triggerpostun -- konqueror-plugin-macromedia-flash
-%nsplugin_install -f -d %{_libdir}/kde3/plugins/konqueror libflashplayer.so
 %endif
 
 %files
 %defattr(644,root,root,755)
-
 %if %{without license_agreement}
 %attr(755,root,root) %{_bindir}/%{base_name}.install
 %{_datadir}/%{base_name}
-
 %else
-%doc Readme.txt
-%attr(755,root,root) %{_plugindir}/*.so
-%{_plugindir}/*.xpt
+%doc *.txt
+%dir %{_sysconfdir}
+%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mms.cfg
+%attr(755,root,root) %{_browserpluginsdir}/*.so
 %endif
This page took 0.870542 seconds and 4 git commands to generate.