]> git.pld-linux.org Git - packages/adobe-flash.git/blobdiff - adobe-flash.spec
- update URL
[packages/adobe-flash.git] / adobe-flash.spec
index 4b2e79e318f33f18d81b1088f6b4720b07f4d594..ee54b06b8ebade9c89f96951d057ffcd8a86964b 100644 (file)
@@ -2,54 +2,60 @@
 # Conditional build:
 %bcond_with    license_agreement       # generates package
 #
+%define                _ver_major      9
+%define                _ver_minor      0
+%define                _ver_patch      31
+%define                _ver_serial     0
+%define                base_name       macromedia-flash
 Summary:       Flash plugin for Netscape-compatible WWW browsers
 Summary(pl):   Wtyczka Flash dla przeglĀ±darek WWW zgodnych z Netscape
-%define                base_name       macromedia-flash
 %if %{with license_agreement}
 Name:          %{base_name}
 %else
 Name:          %{base_name}-installer
 %endif
-Version:       7.0r25
-Release:       2.13%{?with_license_agreement:wla}
+%define                _rel 1
+Version:       %{_ver_major}.%{_ver_minor}.%{_ver_patch}.%{_ver_serial}
+Release:       %{_rel}%{?with_license_agreement:wla}
 License:       Free to use, non-distributable
 Group:         X11/Applications/Multimedia
 %if %{with license_agreement}
-Source0:       http://fpdownload.macromedia.com/get/shockwave/flash/english/linux/%{version}/install_flash_player_7_linux.tar.gz
-# NoSource0-md5:       79c59a5ea29347e01c8e6575dd054cd1
+Source0:       http://fpdownload.macromedia.com/get/flashplayer/current/install_flash_player_9_linux.tar.gz
+# NoSource0-md5:       76b38231a68995935185aa42dfda9db7
+%else
+Source0:       license-installer.sh
+# NoSource0-md5:       76b38231a68995935185aa42dfda9db7
 %endif
-URL:           http://www.macromedia.com/software/flash/
-BuildRequires: rpmbuild(macros) >= 1.224
-Requires:      browser-plugins
-%if %{without license_agreement}
-Requires:      /usr/bin/builder
+URL:           http://www.adobe.com/products/flashplayer/
+%if %{with license_agreement}
+BuildRequires: rpmbuild(macros) >= 1.357
+Requires:      browser-plugins >= 2.0
+%else
+Requires:      rpm-build-tools
 %endif
 Obsoletes:     flash-plugin
-Obsoletes:     mozilla-plugin-macromedia-flash
-Obsoletes:     mozilla-firefox-plugin-macromedia-flash
 Obsoletes:     konqueror-plugin-macromedia-flash
+Obsoletes:     mozilla-firefox-plugin-macromedia-flash
+Obsoletes:     mozilla-plugin-macromedia-flash
 ExclusiveArch: %{ix86}
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
-%define                _plugindir      %{_libdir}/browser-plugins
-
-# TODO: opera, galeon and skipstone.
-# use macro, otherwise extra LF inserted along with the ifarch
-%define        browsers mozilla, mozilla-firefox, konqueror
+%define                _sysconfdir     /etc/adobe
 
 %description
-Flash plugin for Netscape-compatible WWW browsers.
-
-Supported browsers: %{browsers}.
+Adobe(R) Flash(R) Player is the high-performance, lightweight, highly expressive
+client runtime that delivers powerful and consistent user experiences across
+major operating systems, browsers, mobile phones, and devices. Installed on
+over 700 million Internet-connected desktops and mobile devices, Flash Player
+enables organizations and individuals to build and deliver great digital
+experiences to their end users.
 
 %description -l pl
 Wtyczka Flash dla przeglĀ±darek WWW zgodnych z Netscape.
 
-Supported browsers: %{browsers}.
-
 %prep
 %if %{with license_agreement}
-%setup -q -n install_flash_player_7_linux
+%setup -q -n install_flash_player_%{_ver_major}_linux
 %endif
 
 %install
@@ -57,64 +63,25 @@ rm -rf $RPM_BUILD_ROOT
 %if %{without license_agreement}
 install -d $RPM_BUILD_ROOT{%{_bindir},%{_datadir}/%{base_name}}
 
-cat <<'EOF' >$RPM_BUILD_ROOT%{_bindir}/%{base_name}.install
-#!/bin/sh
-if [ "$1" = "--with" -a "$2" = "license_agreement" ]; then
-       TMPDIR=`rpm --eval "%%{tmpdir}"`; export TMPDIR
-       SPECDIR=`rpm --eval "%%{_specdir}"`; export SPECDIR
-       SRPMDIR=`rpm --eval "%%{_srcrpmdir}"`; export SRPMDIR
-       SOURCEDIR=`rpm --eval "%%{_sourcedir}"`; export SOURCEDIR
-       BUILDDIR=`rpm --eval "%%{_builddir}"`; export BUILDDIR
-       RPMDIR=`rpm --eval "%%{_rpmdir}"`; export RPMDIR
-       BACKUP=0
-       mkdir -p $TMPDIR $SPECDIR $SRPMDIR $RPMDIR $SRPMDIR $SOURCEDIR $BUILDDIR
-       if [ -f $SPECDIR/%{base_name}.spec ]; then
-               BACKUP=1
-               mv -f $SPECDIR/%{base_name}.spec $SPECDIR/%{base_name}.spec.prev
-       fi
-       if echo "$3" | grep '\.src\.rpm$' >/dev/null; then
-               ( cd $SRPMDIR
-               if echo "$3" | grep '://' >/dev/null; then
-                       wget --passive-ftp -t0 "$3"
-               else
-                       cp -f "$3" .
-               fi
-               rpm2cpio `basename "$3"` | ( cd $TMPDIR; cpio -i %{base_name}.spec )
-               )
-               cp -i $TMPDIR/%{base_name}.spec $SPECDIR/%{base_name}.spec || exit 1
-       else
-               cp -i "$3" $SPECDIR || exit 1
-       fi
-       ( cd $SPECDIR
-       %{_bindir}/builder -nc -ncs --with license_agreement --opts --target=%{_target_cpu} %{base_name}.spec
-       if [ "$?" -ne 0 ]; then
-               exit 2
-       fi
-       RPMNAME=%{base_name}-%{version}-%{release}wla.%{_target_cpu}.rpm
-       RPMNAMES="$RPMNAMES $RPMDIR/$RPMNAME"
-       rpm -U $RPMNAMES || echo -e "Install manually the file(s):\n   $RPMNAMES" )
-       if [ "$BACKUP" -eq 1 ]; then
-               if [ -f $SPECDIR/%{base_name}.spec.prev ]; then
-                       mv -f $SPECDIR/%{base_name}.spec.prev $SPECDIR/%{base_name}.spec
-               fi
-       fi
-else
-       echo "
-License issues made us not to include inherent files into
-this package by default. If you want to create full working
-package please build it with the following command:
-
-$0 --with license_agreement %{_datadir}/%{base_name}/%{base_name}.spec
-"
-fi
-EOF
+sed -e '
+       s/@BASE_NAME@/%{base_name}/g
+       s/@TARGET_CPU@/%{_target_cpu}/g
+       s-@VERSION@-%{version}-g
+       s-@RELEASE@-%{release}-g
+       s,@SPECFILE@,%{_datadir}/%{base_name}/%{base_name}.spec,g
+' %{SOURCE0} > $RPM_BUILD_ROOT%{_bindir}/%{base_name}.install
 
 install %{_specdir}/%{base_name}.spec $RPM_BUILD_ROOT%{_datadir}/%{base_name}
 
 %else
 
-install -d $RPM_BUILD_ROOT%{_plugindir}
-install *.{so,xpt} $RPM_BUILD_ROOT%{_plugindir}
+install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_browserpluginsdir}}
+cat <<'EOF' > $RPM_BUILD_ROOT%{_sysconfdir}/mms.cfg
+# http://www.adobe.com/cfusion/knowledgebase/index.cfm?id=16701594
+AutoUpdateDisable=1
+AutoUpdateInterval=0
+EOF
+install *.so $RPM_BUILD_ROOT%{_browserpluginsdir}
 
 %endif
 
@@ -122,54 +89,26 @@ install *.{so,xpt} $RPM_BUILD_ROOT%{_plugindir}
 rm -rf $RPM_BUILD_ROOT
 
 %if %{without license_agreement}
-%pre
-echo "
-License issues made us not to include inherent files into
-this package by default. If you want to create full working
-package please build it with the following command:
-
-%{base_name}.install --with license_agreement %{_datadir}/%{base_name}/%{base_name}.spec
-"
+%post
+%{_bindir}/%{base_name}.install
 %else
+%post
+%update_browser_plugins
 
-%triggerin -- mozilla-firefox
-%nsplugin_install -d %{_libdir}/mozilla-firefox/plugins libflashplayer.so flashplayer.xpt
-
-%triggerun -- mozilla-firefox
-%nsplugin_uninstall -d %{_libdir}/mozilla-firefox/plugins libflashplayer.so flashplayer.xpt
-
-%triggerin -- mozilla
-%nsplugin_install -d %{_libdir}/mozilla/plugins libflashplayer.so flashplayer.xpt
-umask 022
-rm -f /usr/%{_lib}/mozilla/components/{compreg,xpti}.dat
-if [ -x /usr/bin/regxpcom ]; then
-       MOZILLA_FIVE_HOME=/usr/%{_lib}/mozilla /usr/bin/regxpcom
+%postun
+if [ "$1" = 0 ]; then
+       %update_browser_plugins
 fi
-
-%triggerun -- mozilla
-%nsplugin_uninstall -d %{_libdir}/mozilla/plugins libflashplayer.so flashplayer.xpt
-umask 022
-rm -f /usr/%{_lib}/mozilla/components/{compreg,xpti}.dat
-if [ -x /usr/bin/regxpcom ]; then
-       MOZILLA_FIVE_HOME=/usr/%{_lib}/mozilla /usr/bin/regxpcom
-fi
-
-%triggerin -- konqueror
-%nsplugin_install -d %{_libdir}/kde3/plugins/konqueror libflashplayer.so
-
-%triggerun -- konqueror
-%nsplugin_uninstall -d %{_libdir}/kde3/plugins/konqueror libflashplayer.so
-
 %endif
 
 %files
 %defattr(644,root,root,755)
-
 %if %{without license_agreement}
 %attr(755,root,root) %{_bindir}/%{base_name}.install
 %{_datadir}/%{base_name}
-
 %else
-%attr(755,root,root) %{_plugindir}/*.so
-%{_plugindir}/*.xpt
+%doc *.txt
+%dir %{_sysconfdir}
+%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mms.cfg
+%attr(755,root,root) %{_browserpluginsdir}/*.so
 %endif
This page took 0.037003 seconds and 4 git commands to generate.