]> git.pld-linux.org Git - packages/adobe-flash.git/blobdiff - adobe-flash.spec
- 64bit flash need to be 'patched' to avoid audio problems with glibc 2.13
[packages/adobe-flash.git] / adobe-flash.spec
index f68460c5cf4792cbdf897be83b3ce5e31e890e09..827d16b6a14fc984abb51d023a8f0c382d5eb76f 100644 (file)
 #
 # Conditional build:
 %bcond_with    license_agreement       # generates package
-#
-%define                _ver_major      7
-%define                _ver_minor      0
-%define                _ver_patch      63
-%define                _ver_serial     0
-%define                base_name       macromedia-flash
+
+%ifarch %{ix86}
+%define                ver             10.2.152.27
+%define                libmark %{nil}
+%endif
+%ifarch %{x8664}
+%define                ver             10.3.162.29
+%define                libmark ()(64bit)
+%endif
+
+%define                base_name       adobe-flash
+%define                rel 1
 Summary:       Flash plugin for Netscape-compatible WWW browsers
-Summary(pl):   Wtyczka Flash dla przegl±darek WWW zgodnych z Netscape
+Summary(pl.UTF-8):     Wtyczka Flash dla przeglądarek WWW zgodnych z Netscape
 %if %{with license_agreement}
 Name:          %{base_name}
 %else
 Name:          %{base_name}-installer
 %endif
-%define                _rel 2
-Version:       %{_ver_major}.%{_ver_minor}.%{_ver_patch}.%{_ver_serial}
-Release:       %{_rel}%{?with_license_agreement:wla}
+Version:       %{ver}
+Release:       %{rel}%{?with_license_agreement:wla}
+Epoch:         1
 License:       Free to use, non-distributable
 Group:         X11/Applications/Multimedia
 %if %{with license_agreement}
-Source0:       http://distfiles.gentoo.org/distfiles/flash-plugin-%{_ver_major}.%{_ver_minor}.%{_ver_patch}.tar.gz
-# NoSource0-md5:       a835bc6613c76f62c74a50406bd5801d
+#Source0:      http://download.macromedia.com/pub/labs/flashplayer10/flashplayer10_2_p2_32bit_linux_111710.tar.gz
+#Source0:      http://fpdownload.macromedia.com/get/flashplayer/current/flash-plugin-%{version}-release.i386.rpm
+Source0:       http://fpdownload.macromedia.com/get/flashplayer/current/install_flash_player_10_linux.tar.gz
+# NoSource0-md5:       e9fc57403796a4992474e4f25857ca14
+NoSource:      0
+##Source1:     http://download.macromedia.com/pub/labs/flashplayer10/libflashplayer-%{version}.linux-x86_64.so.tar.gz
+Source1:       http://download.macromedia.com/pub/labs/flashplayer10/flashplayer10_2_p3_64bit_linux_111710.tar.gz
+# NoSource1-md5:       49b55c7eb8044453e5f6f2e4b3cb4084
+NoSource:      1
+Source2:       mms.cfg
 %else
-Source0:       license-installer.sh
+Source3:       http://svn.pld-linux.org/svn/license-installer/license-installer.sh
+# Source3-md5: 329c25f457fea66ec502b7ef70cb9ede
 %endif
-URL:           http://www.macromedia.com/software/flashplayer/
+Source4:       memcpy-to-memmove.sh
+URL:           http://www.adobe.com/products/flashplayer/
 %if %{with license_agreement}
-BuildRequires: rpmbuild(macros) >= 1.236
-Requires:      browser-plugins(%{_target_cpu})
-%endif
-%if %{without license_agreement}
-Requires:      rpm-build-tools
+BuildRequires: rpmbuild(macros) >= 1.357
+BuildRequires: sed >= 4.0
+Requires:      browser-plugins >= 2.0
+# dlopened by player
+Requires:      libasound.so.2%{libmark}
+Requires:      libcurl.so.4%{libmark}
+%else
+Requires:      rpm-build-tools >= 4.4.37
+Requires:      rpmbuild(macros) >= 1.544
 %endif
+Provides:      browser(flash)
+Provides:      macromedia-flash
 Obsoletes:     flash-plugin
 Obsoletes:     konqueror-plugin-macromedia-flash
+Obsoletes:     macromedia-flash
 Obsoletes:     mozilla-firefox-plugin-macromedia-flash
 Obsoletes:     mozilla-plugin-macromedia-flash
-ExclusiveArch: %{ix86}
+ExclusiveArch: %{ix86} %{x8664}
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
-%define                _plugindir      %{_libdir}/browser-plugins
-
-# TODO: galeon and skipstone.
-# use macro, otherwise extra LF inserted along with the ifarch
-%define        browsers mozilla, mozilla-firefox, konqueror, opera
+%define                _sysconfdir     /etc/adobe
 
-%description
-Flash plugin for Netscape-compatible WWW browsers.
+# So that building package on AC system won't write package name dep that Th system can't understand (libstdc++4)
+%define                _noautoreqdep   libstdc++.so.6
 
-Supported browsers: %{browsers}.
+# No debuginfo to be stored
+%define                _enable_debug_packages  0
 
-%description -l pl
-Wtyczka Flash dla przegl±darek WWW zgodnych z Netscape.
+%description
+Adobe(R) Flash(R) Player for Linux - the next-generation client
+runtime for engaging with Flash content and applications on Linux.
 
-Obs³ugiwane przegl±darki: %{browsers}.
+%description -l pl.UTF-8
+Adobe(R) Flash(R) Player - środowisko nowej generacji do obsługi
+treści i aplikacji we Flashu pod Linuksem.
 
 %prep
 %if %{with license_agreement}
-%setup -q -n install_flash_player_7_linux
+%ifarch %{x8664}
+%setup -q -T -c -b 1
+%else
+%setup -q -T -c -b 0
+%endif
+
+%build
+s=$(echo 'LNX %{version}' | tr . ,)
+v=$(strings libflashplayer.so | grep '^LNX ')
+if [ "$v" != "$s" ]; then
+       : wrong version
+       exit 1
+fi
+
+%ifarch %{x8664}
+# Bug #354073: Patch binary to use memmove instead of memcpy from
+# Redhat's bug https://bugzilla.redhat.com/show_bug.cgi?id=638477#c94
+cp libflashplayer.so libflashplayer.so.orig
+/bin/bash %{SOURCE4} libflashplayer.so \
+|| (echo "memcpy-to-memmove.sh failed" && exit 1)
+%endif
 %endif
 
 %install
@@ -72,15 +115,16 @@ sed -e '
        s-@VERSION@-%{version}-g
        s-@RELEASE@-%{release}-g
        s,@SPECFILE@,%{_datadir}/%{base_name}/%{base_name}.spec,g
-' %{SOURCE0} > $RPM_BUILD_ROOT%{_bindir}/%{base_name}.install
+       s,@DATADIR@,%{_datadir}/%{base_name},g
+' %{SOURCE3} > $RPM_BUILD_ROOT%{_bindir}/%{base_name}.install
 
-install %{_specdir}/%{base_name}.spec $RPM_BUILD_ROOT%{_datadir}/%{base_name}
+cp -p %{_specdir}/%{base_name}.spec $RPM_BUILD_ROOT%{_datadir}/%{base_name}
 
 %else
 
-install -d $RPM_BUILD_ROOT%{_plugindir}
-install *.{so,xpt} $RPM_BUILD_ROOT%{_plugindir}
-
+install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_browserpluginsdir}}
+cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/mms.cfg
+install -p *.so $RPM_BUILD_ROOT%{_browserpluginsdir}
 %endif
 
 %clean
@@ -89,74 +133,23 @@ rm -rf $RPM_BUILD_ROOT
 %if %{without license_agreement}
 %post
 %{_bindir}/%{base_name}.install
-
 %else
+%post
+%update_browser_plugins
 
-%triggerin -- mozilla-firefox
-%nsplugin_install -d %{_libdir}/mozilla-firefox/plugins libflashplayer.so flashplayer.xpt
-
-%triggerun -- mozilla-firefox
-%nsplugin_uninstall -d %{_libdir}/mozilla-firefox/plugins libflashplayer.so flashplayer.xpt
-
-%triggerin -- mozilla
-%nsplugin_install -d %{_libdir}/mozilla/plugins libflashplayer.so flashplayer.xpt
-if [ -d /usr/%{_lib}/mozilla ]; then
-       umask 022
-       rm -f /usr/%{_lib}/mozilla/components/{compreg,xpti}.dat
-       if [ -x /usr/bin/regxpcom ]; then
-               MOZILLA_FIVE_HOME=/usr/%{_lib}/mozilla /usr/bin/regxpcom
-       fi
-fi
-
-%triggerun -- mozilla
-%nsplugin_uninstall -d %{_libdir}/mozilla/plugins libflashplayer.so flashplayer.xpt
-if [ -d /usr/%{_lib}/mozilla ]; then
-       umask 022
-       rm -f /usr/%{_lib}/mozilla/components/{compreg,xpti}.dat
-       if [ -x /usr/bin/regxpcom ]; then
-               MOZILLA_FIVE_HOME=/usr/%{_lib}/mozilla /usr/bin/regxpcom
-       fi
+%postun
+if [ "$1" = 0 ]; then
+       %update_browser_plugins
 fi
-
-%triggerin -- konqueror
-%nsplugin_install -d %{_libdir}/kde3/plugins/konqueror libflashplayer.so
-
-%triggerun -- konqueror
-%nsplugin_uninstall -d %{_libdir}/kde3/plugins/konqueror libflashplayer.so
-
-%triggerin -- opera
-%nsplugin_install -d %{_libdir}/opera/plugins libflashplayer.so
-
-%triggerun -- opera
-%nsplugin_uninstall -d %{_libdir}/opera/plugins libflashplayer.so
-
-%triggerin -- seamonkey
-%nsplugin_install -d %{_libdir}/seamonkey/plugins libflashplayer.so
-
-%triggerun -- seamonkey
-%nsplugin_uninstall -d %{_libdir}/seamonkey/plugins libflashplayer.so
-
-# as rpm removes the old obsoleted package files after the triggers
-# above are ran, add another trigger to make the links there.
-%triggerpostun -- mozilla-firefox-plugin-macromedia-flash
-%nsplugin_install -f -d %{_libdir}/mozilla-firefox/plugins libflashplayer.so flashplayer.xpt
-
-%triggerpostun -- mozilla-plugin-macromedia-flash
-%nsplugin_install -f -d %{_libdir}/mozilla/plugins libflashplayer.so flashplayer.xpt
-
-%triggerpostun -- konqueror-plugin-macromedia-flash
-%nsplugin_install -f -d %{_libdir}/kde3/plugins/konqueror libflashplayer.so
 %endif
 
 %files
 %defattr(644,root,root,755)
-
 %if %{without license_agreement}
 %attr(755,root,root) %{_bindir}/%{base_name}.install
 %{_datadir}/%{base_name}
-
 %else
-%doc Readme.txt
-%attr(755,root,root) %{_plugindir}/*.so
-%{_plugindir}/*.xpt
+%dir %{_sysconfdir}
+%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mms.cfg
+%attr(755,root,root) %{_browserpluginsdir}/*.so
 %endif
This page took 0.082431 seconds and 4 git commands to generate.