]> git.pld-linux.org Git - packages/adobe-flash.git/blobdiff - adobe-flash.spec
- 64bit flash need to be 'patched' to avoid audio problems with glibc 2.13
[packages/adobe-flash.git] / adobe-flash.spec
index b6de0d835a1ad6f607e0b3e1527b71d49986cb96..827d16b6a14fc984abb51d023a8f0c382d5eb76f 100644 (file)
@@ -2,15 +2,13 @@
 # Conditional build:
 %bcond_with    license_agreement       # generates package
 
-%define                ver_major       10
-%define                ver_minor       1
-%define                ver_patch       82
-%define                ver_serial      76
-
+%ifarch %{ix86}
+%define                ver             10.2.152.27
+%define                libmark %{nil}
+%endif
 %ifarch %{x8664}
-%define                libmark         ()(64bit)
-%else
-%define                libmark         %{nil}
+%define                ver             10.3.162.29
+%define                libmark ()(64bit)
 %endif
 
 %define                base_name       adobe-flash
@@ -22,22 +20,27 @@ Name:               %{base_name}
 %else
 Name:          %{base_name}-installer
 %endif
-Version:       %{ver_major}.%{ver_minor}.%{ver_patch}.%{ver_serial}
+Version:       %{ver}
 Release:       %{rel}%{?with_license_agreement:wla}
 Epoch:         1
 License:       Free to use, non-distributable
 Group:         X11/Applications/Multimedia
 %if %{with license_agreement}
+#Source0:      http://download.macromedia.com/pub/labs/flashplayer10/flashplayer10_2_p2_32bit_linux_111710.tar.gz
+#Source0:      http://fpdownload.macromedia.com/get/flashplayer/current/flash-plugin-%{version}-release.i386.rpm
 Source0:       http://fpdownload.macromedia.com/get/flashplayer/current/install_flash_player_10_linux.tar.gz
-# NoSource0-md5:       7f122a6bf62403c2916f37df48c18768
+# NoSource0-md5:       e9fc57403796a4992474e4f25857ca14
 NoSource:      0
-#Source1:      http://download.macromedia.com/pub/labs/flashplayer10/libflashplayer-%{version}.linux-x86_64.so.tar.gz
-# NoSource1-md5:       4a4561e456612a6751653b58342d53df
-#NoSource:     1
+##Source1:     http://download.macromedia.com/pub/labs/flashplayer10/libflashplayer-%{version}.linux-x86_64.so.tar.gz
+Source1:       http://download.macromedia.com/pub/labs/flashplayer10/flashplayer10_2_p3_64bit_linux_111710.tar.gz
+# NoSource1-md5:       49b55c7eb8044453e5f6f2e4b3cb4084
+NoSource:      1
+Source2:       mms.cfg
 %else
-Source2:       http://svn.pld-linux.org/svn/license-installer/license-installer.sh
-# Source2-md5: 4fb1600353dd57fe088e0b12fb0ecac2
+Source3:       http://svn.pld-linux.org/svn/license-installer/license-installer.sh
+# Source3-md5: 329c25f457fea66ec502b7ef70cb9ede
 %endif
+Source4:       memcpy-to-memmove.sh
 URL:           http://www.adobe.com/products/flashplayer/
 %if %{with license_agreement}
 BuildRequires: rpmbuild(macros) >= 1.357
@@ -57,8 +60,7 @@ Obsoletes:    konqueror-plugin-macromedia-flash
 Obsoletes:     macromedia-flash
 Obsoletes:     mozilla-firefox-plugin-macromedia-flash
 Obsoletes:     mozilla-plugin-macromedia-flash
-ExclusiveArch: %{ix86}
-# %{x8664}
+ExclusiveArch: %{ix86} %{x8664}
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %define                _sysconfdir     /etc/adobe
@@ -86,12 +88,20 @@ treÅ›ci i aplikacji we Flashu pod Linuksem.
 %endif
 
 %build
-s='LNX %{ver_major},%{ver_minor},%{ver_patch},%{ver_serial}'
-v=$(strings libflashplayer.so | grep "$s")
+s=$(echo 'LNX %{version}' | tr . ,)
+v=$(strings libflashplayer.so | grep '^LNX ')
 if [ "$v" != "$s" ]; then
        : wrong version
        exit 1
 fi
+
+%ifarch %{x8664}
+# Bug #354073: Patch binary to use memmove instead of memcpy from
+# Redhat's bug https://bugzilla.redhat.com/show_bug.cgi?id=638477#c94
+cp libflashplayer.so libflashplayer.so.orig
+/bin/bash %{SOURCE4} libflashplayer.so \
+|| (echo "memcpy-to-memmove.sh failed" && exit 1)
+%endif
 %endif
 
 %install
@@ -106,21 +116,15 @@ sed -e '
        s-@RELEASE@-%{release}-g
        s,@SPECFILE@,%{_datadir}/%{base_name}/%{base_name}.spec,g
        s,@DATADIR@,%{_datadir}/%{base_name},g
-' %{SOURCE2} > $RPM_BUILD_ROOT%{_bindir}/%{base_name}.install
+' %{SOURCE3} > $RPM_BUILD_ROOT%{_bindir}/%{base_name}.install
 
-install %{_specdir}/%{base_name}.spec $RPM_BUILD_ROOT%{_datadir}/%{base_name}
+cp -p %{_specdir}/%{base_name}.spec $RPM_BUILD_ROOT%{_datadir}/%{base_name}
 
 %else
 
 install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_browserpluginsdir}}
-cat <<'EOF' > $RPM_BUILD_ROOT%{_sysconfdir}/mms.cfg
-# http://www.adobe.com/cfusion/knowledgebase/index.cfm?id=16701594
-# http://www.adobe.com/devnet/flashplayer/articles/flash_player_admin_guide.html
-AutoUpdateDisable=1
-AutoUpdateInterval=0
-# OverrideGPUValidation=true
-EOF
-install *.so $RPM_BUILD_ROOT%{_browserpluginsdir}
+cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/mms.cfg
+install -p *.so $RPM_BUILD_ROOT%{_browserpluginsdir}
 %endif
 
 %clean
This page took 0.099374 seconds and 4 git commands to generate.