]> git.pld-linux.org Git - packages/adobe-flash.git/blobdiff - adobe-flash.spec
- 64bit flash need to be 'patched' to avoid audio problems with glibc 2.13
[packages/adobe-flash.git] / adobe-flash.spec
index 725e5148e11e5f21ffe63ca838e8c942bfdd5ca8..827d16b6a14fc984abb51d023a8f0c382d5eb76f 100644 (file)
@@ -2,18 +2,13 @@
 # Conditional build:
 %bcond_with    license_agreement       # generates package
 
+%ifarch %{ix86}
+%define                ver             10.2.152.27
+%define                libmark %{nil}
+%endif
 %ifarch %{x8664}
-%define                ver_major       10
-%define                ver_minor       2
-%define                ver_patch       161
-%define                ver_serial      22
-%define                libmark         ()(64bit)
-%else
-%define                ver_major       10
-%define                ver_minor       2
-%define                ver_patch       161
-%define                ver_serial      22
-%define                libmark         %{nil}
+%define                ver             10.3.162.29
+%define                libmark ()(64bit)
 %endif
 
 %define                base_name       adobe-flash
@@ -25,24 +20,27 @@ Name:               %{base_name}
 %else
 Name:          %{base_name}-installer
 %endif
-Version:       %{ver_major}.%{ver_minor}.%{ver_patch}.%{ver_serial}
+Version:       %{ver}
 Release:       %{rel}%{?with_license_agreement:wla}
 Epoch:         1
 License:       Free to use, non-distributable
 Group:         X11/Applications/Multimedia
 %if %{with license_agreement}
-#Source0:      http://fpdownload.macromedia.com/get/flashplayer/current/install_flash_player_10_linux.tar.gz
-Source0:       http://download.macromedia.com/pub/labs/flashplayer10/flashplayer_square_p1_32bit_linux_091510.tar.gz
-# NoSource0-md5:       72ccae191545eb921a445b07ed3ceb06
+#Source0:      http://download.macromedia.com/pub/labs/flashplayer10/flashplayer10_2_p2_32bit_linux_111710.tar.gz
+#Source0:      http://fpdownload.macromedia.com/get/flashplayer/current/flash-plugin-%{version}-release.i386.rpm
+Source0:       http://fpdownload.macromedia.com/get/flashplayer/current/install_flash_player_10_linux.tar.gz
+# NoSource0-md5:       e9fc57403796a4992474e4f25857ca14
 NoSource:      0
-#Source1:      http://download.macromedia.com/pub/labs/flashplayer10/libflashplayer-%{version}.linux-x86_64.so.tar.gz
-Source1:       http://download.macromedia.com/pub/labs/flashplayer10/flashplayer_square_p1_64bit_linux_091510.tar.gz
-# NoSource1-md5:       338e954c02ba6776b6b8a908e6f96b5f
+##Source1:     http://download.macromedia.com/pub/labs/flashplayer10/libflashplayer-%{version}.linux-x86_64.so.tar.gz
+Source1:       http://download.macromedia.com/pub/labs/flashplayer10/flashplayer10_2_p3_64bit_linux_111710.tar.gz
+# NoSource1-md5:       49b55c7eb8044453e5f6f2e4b3cb4084
 NoSource:      1
+Source2:       mms.cfg
 %else
-Source2:       http://svn.pld-linux.org/svn/license-installer/license-installer.sh
-# Source2-md5: 329c25f457fea66ec502b7ef70cb9ede
+Source3:       http://svn.pld-linux.org/svn/license-installer/license-installer.sh
+# Source3-md5: 329c25f457fea66ec502b7ef70cb9ede
 %endif
+Source4:       memcpy-to-memmove.sh
 URL:           http://www.adobe.com/products/flashplayer/
 %if %{with license_agreement}
 BuildRequires: rpmbuild(macros) >= 1.357
@@ -90,12 +88,20 @@ treÅ›ci i aplikacji we Flashu pod Linuksem.
 %endif
 
 %build
-s='LNX %{ver_major},%{ver_minor},%{ver_patch},%{ver_serial}'
+s=$(echo 'LNX %{version}' | tr . ,)
 v=$(strings libflashplayer.so | grep '^LNX ')
 if [ "$v" != "$s" ]; then
        : wrong version
        exit 1
 fi
+
+%ifarch %{x8664}
+# Bug #354073: Patch binary to use memmove instead of memcpy from
+# Redhat's bug https://bugzilla.redhat.com/show_bug.cgi?id=638477#c94
+cp libflashplayer.so libflashplayer.so.orig
+/bin/bash %{SOURCE4} libflashplayer.so \
+|| (echo "memcpy-to-memmove.sh failed" && exit 1)
+%endif
 %endif
 
 %install
@@ -110,21 +116,15 @@ sed -e '
        s-@RELEASE@-%{release}-g
        s,@SPECFILE@,%{_datadir}/%{base_name}/%{base_name}.spec,g
        s,@DATADIR@,%{_datadir}/%{base_name},g
-' %{SOURCE2} > $RPM_BUILD_ROOT%{_bindir}/%{base_name}.install
+' %{SOURCE3} > $RPM_BUILD_ROOT%{_bindir}/%{base_name}.install
 
-install %{_specdir}/%{base_name}.spec $RPM_BUILD_ROOT%{_datadir}/%{base_name}
+cp -p %{_specdir}/%{base_name}.spec $RPM_BUILD_ROOT%{_datadir}/%{base_name}
 
 %else
 
 install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_browserpluginsdir}}
-cat <<'EOF' > $RPM_BUILD_ROOT%{_sysconfdir}/mms.cfg
-# http://www.adobe.com/cfusion/knowledgebase/index.cfm?id=16701594
-# http://www.adobe.com/devnet/flashplayer/articles/flash_player_admin_guide.html
-AutoUpdateDisable=1
-AutoUpdateInterval=0
-# OverrideGPUValidation=true
-EOF
-install *.so $RPM_BUILD_ROOT%{_browserpluginsdir}
+cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/mms.cfg
+install -p *.so $RPM_BUILD_ROOT%{_browserpluginsdir}
 %endif
 
 %clean
This page took 0.0777139999999999 seconds and 4 git commands to generate.