]> git.pld-linux.org Git - packages/adobe-flash.git/blobdiff - adobe-flash.spec
- 64bit flash need to be 'patched' to avoid audio problems with glibc 2.13
[packages/adobe-flash.git] / adobe-flash.spec
index 3c02c8fdd2be7b637625176af085ba7ed6136708..827d16b6a14fc984abb51d023a8f0c382d5eb76f 100644 (file)
@@ -1,13 +1,18 @@
 #
 # Conditional build:
 %bcond_with    license_agreement       # generates package
-#
-%define                ver_major       10
-%define                ver_minor       0
-%define                ver_patch       0
-%define                ver_serial      0
+
+%ifarch %{ix86}
+%define                ver             10.2.152.27
+%define                libmark %{nil}
+%endif
+%ifarch %{x8664}
+%define                ver             10.3.162.29
+%define                libmark ()(64bit)
+%endif
+
 %define                base_name       adobe-flash
-%define                rel 2
+%define                rel 1
 Summary:       Flash plugin for Netscape-compatible WWW browsers
 Summary(pl.UTF-8):     Wtyczka Flash dla przeglądarek WWW zgodnych z Netscape
 %if %{with license_agreement}
@@ -15,42 +20,59 @@ Name:               %{base_name}
 %else
 Name:          %{base_name}-installer
 %endif
-Version:       %{ver_major}.%{ver_minor}.%{ver_patch}.%{ver_serial}
+Version:       %{ver}
 Release:       %{rel}%{?with_license_agreement:wla}
+Epoch:         1
 License:       Free to use, non-distributable
 Group:         X11/Applications/Multimedia
 %if %{with license_agreement}
-Source0:       http://download.macromedia.com/pub/labs/flashplayer10/flashplayer10_install_linux_070208.tar.gz
-# NoSource0-md5:       
+#Source0:      http://download.macromedia.com/pub/labs/flashplayer10/flashplayer10_2_p2_32bit_linux_111710.tar.gz
+#Source0:      http://fpdownload.macromedia.com/get/flashplayer/current/flash-plugin-%{version}-release.i386.rpm
+Source0:       http://fpdownload.macromedia.com/get/flashplayer/current/install_flash_player_10_linux.tar.gz
+# NoSource0-md5:       e9fc57403796a4992474e4f25857ca14
+NoSource:      0
+##Source1:     http://download.macromedia.com/pub/labs/flashplayer10/libflashplayer-%{version}.linux-x86_64.so.tar.gz
+Source1:       http://download.macromedia.com/pub/labs/flashplayer10/flashplayer10_2_p3_64bit_linux_111710.tar.gz
+# NoSource1-md5:       49b55c7eb8044453e5f6f2e4b3cb4084
+NoSource:      1
+Source2:       mms.cfg
 %else
-Source1:       license-installer.sh
+Source3:       http://svn.pld-linux.org/svn/license-installer/license-installer.sh
+# Source3-md5: 329c25f457fea66ec502b7ef70cb9ede
 %endif
+Source4:       memcpy-to-memmove.sh
 URL:           http://www.adobe.com/products/flashplayer/
 %if %{with license_agreement}
 BuildRequires: rpmbuild(macros) >= 1.357
+BuildRequires: sed >= 4.0
 Requires:      browser-plugins >= 2.0
-# apparently dlopened by player
-Requires:      libasound.so.2
+# dlopened by player
+Requires:      libasound.so.2%{libmark}
+Requires:      libcurl.so.4%{libmark}
 %else
-Requires:      rpm-build-tools
+Requires:      rpm-build-tools >= 4.4.37
+Requires:      rpmbuild(macros) >= 1.544
 %endif
-Provides:      macromedia-flash
 Provides:      browser(flash)
+Provides:      macromedia-flash
 Obsoletes:     flash-plugin
 Obsoletes:     konqueror-plugin-macromedia-flash
 Obsoletes:     macromedia-flash
 Obsoletes:     mozilla-firefox-plugin-macromedia-flash
 Obsoletes:     mozilla-plugin-macromedia-flash
-ExclusiveArch: %{ix86}
+ExclusiveArch: %{ix86} %{x8664}
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %define                _sysconfdir     /etc/adobe
 
+# So that building package on AC system won't write package name dep that Th system can't understand (libstdc++4)
+%define                _noautoreqdep   libstdc++.so.6
+
 # No debuginfo to be stored
 %define                _enable_debug_packages  0
 
 %description
-Adobe(R) Flash(R) Player for Linux - the next-generation client
+Adobe(R) Flash(R) Player for Linux - the next-generation client
 runtime for engaging with Flash content and applications on Linux.
 
 %description -l pl.UTF-8
@@ -59,7 +81,27 @@ treści i aplikacji we Flashu pod Linuksem.
 
 %prep
 %if %{with license_agreement}
-%setup -q -n install_flash_player_%{ver_major}_linux
+%ifarch %{x8664}
+%setup -q -T -c -b 1
+%else
+%setup -q -T -c -b 0
+%endif
+
+%build
+s=$(echo 'LNX %{version}' | tr . ,)
+v=$(strings libflashplayer.so | grep '^LNX ')
+if [ "$v" != "$s" ]; then
+       : wrong version
+       exit 1
+fi
+
+%ifarch %{x8664}
+# Bug #354073: Patch binary to use memmove instead of memcpy from
+# Redhat's bug https://bugzilla.redhat.com/show_bug.cgi?id=638477#c94
+cp libflashplayer.so libflashplayer.so.orig
+/bin/bash %{SOURCE4} libflashplayer.so \
+|| (echo "memcpy-to-memmove.sh failed" && exit 1)
+%endif
 %endif
 
 %install
@@ -73,20 +115,16 @@ sed -e '
        s-@VERSION@-%{version}-g
        s-@RELEASE@-%{release}-g
        s,@SPECFILE@,%{_datadir}/%{base_name}/%{base_name}.spec,g
-' %{SOURCE1} > $RPM_BUILD_ROOT%{_bindir}/%{base_name}.install
+       s,@DATADIR@,%{_datadir}/%{base_name},g
+' %{SOURCE3} > $RPM_BUILD_ROOT%{_bindir}/%{base_name}.install
 
-install %{_specdir}/%{base_name}.spec $RPM_BUILD_ROOT%{_datadir}/%{base_name}
+cp -p %{_specdir}/%{base_name}.spec $RPM_BUILD_ROOT%{_datadir}/%{base_name}
 
 %else
 
 install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_browserpluginsdir}}
-cat <<'EOF' > $RPM_BUILD_ROOT%{_sysconfdir}/mms.cfg
-# http://www.adobe.com/cfusion/knowledgebase/index.cfm?id=16701594
-AutoUpdateDisable=1
-AutoUpdateInterval=0
-EOF
-install *.so $RPM_BUILD_ROOT%{_browserpluginsdir}
-
+cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/mms.cfg
+install -p *.so $RPM_BUILD_ROOT%{_browserpluginsdir}
 %endif
 
 %clean
This page took 0.046486 seconds and 4 git commands to generate.