]> git.pld-linux.org Git - packages/adobe-flash.git/blobdiff - adobe-flash.spec
- updated to 10.0.15.3, x86_64 version updated to 10.0.7.d21.1
[packages/adobe-flash.git] / adobe-flash.spec
index a3cf5f8136589960d198e9574fe41857f172de0e..7a103b22f4708b980876c754f7c13a9ab65a5437 100644 (file)
@@ -2,60 +2,84 @@
 # Conditional build:
 %bcond_with    license_agreement       # generates package
 #
-%define                _ver_major      9
-%define                _ver_minor      0
-%define                _ver_patch      31
-%define                _ver_serial     0
-%define                base_name       macromedia-flash
+%ifarch %{x8664}
+%define         ver_major       10
+%define         ver_minor       0
+%define         ver_patch       d21
+%define         ver_serial      1
+%define                libmark         ()(64bit)
+%else
+%define                ver_major       10
+%define                ver_minor       0
+%define                ver_patch       15
+%define                ver_serial      3
+%define                libmark         %{nil}
+%endif
+%define                base_name       adobe-flash
+%define                rel 1
 Summary:       Flash plugin for Netscape-compatible WWW browsers
-Summary(pl):   Wtyczka Flash dla przegl±darek WWW zgodnych z Netscape
+Summary(pl.UTF-8):     Wtyczka Flash dla przeglądarek WWW zgodnych z Netscape
 %if %{with license_agreement}
 Name:          %{base_name}
 %else
 Name:          %{base_name}-installer
 %endif
-%define                _rel 1
-Version:       %{_ver_major}.%{_ver_minor}.%{_ver_patch}.%{_ver_serial}
-Release:       %{_rel}%{?with_license_agreement:wla}
+Version:       %{ver_major}.%{ver_minor}.%{ver_patch}.%{ver_serial}
+Release:       %{rel}%{?with_license_agreement:wla}
 License:       Free to use, non-distributable
 Group:         X11/Applications/Multimedia
 %if %{with license_agreement}
-Source0:       http://fpdownload.macromedia.com/get/flashplayer/current/install_flash_player_9_linux.tar.gz
-# NoSource0-md5:       76b38231a68995935185aa42dfda9db7
+Source0:       http://fpdownload.macromedia.com/get/flashplayer/current/install_flash_player_10_linux.tar.gz
+# NoSource0-md5:       afab0b40b0ae11445e2e90a4a9224a8a
+Source1:       http://download.macromedia.com/pub/labs/flashplayer10/libflashplayer-10.0.d21.1.linux-x86_64.so.tar.gz
+# NoSource1-md5:       c165af9d4e324bfaf6d1cfbdbe959fbb
 %else
-Source0:       license-installer.sh
-# NoSource0-md5:       76b38231a68995935185aa42dfda9db7
+Source2:       license-installer.sh
 %endif
-URL:           http://labs.adobe.com/technologies/flashplayer9/
+URL:           http://www.adobe.com/products/flashplayer/
 %if %{with license_agreement}
 BuildRequires: rpmbuild(macros) >= 1.357
+BuildRequires: sed >= 4.0
 Requires:      browser-plugins >= 2.0
+# dlopened by player
+Requires:      libasound.so.2%{libmark}
+Requires:      libcurl.so.4%{libmark}
 %else
 Requires:      rpm-build-tools
 %endif
+Provides:      browser(flash)
+Provides:      macromedia-flash
 Obsoletes:     flash-plugin
 Obsoletes:     konqueror-plugin-macromedia-flash
+Obsoletes:     macromedia-flash
 Obsoletes:     mozilla-firefox-plugin-macromedia-flash
 Obsoletes:     mozilla-plugin-macromedia-flash
-ExclusiveArch: %{ix86}
+ExclusiveArch: %{ix86} %{x8664}
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %define                _sysconfdir     /etc/adobe
 
+# So that building package on AC system won't write package name dep that Th system can't understand (libstdc++4)
+%define                _noautoreqdep   libstdc++.so.6
+
+# No debuginfo to be stored
+%define                _enable_debug_packages  0
+
 %description
-Adobe(R) Flash(R) Player is the high-performance, lightweight, highly expressive
-client runtime that delivers powerful and consistent user experiences across
-major operating systems, browsers, mobile phones, and devices. Installed on
-over 700 million Internet-connected desktops and mobile devices, Flash Player
-enables organizations and individuals to build and deliver great digital
-experiences to their end users.
+Adobe(R) Flash(R) Player for Linux - the next-generation client
+runtime for engaging with Flash content and applications on Linux.
 
-%description -l pl
-Wtyczka Flash dla przegl±darek WWW zgodnych z Netscape.
+%description -l pl.UTF-8
+Adobe(R) Flash(R) Player - środowisko nowej generacji do obsługi
+treści i aplikacji we Flashu pod Linuksem.
 
 %prep
 %if %{with license_agreement}
-%setup -q -n install_flash_player_%{_ver_major}_linux
+%ifarch %{x8664}
+%setup -q -T -c -b 1
+%else
+%setup -q -T -b 0 -n install_flash_player_%{ver_major}_linux
+%endif
 %endif
 
 %install
@@ -69,7 +93,7 @@ sed -e '
        s-@VERSION@-%{version}-g
        s-@RELEASE@-%{release}-g
        s,@SPECFILE@,%{_datadir}/%{base_name}/%{base_name}.spec,g
-' %{SOURCE0} > $RPM_BUILD_ROOT%{_bindir}/%{base_name}.install
+' %{SOURCE2} > $RPM_BUILD_ROOT%{_bindir}/%{base_name}.install
 
 install %{_specdir}/%{base_name}.spec $RPM_BUILD_ROOT%{_datadir}/%{base_name}
 
@@ -78,11 +102,12 @@ install %{_specdir}/%{base_name}.spec $RPM_BUILD_ROOT%{_datadir}/%{base_name}
 install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_browserpluginsdir}}
 cat <<'EOF' > $RPM_BUILD_ROOT%{_sysconfdir}/mms.cfg
 # http://www.adobe.com/cfusion/knowledgebase/index.cfm?id=16701594
+# http://www.adobe.com/devnet/flashplayer/articles/flash_player_admin_guide.html
 AutoUpdateDisable=1
 AutoUpdateInterval=0
+# OverrideGPUValidation=true
 EOF
 install *.so $RPM_BUILD_ROOT%{_browserpluginsdir}
-
 %endif
 
 %clean
@@ -107,7 +132,6 @@ fi
 %attr(755,root,root) %{_bindir}/%{base_name}.install
 %{_datadir}/%{base_name}
 %else
-%doc *.txt
 %dir %{_sysconfdir}
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mms.cfg
 %attr(755,root,root) %{_browserpluginsdir}/*.so
This page took 0.054165 seconds and 4 git commands to generate.