]> git.pld-linux.org Git - packages/adobe-flash.git/blobdiff - adobe-flash.spec
- updated to 10.0.15.3, x86_64 version updated to 10.0.7.d21.1
[packages/adobe-flash.git] / adobe-flash.spec
index 62fb1e1ef099de56eb623ffb7df91656849454c1..7a103b22f4708b980876c754f7c13a9ab65a5437 100644 (file)
@@ -2,56 +2,84 @@
 # Conditional build:
 %bcond_with    license_agreement       # generates package
 #
+%ifarch %{x8664}
+%define         ver_major       10
+%define         ver_minor       0
+%define         ver_patch       d21
+%define         ver_serial      1
+%define                libmark         ()(64bit)
+%else
+%define                ver_major       10
+%define                ver_minor       0
+%define                ver_patch       15
+%define                ver_serial      3
+%define                libmark         %{nil}
+%endif
+%define                base_name       adobe-flash
+%define                rel 1
 Summary:       Flash plugin for Netscape-compatible WWW browsers
-Summary(pl):   Wtyczka Flash dla przegl±darek WWW zgodnych z Netscape
-%define                base_name       macromedia-flash
+Summary(pl.UTF-8):     Wtyczka Flash dla przeglądarek WWW zgodnych z Netscape
 %if %{with license_agreement}
 Name:          %{base_name}
 %else
 Name:          %{base_name}-installer
 %endif
-Version:       7.0r25
-Release:       2.17%{?with_license_agreement:wla}
+Version:       %{ver_major}.%{ver_minor}.%{ver_patch}.%{ver_serial}
+Release:       %{rel}%{?with_license_agreement:wla}
 License:       Free to use, non-distributable
 Group:         X11/Applications/Multimedia
 %if %{with license_agreement}
-Source0:       http://fpdownload.macromedia.com/get/shockwave/flash/english/linux/%{version}/install_flash_player_7_linux.tar.gz
-# NoSource0-md5:       79c59a5ea29347e01c8e6575dd054cd1
+Source0:       http://fpdownload.macromedia.com/get/flashplayer/current/install_flash_player_10_linux.tar.gz
+# NoSource0-md5:       afab0b40b0ae11445e2e90a4a9224a8a
+Source1:       http://download.macromedia.com/pub/labs/flashplayer10/libflashplayer-10.0.d21.1.linux-x86_64.so.tar.gz
+# NoSource1-md5:       c165af9d4e324bfaf6d1cfbdbe959fbb
 %else
-Source0:       license-installer.sh
+Source2:       license-installer.sh
 %endif
-URL:           http://www.macromedia.com/software/flash/
-BuildRequires: rpmbuild(macros) >= 1.224
-Requires:      browser-plugins
-%if %{without license_agreement}
-Requires:      /usr/bin/builder
+URL:           http://www.adobe.com/products/flashplayer/
+%if %{with license_agreement}
+BuildRequires: rpmbuild(macros) >= 1.357
+BuildRequires: sed >= 4.0
+Requires:      browser-plugins >= 2.0
+# dlopened by player
+Requires:      libasound.so.2%{libmark}
+Requires:      libcurl.so.4%{libmark}
+%else
+Requires:      rpm-build-tools
 %endif
+Provides:      browser(flash)
+Provides:      macromedia-flash
 Obsoletes:     flash-plugin
-Obsoletes:     mozilla-plugin-macromedia-flash
-Obsoletes:     mozilla-firefox-plugin-macromedia-flash
 Obsoletes:     konqueror-plugin-macromedia-flash
-ExclusiveArch: %{ix86}
+Obsoletes:     macromedia-flash
+Obsoletes:     mozilla-firefox-plugin-macromedia-flash
+Obsoletes:     mozilla-plugin-macromedia-flash
+ExclusiveArch: %{ix86} %{x8664}
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
-%define                _plugindir      %{_libdir}/browser-plugins
-
-# TODO: opera, galeon and skipstone.
-# use macro, otherwise extra LF inserted along with the ifarch
-%define        browsers mozilla, mozilla-firefox, konqueror
+%define                _sysconfdir     /etc/adobe
 
-%description
-Flash plugin for Netscape-compatible WWW browsers.
+# So that building package on AC system won't write package name dep that Th system can't understand (libstdc++4)
+%define                _noautoreqdep   libstdc++.so.6
 
-Supported browsers: %{browsers}.
+# No debuginfo to be stored
+%define                _enable_debug_packages  0
 
-%description -l pl
-Wtyczka Flash dla przegl±darek WWW zgodnych z Netscape.
+%description
+Adobe(R) Flash(R) Player for Linux - the next-generation client
+runtime for engaging with Flash content and applications on Linux.
 
-Supported browsers: %{browsers}.
+%description -l pl.UTF-8
+Adobe(R) Flash(R) Player - środowisko nowej generacji do obsługi
+treści i aplikacji we Flashu pod Linuksem.
 
 %prep
 %if %{with license_agreement}
-%setup -q -n install_flash_player_7_linux
+%ifarch %{x8664}
+%setup -q -T -c -b 1
+%else
+%setup -q -T -b 0 -n install_flash_player_%{ver_major}_linux
+%endif
 %endif
 
 %install
@@ -65,64 +93,46 @@ sed -e '
        s-@VERSION@-%{version}-g
        s-@RELEASE@-%{release}-g
        s,@SPECFILE@,%{_datadir}/%{base_name}/%{base_name}.spec,g
-' %{SOURCE0} > $RPM_BUILD_ROOT%{_bindir}/%{base_name}.install
+' %{SOURCE2} > $RPM_BUILD_ROOT%{_bindir}/%{base_name}.install
 
 install %{_specdir}/%{base_name}.spec $RPM_BUILD_ROOT%{_datadir}/%{base_name}
 
 %else
 
-install -d $RPM_BUILD_ROOT%{_plugindir}
-install *.{so,xpt} $RPM_BUILD_ROOT%{_plugindir}
-
+install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_browserpluginsdir}}
+cat <<'EOF' > $RPM_BUILD_ROOT%{_sysconfdir}/mms.cfg
+# http://www.adobe.com/cfusion/knowledgebase/index.cfm?id=16701594
+# http://www.adobe.com/devnet/flashplayer/articles/flash_player_admin_guide.html
+AutoUpdateDisable=1
+AutoUpdateInterval=0
+# OverrideGPUValidation=true
+EOF
+install *.so $RPM_BUILD_ROOT%{_browserpluginsdir}
 %endif
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %if %{without license_agreement}
-%pre
+%post
 %{_bindir}/%{base_name}.install
-
 %else
+%post
+%update_browser_plugins
 
-%triggerin -- mozilla-firefox
-%nsplugin_install -d %{_libdir}/mozilla-firefox/plugins libflashplayer.so flashplayer.xpt
-
-%triggerun -- mozilla-firefox
-%nsplugin_uninstall -d %{_libdir}/mozilla-firefox/plugins libflashplayer.so flashplayer.xpt
-
-%triggerin -- mozilla
-%nsplugin_install -d %{_libdir}/mozilla/plugins libflashplayer.so flashplayer.xpt
-umask 022
-rm -f /usr/%{_lib}/mozilla/components/{compreg,xpti}.dat
-if [ -x /usr/bin/regxpcom ]; then
-       MOZILLA_FIVE_HOME=/usr/%{_lib}/mozilla /usr/bin/regxpcom
-fi
-
-%triggerun -- mozilla
-%nsplugin_uninstall -d %{_libdir}/mozilla/plugins libflashplayer.so flashplayer.xpt
-umask 022
-rm -f /usr/%{_lib}/mozilla/components/{compreg,xpti}.dat
-if [ -x /usr/bin/regxpcom ]; then
-       MOZILLA_FIVE_HOME=/usr/%{_lib}/mozilla /usr/bin/regxpcom
+%postun
+if [ "$1" = 0 ]; then
+       %update_browser_plugins
 fi
-
-%triggerin -- konqueror
-%nsplugin_install -d %{_libdir}/kde3/plugins/konqueror libflashplayer.so
-
-%triggerun -- konqueror
-%nsplugin_uninstall -d %{_libdir}/kde3/plugins/konqueror libflashplayer.so
-
 %endif
 
 %files
 %defattr(644,root,root,755)
-
 %if %{without license_agreement}
 %attr(755,root,root) %{_bindir}/%{base_name}.install
 %{_datadir}/%{base_name}
-
 %else
-%attr(755,root,root) %{_plugindir}/*.so
-%{_plugindir}/*.xpt
+%dir %{_sysconfdir}
+%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mms.cfg
+%attr(755,root,root) %{_browserpluginsdir}/*.so
 %endif
This page took 0.068348 seconds and 4 git commands to generate.