]> git.pld-linux.org Git - packages/R.git/blobdiff - R.spec
- up to 2.2.1
[packages/R.git] / R.spec
diff --git a/R.spec b/R.spec
index d13d3b12551fb885a45fcb1a710a6cf79b3b7b8d..e84434a12fa43549cd2cc4ea985064253d595ab5 100644 (file)
--- a/R.spec
+++ b/R.spec
@@ -1,39 +1,52 @@
-Summary: A language for data analysis and graphics
-Name: R
-Version: 0.61.1
-Release: 3
-Source0: ftp.stat.math.ethz.ch:/R-CRAN/src/base/r-0_61_1.tgz
-Source1: ftp.stat.math.ethz.ch:/R-CRAN/src/contrib/mlbench_0.2-2.tar.gz
-Source2: ftp.stat.math.ethz.ch:/R-CRAN/src/contrib/acepack_1.0-2.tar.gz
-Source3: ftp.stat.math.ethz.ch:/R-CRAN/src/contrib/bootstrap_1.0-3.tar.gz
-Source4: ftp.stat.math.ethz.ch:/R-CRAN/src/contrib/class_VR5-4.tar.gz
-Source5: ftp.stat.math.ethz.ch:/R-CRAN/src/contrib/clus_1.0-2.tar.gz
-Source6: ftp.stat.math.ethz.ch:/R-CRAN/src/contrib/ctest_0.9-1.tar.gz
-Source7: ftp.stat.math.ethz.ch:/R-CRAN/src/contrib/date_1.0-3.tar.gz
-Source8: ftp.stat.math.ethz.ch:/R-CRAN/src/contrib/e1071_0.7-3.tar.gz
-Source9: ftp.stat.math.ethz.ch:/R-CRAN/src/contrib/fracdiff_1.0-2.tar.gz
-Source10: ftp.stat.math.ethz.ch:/R-CRAN/src/contrib/gee_3.13-2.tar.gz
-Source11: ftp.stat.math.ethz.ch:/R-CRAN/src/contrib/integrate_1.0-3.tar.gz
-Source12: ftp.stat.math.ethz.ch:/R-CRAN/src/contrib/jpn_1.0-1.tar.gz
-Source13: ftp.stat.math.ethz.ch:/R-CRAN/src/contrib/leaps_1.0-3.tar.gz
-Source14: ftp.stat.math.ethz.ch:/R-CRAN/src/contrib/nnet_VR5-3.tar.gz
-Source15: ftp.stat.math.ethz.ch:/R-CRAN/src/contrib/oz_1.0-1.tar.gz
-Source16: ftp.stat.math.ethz.ch:/R-CRAN/src/contrib/polynom_1.0-3.tar.gz
-Source17: ftp.stat.math.ethz.ch:/R-CRAN/src/contrib/ratetables_1.0-2.tar.gz
-Source18: ftp.stat.math.ethz.ch:/R-CRAN/src/contrib/rational_1.0-1.tar.gz
-Source19: ftp.stat.math.ethz.ch:/R-CRAN/src/contrib/spatial_VR5-2.tar.gz
-Source20: ftp.stat.math.ethz.ch:/R-CRAN/src/contrib/splines_2.0-1.tar.gz
-Source21: ftp.stat.math.ethz.ch:/R-CRAN/src/contrib/survival4_1.0-3.tar.gz
-Source22: ftp.stat.math.ethz.ch:/R-CRAN/src/contrib/xgobi_1.0-2.tar.gz
-Source23: ftp.stat.math.ethz.ch:/R-CRAN/src/contrib/principal.curve_1.0-2.tar.gz
-Source24: ftp.stat.math.ethz.ch:/R-CRAN/src/contrib/quadprog_1.0-2.tar.gz
-Patch0: R-0.61.rpm.patch3
-Copyright: gpl
-Group: Development/Languages
-Packager: Martyn Plummer <plummer@iarc.fr>
-URL: http://stat.auckland.ac.nz/r/r.html
-Provides: R-base R-contrib
-BuildRoot: /tmp/R
+# TODO:
+# - move perl R libraries to standard perl location
+# - script for rpm to autoprovides/autorequires R internals
+#
+# Conditional build:
+%bcond_without gnome   # without GNOME support
+#
+%include       /usr/lib/rpm/macros.perl
+Summary:       A language for data analysis and graphics
+Summary(pl):   Jêzyk do analizy danych oraz grafiki
+Name:          R
+Version:       2.2.1
+Release:       1
+License:       Mixed (distributable), mostly GPL
+Group:         Development/Languages
+# CRAN master site: ftp://cran.r-project.org/pub/R/src/
+Source0:       ftp://stat.ethz.ch/R-CRAN/src/base/R-2/%{name}-%{version}.tar.gz
+# Source0-md5: 42542290c6d1585af7ded330f811385c
+Source1:       %{name}.desktop
+URL:           http://www.r-project.org/
+BuildRequires: XFree86-devel
+BuildRequires: autoconf
+BuildRequires: automake
+BuildRequires: blas-devel
+BuildRequires: bzip2-devel
+BuildRequires: gcc-c++
+BuildRequires: gcc-g77
+BuildRequires: gettext-devel
+BuildRequires: libjpeg-devel >= 6b
+BuildRequires: libpng-devel >= 1.0.5
+BuildRequires: libstdc++-devel
+BuildRequires: libtool
+BuildRequires: libxml-devel
+BuildRequires: perl-base >= 1:5.6
+BuildRequires: readline-devel
+BuildRequires: rpm-perlprov
+BuildRequires: tcl-devel
+BuildRequires: tetex-latex
+BuildRequires: tetex-dvips
+BuildRequires: tetex-pdftex
+BuildRequires: tk-devel
+BuildRequires: zip
+BuildRequires: zlib >= 1.1.3
+#BuildRequires:        lpr
+#Requires:     lpr
+%{?with_gnome:BuildRequires:   gnome-libs-devel}
+%{?with_gnome:BuildRequires:   ORBit-devel}
+%{?with_gnome:BuildRequires:   libglade-gnome-devel}
+BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
 A system for statistical computation and graphics. R consists of a
@@ -42,250 +55,184 @@ to certain system functions, and the ability to run programs stored in
 script files.
 
 The design of R has been heavily influenced by two existing languages:
-Becker, Chambers & Wilks' S and Sussman's Scheme. Whereas the resulting
-language is very similar in appearance to S, the underlying implementation
-and semantics are derived from Scheme.
+Becker, Chambers & Wilks' S and Sussman's Scheme. Whereas the
+resulting language is very similar in appearance to S, the underlying
+implementation and semantics are derived from Scheme.
+
+%description -l pl
+System do obliczeñ statystycznych i grafiki. R sk³ada siê z jêzyka
+oraz ¶rodowiska uruchomieniowego z grafik±, debuggerem, dostêpem do
+niektórych funkcji systemowych oraz mo¿liwo¶ci± uruchamiania programów
+zapisanych w skryptach.
+
+Jêzyk R by³ zainspirowany dwoma istniej±cymi jêzykami: S (Beckera,
+Chambersa i Wilksa) oraz Scheme (Sussmana). R jest podobny do S, ale
+implementacja i semantyka wywodzi siê ze Scheme.
 
 %package base
-Summary: The R base distribution
-Group: Development/Languages
-Version: 0.61.1
-Conflicts: R-contrib < 1998.1.1
-Provides: R-acepack R-bootstrap R-class R-clus R-ctest R-date R-e1071 
-Provides: R-fracdiff R-gee R-integrate R-jpn R-leaps R-mlbench R-nnet R-oz 
-Provides: R-polynom R-principal.curve R-quadprog R-ratetables R-rational 
-Provides: R-spatial R-splines R-survival4 R-xgobi
+Summary:       The R base distribution
+Summary(pl):   Podstawowa dystrybucja R
+License:       GPL v2 / LGPL
+Group:         Development/Languages
+Requires(post):        textutils
+Requires(post):        perl-base
+Provides:      R-cran-base
+Provides:      R-cran-datasets
+Provides:      R-cran-grid
+Provides:      R-cran-graphics
+Provides:      R-cran-grDevices
+Provides:      R-cran-methods
+Provides:      R-cran-utils
+Provides:      R-cran-tcltk
+Provides:      R-cran-splines
+Provides:      R-cran-stats
+Provides:      R-cran-stats4
+Provides:      R-cran-tools
 
 %description base
 R is a language and run-time environment for carrying out interactive
-statistical data analysis. It is not entirely dissimilar to the S language
-developed at AT&T Bell Laboratories (and now Lucent Technologies). Indeed,
-S users will find the environment quite familiar and a good deal of S
-software will run without change under R.
-
-%package contrib
-Summary: contributed packages for the R language
-Group: Development/Languages
-Copyright: Mixed
-URL: http://www.ci.tuwien.ac.at/R/
-Version: 1998.01.22
-Release: 3
-Requires: R-base >= 0.60
-
-%description contrib
-Packages which extend the capabilities of the R base distribution
-and are distributed on the Comprehensive R Archive Network (CRAN).
-
-%package mlbench
-Summary: Machine learning benchmarks
-Group: Development/Languages
-Copyright: GPL
-URL: http://www.ics.uci.edu/~mlearn/MLRepository.html
-Version: 0.2.2
-Release: 3
-Requires: R-base >= 0.60
-
-%description mlbench
-R package which contains a collection of real-world datasets and
-functions for creating artificial datasets that work as benchmarks
-for machine learning methods.
+statistical data analysis. It is not entirely dissimilar to the S
+language developed at AT&T Bell Laboratories (and now Lucent
+Technologies). Indeed, S users will find the environment quite
+familiar and a good deal of S software will run without change under
+R.
+
+%description base -l pl
+R jest jêzykiem i ¶rodowiskiem uruchomieniowym do interaktywnej
+analizy danych statystycznych. R nie jest ca³kowicie zgodny z jêzykiem
+S opracowanym w AT&T Bell Laboratiories (a teraz Lucent Technologies),
+mimo to u¿ytkownicy S zauwa¿± zbli¿one ¶rodowisko, a du¿a czê¶æ
+oprogramowania w S bêdzie dzia³a³a bez zmian w R.
+
+%package recommended
+Summary:       Recommended contributed packages for the R language
+Summary(pl):   Zalecane dodatkowe pakiety do jêzyka R
+Group:         Development/Languages
+Requires:      R-cran-KernSmooth
+Requires:      R-cran-VR
+Requires:      R-cran-boot
+Requires:      R-cran-cluster
+Requires:      R-cran-foreign
+Requires:      R-cran-lattice
+Requires:      R-cran-mgcv
+Requires:      R-cran-nlme
+Requires:      R-cran-rpart
+Requires:      R-cran-survival
+License:       GPL, free or free for non-commercial use
+URL:           http://www.ci.tuwien.ac.at/R/
+Requires(post,postun): R-base
+Requires(post,postun): perl-base
+Requires(post,postun): textutils
+Obsoletes:     R-contrib
+Requires:      R-base = %{version}-%{release}
+
+%description recommended
+Packages which extend the capabilities of the R base distribution and
+are distributed on the Comprehensive R Archive Network (CRAN).
+
+%description recommended -l pl
+Pakiety rozszerzaj±ce mo¿liwo¶ci podstawowej dystrybucji jêzyka R,
+dystrubuowane w archiwum CRAN (Comprehensive R Archive Network).
 
 %prep
-%setup -c -n R-cran -T -b 2
-%setup -c -n R-cran -T -D -b 3
-%setup -c -n R-cran -T -D -b 4
-%setup -c -n R-cran -T -D -b 5
-%setup -c -n R-cran -T -D -b 6
-%setup -c -n R-cran -T -D -b 7
-%setup -c -n R-cran -T -D -b 8
-%setup -c -n R-cran -T -D -b 9
-%setup -c -n R-cran -T -D -b 10
-%setup -c -n R-cran -T -D -b 11
-%setup -c -n R-cran -T -D -b 12
-%setup -c -n R-cran -T -D -b 13
-%setup -c -n R-cran -T -D -b 14
-%setup -c -n R-cran -T -D -b 15
-%setup -c -n R-cran -T -D -b 16
-%setup -c -n R-cran -T -D -b 17
-%setup -c -n R-cran -T -D -b 18
-%setup -c -n R-cran -T -D -b 19
-%setup -c -n R-cran -T -D -b 20
-%setup -c -n R-cran -T -D -b 21
-%setup -c -n R-cran -T -D -b 22
-%setup -c -n R-cran -T -D -b 23
-%setup -c -n R-cran -T -D -b 24
-%setup 
-%setup  -T -D -a 1
-%patch0 -p1
-# These files have the path for PERL hard-coded as /usr/local/bin/perl
+%setup -q
+
+# These files have the path for Perl hard-coded as /usr/local/bin/perl
 # We need to remove them to avoid dependency problems
-rm ./doc/keyword-test.orig ./etc/undoc/R-funs.orig ./etc/undoc/extrExamp.orig 
+rm -f ./doc/keyword-test.orig ./etc/undoc/R-funs.orig ./etc/undoc/extrExamp.orig
 
 %build
-
-make 
-make help
-make html
-make clean
-make acclean
-
-# Install contrib packages
-#
-RHOME=`pwd`;export RHOME
-cd ../R-cran
-for pkg in `ls`
-do
-       ${RHOME}/etc/INSTALL -latex ${pkg}
-done
-cd ${RHOME}
-
-# Install mlbench
-#
-${RHOME}/etc/INSTALL mlbench
-
-#Remove old template files.
-#
-for oldinfile in `find . -name '*.in' -print`
-do
-       rm ${oldinfile}
-done
-
-# Gather documentation from contrib packages in one directory
-# Assume that anything not in one of the standard directories is
-# documentation, and copy it.
-#
-mkdir ${RHOME}/contrib
-cd ${RPM_BUILD_DIR}/R-cran
-for pkg in `ls`; do
-        if [ -d ${pkg} ]; then
-               mkdir ${RHOME}/${pkg}
-                for docfile in `ls ${pkg}`; do
-                        case $docfile in
-                                INDEX) ;;
-                                TITLE) ;;
-                                R) ;;
-                                man) ;;
-                                src) ;;
-                                src-c) ;;
-                                data) ;;
-                                *) cp -R -P ${pkg}/${docfile} ${RHOME};;
-                        esac
-                done
-        fi
-done
-cd ${RHOME}
-
+%{__aclocal} -I m4
+%{__autoconf}
+cp -f /usr/share/automake/config.* .
+%configure \
+       --with%{!?with_gnome:out}-gnome \
+       --enable-R-shlib \
+       --enable-linux-lfs \
+       --with-zlib \
+       --with-bzlib \
+       --with-pcre \
+       --without-recommended-packages
+
+%{__make}
+%{__make} check
+%{__make} docs
+%{__make} help
+%{__make} html
+%{__make} info
 
 %install
-install -d ${RPM_BUILD_ROOT}%{_mandir}/man1
-install R.1 ${RPM_BUILD_ROOT}%{_mandir}/man1/
-install -d ${RPM_BUILD_ROOT}%{_libdir}/R
-cp -R afm bin cmd demos doc etc html include library ${RPM_BUILD_ROOT}%{_libdir}/R
-install -d ${RPM_BUILD_ROOT}%{_bindir}
-install -m 755 bin/R ${RPM_BUILD_ROOT}%{_bindir}/R
+rm -rf $RPM_BUILD_ROOT
+install -d $RPM_BUILD_ROOT{%{_bindir},%{_mandir}/man1,%{_libdir}/R,%{_includedir},%{_desktopdir}}
 
-%files base
-%attr(-,root,root) %{_mandir}/man1/R.1
-%attr(-,root,root) %{_bindir}/R
-%attr(-,root,root) %dir %{_libdir}/R
-%attr(-,root,root) %{_libdir}/R/afm
-%attr(-,root,root) %{_libdir}/R/bin
-%attr(-,root,root) %{_libdir}/R/cmd
-%attr(-,root,root) %{_libdir}/R/demos
-%attr(-,root,root) %{_libdir}/R/etc
-%attr(-,root,root) %{_libdir}/R/html
-%attr(-,root,root) %{_libdir}/R/include
-%attr(-,root,root) %dir %{_libdir}/R/library
-%attr(-,root,root) %{_libdir}/R/library/base/
-%attr(-,root,root) %{_libdir}/R/library/eda/
-%attr(-,root,root) %{_libdir}/R/library/mva/
-%attr(-,root,root) %{_libdir}/R/library/stepfun/
-%attr(-,root,root) %doc CHANGES COPYING COPYRIGHTS MIRROR-SITES PROJECTS README RESOURCES TASKS
+%{__make} install \
+       rhome=$RPM_BUILD_ROOT%{_libdir}/R \
+       mandir=$RPM_BUILD_ROOT%{_mandir} \
+       bindir=$RPM_BUILD_ROOT%{_bindir} \
+       
 
-%files contrib
-%attr(-,root,root) %{_libdir}/R/library/acepack
-%attr(-,root,root) %doc acepack
-%attr(-,root,root) %{_libdir}/R/library/bootstrap
-%attr(-,root,root) %doc bootstrap
-%attr(-,root,root) %{_libdir}/R/library/class
-%attr(-,root,root) %doc class
-%attr(-,root,root) %{_libdir}/R/library/clus
-%attr(-,root,root) %doc clus
-%attr(-,root,root) %{_libdir}/R/library/ctest
-%attr(-,root,root) %doc ctest
-%attr(-,root,root) %{_libdir}/R/library/date
-%attr(-,root,root) %doc date
-%attr(-,root,root) %{_libdir}/R/library/e1071
-%attr(-,root,root) %doc e1071
-%attr(-,root,root) %{_libdir}/R/library/fracdiff
-%attr(-,root,root) %doc fracdiff
-%attr(-,root,root) %{_libdir}/R/library/gee
-%attr(-,root,root) %doc gee
-%attr(-,root,root) %{_libdir}/R/library/integrate
-%attr(-,root,root) %doc integrate
-%attr(-,root,root) %{_libdir}/R/library/jpn
-%attr(-,root,root) %doc jpn
-%attr(-,root,root) %{_libdir}/R/library/leaps
-%attr(-,root,root) %doc leaps
-%attr(-,root,root) %{_libdir}/R/library/nnet
-%attr(-,root,root) %doc nnet
-%attr(-,root,root) %{_libdir}/R/library/oz
-%attr(-,root,root) %doc oz
-%attr(-,root,root) %{_libdir}/R/library/polynom
-%attr(-,root,root) %doc polynom
-%attr(-,root,root) %{_libdir}/R/library/ratetables
-%attr(-,root,root) %doc ratetables
-%attr(-,root,root) %{_libdir}/R/library/rational
-%attr(-,root,root) %doc rational
-%attr(-,root,root) %{_libdir}/R/library/spatial
-%attr(-,root,root) %doc spatial
-%attr(-,root,root) %{_libdir}/R/library/splines
-%attr(-,root,root) %doc splines
-%attr(-,root,root) %{_libdir}/R/library/survival4
-%attr(-,root,root) %doc survival4
-%attr(-,root,root) %{_libdir}/R/library/xgobi
-%attr(-,root,root) %doc xgobi
-%attr(-,root,root) %{_libdir}/R/library/principal.curve
-%attr(-,root,root) %doc principal.curve
-%attr(-,root,root) %{_libdir}/R/library/quadprog
-%attr(-,root,root) %doc quadprog
+install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
 
-%files mlbench
-%attr(-,root,root) %{_libdir}/R/library/mlbench
-%attr(-,root,root) %doc mlbench/COPYRIGHT
-%attr(-,root,root) %doc mlbench/ChangeLog
-%attr(-,root,root) %doc mlbench/README
+find $RPM_BUILD_ROOT%{_libdir}/R -name 'Makefile*' -exec rm -f {} \;
+mv $RPM_BUILD_ROOT%{_libdir}/R/lib/libR*.so $RPM_BUILD_ROOT%{_libdir}
+mv $RPM_BUILD_ROOT%{_libdir}/%{name}/include $RPM_BUILD_ROOT%{_includedir}/R
+ln -sf %{_includedir}/R $RPM_BUILD_ROOT%{_libdir}/R/include
+rm $RPM_BUILD_ROOT%{_bindir}/%{name}
+sed -i -e "s#$RPM_BUILD_ROOT##g" $RPM_BUILD_ROOT%{_libdir}/%{name}/bin/%{name}
+ln -sf %{_libdir}/%{name}/bin/%{name} $RPM_BUILD_ROOT%{_bindir}/%{name}
 
 %clean
-# Tidy up after build. We have to be quite careful here in case some
-# idiot (me) uses a build root of /. This leaves the directory structure
-# in place but removes the files owned by R.
-rm -f  ${RPM_BUILD_ROOT}%{_mandir}/man1/R.1
-rm -f  ${RPM_BUILD_ROOT}%{_bindir}/R
-rm -rf ${RPM_BUILD_ROOT}%{_libdir}/R
-rm -rf ${RPM_BUILD_ROOT}/usr/doc/R-*
-
-%post base
-(cd %{_libdir}/R/library; cat */TITLE > LibIndex; ../etc/build-htmlpkglist)
-
-%preun base
-# These files are not owned by any package, so we have to remove them
-# but only if this is the last version of R-base on the system.
-#
-if [ "$1" = 0 ];
-then
-       rm -f %{_libdir}/R/library/LibIndex
-       rm -f %{_libdir}/R/library/index.html
-fi
-
-%post contrib
-(cd %{_libdir}/R/library; cat */TITLE > LibIndex; ../etc/build-htmlpkglist)
+rm -rf $RPM_BUILD_ROOT
 
-%postun contrib
-(cd %{_libdir}/R/library; cat */TITLE > LibIndex; ../etc/build-htmlpkglist)
+%post
+(cd %{_libdir}/R/library; umask 022; cat */CONTENTS > ../doc/html/search/index.txt
+ R_HOME=%{_libdir}/R ../bin/Rcmd perl ../share/perl/build-help.pl --htmllist)
+/sbin/ldconfig
 
-%post mlbench
-(cd %{_libdir}/R/library; cat */TITLE > LibIndex; ../etc/build-htmlpkglist)
+%postun        -p /sbin/ldconfig
 
-%postun mlbench
-(cd %{_libdir}/R/library; cat */TITLE > LibIndex; ../etc/build-htmlpkglist)
+%files base
+%defattr(644,root,root,755)
+%doc COPYRIGHTS FAQ NEWS README RESOURCES THANKS Y2K
+
+%{_mandir}/man1/R.1*
+%attr(755,root,root) %{_bindir}/R
+%dir %{_libdir}/R
+%attr(755,root,root) %{_libdir}/R/bin
+%attr(755,root,root) %{_libdir}/libR*.so
+%{_libdir}/R/etc
+%{_libdir}/R/include
+%{_includedir}/R
+%{_libdir}/R/share
+%{_libdir}/R/AUTHORS
+%dir %{_libdir}/R/library
+# %{_libdir}/R/doc %except %{_libdir}/R/doc/html/{packages.html,search/index.txt}
+%dir %{_libdir}/R/doc
+%{_libdir}/R/doc/[KRm]*
+%dir %{_libdir}/R/doc/html
+%{_libdir}/R/doc/html/*.css
+%{_libdir}/R/doc/html/[Ra-lr-u]*.html
+%{_libdir}/R/doc/html/packages-head.html
+%{_libdir}/R/doc/html/*.jpg
+%dir %{_libdir}/R/doc/html/search
+%{_libdir}/R/doc/html/search/[A-Z]*
+%ghost %{_libdir}/R/doc/html/search/index.txt
+%ghost %{_libdir}/R/doc/html/packages.html
+%{_desktopdir}/*
+
+%attr(755,root,root) %{_libdir}/%{name}/modules
+
+%{_libdir}/%{name}/library/base
+%{_libdir}/%{name}/library/datasets
+%{_libdir}/%{name}/library/grid
+%{_libdir}/%{name}/library/graphics
+%{_libdir}/%{name}/library/grDevices
+%{_libdir}/%{name}/library/methods
+%{_libdir}/%{name}/library/utils
+%{_libdir}/%{name}/library/tcltk
+%{_libdir}/%{name}/library/splines
+%{_libdir}/%{name}/library/stats
+%{_libdir}/%{name}/library/stats4
+%{_libdir}/%{name}/library/tools
+
+%files recommended
This page took 1.320861 seconds and 4 git commands to generate.