]> git.pld-linux.org Git - packages/FlightGear.git/blobdiff - FlightGear.spec
- fixes for OpenSceneGraph 3.3.2 API changes
[packages/FlightGear.git] / FlightGear.spec
index f27f56275a827eb33b0c2e9192ea29593f8189ab..a5d1743660c90115c499ed4df98cbd8f60af03cf 100644 (file)
@@ -1,34 +1,40 @@
+# TODO:
+# - Make FlightGear-extra-planes for subset of planes from
+#   http://www.flightgear.org/Downloads/aircraft/index.shtml
+
 Summary:       Free Flight Simulator
-Summary(pl):   darmowy symulator lotu
+Summary(pl.UTF-8):     darmowy symulator lotu
 Name:          FlightGear
-Version:       0.7.6
+Version:       3.2.0
 Release:       1
-Group:         X11/Applications/Games
-Group(de):     X11/Applikationen/Spiele
-Group(pl):     X11/Aplikacje/Gry
 License:       GPL
-Source0:       ftp://ftp.flightgear.org/pub/fgfs/Source/%{name}-%{version}.tar.gz
-Source1:       ftp://ftp.flightgear.org/pub/fgfs/Shared/fgfs-base-%{version}.tar.gz
-Source2:       ftp://ftp.flightgear.org/pub/fgfs/Shared/fgfs-docs-%{version}.tar.gz
-Patch0:                %{name}-libs.patch
-URL:           http://www.flightgear.org
-Requires:      OpenGL
+Group:         X11/Applications/Games
+Source0:       ftp://mirrors.ibiblio.org/pub/mirrors/flightgear/ftp/Source/flightgear-%{version}.tar.bz2
+# Source0-md5: 0a16920cc22ea070f8bb345e76c55e05
+Source1:       ftp://mirrors.ibiblio.org/pub/mirrors/flightgear/ftp/Shared/%{name}-data-%{version}.tar.bz2
+# Source1-md5: 24774fae7199bcbc5e23672f4a586884
+#Source2:      ftp://ftp.flightgear.org/pub/fgfs/Everything-0.7/Base-Packages/fgfs-docs-0.7.7.tar.gz
+## Source2-md5:        31f35d3e63e522565e8990ead99e7507
+Patch0:                flightgear-cmake.patch
+Patch1:                OpenSceneGraph-3.3.2.patch
+URL:           http://www.flightgear.org/
+BuildRequires: OpenAL-devel
 BuildRequires: OpenGL-devel
-BuildRequires: XFree86-devel
+BuildRequires: SimGear-devel = %{version}
+BuildRequires: cmake
+BuildRequires: fltk-gl-devel
+BuildRequires: freeglut-devel
 BuildRequires: libstdc++-devel
-BuildRequires: glut-devel
-BuildRequires: automake
-BuildRequires: autoconf
-BuildRequires: plib >= 1.2.0
-BuildRequires: SimGear-devel >= 0.0.14
+BuildRequires: libxml-devel
+BuildRequires: plib-devel >= 1.8.5-3
 BuildRequires: zlib-devel
-BuildRequires: metakit-devel
-BuildRequireS: findutils
+Requires:      %{name}-data = %{version}
+Requires:      OpenGL
+Requires:      OpenSceneGraph-plugins
+Requires:      plib >= 1.8.4
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
-%define _noautoreqdep  libGL.so.1 libGLU.so.1
-%define _prefix                /usr/X11R6
-%define        _mandir         %{_prefix}/man
+%define                _noautoreqdep   libGL.so.1 libGLU.so.1 libGLcore.so.1
 
 %description
 The Flight Gear project is working to create a sophisticated flight
@@ -36,43 +42,56 @@ simulator framework for the development and pursuit of interesting
 flight simulator ideas. We are developing a solid basic sim that can
 be expanded and improved upon by anyone interested in contributing.
 
-%description -l pl
-Projet Flight Gear to wyszukany symulator lotów pozwalaj±cy
-rozpowszechniaæ idee tego typu symulacji.
+%description -l pl.UTF-8
+Projekt Flight Gear to wyrafinowany symulator lotów pozwalający
+rozpowszechniać idee tego typu symulacji.
+
+%package data
+Summary:       FlightGear base scenery and data files
+License:       GPL v2+
+Group:         Applications/Games
+%if "%{_rpmversion}" >= "5"
+BuildArch:     noarch
+%endif
+
+%description data
+This package contains the base scenery for FlightGear and must be
+installed
 
 %prep
-%setup -q -a 1 -a 2
+%setup -q -n flightgear-%{version} -a 1
 %patch0 -p1
+%patch1 -p1
+
+cat > runfgfs <<'EOF'
+#!/bin/sh
+exec %{_bindir}/fgfs --fg-root=%{_datadir}/games/%{name}/fgdata "$@"
+EOF
 
 %build
-rm missing
-aclocal
-autoconf
-automake -a -c
-%configure \
-       --with-network-olk
+install -d build
+cd build
+%cmake ..
 %{__make}
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT%{_datadir}
-%{__make} DESTDIR="$RPM_BUILD_ROOT" install
-
-echo "#!/bin/sh" > runfgfs
-echo "exec %{_bindir}/fgfs --fg-root=%{_datadir}/%{name} \$*" >> runfgfs
-install runfgfs $RPM_BUILD_ROOT%{_bindir}
-cp -a %{name} $RPM_BUILD_ROOT%{_datadir}
-find %{name}-0.7 -name 'CVS' -type d | xargs rm -rf
+install -d $RPM_BUILD_ROOT%{_datadir}/games/%{name}
+%{__make} -C build install \
+       DESTDIR=$RPM_BUILD_ROOT
 
-gzip -9nf AUTHORS NEWS
+install -p runfgfs $RPM_BUILD_ROOT%{_bindir}
+cp -a fgdata $RPM_BUILD_ROOT%{_datadir}/games/%{name}
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
-%doc %{name}-0.7/docs/*
-%doc *.gz
-%attr(755,root,root) %{_bindir}/fgfs
-%attr(755,root,root) %{_bindir}/runfgfs
-%{_datadir}/%{name}
+%doc AUTHORS NEWS docs-mini/*
+%attr(755,root,root) %{_bindir}/*
+%{_mandir}/*/*
+
+%files data
+%defattr(644,root,root,755)
+%{_datadir}/games/%{name}
This page took 0.064292 seconds and 4 git commands to generate.