]> git.pld-linux.org Git - packages/DirectFB.git/blobdiff - DirectFB.spec
- updated gcc4 and fix patches
[packages/DirectFB.git] / DirectFB.spec
index ea6c7227ab3bc87fd31dd7805ce301b2eaa8b161..c33b2418c6d6cdf6d6cf8582345f3c538ec4085e 100644 (file)
@@ -1,23 +1,39 @@
 #
+# TODO:
+#      - fix x86-64 int32<->ptr64 casts.
+#
+#      tree.c:88: warning: cast from pointer to integer of different size
+#      tree.c:102: warning: cast from pointer to integer of different size
+#      fonts.c:144: warning: cast to pointer from integer of different size
+#      fonts.c:211: warning: cast to pointer from integer of different size
+#      gfxcard.c:1451: warning: cast to pointer from integer of different size
+#      fbdev.c:459: warning: cast from pointer to integer of different size
+#      fbdev.c:578: warning: cast from pointer to integer of different size
+#      fbdev.c:708: warning: cast from pointer to integer of different size
+#      idirectfbfont_ft2.c:130: warning: cast from pointer to integer of different size
+#      idirectfbfont_ft2.c:292: warning: cast from pointer to integer of different size
+#      idirectfbfont_ft2.c:653: warning: cast to pointer from integer of different size
+#
 # Conditional build:
 %bcond_with    multi           # build Multi-application core (requires working /dev/fusion*)
 #
 Summary:       DirectFB - Hardware graphics acceleration
 Summary(pl):   DirectFB - Wspomaganie grafiki
 Name:          DirectFB
-Version:       0.9.24
-Release:       1
+Version:       1.0.0
+Release:       0.2
 Epoch:         1
 License:       LGPL v2+
 Group:         Libraries
 Source0:       http://www.directfb.org/downloads/Core/%{name}-%{version}.tar.gz
-# Source0-md5: 1f4b56b20d4e6f5c6ceb15c1c4fd2ecd
+# Source0-md5: ad746c49dc89ba6f99df71b17bbb1dc8
 Source1:       http://www.directfb.org/downloads/Extras/DFBTutorials-0.5.0.tar.gz
 # Source1-md5: 13e443a64bddd68835b574045d9025e9
 Patch0:                %{name}-am.patch
 Patch1:                %{name}-pmake.patch
 Patch2:                %{name}-fix.patch
-Patch3:                %{name}-sh.patch
+Patch3:                %{name}-gcc4.patch
+Patch4:                %{name}-llh-ppc.patch
 URL:           http://www.directfb.org/
 BuildRequires: SDL-devel
 BuildRequires: XFree86-devel
@@ -35,7 +51,9 @@ BuildRequires:        zlib-devel >= 1.1.3
 %{?with_multi:Provides:        DirectFB(multi)}
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
-%define                dfbdir  %{_libdir}/directfb-%{version}
+%define                dfbdir  %{_libdir}/directfb-1.0-0
+
+%define                specflags       -fno-strict-aliasing
 
 %ifarch %{ix86}
 # gcc running out of registers with -O0 in generic_mmx.h
@@ -178,6 +196,48 @@ nie nale
 tego portu. Sterownik mo¿e utrudniæ wspó³pracê z innymi urz±dzeniami
 pod³±czonymi do /dev/ttyS0 (jak mysz, modem itp.).
 
+%package input-dynapro
+Summary:       Dynapro touchscreen input driver for DirectFB
+Summary(pl):   Sterownik wej¶ciowy do touchscreenów Dynapro dla DirectFB
+Group:         Libraries
+Requires:      %{name} = %{epoch}:%{version}-%{release}
+
+%description input-dynapro
+Dynapro touchscreen input driver for DirectFB.
+
+NOTE: currently it uses hardcoded /dev/ttyS0 port, so don't install it
+unless you don't have Dynapro device connected to this port. It can mess
+with other devices connected to this port (mouse, modem etc.).
+
+%description input-dynapro -l pl
+Sterownik wej¶ciowy do touchscreenów Dynapro dla DirectFB.
+
+UWAGA: aktualnie u¿ywa zakodowanego na sta³e portu /dev/ttyS0, wiêc
+nie nale¿y go instalowaæ, je¶li urz±dzenie Dynapro nie jest pod³±czone do
+tego portu. Sterownik mo¿e utrudniæ wspó³pracê z innymi urz±dzeniami
+pod³±czonymi do /dev/ttyS0 (jak mysz, modem itp.).
+
+%package input-gunze
+Summary:       Gunze touchscreen input driver for DirectFB
+Summary(pl):   Sterownik wej¶ciowy do touchscreenów Gunze dla DirectFB
+Group:         Libraries
+Requires:      %{name} = %{epoch}:%{version}-%{release}
+
+%description input-gunze
+Gunze touchscreen input driver for DirectFB.
+
+NOTE: currently it uses hardcoded /dev/ttyS0 port, so don't install it
+unless you don't have Gunze device connected to this port. It can mess
+with other devices connected to this port (mouse, modem etc.).
+
+%description input-gunze -l pl
+Sterownik wej¶ciowy do touchscreenów Gunze dla DirectFB.
+
+UWAGA: aktualnie u¿ywa zakodowanego na sta³e portu /dev/ttyS0, wiêc
+nie nale¿y go instalowaæ, je¶li urz±dzenie Gunze nie jest pod³±czone do
+tego portu. Sterownik mo¿e utrudniæ wspó³pracê z innymi urz±dzeniami
+pod³±czonymi do /dev/ttyS0 (jak mysz, modem itp.).
+
 %package input-mutouch
 Summary:       MuTouch touchscreen input driver for DirectFB
 Summary(pl):   Sterownik wej¶ciowy do touchscreenów MuTouch dla DirectFB
@@ -200,6 +260,7 @@ UWAGA: do dzia
 %patch1 -p1
 %patch2 -p1
 %patch3 -p1
+%patch4 -p1
 
 %build
 %{__libtoolize}
@@ -208,9 +269,9 @@ UWAGA: do dzia
 %{__automake}
 # MMX and SSE are detected at runtime, so it's safe to enable
 %configure \
+       --with-inputdrivers=dynapro,elo-input,gunze,joystick,keyboard,linuxinput,lirc,mutouch,penmount,ps2mouse,serialmouse,sonypijogdial,ucb1x00,wm97xx \
        %{!?debug:--disable-debug} \
        --disable-maintainer-mode \
-       --enable-elo-input \
        --enable-fast-install \
        --enable-linux-input \
        %{?with_multi:--enable-multi} \
@@ -223,7 +284,7 @@ UWAGA: do dzia
        --enable-voodoo \
        --enable-x11 \
        --enable-zlib \
-%ifarch %{ix86}
+%ifarch %{ix86} %{x8664}
 %ifnarch i386 i486
        --enable-mmx \
 %endif
@@ -232,7 +293,8 @@ UWAGA: do dzia
 %endif
 %endif
 
-%{__make}
+%{__make} \
+       X11_LIBS=%{_prefix}/X11R6/%{_lib}
 
 %install
 rm -rf $RPM_BUILD_ROOT
@@ -257,10 +319,14 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_bindir}/dfbdump
 %attr(755,root,root) %{_bindir}/dfbg
 %attr(755,root,root) %{_bindir}/dfbinfo
+%attr(755,root,root) %{_bindir}/dfbinput
 %attr(755,root,root) %{_bindir}/dfblayer
+%attr(755,root,root) %{_bindir}/dfbpenmount
 %attr(755,root,root) %{_bindir}/dfbproxy
 %attr(755,root,root) %{_bindir}/dfbscreen
 %attr(755,root,root) %{_bindir}/dfbsummon
+%attr(755,root,root) %{_bindir}/mkdfiff
+%attr(755,root,root) %{_bindir}/mkdgiff
 %attr(755,root,root) %{_bindir}/uwmdump
 %attr(755,root,root) %{_libdir}/libdirect-*.so.*.*.*
 %attr(755,root,root) %{_libdir}/libdirectfb-*.so.*.*.*
@@ -382,6 +448,14 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %attr(755,root,root) %{dfbdir}/inputdrivers/libdirectfb_elo.so
 
+%files input-dynapro
+%defattr(644,root,root,755)
+%attr(755,root,root) %{dfbdir}/inputdrivers/libdirectfb_dynapro.so
+
+%files input-gunze
+%defattr(644,root,root,755)
+%attr(755,root,root) %{dfbdir}/inputdrivers/libdirectfb_gunze.so
+
 %files input-mutouch
 %defattr(644,root,root,755)
 %attr(755,root,root) %{dfbdir}/inputdrivers/libdirectfb_mutouch.so
This page took 0.065674 seconds and 4 git commands to generate.