]> git.pld-linux.org Git - packages/eventum.git/blobdiff - eventum.spec
update irc bot status
[packages/eventum.git] / eventum.spec
index ded3ef15a4782e628864871f425eacaf27bdab99..818d6b87596fecc23d4eac43748d73dc384f7fc9 100644 (file)
@@ -2,21 +2,21 @@
 # Conditional build:
 %bcond_with    order   # with experimental order patch
 
 # Conditional build:
 %bcond_with    order   # with experimental order patch
 
-%define                rel             1.8
-%define                subver  101
-%define                githash e275162
+%define                rel             1.9
+%define                subver  277
+%define                githash 3277427
 %define                php_min_version 5.3.3
 %include       /usr/lib/rpm/macros.php
 Summary:       Eventum Issue / Bug tracking system
 Summary(pl.UTF-8):     Eventum - system śledzenia spraw/błędów
 Name:          eventum
 %define                php_min_version 5.3.3
 %include       /usr/lib/rpm/macros.php
 Summary:       Eventum Issue / Bug tracking system
 Summary(pl.UTF-8):     Eventum - system śledzenia spraw/błędów
 Name:          eventum
-Version:       3.0.2
+Version:       3.0.3
 Release:       %{?subver:1.%{subver}.%{?githash:g%{githash}.}}%{rel}
 License:       GPL v2
 Group:         Applications/WWW
 #Source0:      https://github.com/eventum/eventum/releases/download/v%{version}/%{name}-%{version}.tar.gz
 Source0:       %{name}-%{version}-%{subver}-g%{githash}.tar.gz
 Release:       %{?subver:1.%{subver}.%{?githash:g%{githash}.}}%{rel}
 License:       GPL v2
 Group:         Applications/WWW
 #Source0:      https://github.com/eventum/eventum/releases/download/v%{version}/%{name}-%{version}.tar.gz
 Source0:       %{name}-%{version}-%{subver}-g%{githash}.tar.gz
-# Source0-md5: 57aa4927f9b93e807848ffdaa3acc2a5
+# Source0-md5: 46f5d66f6c51bdc353be0f27fa0fa990
 Source1:       %{name}-apache.conf
 Source2:       %{name}-mail-queue.cron
 Source3:       %{name}-mail-download.cron
 Source1:       %{name}-apache.conf
 Source2:       %{name}-mail-queue.cron
 Source3:       %{name}-mail-download.cron
@@ -33,14 +33,12 @@ Source15:   %{name}-lighttpd.conf
 Source16:      http://www.isocra.com/images/updown2.gif
 # Source16-md5:        deb6eeb2552ba757d3a949ed10c4107d
 Source17:      %{name}.tmpfiles
 Source16:      http://www.isocra.com/images/updown2.gif
 # Source16-md5:        deb6eeb2552ba757d3a949ed10c4107d
 Source17:      %{name}.tmpfiles
-#Patch0:               %{name}-lf.patch
 Patch2:                %{name}-order.patch
 #Patch3:               group-users.patch
 #Patch4:               https://github.com/glensc/eventum/compare/cf_escape.patch
 # packaging patches that probably never go upstream
 Patch100:      %{name}-paths.patch
 Patch101:      %{name}-cvs-config.patch
 Patch2:                %{name}-order.patch
 #Patch3:               group-users.patch
 #Patch4:               https://github.com/glensc/eventum/compare/cf_escape.patch
 # packaging patches that probably never go upstream
 Patch100:      %{name}-paths.patch
 Patch101:      %{name}-cvs-config.patch
-Patch105:      %{name}-bot-reconnect.patch
 Patch107:      %{name}-gettext.patch
 Patch108:      autoload.patch
 # some tests
 Patch107:      %{name}-gettext.patch
 Patch108:      autoload.patch
 # some tests
@@ -155,6 +153,13 @@ Ten pakiet należy zainstalować w celu wstępnej konfiguracji Eventum po
 pierwszej instalacji. Potem należy go odinstalować, jako że
 pozostawienie plików instalacyjnych mogłoby być niebezpieczne.
 
 pierwszej instalacji. Potem należy go odinstalować, jako że
 pozostawienie plików instalacyjnych mogłoby być niebezpieczne.
 
+%package doc
+Summary:       Eventum documentation and Wiki
+Group:         Documentation
+
+%description doc
+Eventum documentation and copy of Wiki.
+
 %package mail-queue
 Summary:       Eventum mail queue process
 Summary(pl.UTF-8):     Przetwarzanie kolejki poczty Eventum
 %package mail-queue
 Summary:       Eventum mail queue process
 Summary(pl.UTF-8):     Przetwarzanie kolejki poczty Eventum
@@ -362,7 +367,7 @@ Group:              Applications/WWW
 Requires(post,preun):  /sbin/chkconfig
 Requires:      %{name} = %{version}-%{release}
 Requires:      php(sockets)
 Requires(post,preun):  /sbin/chkconfig
 Requires:      %{name} = %{version}-%{release}
 Requires:      php(sockets)
-Requires:      php-pear-Net_SmartIRC
+Requires:      php-pear-Net_SmartIRC >= 1.1
 Requires:      rc-scripts >= 0.4.0.18
 
 %description irc
 Requires:      rc-scripts >= 0.4.0.18
 
 %description irc
@@ -461,7 +466,6 @@ mv docs/examples .
 rm docs/COPYING
 
 # bug fixes / features
 rm docs/COPYING
 
 # bug fixes / features
-#%patch0 -p1
 %{?with_order:%patch2 -p1}
 #%patch3 -p0
 #%patch4 -p1
 %{?with_order:%patch2 -p1}
 #%patch3 -p0
 #%patch4 -p1
@@ -490,13 +494,25 @@ rm -f config/config.php
 # packaging
 %patch100 -p1
 %patch101 -p1
 # packaging
 %patch100 -p1
 %patch101 -p1
-%patch105 -p1
 %patch107 -p1
 %patch108 -p1
 
 %patch107 -p1
 %patch108 -p1
 
-%{__sed} -i -e "
-s;define('CONFIG_PATH'.*');define('CONFIG_PATH', '%{_webappdir}');
-" upgrade/{*/,}*.php
+# cleanup vendor. keep only needed libraries.
+# (the rest are packaged with system packages)
+mv vendor vendor.dist
+vendor() {
+       local path dir
+       for path; do
+               dir=$(dirname $path)
+               test -d vendor/$dir || mkdir -p vendor/$dir
+               mv vendor.dist/$path vendor/$path
+       done
+}
+vendor autoload.php
+vendor composer/autoload_{classmap,files,namespaces,real,psr4}.php
+vendor composer/ClassLoader.php
+vendor ircmaxell/{password-compat,random-lib,security-lib}
+vendor zendframework/zend-config
 
 # remove backups from patching as we use globs to package files to buildroot
 find '(' -name '*~' -o -name '*.orig' ')' | xargs -r rm -v
 
 # remove backups from patching as we use globs to package files to buildroot
 find '(' -name '*~' -o -name '*.orig' ')' | xargs -r rm -v
@@ -515,13 +531,14 @@ install -d \
        $RPM_BUILD_ROOT%{_appdir}/{include,htdocs/misc,upgrade} \
        $RPM_BUILD_ROOT%{systemdtmpfilesdir}
 
        $RPM_BUILD_ROOT%{_appdir}/{include,htdocs/misc,upgrade} \
        $RPM_BUILD_ROOT%{systemdtmpfilesdir}
 
-%{__make} install-eventum install-cli install-irc install-scm install-localization \
+%{__make} install-eventum install-cli install-scm install-localization \
        sysconfdir=%{_webappdir} \
        localedir=%{_localedir} \
        DESTDIR=$RPM_BUILD_ROOT
 
        sysconfdir=%{_webappdir} \
        localedir=%{_localedir} \
        DESTDIR=$RPM_BUILD_ROOT
 
-install -d $RPM_BUILD_ROOT%{_appdir}/vendor
-cp -a vendor/autoload.php vendor/composer $RPM_BUILD_ROOT%{_appdir}/vendor
+ln -s %{_webappdir} $RPM_BUILD_ROOT%{_appdir}/config
+
+cp -a vendor $RPM_BUILD_ROOT%{_appdir}
 
 # unsupported locale
 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/ht
 
 # unsupported locale
 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/ht
@@ -655,7 +672,6 @@ done
 
 %files -f %{name}.lang
 %defattr(644,root,root,755)
 
 %files -f %{name}.lang
 %defattr(644,root,root,755)
-%doc docs/*
 %attr(751,root,root) %dir %{_webappdir}
 %attr(751,root,root) %dir %{_webappdir}/custom_field
 %attr(751,root,root) %dir %{_webappdir}/templates
 %attr(751,root,root) %dir %{_webappdir}
 %attr(751,root,root) %dir %{_webappdir}/custom_field
 %attr(751,root,root) %dir %{_webappdir}/templates
@@ -673,6 +689,8 @@ done
 %dir %attr(750,root,root) /var/log/archive/%{name}
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/%{name}
 
 %dir %attr(750,root,root) /var/log/archive/%{name}
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/%{name}
 
+%{_appdir}/config
+
 %dir %{_appdir}/bin
 %attr(755,root,root) %{_appdir}/bin/process_all_emails.php
 
 %dir %{_appdir}/bin
 %attr(755,root,root) %{_appdir}/bin/process_all_emails.php
 
@@ -702,19 +720,12 @@ done
 %attr(755,root,root) %{_appdir}/upgrade/scm_trac_import.php
 %{_appdir}/upgrade/patches
 
 %attr(755,root,root) %{_appdir}/upgrade/scm_trac_import.php
 %{_appdir}/upgrade/patches
 
-%dir %{_appdir}/vendor
-%dir %{_appdir}/vendor/composer
-%{_appdir}/vendor/autoload.php
-%{_appdir}/vendor/composer/ClassLoader.php
-%{_appdir}/vendor/composer/autoload_*.php
-%{_appdir}/vendor/composer/include_paths.php
+%{_appdir}/vendor
 
 %dir %{_appdir}/lib
 %{_appdir}/lib/eventum
 %exclude %{_appdir}/lib/eventum/class.monitor.php
 
 
 %dir %{_appdir}/lib
 %{_appdir}/lib/eventum
 %exclude %{_appdir}/lib/eventum/class.monitor.php
 
-%{_examplesdir}/%{name}-%{version}
-
 %{systemdtmpfilesdir}/%{name}.conf
 %dir %attr(730,root,http) /var/run/%{name}
 %dir %attr(730,root,http) /var/cache/%{name}
 %{systemdtmpfilesdir}/%{name}.conf
 %dir %attr(730,root,http) /var/run/%{name}
 %dir %attr(730,root,http) /var/cache/%{name}
@@ -734,6 +745,10 @@ done
 %defattr(644,root,root,755)
 %{_appdir}/htdocs/setup
 
 %defattr(644,root,root,755)
 %{_appdir}/htdocs/setup
 
+%files doc
+%doc docs/*
+%{_examplesdir}/%{name}-%{version}
+
 %files mail-queue
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_appdir}/bin/process_mail_queue.php
 %files mail-queue
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_appdir}/bin/process_mail_queue.php
@@ -776,7 +791,7 @@ done
 %defattr(644,root,root,755)
 %attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/irc_config.php
 %attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/eventum-irc
 %defattr(644,root,root,755)
 %attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/irc_config.php
 %attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/eventum-irc
-%attr(755,root,root) %{_sbindir}/%{name}-irc-bot
+%attr(755,root,root) %{_appdir}/bin/irc-bot.php
 %attr(754,root,root) /etc/rc.d/init.d/%{name}-irc
 
 %files cli
 %attr(754,root,root) /etc/rc.d/init.d/%{name}-irc
 
 %files cli
This page took 0.033139 seconds and 4 git commands to generate.