]> git.pld-linux.org Git - packages/curl.git/blobdiff - curl.spec
- revert openldap version bump
[packages/curl.git] / curl.spec
index eb82761bf2e3149f5f75e61a143296664604515a..19df54c6fa35e7ca8f33854e7f5cf1f109787e9d 100644 (file)
--- a/curl.spec
+++ b/curl.spec
@@ -1,18 +1,42 @@
+#
+# Conditional build:
+%bcond_with    ares            # with c-ares (asynchronous DNS operations) library (disables IPv6)
+%bcond_without ssh             # without SSH support
+%bcond_without ssl             # without SSL support
+%bcond_without kerberos5       # without MIT Kerberos 5 support
+#
 Summary:       A utility for getting files from remote servers (FTP, HTTP, and others)
 Summary:       A utility for getting files from remote servers (FTP, HTTP, and others)
-Summary(pl):   Narzêdzie do ¶ci±gania plików z serwerów (FTP, HTTP i innych)
+Summary(es.UTF-8):     Un cliente para bajar archivos de servidores (FTP, HTTP, y otros)
+Summary(pl.UTF-8):     Narzędzie do ściągania plików z serwerów (FTP, HTTP i innych)
+Summary(pt_BR.UTF-8):  Busca URL (suporta FTP, TELNET, LDAP, GOPHER, DICT, HTTP e HTTPS)
+Summary(ru.UTF-8):     Утилита для получения файлов с серверов FTP, HTTP и других
+Summary(uk.UTF-8):     Утиліта для отримання файлів з серверів FTP, HTTP та інших
 Name:          curl
 Name:          curl
-Version:       7.9
+Version:       7.17.1
 Release:       2
 Release:       2
-License:       MPL
-Vendor:                Daniel Stenberg <Daniel.Stenberg@sth.frontec.se>
+License:       MIT-like
 Group:         Applications/Networking
 Group:         Applications/Networking
-Group(de):     Applikationen/Netzwerkwesen
-Group(pl):     Aplikacje/Sieciowe
-Source0:       http://curl.haxx.se/download/%{name}-%{version}.tar.gz
+Source0:       http://curl.haxx.se/download/%{name}-%{version}.tar.bz2
+# Source0-md5: 1fa635d1dfde8337c98c82749d75c1de
 Patch0:                %{name}-no_strip.patch
 Patch0:                %{name}-no_strip.patch
-Patch1:                %{name}-readtimeout-fix.patch
+Patch1:                %{name}-ac.patch
+Patch2:                %{name}-pc.patch
 URL:           http://curl.haxx.se/
 URL:           http://curl.haxx.se/
-%{!?_without_ssl:BuildRequires:        openssl-devel >= 0.9.6a}
+BuildRequires: autoconf >= 2.57
+BuildRequires: automake
+%{?with_ares:BuildRequires:    c-ares-devel}
+%{?with_kerberos5:BuildRequires:       krb5-devel}
+BuildRequires: libidn-devel >= 0.4.1
+%{?with_ssh:BuildRequires:     libssh2-devel >= 0.16}
+BuildRequires: libtool
+BuildRequires: openldap-devel
+%{?with_ssl:BuildRequires:     openssl-devel >= 0.9.7d}
+BuildRequires: zlib-devel
+Requires:      %{name}-libs = %{version}-%{release}
+Requires:      libidn >= 0.4.1
+%{?with_ssh:Requires:  libssh2 >= 0.16}
+Requires:      openssl-tools >= 0.9.7d
+Obsoletes:     libcurl2
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
@@ -29,94 +53,166 @@ to work without user interaction or any kind of interactivity. cURL
 offers many useful capabilities, like proxy support, user
 authentication, FTP upload, HTTP post, and file transfer resume.
 
 offers many useful capabilities, like proxy support, user
 authentication, FTP upload, HTTP post, and file transfer resume.
 
-%description -l pl
-cURL jest narzêdziem do ¶ci±gania plików o sk³adni URL. Obs³uguje FTP,
-HTTP, HTTPS, GOPHER, TELNET, DICT, FILE i LDAP. cURL obs³uguje równie¿
-HTTP POST, HTTP PUT, za³adowywanie (uploading) FTP, za³adowywanie HTTP
+%description -l pl.UTF-8
+cURL jest narzędziem do ściągania plików o składni URL. Obsługuje FTP,
+HTTP, HTTPS, GOPHER, TELNET, DICT, FILE i LDAP. cURL obsługuje również
+HTTP POST, HTTP PUT, załadowywanie (uploading) FTP, załadowywanie HTTP
 oparte na formularzu, serwery proksy, ciasteczka, autoryzacja
 oparte na formularzu, serwery proksy, ciasteczka, autoryzacja
-u¿ytkownik/has³o oraz wiele innych u¿ytecznych sztuczek. Curla u¿ywa
-siê g³ównie wtedy, kiedy chce siê automatycznie ¶ci±gn±æ lub wys³aæ
-pliki z/na serwer u¿ywaj±c jednego z dostêpnych protoko³ów.
+użytkownik/hasło oraz wiele innych użytecznych sztuczek. Curla używa
+się głównie wtedy, kiedy chce się automatycznie ściągnąć lub wysłać
+pliki z/na serwer używając jednego z dostępnych protokołów.
+%{?with_ssl:Ten pakiet obsługuje także SSL.}
+
+%description -l pt_BR.UTF-8
+Curl é um cliente para baixar/enviar arquivos de/para servidores
+usando um dos protocolos suportados. É projetado para funcionar sem a
+interação do usuário.
+
+Curl trabalha com proxy, autenticação, FTP put, HTTP post, e pode
+continuar transferências interrompidas, e mais...
+
+%description -l ru.UTF-8
+curl - это клиент с множеством поддерживаемых протоколов для получения
+файлов с серверов, спроектированный для работы как в неинтерактивном
+режиме, так и с возможностью диалога с пользователем.
+
+curl поддерживает много полезных возможностей, среди которых поддержка
+прокси, авторизация пользователя, закачивание по FTP, поддержка HTTP
+POST, восстановление прерванной пересылки и многое другое.
+
+curl - це кл╕╓нт з багатьма п╕дтримуваними протоколами для отримання
+файл╕в з сервер╕в, спроектований для роботи як в не╕нтерактивному
+режим╕, так ╕ з можлив╕стю д╕алогу з користувачем.
+
+curl п╕дтриму╓ багато корисних можливостей, серед яких п╕дтримка
+прокс╕, авторизац╕я користувача, в╕двантаження по FTP, HTTP POST,
+в╕дновлення перервано╖ пересилки та багато ╕ншого.
+
+%package libs
+Summary:       curl library
+Summary(pl.UTF-8):     Biblioteka curl
+Group:         Libraries
+
+%description libs
+curl library.
+
+%description libs -l pl.UTF-8
+Biblioteka curl.
 
 %package devel
 Summary:       Header files and development documentation for curl library
 
 %package devel
 Summary:       Header files and development documentation for curl library
-Summary(pl):   Pliki nag³ówkowe i dokumentacja do biblioteki curl
+Summary(pl.UTF-8):     Pliki nagłówkowe i dokumentacja do biblioteki curl
+Summary(pt_BR.UTF-8):  Arquivos de cabeçalho e bibliotecas de desenvolvimento
+Summary(ru.UTF-8):     Файлы для разработки с использованием библиотеки curl
+Summary(uk.UTF-8):     Файли для розробки з використанням бібліотеки curl
 Group:         Development/Libraries
 Group:         Development/Libraries
-Group(de):     Entwicklung/Libraries
-Group(es):     Desarrollo/Bibliotecas
-Group(fr):     Development/Librairies
-Group(pl):     Programowanie/Biblioteki
-Group(pt_BR):  Desenvolvimento/Bibliotecas
-Group(ru):     òÁÚÒÁÂÏÔËÁ/âÉÂÌÉÏÔÅËÉ
-Group(uk):     òÏÚÒÏÂËÁ/â¦Â̦ÏÔÅËÉ
-Requires:      %{name} = %{version}
+Requires:      %{name}-libs = %{version}-%{release}
+%{?with_ares:Requires: c-ares-devel}
+%{?with_kerberos5:Requires:    krb5-devel}
+Requires:      libidn-devel >= 0.4.1
+%{?with_ssh:Requires:  libssh2-devel >= 0.16}
+%{?with_ssl:Requires:  openssl-devel >= 0.9.7c}
+Requires:      zlib-devel
+Obsoletes:     libcurl2-devel
 
 %description devel
 Header files and development documentation for curl library.
 
 
 %description devel
 Header files and development documentation for curl library.
 
-%description -l pl devel
-Pliki nag³ówkowe i dokumentacja do biblioteki curl.
+%description devel -l pl.UTF-8
+Pliki nagłówkowe i dokumentacja do biblioteki curl.
+
+%description devel -l pt_BR.UTF-8
+Arquivos de cabeçalho e bibliotecas de desenvolvimento.
+
+%description devel -l ru.UTF-8
+Этот пакет содержит файлы, необходимые для разработки программ с
+использованием библиотеки curl.
+
+%description devel -l uk.UTF-8
+Цей пакет містить файли, необхідні для розробки програм з
+використанням бібліотеки curl.
 
 %package static
 Summary:       Static version of curl library
 
 %package static
 Summary:       Static version of curl library
-Summary(pl):   Statyczna wersja biblioteki curl
+Summary(pl.UTF-8):     Statyczna wersja biblioteki curl
+Summary(pt_BR.UTF-8):  Bibliotecas estáticas para desenvolvimento com o curl
+Summary(ru.UTF-8):     Статические библиотеки для разработки с использованием библиотеки curl
+Summary(uk.UTF-8):     Статичні бібліотеки для розробки з використанням бібліотеки curl
 Group:         Development/Libraries
 Group:         Development/Libraries
-Group(de):     Entwicklung/Libraries
-Group(es):     Desarrollo/Bibliotecas
-Group(fr):     Development/Librairies
-Group(pl):     Programowanie/Biblioteki
-Group(pt_BR):  Desenvolvimento/Bibliotecas
-Group(ru):     òÁÚÒÁÂÏÔËÁ/âÉÂÌÉÏÔÅËÉ
-Group(uk):     òÏÚÒÏÂËÁ/â¦Â̦ÏÔÅËÉ
-Requires:      %{name}-devel = %{version}
+Requires:      %{name}-devel = %{version}-%{release}
 
 %description static
 Static version of curl library.
 
 
 %description static
 Static version of curl library.
 
-%description -l pl static
+%description static -l pl.UTF-8
 Statyczna wersja biblioteki curl.
 
 Statyczna wersja biblioteki curl.
 
+%description static -l pt_BR.UTF-8
+Bibliotecas estáticas para desenvolvimento com o curl.
+
+%description static -l ru.UTF-8
+Этот пакет содержит статическую библиотеку для разработки программ с
+использованием библиотеки curl.
+
+%description static -l uk.UTF-8
+Цей пакет містить статичну бібліотеку для розробки програм з
+використанням бібліотеки curl.
+
 %prep
 %setup -q
 %patch0 -p1
 %prep
 %setup -q
 %patch0 -p1
-%patch1        
+%patch1 -p1
+%patch2 -p1
 
 %build
 
 %build
+%{__libtoolize}
+%{__aclocal}
+%{__autoconf}
+%{__autoheader}
+%{__automake}
 %configure \
 %configure \
-       %{!?_without_ssl:--with-ssl=%{_prefix}} \
-       --with-ipv6
+       ac_cv_header_gss_h=no \
+       %{?with_ssl:--with-ssl=%{_prefix}} \
+       %{?with_ssl:--with-ca-bundle=/usr/share/ssl/ca-bundle.crt} \
+       %{?with_kerberos5:--with-gssapi=%{_prefix}} \
+       %{?with_ares:--enable-ares=%{_prefix}} \
+       --%{?with_ares:dis}%{!?with_ares:en}able-ipv6
 
 
-%{__make} 
+%{__make}
 
 %install
 rm -rf $RPM_BUILD_ROOT
 
 
 %install
 rm -rf $RPM_BUILD_ROOT
 
-%{__make} install DESTDIR=$RPM_BUILD_ROOT
-
-gzip -9nf CHANGES LEGAL README docs/TheArtOfHttpScripting
-gzip -9nf docs/{BUGS,CONTRIBUTE,FAQ,FEATURES,INTERNALS,MANUAL,README*,RESOURCES,THANKS,TODO}
+%{__make} install \
+       DESTDIR=$RPM_BUILD_ROOT
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
-%post  -p /sbin/ldconfig
-%postun -p /sbin/ldconfig
+%post  libs -p /sbin/ldconfig
+%postun libs -p /sbin/ldconfig
 
 %files
 %defattr(644,root,root,755)
 
 %files
 %defattr(644,root,root,755)
-%doc *.gz docs/*.gz
-%attr(755,root,root) %{_bindir}/%{name}
-%attr(755,root,root) %{_libdir}/lib*.so.*.*
-%{_mandir}/man1/*
+%doc CHANGES COPYING README docs/{BUGS,FAQ,FEATURES,HISTORY,KNOWN_BUGS,MANUAL,SSLCERTS,THANKS,TODO,TheArtOfHttpScripting}
+%attr(755,root,root) %{_bindir}/curl
+%{_mandir}/man1/curl.1*
+
+%files libs
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_libdir}/libcurl.so.*.*.*
 
 %files devel
 %defattr(644,root,root,755)
 
 %files devel
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_bindir}/%{name}-config
-%attr(755,root,root) %{_libdir}/lib*.so
-%attr(755,root,root) %{_libdir}/lib*.la
-%{_mandir}/man3/*
-%{_includedir}/*
+%doc docs/{CONTRIBUTE,INTERNALS,LICENSE-MIXING,RESOURCES}
+%attr(755,root,root) %{_bindir}/curl-config
+%attr(755,root,root) %{_libdir}/libcurl.so
+%{_libdir}/libcurl.la
+%{_includedir}/curl
+%{_pkgconfigdir}/libcurl.pc
+%{_mandir}/man1/curl-config.1*
+%{_mandir}/man3/*curl*.3*
 
 %files static
 %defattr(644,root,root,755)
 
 %files static
 %defattr(644,root,root,755)
-%{_libdir}/lib*.a
+%{_libdir}/libcurl.a
This page took 0.077536 seconds and 4 git commands to generate.