]> git.pld-linux.org Git - packages/R.git/blobdiff - R.spec
S: rkward (gui)
[packages/R.git] / R.spec
diff --git a/R.spec b/R.spec
index e84434a12fa43549cd2cc4ea985064253d595ab5..f60e849bcb410bef0f4457c645473a401a0da9d9 100644 (file)
--- a/R.spec
+++ b/R.spec
@@ -1,51 +1,69 @@
+#
+# Conditional build
+%bcond_without tcl             # disable tcl support
+%bcond_without tests           # do not run "make check"
+#
+# NOTE:
+# - /etc/localtime must be present for tests to work
+#
 # TODO:
 # TODO:
-# - move perl R libraries to standard perl location
+# - faulty build on i486 (test stats-Ex.R):
+#      error in optim(init[mask], getLike, method = "L-BFGS-B", lower = rep(0,  :
+#          non-finite value supplied by optim
 # - script for rpm to autoprovides/autorequires R internals
 #
 # - script for rpm to autoprovides/autorequires R internals
 #
-# Conditional build:
-%bcond_without gnome   # without GNOME support
-#
 %include       /usr/lib/rpm/macros.perl
 Summary:       A language for data analysis and graphics
 %include       /usr/lib/rpm/macros.perl
 Summary:       A language for data analysis and graphics
-Summary(pl):   Jêzyk do analizy danych oraz grafiki
+Summary(pl.UTF-8):     Język do analizy danych oraz grafiki
 Name:          R
 Name:          R
-Version:       2.2.1
-Release:       1
+Version:       2.11.0
+Release:       2
 License:       Mixed (distributable), mostly GPL
 Group:         Development/Languages
 # CRAN master site: ftp://cran.r-project.org/pub/R/src/
 Source0:       ftp://stat.ethz.ch/R-CRAN/src/base/R-2/%{name}-%{version}.tar.gz
 License:       Mixed (distributable), mostly GPL
 Group:         Development/Languages
 # CRAN master site: ftp://cran.r-project.org/pub/R/src/
 Source0:       ftp://stat.ethz.ch/R-CRAN/src/base/R-2/%{name}-%{version}.tar.gz
-# Source0-md5: 42542290c6d1585af7ded330f811385c
+# Source0-md5: c6c1e866299f533617750889c729bfb3
 Source1:       %{name}.desktop
 URL:           http://www.r-project.org/
 Source1:       %{name}.desktop
 URL:           http://www.r-project.org/
-BuildRequires: XFree86-devel
 BuildRequires: autoconf
 BuildRequires: automake
 BuildRequires: blas-devel
 BuildRequires: bzip2-devel
 BuildRequires: autoconf
 BuildRequires: automake
 BuildRequires: blas-devel
 BuildRequires: bzip2-devel
+BuildRequires: cairo-devel
 BuildRequires: gcc-c++
 BuildRequires: gcc-c++
-BuildRequires: gcc-g77
+BuildRequires: gcc-fortran
 BuildRequires: gettext-devel
 BuildRequires: gettext-devel
+BuildRequires: lapack-devel >= 3.1.1-4
+BuildRequires: libicu-devel
 BuildRequires: libjpeg-devel >= 6b
 BuildRequires: libpng-devel >= 1.0.5
 BuildRequires: libstdc++-devel
 BuildRequires: libtool
 BuildRequires: libjpeg-devel >= 6b
 BuildRequires: libpng-devel >= 1.0.5
 BuildRequires: libstdc++-devel
 BuildRequires: libtool
-BuildRequires: libxml-devel
+BuildRequires: libxml2-devel >= 2.6.26
+BuildRequires: pango-devel
+BuildRequires: pcre-devel
 BuildRequires: perl-base >= 1:5.6
 BuildRequires: perl-base >= 1:5.6
+BuildRequires: pkgconfig
 BuildRequires: readline-devel
 BuildRequires: rpm-perlprov
 BuildRequires: readline-devel
 BuildRequires: rpm-perlprov
-BuildRequires: tcl-devel
-BuildRequires: tetex-latex
+%{?with_tcl:BuildRequires:     tcl-devel}
 BuildRequires: tetex-dvips
 BuildRequires: tetex-dvips
+BuildRequires: tetex-latex
 BuildRequires: tetex-pdftex
 BuildRequires: tetex-pdftex
-BuildRequires: tk-devel
+%{?with_tcl:BuildRequires:     tk-devel}
+BuildRequires: xorg-lib-libX11-devel
+BuildRequires: xorg-lib-libXmu-devel
+BuildRequires: xorg-lib-libXt-devel
+BuildRequires: xz-devel
 BuildRequires: zip
 BuildRequires: zip
-BuildRequires: zlib >= 1.1.3
-#BuildRequires:        lpr
+BuildRequires: zlib-devel >= 1.1.3
 #Requires:     lpr
 #Requires:     lpr
-%{?with_gnome:BuildRequires:   gnome-libs-devel}
-%{?with_gnome:BuildRequires:   ORBit-devel}
-%{?with_gnome:BuildRequires:   libglade-gnome-devel}
+Requires(post):        perl-base
+Requires(post):        textutils
+Suggests:      rkward
+Obsoletes:     R-base
+Obsoletes:     R-contrib
+Obsoletes:     R-recommended
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
@@ -59,144 +77,93 @@ Becker, Chambers & Wilks' S and Sussman's Scheme. Whereas the
 resulting language is very similar in appearance to S, the underlying
 implementation and semantics are derived from Scheme.
 
 resulting language is very similar in appearance to S, the underlying
 implementation and semantics are derived from Scheme.
 
-%description -l pl
-System do obliczeñ statystycznych i grafiki. R sk³ada siê z jêzyka
-oraz ¶rodowiska uruchomieniowego z grafik±, debuggerem, dostêpem do
-niektórych funkcji systemowych oraz mo¿liwo¶ci± uruchamiania programów
+%description -l pl.UTF-8
+System do obliczeń statystycznych i grafiki. R składa się z języka
+oraz środowiska uruchomieniowego z grafiką, debuggerem, dostępem do
+niektórych funkcji systemowych oraz możliwością uruchamiania programów
 zapisanych w skryptach.
 
 zapisanych w skryptach.
 
-Jêzyk R by³ zainspirowany dwoma istniej±cymi jêzykami: S (Beckera,
+Język R był zainspirowany dwoma istniejącymi językami: S (Beckera,
 Chambersa i Wilksa) oraz Scheme (Sussmana). R jest podobny do S, ale
 Chambersa i Wilksa) oraz Scheme (Sussmana). R jest podobny do S, ale
-implementacja i semantyka wywodzi siê ze Scheme.
-
-%package base
-Summary:       The R base distribution
-Summary(pl):   Podstawowa dystrybucja R
-License:       GPL v2 / LGPL
-Group:         Development/Languages
-Requires(post):        textutils
-Requires(post):        perl-base
-Provides:      R-cran-base
-Provides:      R-cran-datasets
-Provides:      R-cran-grid
-Provides:      R-cran-graphics
-Provides:      R-cran-grDevices
-Provides:      R-cran-methods
-Provides:      R-cran-utils
-Provides:      R-cran-tcltk
-Provides:      R-cran-splines
-Provides:      R-cran-stats
-Provides:      R-cran-stats4
-Provides:      R-cran-tools
-
-%description base
-R is a language and run-time environment for carrying out interactive
-statistical data analysis. It is not entirely dissimilar to the S
-language developed at AT&T Bell Laboratories (and now Lucent
-Technologies). Indeed, S users will find the environment quite
-familiar and a good deal of S software will run without change under
-R.
-
-%description base -l pl
-R jest jêzykiem i ¶rodowiskiem uruchomieniowym do interaktywnej
-analizy danych statystycznych. R nie jest ca³kowicie zgodny z jêzykiem
-S opracowanym w AT&T Bell Laboratiories (a teraz Lucent Technologies),
-mimo to u¿ytkownicy S zauwa¿± zbli¿one ¶rodowisko, a du¿a czê¶æ
-oprogramowania w S bêdzie dzia³a³a bez zmian w R.
-
-%package recommended
-Summary:       Recommended contributed packages for the R language
-Summary(pl):   Zalecane dodatkowe pakiety do jêzyka R
-Group:         Development/Languages
-Requires:      R-cran-KernSmooth
-Requires:      R-cran-VR
-Requires:      R-cran-boot
-Requires:      R-cran-cluster
-Requires:      R-cran-foreign
-Requires:      R-cran-lattice
-Requires:      R-cran-mgcv
-Requires:      R-cran-nlme
-Requires:      R-cran-rpart
-Requires:      R-cran-survival
-License:       GPL, free or free for non-commercial use
-URL:           http://www.ci.tuwien.ac.at/R/
-Requires(post,postun): R-base
-Requires(post,postun): perl-base
-Requires(post,postun): textutils
-Obsoletes:     R-contrib
-Requires:      R-base = %{version}-%{release}
-
-%description recommended
-Packages which extend the capabilities of the R base distribution and
-are distributed on the Comprehensive R Archive Network (CRAN).
-
-%description recommended -l pl
-Pakiety rozszerzaj±ce mo¿liwo¶ci podstawowej dystrybucji jêzyka R,
-dystrubuowane w archiwum CRAN (Comprehensive R Archive Network).
+implementacja i semantyka wywodzi się ze Scheme.
 
 %prep
 %setup -q
 
 
 %prep
 %setup -q
 
-# These files have the path for Perl hard-coded as /usr/local/bin/perl
-# We need to remove them to avoid dependency problems
-rm -f ./doc/keyword-test.orig ./etc/undoc/R-funs.orig ./etc/undoc/extrExamp.orig
-
 %build
 %{__aclocal} -I m4
 %{__autoconf}
 %build
 %{__aclocal} -I m4
 %{__autoconf}
-cp -f /usr/share/automake/config.* .
 %configure \
 %configure \
-       --with%{!?with_gnome:out}-gnome \
        --enable-R-shlib \
        --enable-linux-lfs \
        --enable-R-shlib \
        --enable-linux-lfs \
-       --with-zlib \
-       --with-bzlib \
-       --with-pcre \
-       --without-recommended-packages
+       --with-system-zlib \
+       --with-system-bzlib \
+       --with-system-pcre \
+       --with-system-xz \
+       --with-libpng \
+       --with-jpeglib \
+       --with-blas \
+       --with-lapack \
+       --with-readline \
+       --with%{!?with_tcl:out}-tcltk \
+       --with-cairo \
+       --with-libpng \
+       --with-jpeglib \
+       --with-system-zlib \
+       --with-system-bzlib \
+       --with-system-pcre \
+       --with-iconv \
+       --with-ICU \
+       --with-x \
+       --with-recommended-packages
 
 %{__make}
 
 %{__make}
+%if %{with tests}
 %{__make} check
 %{__make} check
-%{__make} docs
-%{__make} help
-%{__make} html
-%{__make} info
+%endif
+%{__make} docs pdf info
 
 %install
 rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT{%{_bindir},%{_mandir}/man1,%{_libdir}/R,%{_includedir},%{_desktopdir}}
 
 %install
 rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT{%{_bindir},%{_mandir}/man1,%{_libdir}/R,%{_includedir},%{_desktopdir}}
+install -d $RPM_BUILD_ROOT%{perl_vendorlib}/{R,Text}
 
 
-%{__make} install \
-       rhome=$RPM_BUILD_ROOT%{_libdir}/R \
-       mandir=$RPM_BUILD_ROOT%{_mandir} \
-       bindir=$RPM_BUILD_ROOT%{_bindir} \
-       
+%{__make} -j1 install \
+       DESTDIR=$RPM_BUILD_ROOT
 
 install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
 
 
 install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
 
-find $RPM_BUILD_ROOT%{_libdir}/R -name 'Makefile*' -exec rm -f {} \;
 mv $RPM_BUILD_ROOT%{_libdir}/R/lib/libR*.so $RPM_BUILD_ROOT%{_libdir}
 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/include $RPM_BUILD_ROOT%{_includedir}/R
 ln -sf %{_includedir}/R $RPM_BUILD_ROOT%{_libdir}/R/include
 mv $RPM_BUILD_ROOT%{_libdir}/R/lib/libR*.so $RPM_BUILD_ROOT%{_libdir}
 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/include $RPM_BUILD_ROOT%{_includedir}/R
 ln -sf %{_includedir}/R $RPM_BUILD_ROOT%{_libdir}/R/include
-rm $RPM_BUILD_ROOT%{_bindir}/%{name}
-sed -i -e "s#$RPM_BUILD_ROOT##g" $RPM_BUILD_ROOT%{_libdir}/%{name}/bin/%{name}
-ln -sf %{_libdir}/%{name}/bin/%{name} $RPM_BUILD_ROOT%{_bindir}/%{name}
+
+(cd $RPM_BUILD_ROOT%{_libdir}/%{name}/share/perl/R/
+for f in * ; do
+  ln -s %{_libdir}/%{name}/share/perl/R/$f $RPM_BUILD_ROOT%{perl_vendorlib}/R/
+done)
+(cd $RPM_BUILD_ROOT%{_libdir}/%{name}/share/perl/Text
+for f in * ; do
+  ln -s %{_libdir}/%{name}/share/perl/Text/$f $RPM_BUILD_ROOT%{perl_vendorlib}/Text/
+done)
+
+rm -r $RPM_BUILD_ROOT%{perl_vendorlib}/R
+rm -r $RPM_BUILD_ROOT%{_libdir}/R/share/perl/File
+mv    $RPM_BUILD_ROOT%{_libdir}/R/share/perl/R $RPM_BUILD_ROOT%{perl_vendorlib}
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
-%post
-(cd %{_libdir}/R/library; umask 022; cat */CONTENTS > ../doc/html/search/index.txt
- R_HOME=%{_libdir}/R ../bin/Rcmd perl ../share/perl/build-help.pl --htmllist)
-/sbin/ldconfig
-
-%postun        -p /sbin/ldconfig
+%post -p /sbin/ldconfig
+%postun -p /sbin/ldconfig
 
 
-%files base
+%files
 %defattr(644,root,root,755)
 %defattr(644,root,root,755)
-%doc COPYRIGHTS FAQ NEWS README RESOURCES THANKS Y2K
+%doc NEWS README doc/{AUTHORS,COPYRIGHTS,FAQ,RESOURCES,THANKS}
 
 %{_mandir}/man1/R.1*
 
 %{_mandir}/man1/R.1*
+%{_mandir}/man1/Rscript*
 %attr(755,root,root) %{_bindir}/R
 %attr(755,root,root) %{_bindir}/R
+%attr(755,root,root) %{_bindir}/Rscript
 %dir %{_libdir}/R
 %attr(755,root,root) %{_libdir}/R/bin
 %attr(755,root,root) %{_libdir}/libR*.so
 %dir %{_libdir}/R
 %attr(755,root,root) %{_libdir}/R/bin
 %attr(755,root,root) %{_libdir}/libR*.so
@@ -204,35 +171,52 @@ rm -rf $RPM_BUILD_ROOT
 %{_libdir}/R/include
 %{_includedir}/R
 %{_libdir}/R/share
 %{_libdir}/R/include
 %{_includedir}/R
 %{_libdir}/R/share
-%{_libdir}/R/AUTHORS
+%{_libdir}/R/COPYING
+%{_libdir}/R/NEWS
+%{_libdir}/R/SVN-REVISION
 %dir %{_libdir}/R/library
 %dir %{_libdir}/R/library
+%{_libdir}/%{name}/library/R.css
 # %{_libdir}/R/doc %except %{_libdir}/R/doc/html/{packages.html,search/index.txt}
 %dir %{_libdir}/R/doc
 %{_libdir}/R/doc/[KRm]*
 %dir %{_libdir}/R/doc/html
 %{_libdir}/R/doc/html/*.css
 %{_libdir}/R/doc/html/[Ra-lr-u]*.html
 # %{_libdir}/R/doc %except %{_libdir}/R/doc/html/{packages.html,search/index.txt}
 %dir %{_libdir}/R/doc
 %{_libdir}/R/doc/[KRm]*
 %dir %{_libdir}/R/doc/html
 %{_libdir}/R/doc/html/*.css
 %{_libdir}/R/doc/html/[Ra-lr-u]*.html
-%{_libdir}/R/doc/html/packages-head.html
+%{_libdir}/R/doc/html/packages-head*.html
 %{_libdir}/R/doc/html/*.jpg
 %{_libdir}/R/doc/html/*.jpg
-%dir %{_libdir}/R/doc/html/search
-%{_libdir}/R/doc/html/search/[A-Z]*
-%ghost %{_libdir}/R/doc/html/search/index.txt
 %ghost %{_libdir}/R/doc/html/packages.html
 %ghost %{_libdir}/R/doc/html/packages.html
-%{_desktopdir}/*
+%{_desktopdir}/*.desktop
+
+%{perl_vendorlib}/R
 
 %attr(755,root,root) %{_libdir}/%{name}/modules
 
 
 %attr(755,root,root) %{_libdir}/%{name}/modules
 
+%{_libdir}/%{name}/library/KernSmooth
+%{_libdir}/%{name}/library/MASS
+%{_libdir}/%{name}/library/Matrix
 %{_libdir}/%{name}/library/base
 %{_libdir}/%{name}/library/base
+%{_libdir}/%{name}/library/boot
+%{_libdir}/%{name}/library/class
+%{_libdir}/%{name}/library/cluster
+%{_libdir}/%{name}/library/codetools
 %{_libdir}/%{name}/library/datasets
 %{_libdir}/%{name}/library/datasets
-%{_libdir}/%{name}/library/grid
-%{_libdir}/%{name}/library/graphics
+%{_libdir}/%{name}/library/foreign
 %{_libdir}/%{name}/library/grDevices
 %{_libdir}/%{name}/library/grDevices
+%{_libdir}/%{name}/library/graphics
+%{_libdir}/%{name}/library/grid
+%{_libdir}/%{name}/library/lattice
 %{_libdir}/%{name}/library/methods
 %{_libdir}/%{name}/library/methods
-%{_libdir}/%{name}/library/utils
-%{_libdir}/%{name}/library/tcltk
+%{_libdir}/%{name}/library/mgcv
+%{_libdir}/%{name}/library/nlme
+%{_libdir}/%{name}/library/nnet
+%{_libdir}/%{name}/library/rpart
+%{_libdir}/%{name}/library/spatial
 %{_libdir}/%{name}/library/splines
 %{_libdir}/%{name}/library/stats
 %{_libdir}/%{name}/library/stats4
 %{_libdir}/%{name}/library/splines
 %{_libdir}/%{name}/library/stats
 %{_libdir}/%{name}/library/stats4
+%{_libdir}/%{name}/library/survival
+%{_libdir}/%{name}/library/tcltk
 %{_libdir}/%{name}/library/tools
 %{_libdir}/%{name}/library/tools
+%{_libdir}/%{name}/library/utils
 
 
-%files recommended
+%{_pkgconfigdir}/*.pc
This page took 0.066381 seconds and 4 git commands to generate.