]> git.pld-linux.org Git - packages/zsh.git/blob - zsh.spec
- release 3,
[packages/zsh.git] / zsh.spec
1 # $Revision: 1.46 $ $Date: 2002-02-09 19:24:45 $
2 #
3 # Conditional build:
4 # _without_static       - without static version
5 #
6 Summary:        Enhanced bourne shell
7 Summary(de):    Enhanced Bourne Shell
8 Summary(es):    Shell bourne mejorada
9 Summary(fr):    Bourne shell amélioré
10 Summary(tr):    Geliþmiþ bir BASH sürümü
11 Summary(pl):    Ulepszona pow³oka Bourne'a
12 Summary(pt_BR): Shell bourne melhorada
13 Name:           zsh
14 Version:        4.0.4
15 Release:        3
16 License:        BSD-like
17 Group:          Applications/Shells
18 Group(cs):      Aplikace/Shelly
19 Group(de):      Anwendungen/Shells
20 Group(es):      Aplicaciones/Shells
21 Group(fr):      Applications/Shells
22 Group(ja):      ¥¢¥×¥ê¥±¡¼¥·¥ç¥ó/¥·¥§¥ë
23 Group(pl):      Aplikacje/Pow³oki
24 Group(pt):      Aplicações/Shells
25 Group(pt_BR):   Aplicações/Shells
26 Group(ru):      ðÒÉÌÏÖÅÎÉÑ/ïÂÏÌÏÞËÉ
27 URL:            http://www.zsh.org/
28 Source0:        ftp://ftp.zsh.org/pub/zsh/%{name}-%{version}.tar.gz
29 Source1:        %{name}.1.pl
30 Patch0:         %{name}-info.patch
31 Patch1:         %{name}-tinfo.patch
32 Patch2:         %{name}-addons.patch
33 Patch3:         %{name}-paths.patch
34 Patch4:         %{name}-no_nis.patch
35 Prereq:         grep
36 Prereq:         fileutils
37 BuildRequires:  autoconf
38 BuildRequires:  ncurses-devel >= 5.1
39 BuildRequires:  texinfo
40 %{!?_without_static:BuildRequires:      glibc-static}
41 %{!?_without_static:BuildRequires:      ncurses-static}
42 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
43 Obsoletes:      zsh-doc-html, zsh-doc-ps, zsh-doc-dvi
44
45 %define         _bindir         /bin
46
47 %description
48 zsh is an enhanced version of the Bourne shell with csh additions and
49 most features of ksh, bash, and tcsh.
50
51 %description -l es
52 zsh es una versión mejorada del bourne shell con estas
53 características:
54 - muy próximo de la gramática del ksh/sh, con adiciones csh,
55 - varias características del ksh, bash y tcsh,
56 - 75 funciones empotradas, 89 opciones, 154 combinaciones de teclas,
57 - selección,
58 - funciones shell ...y mucho más.
59
60 %description -l pl
61 zsh jest ulepszon± pow³ok± Bourne'a z elementami pow³oki csh. Posiada
62 wiêkszo¶æ cech ksh, bash i tcsh.
63
64 %description -l pt_BR
65 zsh é uma versão melhorada do bourne shell com essas características:
66 - muito próximo da gramática do ksh/sh, com adições csh,
67 - várias características do ksh, bash e tcsh,
68 - 75 funções embutidas, 89 opções, 154 combinações de teclas,
69 - seleção,
70 - funções shell ...e muito mais.
71
72 %package completions
73 Summary:        Files needed for advanced TAB-completion
74 Summary(pl):    Pliki potrzebne dla zaawansowanej TAB-completion
75 Group:          Applications/Shells
76 Group(cs):      Aplikace/Shelly
77 Group(de):      Anwendungen/Shells
78 Group(es):      Aplicaciones/Shells
79 Group(fr):      Applications/Shells
80 Group(ja):      ¥¢¥×¥ê¥±¡¼¥·¥ç¥ó/¥·¥§¥ë
81 Group(pl):      Aplikacje/Pow³oki
82 Group(pt):      Aplicações/Shells
83 Group(pt_BR):   Aplicações/Shells
84 Group(ru):      ðÒÉÌÏÖÅÎÉÑ/ïÂÏÌÏÞËÉ
85 Requires:       %{name} = %{version}
86
87 %description completions
88 This package contains files needed for advanced tab completion in zsh.
89
90 %description -l pl completions
91 Ten pakiet zawiera pliki wymagane przez zsh dla zaawansowanej
92 TAB-completion.
93
94 %package static
95 Summary:        Statically linked Enhanced bourne shell
96 Summary(pl):    Zaawansowany bourne SHell - linkowany statycznie
97 Group:          Applications/Shells
98 Group(cs):      Aplikace/Shelly
99 Group(de):      Anwendungen/Shells
100 Group(es):      Aplicaciones/Shells
101 Group(fr):      Applications/Shells
102 Group(ja):      ¥¢¥×¥ê¥±¡¼¥·¥ç¥ó/¥·¥§¥ë
103 Group(pl):      Aplikacje/Pow³oki
104 Group(pt):      Aplicações/Shells
105 Group(pt_BR):   Aplicações/Shells
106 Group(ru):      ðÒÉÌÏÖÅÎÉÑ/ïÂÏÌÏÞËÉ
107 Requires:       %{name} = %{version}
108
109 %description static
110 zsh is an enhanced version of the Bourne shell with csh additions and
111 most features of ksh, bash, and tcsh.
112
113 %description -l pl static
114 zsh jest ulepszon± pow³ok± Bourne'a z elementami pow³oki csh. Posiada
115 wiêkszo¶æ cech ksh, bash i tcsh. W tym pakiecie jest statycznie
116 linkowany.
117
118 %prep
119 %setup -q
120 %patch0 -p1
121 %patch1 -p1
122 %patch2 -p1
123 %patch3 -p1
124 %patch4 -p1
125
126 %build
127 autoconf
128
129 %if %{!?_without_static:1}%{?_without_static:0}
130 LDFLAGS="%{rpmldflags} -static"
131 %configure
132 %{__make}
133 mv -f Src/zsh Src/zsh.static
134 LDFLAGS="%{rpmldflags}"
135 %endif
136
137 %configure \
138         --enable-maildir-support
139 %{__make}
140
141 (cd Doc; makeinfo zsh.texi)
142
143 %install
144 rm -rf $RPM_BUILD_ROOT
145 install -d $RPM_BUILD_ROOT{%{_infodir},%{_sysconfdir},%{_bindir},%{_mandir}/pl/man1}
146
147 %{__make} install DESTDIR=$RPM_BUILD_ROOT
148
149 %{!?_without_static:install Src/zsh.static $RPM_BUILD_ROOT%{_bindir}}
150 install Doc/zsh.info*   $RPM_BUILD_ROOT%{_infodir}
151
152 touch $RPM_BUILD_ROOT%{_sysconfdir}/{zlogout,zlogin,zshenv}
153 echo ". /etc/profile" > $RPM_BUILD_ROOT%{_sysconfdir}/zprofile
154 echo -e "PS1='[%%n@%%m %%~]%%(!.#.%%\\$) '\nbindkey -e >/dev/null 2>&1\nalias which=whence" > \
155                                           $RPM_BUILD_ROOT%{_sysconfdir}/zshrc
156
157 rm -f Etc/Makefile*
158 find Functions Util StartupFiles -name .distfiles -o -name .cvsignore | xargs rm -f
159 install %{SOURCE1} $RPM_BUILD_ROOT%{_mandir}/pl/man1/zsh.1
160
161 gzip -9nf Etc/* README LICENCE ChangeLog META-FAQ
162
163 %post
164 if [ ! -f /etc/shells ]; then
165         echo "%{_bindir}/zsh" >> /etc/shells
166 else
167         grep -q '^%{_bindir}/zsh$' /etc/shells || echo "%{_bindir}/zsh" >> /etc/shells
168 fi
169 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} > /dev/null 2>&1
170
171 %preun
172 if [ "$1" = "0" ]; then
173         grep -v '^%{_bindir}/zsh$' /etc/shells > /etc/shells.new
174         mv -f /etc/shells.new /etc/shells
175 fi
176
177 %postun
178 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} > /dev/null 2>&1
179
180 %post static
181 if [ ! -f /etc/shells ]; then
182        echo "%{_bindir}/zsh.static" >> /etc/shells
183 else
184        grep -q '^%{_bindir}/zsh\.static$' /etc/shells || echo "%{_bindir}/zsh.static" >> /etc/shells
185 fi
186
187 %preun static
188 if [ "$1" = "0" ]; then
189        grep -v '^%{_bindir}/zsh\.static$' /etc/shells > /etc/shells.new
190        mv -f /etc/shells.new /etc/shells
191 fi
192
193
194 %clean
195 rm -rf $RPM_BUILD_ROOT
196
197 %files
198 %defattr(644,root,root,755)
199 %doc *.gz Etc/* Util StartupFiles
200 %attr(755,root,root) %{_bindir}/zsh
201 %config %{_sysconfdir}/*
202 %dir %{_libdir}/zsh
203 %dir %{_libdir}/zsh/%{version}
204 %dir %{_datadir}/zsh/
205 %dir %{_datadir}/zsh/site-functions
206 %dir %{_datadir}/zsh/%{version}
207 %dir %{_datadir}/zsh/%{version}/functions
208 %{_datadir}/zsh/%{version}/functions/[^_c]*
209 %{_datadir}/zsh/%{version}/functions/c[^o]*
210 %{_datadir}/zsh/%{version}/functions/co[^m]*
211 %attr(755,root,root) %{_libdir}/zsh/%{version}/*
212 %{_infodir}/zsh.info*
213 %{_mandir}/man1/zsh*.1*
214 %lang(pl) %{_mandir}/pl/man1/zsh*.1*
215
216 %files completions
217 %defattr(644,root,root,755)
218 %{_datadir}/zsh/%{version}/functions/comp*
219 %{_datadir}/zsh/%{version}/functions/_*
220
221 %if %{!?_without_static:1}%{?_without_static:0}
222 %files static
223 %defattr(644,root,root,755)
224 %attr(755,root,root) %{_bindir}/zsh.static
225 %endif
This page took 0.2674 seconds and 4 git commands to generate.