]> git.pld-linux.org Git - packages/zsh.git/blob - zsh.spec
- release 3,
[packages/zsh.git] / zsh.spec
1 # $Revision: 1.33 $ $Date: 2001-07-11 20:07:53 $
2 Summary:        Enhanced bourne shell
3 Summary(de):    Enhanced Bourne Shell
4 Summary(fr):    Bourne shell amélioré
5 Summary(tr):    Geliþmiþ bir BASH sürümü
6 Summary(pl):    Ulepszona pow³oka Bourne'a
7 Name:           zsh
8 Version:        4.0.2
9 Release:        3
10 License:        BSD-like
11 Group:          Applications/Shells
12 Group(de):      Applikationen/Shells
13 Group(pl):      Aplikacje/Pow³oki
14 URL:            http://www.zsh.org/
15 Source0:        ftp://ftp.zsh.org/pub/zsh/%{name}-%{version}.tar.gz
16 Patch0:         %{name}-info.patch
17 Patch1:         %{name}-tinfo.patch
18 Patch2:         %{name}-addons.patch
19 Patch3:         %{name}-paths.patch
20 Patch4:         %{name}-no_nis.patch
21 Prereq:         grep
22 Prereq:         fileutils
23 BuildRequires:  autoconf
24 BuildRequires:  ncurses-devel >= 5.1
25 BuildRequires:  glibc-static
26 BuildRequires:  ncurses-static
27 BuildRequires:  texinfo
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29 Obsoletes:      zsh-doc-html, zsh-doc-ps, zsh-doc-dvi
30
31 %define         _bindir         /bin
32
33 %description
34 zsh is an enhanced version of the Bourne shell with csh additions and
35 most features of ksh, bash, and tcsh.
36
37 %description -l pl
38 zsh jest ulepszon± pow³ok± Bourne'a z elementami pow³oki csh. Posiada
39 wiêkszo¶æ cech ksh, bash i tcsh.
40
41 %package static
42 Summary:        Statically linked Enhanced bourne shell
43 Summary(pl):    Zaawansowany bourne SHell - linkowany statycznie
44 Group:          Applications/Shells
45 Group(de):      Applikationen/Shells
46 Group(pl):      Aplikacje/Pow³oki
47 Requires:       %{name} = %{version}
48
49 %description static
50 zsh is an enhanced version of the Bourne shell with csh additions and
51 most features of ksh, bash, and tcsh.
52
53 %description -l pl static
54 zsh jest ulepszon± pow³ok± Bourne'a z elementami pow³oki csh. Posiada
55 wiêkszo¶æ cech ksh, bash i tcsh. W tym pakiecie jest statycznie
56 linkowany.
57
58 %prep
59 %setup -q
60 %patch0 -p1
61 %patch1 -p1
62 %patch2 -p1
63 %patch3 -p1
64 %patch4 -p1
65
66 %build
67 autoconf
68
69 %configure
70 %{__make}
71 mv -f Src/zsh Src/zsh.static
72
73 %configure \
74         --enable-maildir-support
75 %{__make}
76
77 (cd Doc; makeinfo zsh.texi)
78
79 %install
80 rm -rf $RPM_BUILD_ROOT
81 install -d $RPM_BUILD_ROOT{%{_infodir},%{_sysconfdir},%{_bindir}}
82
83 %{__make} install DESTDIR=$RPM_BUILD_ROOT
84
85 install Src/zsh.static  $RPM_BUILD_ROOT%{_bindir}
86 install Doc/zsh.info*   $RPM_BUILD_ROOT%{_infodir}
87
88 touch $RPM_BUILD_ROOT%{_sysconfdir}/{zlogout,zlogin,zshenv}
89 echo    ". /etc/profile"                > $RPM_BUILD_ROOT%{_sysconfdir}/zprofile
90 echo -e "PS1='[%n@%m %~]%(!.#.%\$) '\nbindkey -e >/dev/null 2>&1" > \
91                                           $RPM_BUILD_ROOT%{_sysconfdir}/zshrc
92                                         
93 rm -f Etc/Makefile*
94 gzip -9nf Etc/* README LICENCE ChangeLog META-FAQ
95
96 %post
97 if [ ! -f /etc/shells ]; then
98         echo "%{_bindir}/zsh" >> /etc/shells
99 else
100         grep -q '^%{_bindir}/zsh$' /etc/shells || echo "%{_bindir}/zsh" >> /etc/shells
101 fi
102 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} > /dev/null 2>&1
103
104 %preun
105 if [ "$1" = "0" ]; then
106         grep -v '^%{_bindir}/zsh$' /etc/shells > /etc/shells.new
107         mv -f /etc/shells.new /etc/shells
108 fi
109
110 %postun
111 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} > /dev/null 2>&1
112
113 %post static
114 if [ ! -f /etc/shells ]; then
115         echo "%{_bindir}/zsh.static" >> /etc/shells
116 else
117         grep -q '^%{_bindir}/zsh\.static$' /etc/shells || echo "%{_bindir}/zsh.static" >> /etc/shells
118 fi
119
120 %preun static
121 if [ "$1" = "0" ]; then
122         grep -v '^%{_bindir}/zsh\.static$' /etc/shells > /etc/shells.new
123         mv -f /etc/shells.new /etc/shells
124 fi
125
126 %clean
127 rm -rf $RPM_BUILD_ROOT
128
129 %files
130 %defattr(644,root,root,755)
131 %doc *.gz Etc/* Util Functions
132 %attr(755,root,root) %{_bindir}/zsh
133 %config %{_sysconfdir}/*
134 %dir %{_libdir}/zsh
135 %dir %{_libdir}/zsh/%{version}
136 %attr(755,root,root) %{_libdir}/zsh/%{version}/*
137 %{_infodir}/zsh.info*
138 %{_mandir}/man1/zsh*.1*
139
140 %files static
141 %defattr(644,root,root,755)
142 %attr(755,root,root) %{_bindir}/zsh.static
This page took 0.049052 seconds and 4 git commands to generate.