]> git.pld-linux.org Git - packages/zsh.git/blob - zsh.spec
- release 4,
[packages/zsh.git] / zsh.spec
1 # $Revision: 1.21 $ $Date: 2000-12-04 07:19:01 $
2 Summary:        Enhanced bourne shell
3 Summary(de):    Enhanced Bourne Shell
4 Summary(fr):    Bourne shell amélioré
5 Summary(tr):    Geliþmiþ bir BASH sürümü
6 Summary(pl):    Ulepszona pow³oka Bourne'a
7 Name:           zsh
8 Version:        3.1.9
9 Release:        4
10 License:        GPL
11 Group:          Applications/Shells
12 Group(de):      Applikationen/Shells
13 Group(pl):      Aplikacje/Pow³oki
14 Source0:        ftp://ftp.zsh.org/pub/zsh/%{name}-%{version}.tar.gz
15 Patch0:         %{name}-info.patch
16 Patch1:         %{name}-DESTDIR.patch
17 Patch2:         %{name}-sys_capability.patch
18 Patch3:         %{name}-cap_get_proc.patch
19 Patch4:         %{name}-tinfo.patch
20 Patch5:         %{name}-addons.patch
21 BuildRequires:  ncurses-devel >= 5.1
22 BuildRequires:  glibc-static
23 BuildRequires:  ncurses-static
24 BuildRequires:  texinfo
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26 Obsoletes:      zsh-doc-html, zsh-doc-ps, zsh-doc-dvi
27
28 %define         _bidir          /
29
30 %description
31 zsh is an enhanced version of the Bourne shell with csh additions and
32 most features of ksh, bash, and tcsh.
33
34 %description -l pl
35 zsh jest ulepszon± pow³ok± Bourne'a z elementami pow³oki csh. Posiada
36 wiêkszo¶æ cech ksh, bash i tcsh.
37
38 %package static
39 Summary:        Statically linked Enhanced bourne shell
40 Summary(pl):    Zaawansowany bourne SHell - linkowany statycznie
41 Group:          Applications/Shells
42 Group(de):      Applikationen/Shells
43 Group(pl):      Aplikacje/Pow³oki
44 Requires:       %{name} = %{version}
45
46 %description static
47 zsh is an enhanced version of the Bourne shell with csh additions and
48 most features of ksh, bash, and tcsh.
49
50 %description -l pl static
51 zsh jest ulepszon± pow³ok± Bourne'a z elementami pow³oki csh. Posiada
52 wiêkszo¶æ cech ksh, bash i tcsh. W tym pakiecie jest statycznie
53 linkowany.
54
55 %prep
56 %setup -q
57 %patch0 -p1
58 %patch1 -p1
59 %patch2 -p1
60 %patch3 -p1
61 %patch4 -p1
62 %patch5 -p1
63
64 %build
65 autoconf
66
67 %configure
68 %{__make}
69 mv -f Src/zsh Src/zsh.static
70
71 %configure \
72         --enable-maildir-support
73 %{__make}
74
75 (cd Doc; makeinfo zsh.texi)
76
77 %install
78 rm -rf $RPM_BUILD_ROOT
79 install -d $RPM_BUILD_ROOT{%{_infodir},%{_sysconfdir}}
80
81 %{__make} install DESTDIR=$RPM_BUILD_ROOT
82
83 install Src/zsh.static $RPM_BUILD_ROOT%{_bindir}
84 install Doc/zsh.info* $RPM_BUILD_ROOT%{_infodir}
85
86 touch $RPM_BUILD_ROOT%{_sysconfdir}/{zlogout,zprofile,zshrc,zlogin,zshenv}
87
88 rm -f Etc/Makefile*
89 gzip -9nf Etc/* README ChangeLog META-FAQ
90
91 %post
92 if [ ! -f /etc/shells ]; then
93         echo "/bin/zsh" >> /etc/shells
94 else
95         while read SHNAME; do
96                 elif [ "$SHNAME" = "/bin/zsh" ]; then
97                         HAS_ZSH=1
98                 fi
99         done < /etc/shells
100         [ -n "$HAS_ZSH" ] || echo "/bin/zsh" >> /etc/shells
101 fi
102 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} > /dev/null 2>&1
103
104 %preun
105 if [ "$1" = "0" ]; then
106         while read SHNAME; do
107                 [ "$SHNAME" = "/bin/zsh" ] ||\
108                 echo "$SHNAME"
109         done < /etc/shells > /etc/shells.new
110         mv -f /etc/shells.new /etc/shells
111 fi
112 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} > /dev/null 2>&1
113
114 %post static
115 if [ ! -f /etc/shells ]; then
116         echo "/bin/zsh.static" >> /etc/shells
117 else
118         while read SHNAME; do
119                 elif [ "$SHNAME" = "/bin/zsh.static" ]; then
120                         HAS_ZSH_STATIC=1
121                 fi
122         done < /etc/shells
123         [ -n "$HAS_ZSH_STATIC" ] || echo "/bin/zsh.static" >> /etc/shells
124 fi
125
126 %preun
127 if [ "$1" = "0" ]; then
128         while read SHNAME; do
129                 [ "$SHNAME" = "/bin/zsh.static" ] ||\
130                 echo "$SHNAME"
131         done < /etc/shells > /etc/shells.new
132         mv -f /etc/shells.new /etc/shells
133 fi
134
135 %clean
136 rm -rf $RPM_BUILD_ROOT
137
138 %files
139 %defattr(644,root,root,755)
140 %doc {META-FAQ,README,ChangeLog}.gz Etc/* Util Functions
141 %doc %{_infodir}/zsh.info*
142 %dir %{_libdir}/zsh/%{version}
143 %config %{_sysconfdir}/*
144
145 %attr(755,root,root) %{_bindir}/zsh
146 %attr(755,root,root) %{_libdir}/zsh/%{version}/*
147 %{_mandir}/man1/zsh*.1.gz
148
149 %files static
150 %defattr(644,root,root,755)
151 %attr(755,root,root) %{_bindir}/zsh.static
This page took 0.038513 seconds and 3 git commands to generate.